Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
driver Nouveau not used
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
xaon
n00b
n00b


Joined: 28 Jun 2014
Posts: 21

PostPosted: Mon Aug 18, 2014 7:36 pm    Post subject: driver Nouveau not used Reply with quote

Hi!

I have a Nvidia GTX660, and i have enabled nouveau driver in kernal

Code:
<*> Nouveau (nVidia) cards


but seems like the the driver is not in use?

Code:


lspci -v

01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 843b
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e8000000 (64-bit, prefetchable) [size=128M]
        Memory at f0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        Expansion ROM at f7000000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [b4] Vendor Specific Information: Len=14 <?>
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Capabilities: [900] #19

01:00.1 Audio device: NVIDIA Corporation GK106 HDMI Audio Controller (rev a1)
        Subsystem: ASUSTeK Computer Inc. Device 843b
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at f7080000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Kernel driver in use: snd_hda_intel


anything i am missing? 8O
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Mon Aug 18, 2014 8:12 pm    Post subject: Reply with quote

Well, bit to little info there.
Did you check the usual suspects in kernel config (and kernel command line) ?
Back to top
View user's profile Send private message
xaon
n00b
n00b


Joined: 28 Jun 2014
Posts: 21

PostPosted: Mon Aug 18, 2014 8:22 pm    Post subject: Reply with quote

VoidMage wrote:
Well, bit to little info there.
Did you check the usual suspects in kernel config (and kernel command line) ?


Hi VoidMage, i am not sure what are the "usual suspects"?

a bit more kernel config, if that helps:

Code:

 <*> /dev/agpgart (AGP Support)  --->                                                                              │ │
  │ │                                           -*- VGA Arbitration                                                                                               │ │
  │ │                                           (16)  Maximum number of GPUs                                                                                      │ │
  │ │                                           [ ] Laptop Hybrid Graphics - GPU switching support                                                                │ │
  │ │                                           <*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->                                         │ │
  │ │                                               I2C encoder or helper chips  --->                                                                             │ │
  │ │                                           < > 3dfx Banshee/Voodoo3+                                                                                         │ │
  │ │                                           < > ATI Rage 128                                                                                                  │ │
  │ │                                           < > ATI Radeon                                                                                                    │ │
  │ │                                           <*> Nouveau (nVidia) cards                                                                                        │ │
  │ │                                           (5)   Maximum debug level                                                                                         │ │
  │ │                                           (3)   Default debug level                                                                                         │ │
  │ │                                           [*]   Support for backlight control                                                                               │ │
  │ │                                           < > Intel I810                                                                                                    │ │
  │ │                                           <*> Intel 8xx/9xx/G3x/G4x/HD Graphics                                                                             │ │
  │ │                                           [*]   Enable modesetting on intel by default                                                                      │ │
  │ │                                           [*]   Enable legacy fbdev support for the modesetting intel driver                                                │ │
  │ │                                           [ ]   Enable preliminary support for prerelease Intel hardware by default                                         │ │
  │ │                                           [ ]   Enable userspace modesetting on Intel hardware (DEPRECATED)                                                 │ │
  │ │                                           < > Matrox g200/g400                                                                                              │ │
  │ │                                           < > SiS video cards                                                                                               │ │
  │ │                                           < > Via unichrome video cards                                                                                     │ │
  │ │                                           < > Savage video cards                                                                                            │ │
  │ │                                           < > DRM driver for VMware Virtual GPU                                                                             │ │
  │ │                                           < > Intel GMA5/600 KMS Framebuffer                                                                                │ │
  │ │                                           < > DisplayLink                                                                                                   │ │
  │ │                                           < > AST server chips                                                                                              │ │
  │ │                                           < > Kernel modesetting driver for MGA G200 server engines                                                         │ │
  │ │                                           < > Cirrus driver for QEMU emulated device                                                                        │ │
  │ │                                           < > QXL virtual GPU                                                                                               │ │
  │ │                                           < > DRM Support for bochs dispi vga interface (qemu stdvga)                                                       │ │
  │ │                                           -*- Lowlevel video output switch controls                                                                         │ │
  │ │                                           -*- Support for frame buffer devices  --->                                                                        │ │
  │ │                                           [ ] Exynos Video driver support  ----                                                                             │ │
  │ │                                           -*- Backlight & LCD device support  --->                                                                          │ │
  │ │                                               Console display driver support  --->                                                                          │ │
  │ │                                           [*] Bootup logo  --->                                                                                             │ │
  │ │                                                                           
Back to top
View user's profile Send private message
FishB8
l33t
l33t


Joined: 17 Mar 2003
Posts: 820

PostPosted: Thu Aug 21, 2014 2:24 am    Post subject: Reply with quote

It's probably best that you make set video drivers as modules rather than built-in. Especially when you are building with Intel drivers also from some reason. It's a waste of space to have stuff loaded that will never be used.

You probably need to check and see what framebuffer device driver is initially being used. The nouveau driver will fail to load with almost anything other than VESA VGA used as the initial framebuffer device driver.
_________________
"...as we enjoy great advantages from the inventions of others, we should be glad of an opportunity to serve others by any invention of ours, and this we should do freely and generously." -Benjamin Franklin
Back to top
View user's profile Send private message
xaon
n00b
n00b


Joined: 28 Jun 2014
Posts: 21

PostPosted: Wed Oct 01, 2014 8:11 pm    Post subject: Reply with quote

i have disable the intel drivers, and make nouveau a module

Code:
< > ATI Radeon                                                                                                    │ │
  │ │                                           <M> Nouveau (nVidia) cards                                                                                        │ │
  │ │                                           (5)   Maximum debug level                                                                                         │ │
  │ │                                           (3)   Default debug level                                                                                         │ │
  │ │                                           [*]   Support for backlight control                                                                               │ │
  │ │                                           < > Intel I810                                                                                                    │ │
  │ │                                           < > Intel 8xx/9xx/G3x/G4x/HD Graphics                                                                             │ │
  │ │                                           < > Matrox g200/g400                   


but when i tried to load the nouveau module, i got

Code:

[    4.949564] nouveau: Unknown symbol wmi_evaluate_method (err 0)
[    4.949582] nouveau: Unknown symbol wmi_has_guid (err 0)



i already have

Code:

 > Device Drivers > X86 Platform Specific Device Drivers > WMI

enabled...
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Thu Oct 02, 2014 12:08 am    Post subject: Reply with quote

It looks like you possibly did not install the new kernel after building it.

Verify with "uname -a" (build date and time) that you are running the kernel you think you are.
Back to top
View user's profile Send private message
xaon
n00b
n00b


Joined: 28 Jun 2014
Posts: 21

PostPosted: Thu Oct 02, 2014 9:58 pm    Post subject: Reply with quote

chithanh wrote:
It looks like you possibly did not install the new kernel after building it.

Verify with "uname -a" (build date and time) that you are running the kernel you think you are.


strange... the timestamp in "uname -a" is not correct...

Code:

Linux localhost 3.14.14-gentoo #1 SMP Sun Aug 17 17:07:56 CEST 2014 x86_64 Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz GenuineIntel GNU/Linux


but i have been compiling the kernel many time these days...

Code:
localhost ~ # ls -lrth /boot/
total 17M
-rw-r--r-- 1 root root 5.2M Oct  2 23:47 vmlinuz-3.14.14-gentoo.old
-rw-r--r-- 1 root root 2.8M Oct  2 23:47 System.map-3.14.14-gentoo.old
-rw-r--r-- 1 root root  91K Oct  2 23:47 config-3.14.14-gentoo.old
-rw-r--r-- 1 root root 5.2M Oct  2 23:47 vmlinuz-3.14.14-gentoo
-rw-r--r-- 1 root root 2.8M Oct  2 23:47 System.map-3.14.14-gentoo
-rw-r--r-- 1 root root  91K Oct  2 23:47 config-3.14.14-gentoo


Code:
menuentry 'gentoo' {
                    set root=(hd1,2)

        linux   /vmlinuz-3.14.14-gentoo root=/dev/sdb6 init=/usr/lib/systemd/systemd
}
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7132
Location: Saint Amant, Acadiana

PostPosted: Thu Oct 02, 2014 10:02 pm    Post subject: Reply with quote

Code:
# mount /boot
# ls -l /boot

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
xaon
n00b
n00b


Joined: 28 Jun 2014
Posts: 21

PostPosted: Thu Oct 02, 2014 10:49 pm    Post subject: Reply with quote

Jaglover wrote:
Code:
# mount /boot
# ls -l /boot



you are absolute right!! and how stupid am i ...

thank you guys!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum