Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] SAMBA + CUPS == keine Drucker
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1792
Location: Oranienburg/Germany

PostPosted: Sat Oct 04, 2014 2:27 pm    Post subject: [solved] SAMBA + CUPS == keine Drucker Reply with quote

Hallo Leute,

ich versuche gerade mein RPi mit Debian gegen ein CubieTruck mit Gentoo auszutauschen. Da der RPi Print-/Scanner Server sowie WLAN AP spielt, sollen diese Funktionen auch wieder laufen. Leider habe ich Probleme, dass die SAMBA Installation die in CUPS konfigurierten Drucker zu erkennen. Als erstes möchte ich ja nur den PDF Drucker frei geben. Folgende Versionen sind installiert:

Code:

[I] net-print/cups-filters
     Available versions:  1.0.53 ~1.0.54 **9999 {dbus +foomatic jpeg perl png static-libs tiff zeroconf}
     Installed versions:  1.0.53(02:04:13 04.10.2014)(foomatic -dbus -jpeg -perl -png -static-libs -tiff -zeroconf)
     Homepage:            http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat
     Description:         Cups PDF filters

[I] net-print/cups-pdf
     Available versions:  *2.6.1 (~)3.0_beta1 {+ppds}
     Installed versions:  3.0_beta1(13:09:52 04.10.2014)(ppds)
     Homepage:            http://www.cups-pdf.de/
     Description:         Provides a virtual printer for CUPS to produce PDF files
[I] net-fs/samba
     Available versions:  [M]3.5.21^t [M]3.5.22^t 3.6.23^t (~)3.6.23-r1^t (~)3.6.24^t [M]~*4.0.21^m [M]~*4.0.22^m [M]~*4.1.11^m [M]~*4.1.12^m {acl addns ads (+)aio avahi caps (+)client cluster cups debug dmapi doc examples fam gnutls iprint ldap ldb +netapi pam quota +readline selinux +server +smbclient smbsharemodes smbtav2 swat syslog test (+)winbind ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" PYTHON_TARGETS="python2_7"}
     Installed versions:  3.6.24^t(16:08:44 04.10.2014)(acl aio client cups ldap ldb netapi pam quota readline server smbclient smbsharemodes swat syslog winbind -addns -ads -avahi -caps -cluster -debug -dmapi -doc -examples -fam -selinux ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="-32 -64 -x32")
     Homepage:            http://www.samba.org/
     Description:         Samba Suite Version 4


Meine smb.conf sieht folgendermaßen aus:
Code:

[global]
   server string = %h server (Samba, Gentoo ARM %v)
   map to guest = Bad User
   obey pam restrictions = Yes
   pam password change = Yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   unix password sync = Yes
   syslog = 0
   log file = /var/log/samba/log.%m
   max log size = 1000
   printcap name = cups
   printing = cups
   load printers = yes
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   guest ok = yes

[print$]
   comment = Printer Drivers
   path = /etc/samba/printer ## # this path holds the driver structure
   guest ok = yes
   browseable = yes
   read only = yes
   write list = root

[printers]
   comment = printers
   path = /var/spool/samba
   create mask = 0700
   printable = Yes
   print ok = Yes
   browseable = no
   public = yes
   writeable = no
   guest ok = yes
   printer admin = root


Egal was ich versuche, die Drucker tauchen nicht auf :(

Code:

smbclient -L localhost
Enter root's password:
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.24]

   Sharename       Type      Comment
   ---------       ----      -------
   print$          Disk      Printer Drivers
   IPC$            IPC       IPC Service (cubietruck server (Samba, Gentoo ARM 3.6.24))
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.24]

   Server               Comment
   ---------            -------
   CUBIETRUCK           cubietruck server (Samba, Gentoo ARM 3.6.24)

   Workgroup            Master
   ---------            -------
   WORKGROUP            CUBIETRUCK


Auf meinem RPi sieht das anders aus:

Code:

smbclient -L raspi
Enter root's password:
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]

   Sharename       Type      Comment
   ---------       ----      -------
   IPC$            IPC       IPC Service (raspi server (Samba, Debian 7.5))
   Virtual_PDF_Printer Printer   Virtual PDF Printer
   HP_DeskJet_1050A Printer   HP_DeskJet_1050A
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]

   Server               Comment
   ---------            -------
   RASPI                raspi server (Samba, Debian 7.5)

   Workgroup            Master
   ---------            -------
   WORKGROUP            cubietruck


Hat vielleicht einer von euch eine Idee, woran das liegen könnte. Bei Google habe ich bis dato noch nichts passendes gefunden.

Danke im Voraus.

Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 16GB, 620GB
3rd: i5-4570, 16GB, 10,5TB
4th: Asus N61VN, 8GB, 240GB
5th: C2D T7200, 2GB, 16GB USB + NFS


Last edited by bbgermany on Tue Oct 07, 2014 9:24 am; edited 1 time in total
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1792
Location: Oranienburg/Germany

PostPosted: Tue Oct 07, 2014 9:24 am    Post subject: Reply with quote

Hi Leute,

habe es selber gefunden. Das kommt davon, wenn man "nur" Konfigurationsdateien kopiert aber nicht auf die Distribution anpasst. Die folgende Zeile hat gefehlt in der cupsd.conf:

Code:

Listen /run/cups/cups.sock


MfG. Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 16GB, 620GB
3rd: i5-4570, 16GB, 10,5TB
4th: Asus N61VN, 8GB, 240GB
5th: C2D T7200, 2GB, 16GB USB + NFS
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum