Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unsolvable blockers on installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Sat Oct 04, 2014 3:42 pm    Post subject: Unsolvable blockers on installation Reply with quote

Hey folks, just decided to install gentoo on my gf's laptop. I am having some severe issues here. I tried to lookup the libav/ffmpeg blocker here, but none of thwe solutions worked for me. How can this happen with a stage3-tarball from yesterday? If I were a total noob, I would have already been gone by now.
Here's what happens, and yes, I copied over the world file from another computer, so I won't have to emerge everything manually. USE="threads" is set globally.
Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.1:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Module-Build-0.420.500:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                 
    (and 6 more with the same problem)

  (dev-lang/perl-5.18.2-r1:0/5.18::gentoo, installed) pulled in by
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/SGMLSpm-1.03-r7:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    (and 5 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/libav-9.16:0/9::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/libav-9.12[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] (>=media-video/libav-9.12[abi_x86_32(-),abi_x86_64(-),X,encode,jpeg2k,mp3,sdl,theora,threads,truetype,vaapi,vdpau,x264]) required by (virtual/ffmpeg-9-r1:0/0::gentoo, ebuild scheduled for merge)

  (media-video/vlc-2.1.5:0/5-7::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/vlc-2.0.1:=[dbus,ogg,vorbis] required by (media-libs/phonon-vlc-0.8.0:0/0::gentoo, ebuild scheduled for merge)

  (media-video/ffmpeg-2.2.7:0/52.55.55::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/ffmpeg-1.2.6-r1:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-video/ffmpeg-1.2.6-r1:0[abi_x86_32(-),abi_x86_64(-)]) required by (media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r2:0.10/0.10::gentoo, ebuild scheduled for merge)
    >=media-video/ffmpeg-1.2:0 required by (media-video/vlc-2.1.5:0/5-7::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13865

PostPosted: Sat Oct 04, 2014 4:49 pm    Post subject: Reply with quote

If you were a total newbie, you could be forgiven for failing to post emerge --info and your package.use settings, if any.

Remove vlc for now. Check that your USE choices are consistent between virtual/ffmpeg and media-video/ffmpeg. Check that you used --newuse in your emerge. If none of that works, remove the imported world file and use it as a reference for what to install, rather than putting it directly in /var/lib/portage.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Mon Oct 13, 2014 7:35 pm    Post subject: Reply with quote

I'm having a similar problem with perl Blockers. Is there a new perl snafu?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43213
Location: 56N 3W

PostPosted: Mon Oct 13, 2014 8:03 pm    Post subject: Reply with quote

audiodef,

Its a feature.

Update all of the Perl virtuals that you have installed
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Tue Oct 14, 2014 1:21 am    Post subject: Reply with quote

perl-cleaner reallyall will likely fail and give you the answer
Quote:
*perl-cleaner is stopping here:
* Fix the problem and start perl-cleaner again.
*
* If you encounter blockers involving virtuals and perl-core, here are
* some things to try:
* Remove all perl-core packages from your world file
* emerge --deselect --ask $(qlist -IC 'perl-core/*')
* Update all the installed Perl virtuals
* emerge -uD1a $(qlist -IC 'virtual/perl-*')
* Afterwards re-run perl-cleaner
which sometimes does the trick.

emerge -uD1a $(qlist -IC 'virtual/perl-*') implements Neddy's solution.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum