Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installation toute fraîche et blocages systemd/udev
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
b0z
n00b
n00b


Joined: 08 Oct 2014
Posts: 3

PostPosted: Sat Oct 11, 2014 10:33 am    Post subject: Installation toute fraîche et blocages systemd/udev Reply with quote

Bonjour à tous,

Utilisateur quotidien de gentoo depuis maintenant plusieurs mois, je dois avouer que ma compréhension du fonctionnement de gentoo se heurte aujourd'hui à un problème que je ne parviens pas à élucider: j'ai hier décidé de réinstaller complètement ma machine afin d'éviter les écueils découvert lors de ma première aventure. Soucieux de ne rien oublier, j'ai suivi de près le manuel gentoo pour architectures AMD64, avec quelques variantes pour obtenir un support UEFI et un système d'initialisation différent d'openRC (systemd).

Voici les différents éléments qui pourront vous aider à résoudre mon problème:
- j'ai ajouté le support pour systemd dans le kernel
- j'ai selectionné le profil gnome/systemd
- je n'ai pas encore booté sur mon kernel compilé, je suis encore en liveUSB

Alors que je passe à l'installation de syslog-ng, portage me pète la traditionnelle erreur (udev is blocking systemd, systemd is blocking udev...). Un petit equery list * m'a fait comprendre qu'udev est déjà installé, ce que je voulais justement éviter pour n'utiliser plus que systemd (rapport à gnome). Comment puis-je me sortir de cette situation sans casser mon système ?

PS: désolé s'il manque des copies de terminal, je créé ce topic depuis une autre machine, n'hésitez à me demander plus de précisions.

Merci d'avance !
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Sat Oct 11, 2014 11:48 am    Post subject: Reply with quote

Bonjour à toi!

Je pense qu'il faut que tu regardes un peu plus de littérature gentoo sur systemd, car il me semble que depuis un moment, les trolls à chapeau rouge on fusionné udev avec systemd. D'où le fait qu'avoir un ebuild udev autonome et un ebuild systemd avec udev embarqué en même temps couine.
Mais je peux me tromper.

[off]J'ai même pas vomi \o/ ;) [/off]
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
b0z
n00b
n00b


Joined: 08 Oct 2014
Posts: 3

PostPosted: Sat Oct 11, 2014 12:28 pm    Post subject: Reply with quote

Hey!

C'est effectivement ce que j'ai lu, donc intuitivement ce que j'aurais envie de faire serait de unmerge udev et de foutre systemd à la place, mais je crains qu'au redémarrage le système ne se lance pas correctement...

Anyway, je vais essayer ^^
Back to top
View user's profile Send private message
b0z
n00b
n00b


Joined: 08 Oct 2014
Posts: 3

PostPosted: Sat Oct 11, 2014 2:25 pm    Post subject: Reply with quote

Problème réglé, pour ceux que ça intéresse:

Bien qu'ayant sélectionné le profil gnome/systemd, certains paquets n'ont pas du être installés avec le flag USE systemd, une bonne mise à jour du set world a donc régénéré les paquets bloquants avec les bonnes options (si je ne me trompe pas :-) )

Tchou
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum