Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Is there an easy way to update the whole system?
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Sat Oct 11, 2014 2:27 pm    Post subject: [Solved] Is there an easy way to update the whole system? Reply with quote

I think there may be some version conflicts or something in my system:

Code:
# emerge net-wireless/wpa_supplicant


ended up:

Code:
 ...
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.1h-r1::gentoo, installed) pulled in by
    >=dev-libs/openssl-0.9.6d:0[bindist=] required by (net-misc/openssh-6.6_p1-r1::gentoo, installed)

  (dev-libs/openssl-1.0.1i::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.1h-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-nds/openldap-2.4.38-r2::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)



dev-libs/glib:2

  (dev-libs/glib-2.40.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.40.0:2 required by (dev-util/gdbus-codegen-2.40.0::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

  (dev-libs/glib-2.38.2-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.1-r4::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2[python,python_targets_python2_7(-),python_single_target_python2_7(+)] required by (media-libs/mesa-10.0.4::gentoo, ebuild scheduled for merge)

  (dev-libs/libxml2-2.9.1-r4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Scalar-List-Utils-1.270.0::gentoo, installed)                                                                             
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/File-Spec-3.400.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-CoreList-2.840.0::gentoo, installed)
    =dev-lang/perl-5.16* required by (virtual/perl-Time-HiRes-1.972.500-r2::gentoo, ebuild scheduled for merge)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Zlib-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Bzip2-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-Compress-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Test-Harness-3.260.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-0.240.0::gentoo, installed)
    (and 6 more with the same problems)

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-Storable-2.410.0-r1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)


Last edited by turboscrew on Fri Oct 24, 2014 11:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13842

PostPosted: Sat Oct 11, 2014 3:19 pm    Post subject: Reply with quote

What is the output of emerge --info ; emerge --pretend --update --verbose --deep --newuse @world?
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Sun Oct 12, 2014 1:11 am    Post subject: Reply with quote

Aargh: now it doesn't boot up to command prompt all of a sudden.
I saw something like "welcome to Gentoo" somewhere in the start-up logs.
Then as if there were a screen clear, then only blinking underscore.

Have to sort that out first.
Are the start-up logs written in some log file?
Or should I start over with the install?
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sun Oct 12, 2014 8:09 am    Post subject: Reply with quote

turboscrew wrote:
Aargh: now it doesn't boot up to command prompt all of a sudden.
I saw something like "welcome to Gentoo" somewhere in the start-up logs.
Then as if there were a screen clear, then only blinking underscore.

Have to sort that out first.
Are the start-up logs written in some log file?

Everything usually logs what it's doing in /var/log/messages (for userland) and /var/log/dmesg (kernel.)

However if your machine is not getting to startup of syslogd, the former won't have been written to. Where things are logged exactly can also vary with configuration.

Not sure by what mechanism the latter will be written once /var is mounted, but it's a ring buffer so gets overwritten in any case, afaik. Hu might have a better idea.
Quote:
Or should I start over with the install?

No you never do that (though it's sometimes recommended, if you haven't run emerge for 2 years or sth). The most you need to do is reboot from the live disk, and chroot in. (Those insns are bit out of date, as I'm fairly sure you need /sys as well: follow the link to the handbook, and let me know how you get on.)

I'd recommend you boot from sysresccd since it's a Gentoo downstream and much easier to run from; that way you can use IRC: chat.freenode.net and /join #gentoo for live support from over 900 people. (Don't worry; most of them won't say anything;)

If you have a live disk you're comfortable with, that's fine too, of course. :)
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Sun Oct 12, 2014 9:48 am    Post subject: Reply with quote

I have the rescue cd, but I've been using the Gentoo Live DVD mostly
(Gentoo Linux 2012 Hybrid Media)
I remember it was the "livedvd-amd64-multilib-2012.1.iso"
from http://gentoo.osuosl.org//releases/amd64/12.1/

I looked into the dmesg, but I didn't find anything suspicious there.
The messages-file seems to be of some funny format when I opened it in editor.
"cat messages | less" seems to be showing it fine, however.


It looks like it is stuck in a loop with mouse. This repeats:

Code:
Oct  4 13:22:23 JAA-GENTOO kernel: [518801.065488] hid-generic 0003:093A:2510.20C0: input,hidraw0: USB HID v1.11 Mouse [PixArt USB Optical Mouse] on usb-0000:00:02.0-4/input0
Oct  4 13:23:23 JAA-GENTOO kernel: [518861.065088] usb 2-4: USB disconnect, device number 69
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.751029] usb 2-4: new low-speed USB device number 70 using ohci-pci
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.940041] usb 2-4: New USB device found, idVendor=093a, idProduct=2510
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.940044] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.940046] usb 2-4: Product: USB Optical Mouse
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.940048] usb 2-4: Manufacturer: PixArt
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.950366] input: PixArt USB Optical Mouse as /devices/pci0000:00/0000:00:02.0/usb2/2-4/2-4:1.0/input/input8399
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.950507] hid-generic 0003:093A:2510.20C1: input,hidraw0: USB HID v1.11 Mouse [PixArt USB Optical Mouse] on usb-0000:00:02.0-4/input0
Oct  4 13:24:25 JAA-GENTOO kernel: [518922.950090] usb 2-4: USB disconnect, device number 70
Oct  4 13:24:27 JAA-GENTOO kernel: [518924.636022] usb 2-4: new low-speed USB device number 71 using ohci-pci
Oct  4 13:24:27 JAA-GENTOO kernel: [518924.826043] usb 2-4: New USB device found, idVendor=093a, idProduct=2510
Oct  4 13:24:27 JAA-GENTOO kernel: [518924.826047] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Oct  4 13:24:27 JAA-GENTOO kernel: [518924.826049] usb 2-4: Product: USB Optical Mouse
Oct  4 13:24:27 JAA-GENTOO kernel: [518924.826051] usb 2-4: Manufacturer: PixArt
Oct  4 13:24:27 JAA-GENTOO kernel: [518924.836361] input: PixArt USB Optical Mouse as /devices/pci0000:00/0000:00:02.0/usb2/2-4/2-4:1.0/input/input8400
Oct  4 13:24:27 JAA-GENTOO kernel: [518924.836499] hid-generic 0003:093A:2510.20C2: input,hidraw0: USB HID v1.11 Mouse [PixArt USB Optical Mouse] on usb-0000:00:02.0-4/input0
Oct  4 13:25:27 JAA-GENTOO kernel: [518984.836094] usb 2-4: USB disconnect, device number 71
Oct  4 13:25:29 JAA-GENTOO kernel: [518986.522023] usb 2-4: new low-speed USB device number 72 using ohci-pci
Oct  4 13:25:29 JAA-GENTOO kernel: [518986.712039] usb 2-4: New USB device found, idVendor=093a, idProduct=2510
Oct  4 13:25:29 JAA-GENTOO kernel: [518986.712042] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Oct  4 13:25:29 JAA-GENTOO kernel: [518986.712045] usb 2-4: Product: USB Optical Mouse
Oct  4 13:25:29 JAA-GENTOO kernel: [518986.712047] usb 2-4: Manufacturer: PixArt


And I don't even have X installed.

Anyway, I'll boot into the Live DVD and run the command in a chrooted terminal?
("emerge --info ; emerge --pretend --update --verbose --deep --newuse @world")
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1969

PostPosted: Sun Oct 12, 2014 11:57 am    Post subject: Reply with quote

turboscrew wrote:
I have the rescue cd, but I've been using the Gentoo Live DVD mostly
(Gentoo Linux 2012 Hybrid Media)
I remember it was the "livedvd-amd64-multilib-2012.1.iso"
from http://gentoo.osuosl.org//releases/amd64/12.1/

I looked into the dmesg, but I didn't find anything suspicious there.
The messages-file seems to be of some funny format when I opened it in editor.
"cat messages | less" seems to be showing it fine, however.


If you are using systemd, the logs are binary. I think there's a special reader to handle them.

Will
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Sun Oct 12, 2014 2:00 pm    Post subject: Reply with quote

I've been under the impression that 3.12.21-gentoo-r1 uses OpenRC.
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Sun Oct 12, 2014 3:07 pm    Post subject: Reply with quote

Ah, my 3rd boot (Sabayon) install messed up the Gentoo boot.
(Using Sabayon now for "live DVD").

But the command:

(
Code:
chroot) JAASABAYON / # emerge --info ; emerge --pretend --update --verbose --deep --newuse @world
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.16.0-sabayon x86_64)
=================================================================
System uname: Linux-3.16.0-sabayon-x86_64-AMD_Phenom-tm-_8550_Triple-Core_Processor-with-gentoo-2.2
KiB Mem:     3079076 total,   1422992 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of tree: Sat, 06 Sep 2014 00:45:01 +0000
ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.6, 3.3.3
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/"
LANG="en_US.iso88591"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.fi.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cdrbindist cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

 * Last emerge --sync was 36d 17h 27m 7s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/glibc-2.19-r1:2.2 [2.17:2.2] USE="(multilib) -debug -gd (-hardened) -nscd -profile (-selinux) -suid -systemtap -vanilla" 19,754 kB
[ebuild     U  ] virtual/libintl-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] sys-devel/gnuconfig-20140212 [20131128] 44 kB
[ebuild     U  ] sys-libs/gdbm-1.11 [1.8.3-r4] USE="berkdb nls%* -exporter% -static-libs%" ABI_X86="(64%*) (-32) (-x32)" 793 kB
[ebuild  N     ] media-libs/libogg-1.3.1  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 398 kB
[ebuild     U  ] sys-libs/timezone-data-2014f [2014a] USE="nls -right_timezone%" 396 kB
[ebuild  N     ] app-text/poppler-data-0.4.6  4,085 kB
[ebuild  N     ] dev-libs/lzo-2.08:2  USE="-examples -static-libs" ABI_X86="(64) (-32) (-x32)" 576 kB
[ebuild  N     ] media-libs/libdvdcss-1.2.13-r1:1.2  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 331 kB
[ebuild  N     ] sys-libs/libutempter-1.1.6-r1  USE="-static-libs" 16 kB
[ebuild  N     ] dev-libs/libaio-0.3.109-r4  USE="multilib -static-libs {-test}" 43 kB
[ebuild  N     ] dev-libs/gobject-introspection-common-1.40.0  1,257 kB
[ebuild  N     ] app-arch/rpm2targz-9.0.0.5g  6 kB
[ebuild  N     ] dev-libs/libksba-1.3.0  USE="-static-libs" 611 kB
[ebuild  N     ] dev-libs/libassuan-2.1.1  USE="-static-libs" 526 kB
[ebuild  N     ] kde-base/kde-env-4.12.5:4/4.12  USE="(-aqua)" 0 kB
[ebuild  N     ] dev-libs/pth-2.0.7-r3  USE="-debug -static-libs" 638 kB
[ebuild  N     ] dev-db/mysql-init-scripts-2.0_pre1-r6  0 kB
[ebuild     U  ] virtual/udev-215 [208-r2] USE="-systemd% (-gudev%) (-introspection%) (-static-libs%)" ABI_X86="(-32%) (-64%*) (-x32%)" 0 kB
[ebuild  N     ] dev-libs/libatasmart-0.19-r1  USE="-static-libs" 252 kB
[ebuild     U  ] net-misc/dhcpcd-6.4.3 [6.2.0-r1] USE="ipv6 udev" 147 kB
[ebuild  N     ] app-admin/eselect-opengl-1.2.7  81 kB
[ebuild  N     ] app-admin/eselect-lib-bin-symlink-0.1.1  45 kB
[ebuild  N     ] app-admin/eselect-cdparanoia-0.1  0 kB
[ebuild  N     ] app-admin/eselect-pinentry-0.4  0 kB
[ebuild     U  ] virtual/pam-0-r1 [0] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  N     ] app-admin/eselect-mesa-0.0.10  3 kB
[ebuild     U  ] sys-apps/man-pages-3.70 [3.67] USE="nls" LINGUAS="-da -de -fr -it -ja -nl -pl -ro -ru -zh_CN" 1,242 kB
[ebuild   R    ] sys-libs/ncurses-5.9-r3:5  USE="cxx gpm* unicode -ada -debug -doc -minimal -profile -static-libs -tinfo -trace" ABI_X86="(64) (-32) (-x32)" 2,761 kB
[ebuild     U  ] sys-apps/less-458 [457] USE="pcre unicode" 500 kB
[ebuild     U  ] app-admin/perl-cleaner-2.16 [2.15] 6 kB
[ebuild  N     ] virtual/eject-0  0 kB
[ebuild     U  ] virtual/libudev-215-r1:0/1 [208:0/1] USE="-static-libs -systemd%" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] dev-libs/libusb-1.0.18:1  USE="udev -debug -doc -examples -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 491 kB
[ebuild  N     ] virtual/libusb-1-r1:1  USE="udev" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild   R    ] sys-libs/zlib-1.2.8-r1  USE="minizip* -static-libs" ABI_X86="(64) (-32) (-x32)" 558 kB
[ebuild  N     ] x11-proto/xf86vidmodeproto-2.3.1-r1  ABI_X86="(64) (-32) (-x32)" 95 kB
[ebuild     U  ] sys-libs/db-4.8.30-r1:4.8 [4.8.30:4.8] USE="cxx -doc -examples -java -tcl {-test}" ABI_X86="(64%*) (-32) (-x32)" 22,351 kB
[ebuild  N     ] x11-proto/xineramaproto-1.2.1-r1  ABI_X86="(64) (-32) (-x32)" 94 kB
[ebuild  N     ] dev-db/sqlite-3.8.4.3:3  USE="readline -debug -doc -icu -secure-delete -static-libs -tcl {-test}" ABI_X86="(64) (-32) (-x32)" 1,892 kB
[ebuild  N     ] media-libs/alsa-lib-1.0.27.2  USE="-alisp -debug -doc -python" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 886 kB
[ebuild  N     ] media-libs/libdvdread-4.2.1  USE="css" ABI_X86="(64) (-32) (-x32)" 94 kB
[ebuild  N     ] x11-proto/damageproto-1.2.1-r1  ABI_X86="(64) (-32) (-x32)" 97 kB
[ebuild     U  ] dev-libs/libgcrypt-1.5.4:0/11 [1.5.3:0/11] USE="-static-libs" 1,478 kB
[ebuild  N     ] app-text/libpaper-1.1.24-r2  ABI_X86="(64) (-32) (-x32)" 347 kB
[ebuild  N     ] dev-libs/libgamin-0.1.10-r4  USE="-debug -python -static-libs" ABI_X86="(64) (-32) (-x32)" 850 kB
[ebuild  N     ] x11-proto/recordproto-1.14.2-r1  USE="-doc" ABI_X86="(64) (-32) (-x32)" 121 kB
[ebuild  N     ] x11-proto/fixesproto-5.0-r1  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/pixman-0.32.4  USE="sse2 (-altivec) (-iwmmxt) (-loongson2f) -mmxext (-neon) -ssse3 -static-libs" ABI_X86="(64) (-32) (-x32)" 685 kB
[ebuild  N     ] x11-apps/rgb-1.0.5  128 kB
[ebuild  N     ] x11-apps/iceauth-1.0.6  131 kB
[ebuild  N     ] dev-libs/libnatspec-0.2.6  USE="-doc -python" 489 kB
[ebuild  N     ] media-libs/libmad-0.15.1b-r8  USE="-debug -static-libs" ABI_X86="(64) (-32) (-x32)" 491 kB
[ebuild  N     ] media-libs/libvorbis-1.3.4  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 1,066 kB
[ebuild  N     ] media-libs/a52dec-0.7.4-r6  USE="-djbfft -oss -static-libs" 236 kB
[ebuild  N     ] media-libs/libdca-0.0.5-r3  USE="-debug -oss -static-libs" ABI_X86="(64) (-32) (-x32)" 388 kB
[ebuild  N     ] media-libs/faad2-2.7-r3  USE="-digitalradio -static-libs" ABI_X86="(64) (-32) (-x32)" 1,111 kB
[ebuild  N     ] dev-libs/nettle-2.7.1:0/4  USE="gmp -doc (-neon) -static-libs {-test}" 1,523 kB
[ebuild  N     ] x11-proto/scrnsaverproto-1.2.2-r1  USE="-doc" ABI_X86="(64) (-32) (-x32)" 117 kB
[ebuild  N     ] x11-proto/compositeproto-0.4.2-r1  ABI_X86="(64) (-32) (-x32)" 99 kB
[ebuild  N     ] dev-libs/icu-52.1:0/52  USE="-debug -doc -examples -static-libs" ABI_X86="(64) (-32) (-x32)" 23,316 kB
[ebuild  N     ] dev-libs/nspr-4.10.6-r1  USE="-debug" ABI_X86="(64) (-32) (-x32)" 1,105 kB
[ebuild  N     ] x11-libs/libxshmfence-1.1  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 285 kB
[ebuild  N     ] media-sound/cdparanoia-3.10.2-r6  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 186 kB
[ebuild  N     ] x11-proto/dri2proto-2.8-r1  ABI_X86="(64) -32 (-x32)" 107 kB
[ebuild  N     ] x11-proto/presentproto-1.0  ABI_X86="(64) -32 (-x32)" 106 kB
[ebuild  N     ] x11-proto/glproto-1.4.17  ABI_X86="(64) -32 (-x32)" 124 kB
[ebuild  N     ] x11-proto/dri3proto-1.0  ABI_X86="(64) -32 (-x32)" 103 kB
[ebuild  N     ] x11-proto/xf86driproto-2.1.1-r1  ABI_X86="(64) -32 (-x32)" 95 kB
[ebuild     U  ] dev-lang/perl-5.18.2-r1:0/5.18 [5.16.3:0/5.16] USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB
[ebuild   R    ] media-libs/libpng-1.6.12:0/16  USE="apng* (-neon) -static-libs" ABI_X86="(64) (-32) (-x32)" 10 kB
[ebuild  N     ] media-libs/lcms-2.5:2  USE="jpeg tiff zlib -doc -static-libs {-test}" 6,837 kB
[ebuild   R    ] app-arch/unzip-6.0-r3  USE="bzip2 natspec* unicode" 1,345 kB
[ebuild     U  ] sys-libs/cracklib-2.9.1-r1 [2.9.1] USE="nls zlib -python -static-libs {-test}" ABI_X86="(64%*) (-32) (-x32)" PYTHON_TARGETS="python2_7" 621 kB
[ebuild  N     ] media-libs/libdvdnav-4.2.1  ABI_X86="(64) (-32) (-x32)" 108 kB
[ebuild  N     ] x11-libs/libpciaccess-0.13.2  USE="zlib -minimal -static-libs" ABI_X86="(64) (-32) (-x32)" 351 kB
[ebuild  N     ] x11-libs/libfontenc-1.1.2  USE="-static-libs" 288 kB
[ebuild     U  ] dev-libs/openssl-1.0.1i [1.0.1h-r1] USE="(sse2) tls-heartbeat zlib -bindist* -gmp -kerberos -rfc3779 -static-libs {-test} -vanilla" ABI_X86="(64%*) (-32) (-x32)" 4,323 kB
[ebuild   R    ] media-libs/freetype-2.5.3-r1:2  USE="X* adobe-cff bzip2 png* -auto-hinter -bindist -debug -doc -fontforge (-harfbuzz) -infinality -static-libs -utils" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild     U  ] virtual/perl-File-Spec-3.400.0-r2 [3.400.0-r1] 0 kB
[ebuild  N     ] media-libs/libmng-2.0.2-r1:0/2  USE="lcms -static-libs" ABI_X86="(64) (-32) (-x32)" 930 kB
[ebuild  N     ] media-libs/jbig2dec-0.11-r1  USE="png -static-libs {-test}" 363 kB
[ebuild  N     ] app-text/qpdf-5.1.1:0/13  USE="-doc -examples -static-libs {-test}" 7,484 kB
[ebuild  N     ] app-dicts/myspell-en-20081002  6,881 kB
[ebuild  N     ] app-crypt/mhash-0.9.9.9-r1  USE="-static-libs" 910 kB
[ebuild  N     ] x11-libs/libdrm-2.4.52  USE="-libkms -static-libs" ABI_X86="(64) (-32) (-x32)" VIDEO_CARDS="intel nouveau radeon vmware (-exynos) (-freedreno) (-omap)" 539 kB
[ebuild     U  ] dev-perl/TermReadKey-2.300.200-r1 [2.300.200] 37 kB
[ebuild  N     ] dev-perl/Net-Daemon-0.480.0-r1  29 kB
[ebuild  N     ] virtual/perl-Storable-2.410.0-r1  0 kB
[ebuild  N     ] virtual/perl-Sys-Syslog-0.320.0-r2  0 kB
[ebuild  N     ] virtual/perl-Time-HiRes-1.972.500-r2  0 kB
[ebuild  N     ] virtual/perl-Term-ANSIColor-4.20.0-r2  0 kB
[ebuild  N     ] virtual/perl-Getopt-Long-2.390.0-r1  0 kB
[ebuild     U  ] dev-perl/XML-Parser-2.410.0-r2 [2.410.0] 233 kB
[ebuild  N     ] app-arch/zip-3.0-r1  USE="bzip2 crypt unicode -natspec" 1,258 kB
[ebuild  NS    ] sys-kernel/gentoo-sources-3.14.14:3.14.14 [3.12.21-r1:3.12.21-r1] USE="-build -deblob -experimental -symlink" 76,945 kB
[ebuild     U  ] dev-lang/python-2.7.7:2.7 [2.7.6:2.7] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -hardened -sqlite -tk -wininst" 10,264 kB
[ebuild     U  ] dev-lang/python-3.3.5-r1:3.3 [3.3.3:3.3] USE="gdbm ipv6 ncurses readline ssl threads xml -build -doc -examples -hardened -sqlite -tk -wininst" 11,845 kB
[ebuild  N     ] dev-lang/orc-0.4.19  USE="-examples -static-libs" ABI_X86="(64) (-32) (-x32)" 736 kB
[ebuild  N     ] dev-perl/File-BaseDir-0.30.0-r1  USE="{-test}" 6 kB
[ebuild  N     ] www-misc/htdig-3.2.0_beta6-r3  USE="ssl" 3,033 kB
[ebuild  N     ] dev-db/virtuoso-odbc-6.1.6  110,602 kB
[ebuild  N     ] dev-perl/PlRPC-0.202.0-r2  18 kB
[ebuild  N     ] x11-apps/mkfontscale-1.1.1  137 kB
[ebuild   R    ] dev-libs/libxml2-2.9.1-r4:2  USE="ipv6 python* readline -debug -examples -icu -lzma -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_2 (-python3_4)" 5,052 kB
[ebuild  N     ] dev-lang/spidermonkey-17.0.0-r3:17  USE="-debug -jit -minimal -static-libs {-test}" 6,621 kB
[ebuild  N     ] dev-perl/File-DesktopEntry-0.40.0-r1  USE="{-test}" 14 kB
[ebuild  N     ] app-misc/media-player-info-21-r1  101 kB
[ebuild  N     ] dev-perl/DBI-1.623.0  USE="{-test}" 583 kB
[ebuild  N     ] x11-apps/mkfontdir-1.0.7  106 kB
[ebuild  N     ] media-fonts/encodings-1.0.4  650 kB
[ebuild     U  ] dev-libs/libxslt-1.1.28-r3 [1.1.28-r1] USE="crypt -debug -python -static-libs" ABI_X86="(64%*) (-32) (-x32)" PYTHON_TARGETS="python2_7" 3,356 kB
[ebuild  N     ] media-fonts/urw-fonts-2.4.9  USE="X" 3,124 kB
[ebuild  N     ] dev-perl/File-MimeInfo-0.170.0-r1  USE="{-test}" 35 kB
[ebuild   R    ] media-fonts/dejavu-2.33  USE="X* -fontforge" 0 kB
[ebuild  N     ] app-arch/libarchive-3.1.2-r1:0/13  USE="acl bzip2 e2fsprogs iconv lzma zlib -expat -lzo -nettle -static-libs -xattr" 4,422 kB
[ebuild     U  ] dev-libs/glib-2.40.0-r1:2 [2.38.2-r1:2] USE="(mime) -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_TARGETS="python2_7" 8,738 kB
[ebuild  N     ] x11-libs/libxcb-1.10  USE="xkb -doc (-selinux) -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-gfx/exiv2-0.23-r1  USE="nls xmp zlib -contrib -doc -examples -static-libs" LINGUAS="-de -es -fi -fr -pl -ru -sk" 3,442 kB
[ebuild  N     ] media-libs/flac-1.3.0  USE="cxx ogg sse -3dnow (-altivec) -debug -static-libs" ABI_X86="(64) (-32) (-x32)" 1,059 kB
[ebuild   R    ] sys-process/psmisc-22.20  USE="X* ipv6 nls (-selinux)" 423 kB
[ebuild  N     ] app-text/iso-codes-3.55  LINGUAS="-af -am -ar -as -ast -az -be -bg -bn -bn_IN -br -bs -byn -ca -crh -cs -cy -da -de -dz -el -en -eo -es -et -eu -fa -fi -fo -fr -ga -gez -gl -gu -haw -he -hi -hr -hu -hy -ia -id -is -it -ja -ka -kk -km -kn -ko -kok -ku -lt -lv -mi -mk -ml -mn -mr -ms -mt -nb -ne -nl -nn -nso -oc -or -pa -pl -ps -pt -pt_BR -ro -ru -rw -si -sk -sl -so -sq -sr -sr@latin -sv -sw -ta -te -th -ti -tig -tk -tl -tr -tt -tt@iqtelif -ug -uk -ve -vi -wa -wal -wo -xh -zh_CN -zh_HK -zh_TW -zu" 3,682 kB
[ebuild  N     ] sys-block/parted-3.1-r1  USE="debug nls readline -device-mapper (-selinux) -static-libs {-test}" 1,489 kB
[ebuild  N     ] app-text/hunspell-1.3.2-r3  USE="ncurses nls readline -static-libs" LINGUAS="-af -bg -ca -cs -cy -da -de -el -en -eo -es -et -fo -fr -ga -gl -he -hr -hu -ia -id -is -it -km -ku -lt -lv -mk -ms -nb -nl -nn -pl -pt -pt_BR -ro -ru -sk -sl -sq -sv -sw -tn -uk -zu" 954 kB
[ebuild     U  ] sys-devel/flex-2.5.39-r1 [2.5.37] USE="nls -static {-test}" ABI_X86="(64%*) -32% (-x32)" 1,316 kB
[ebuild  N     ] dev-lang/yasm-1.2.0-r1  USE="nls -python" PYTHON_TARGETS="python2_7" 1,413 kB
[ebuild     U  ] dev-perl/Locale-gettext-1.50.0-r1 [1.50.0] 8 kB
[ebuild   R    ] app-editors/nano-2.3.2  USE="magic ncurses nls spell* unicode -debug -justify -minimal -slang" 1,686 kB
[ebuild  N     ] x11-libs/libX11-1.6.2  USE="ipv6 -doc -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] dev-util/desktop-file-utils-0.22  USE="-emacs" 128 kB
[ebuild  N     ] app-text/enchant-1.6.0  USE="hunspell -aspell -static-libs -zemberek" 593 kB
[ebuild  N     ] media-libs/xvid-1.3.3  USE="threads -examples -pic" ABI_X86="(64) (-32) (-x32)" 679 kB
[ebuild  N     ] media-libs/audiofile-0.3.6-r1:0/1  USE="flac -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 519 kB
[ebuild  N     ] media-libs/x264-0.0.20140308:0/142  USE="interlaced sse threads -10bit -opencl -pic -static-libs" ABI_X86="(64) (-32) (-x32)" 611 kB
[ebuild  N     ] app-admin/gam-server-0.1.10-r1  USE="-debug" 0 kB
[ebuild  N     ] dev-util/gdbus-codegen-2.40.0  PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 kB
[ebuild     U  ] app-admin/syslog-ng-3.4.8 [3.4.7] USE="ipv6 pcre ssl tcpd -amqp% -caps -dbi -geoip -json -mongodb -pacct% -smtp -spoof-source -systemd" 3,096 kB
[ebuild  N     ] x11-libs/libXext-1.3.2  USE="-doc -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXrender-0.9.8  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXfixes-5.0.1  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-apps/xprop-1.2.2  143 kB
[ebuild  N     ] media-libs/giflib-4.1.6-r3  USE="X -rle -static-libs" ABI_X86="(64) (-32) (-x32)" 495 kB
[ebuild  N     ] dev-libs/libtasn1-3.6:0/6  USE="-doc -static-libs" ABI_X86="(64) (-32) (-x32)" 1,806 kB
[ebuild  N     ] app-admin/gamin-0.1.10-r1  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXi-1.7.2  USE="-doc -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXcursor-1.1.14  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXrandr-1.4.2  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXinerama-1.1.3  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 272 kB
[ebuild  N     ] x11-libs/libXv-1.0.10  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXdamage-1.1.4-r1  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 273 kB
[ebuild  N     ] x11-libs/libXcomposite-0.4.4-r1  USE="-doc -static-libs" ABI_X86="(64) (-32) (-x32)" 278 kB
[ebuild  N     ] virtual/fam-0-r1  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXScrnSaver-1.2.2-r1  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 284 kB
[ebuild  N     ] net-libs/gnutls-2.12.23-r6  USE="cxx nettle nls zlib -bindist -doc -examples -guile -lzo -pkcs11 -static-libs {-test}" 7,109 kB
[ebuild  N     ] x11-libs/libXxf86vm-1.1.3  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 278 kB
[ebuild  N     ] www-client/links-2.8-r1:2  USE="X bzip2 gpm ipv6 jpeg ssl tiff unicode zlib -directfb -fbcon -livecd -lzma (-suid) (-svga)" 0 kB
[ebuild  N     ] x11-libs/libXtst-1.2.2  USE="-doc -static-libs" ABI_X86="(64) (-32) (-x32)" 315 kB
[ebuild   R    ] dev-qt/qtcore-4.8.5-r2:4  USE="exceptions glib iconv qt3support* ssl (-aqua) -debug -icu -pch" 0 kB
[ebuild  N     ] dev-qt/qtscript-4.8.5:4  USE="exceptions iconv jit (-aqua) -debug -pch" 0 kB
[ebuild  N     ] dev-qt/qttest-4.8.5:4  USE="exceptions (-aqua) -debug -pch" 0 kB
[ebuild  N     ] dev-qt/qtxmlpatterns-4.8.5:4  USE="(-aqua) -debug -pch" 0 kB
[ebuild  N     ] app-crypt/qca-2.0.3:2  USE="(-aqua) -debug -doc -examples" 4,425 kB
[ebuild  N     ] media-libs/fontconfig-2.10.92:1.0  USE="-doc -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] app-admin/eselect-fontconfig-1.1  0 kB
[ebuild  N     ] x11-libs/libXft-2.3.1-r1  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 305 kB
[ebuild  N     ] dev-libs/gobject-introspection-1.40.0-r1  USE="cairo -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[ebuild  N     ] media-libs/gstreamer-0.10.36-r2:0.10  USE="introspection nls orc {-test}" ABI_X86="(64) (-32) (-x32)" 2,955 kB
[ebuild  N     ] media-libs/gst-plugins-base-0.10.36-r1:0.10  USE="introspection nls orc" ABI_X86="(64) (-32) (-x32)" 2,309 kB
[ebuild  N     ] media-libs/gst-plugins-ugly-0.10.19-r1:0.10  USE="nls orc" ABI_X86="(64) (-32) (-x32)" 862 kB
[ebuild  N     ] media-libs/gst-plugins-bad-0.10.23-r2:0.10  USE="nls orc" ABI_X86="(64) (-32) (-x32)" 3,087 kB
[ebuild  N     ] media-libs/gst-plugins-good-0.10.31-r1:0.10  USE="nls orc" ABI_X86="(64) (-32) (-x32)" 2,674 kB
[ebuild  N     ] dev-libs/atk-2.12.0-r1  USE="introspection nls {-test}" ABI_X86="(64) (-32) (-x32)" 673 kB
[ebuild  N     ] x11-libs/gdk-pixbuf-2.30.8:2  USE="X introspection jpeg tiff -debug -jpeg2k {-test}" ABI_X86="(64) (-32) (-x32)" 1,306 kB
[ebuild  N     ] media-plugins/gst-plugins-x-0.10.36-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-faad-0.10.23-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-dts-0.10.23-r1:0.10  USE="orc" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-dvdread-0.10.19-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-xvideo-0.10.36-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-x264-0.10.19-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-ogg-0.10.36-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-alsa-0.10.36-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-xvid-0.10.23-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-a52dec-0.10.19-r1:0.10  USE="orc" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-vorbis-0.10.36-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-mad-0.10.19-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-flac-0.10.31-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-resindvd-0.10.23-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-cdparanoia-0.10.36-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/xcb-util-0.3.9  USE="-doc -static-libs {-test}" 282 kB
[ebuild  N     ] x11-libs/xcb-util-wm-0.4.1  USE="-doc -static-libs {-test}" 315 kB
[ebuild  N     ] x11-libs/xcb-util-keysyms-0.3.9  USE="-doc -static-libs {-test}" 280 kB
[ebuild  N     ] x11-libs/xcb-util-renderutil-0.3.8  USE="-doc -static-libs {-test}" 252 kB
[ebuild  N     ] x11-libs/xcb-util-image-0.3.9  USE="-doc -static-libs {-test}" 304 kB
[ebuild     U  ] sys-libs/pam-1.1.8-r2 [1.1.6-r2] USE="berkdb cracklib nls -audit -debug -nis (-selinux) {-test} -vim-syntax" ABI_X86="(64%*) (-32) (-x32)" 1,267 kB
[ebuild   R    ] sys-apps/util-linux-2.24.1-r3  USE="cramfs ncurses nls pam suid udev* unicode -bash-completion -caps -cytune -fdformat -python (-selinux) -slang -static-libs {-test} -tty-helpers" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3 (-python3_4)" PYTHON_TARGETS="python2_7 python3_3 -python3_2 (-python3_4)" 3,461 kB
[ebuild  N     ] x11-libs/libSM-1.2.2  USE="ipv6 uuid -doc -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXt-1.1.4  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-libs/libXmu-1.1.2  USE="ipv6 -doc -static-libs" ABI_X86="(64) (-32) (-x32)" 387 kB
[ebuild     U  ] sys-fs/udev-215-r1 [215] USE="acl firmware-loader gudev* introspection* kmod -doc (-selinux) -static-libs" ABI_X86="(64) (-32) (-x32)" 2,825 kB
[ebuild  N     ] x11-libs/libXpm-3.5.11  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 434 kB
[ebuild  N     ] virtual/libgudev-215-r1  USE="introspection -static-libs -systemd" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] x11-apps/xset-1.2.3  139 kB
[ebuild  N     ] x11-libs/libXaw-1.0.12  USE="-deprecated -doc -static-libs" ABI_X86="(64) (-32) (-x32)" 662 kB
[ebuild   R    ] sys-apps/groff-1.22.2  USE="X* -examples" LINGUAS="-ja" 3,926 kB
[ebuild  N     ] net-nds/openldap-2.4.38-r2  USE="berkdb crypt ipv6 minimal ssl syslog tcpd -cxx -debug -experimental -gnutls -icu -iodbc -kerberos -odbc -overlays -perl -samba -sasl (-selinux) -slp -smbkrb5passwd" ABI_X86="(64) (-32) (-x32)" 5,390 kB
[ebuild  N     ] net-misc/curl-7.36.0  USE="ipv6 ldap ssl -adns -idn -kerberos -metalink -rtmp -ssh -static-libs {-test} -threads" CURL_SSL="openssl -axtls -gnutls -nss -polarssl" 2,744 kB
[ebuild  N     ] media-libs/raptor-2.0.9:2  USE="curl unicode -debug -json -static-libs" 1,747 kB
[ebuild  N     ] dev-libs/rasqal-0.9.29  USE="crypt mhash pcre xml -doc -gmp -static-libs {-test}" 1,514 kB
[ebuild  N     ] sys-apps/gptfdisk-0.8.10  USE="ncurses -static" 187 kB
[ebuild  N     ] dev-libs/redland-1.0.16  USE="berkdb xml -iodbc -mysql -odbc -postgres -sqlite -static-libs" 1,587 kB
[ebuild  N     ] dev-db/virtuoso-server-6.1.6  USE="ldap readline -kerberos" 0 kB
[ebuild  N     ] sys-apps/dbus-1.8.6  USE="X -debug -doc (-selinux) -static-libs -systemd {-test}" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] dev-qt/qtdbus-4.8.5:4  USE="exceptions (-aqua) -debug -pch" 0 kB
[ebuild  N     ] dev-libs/dbus-glib-0.100.2-r1  USE="-debug -doc -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 732 kB
[ebuild  N     ] x11-misc/xdg-utils-1.1.0_rc2  USE="perl -doc" 300 kB
[ebuild  N     ] app-accessibility/at-spi2-core-2.12.0:2  USE="X introspection" 445 kB
[ebuild  N     ] app-accessibility/at-spi2-atk-2.12.1:2  USE="{-test}" 274 kB
[ebuild  N     ] x11-apps/xauth-1.0.8  USE="ipv6" 144 kB
[ebuild  N     ] net-print/cups-1.7.3  USE="X acl dbus pam ssl threads usb -debug -gnutls -java -kerberos -lprng-compat -python (-selinux) -static-libs -systemd -xinetd -zeroconf" ABI_X86="(64) (-32) (-x32)" LINGUAS="ca es fr it ja pt_BR ru" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 8,587 kB
[ebuild  N     ] dev-qt/qtgui-4.8.5-r3:4  USE="accessibility cups exceptions glib mng qt3support tiff xinerama xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace" 0 kB
[ebuild  N     ] dev-util/cmake-2.8.12.2-r1  USE="ncurses qt4 -emacs (-qt5) {-test}" 5,927 kB
[ebuild  N     ] dev-qt/qtsvg-4.8.5:4  USE="accessibility exceptions (-aqua) -debug -pch" 0 kB
[ebuild  N     ] dev-qt/qtwebkit-4.8.5:4  USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" 0 kB
[ebuild  N     ] kde-base/oxygen-icons-4.12.5:4/4.12  USE="(-aqua) -bindist" 28,637 kB
[ebuild  N     ] dev-libs/shared-desktop-ontologies-0.11.0  3,875 kB
[ebuild  N     ] dev-libs/libattica-0.4.2  USE="qt4 -debug (-qt5) {-test}" 56 kB
[ebuild  N     ] dev-libs/libdbusmenu-qt-0.9.2  USE="-debug -doc {-test}" 238 kB
[ebuild  N     ] app-misc/strigi-0.7.8  USE="dbus exif fam qt4 -clucene -debug -ffmpeg -inotify (-log) {-test}" 792 kB
[ebuild  N     ] media-gfx/graphite2-1.2.4-r1  USE="-perl {-test}" ABI_X86="(64) (-32) (-x32)" 6,777 kB
[ebuild  N     ] dev-util/automoc-0.9.88  9 kB
[ebuild  N     ] sys-devel/llvm-3.3-r3:0/3.3  USE="libffi static-analyzer xml -clang -debug -doc -gold -multitarget -ocaml -python {-test} -udis86" ABI_X86="(64) (-32) (-x32)" PYTHON_TARGETS="python2_7 (-pypy)" VIDEO_CARDS="radeon" 13,311 kB
[ebuild  N     ] media-libs/mesa-10.0.4  USE="classic egl gallium llvm nptl -bindist -debug -gbm -gles1 -gles2 -llvm-shared-libs -opencl -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xvmc" ABI_X86="(64) (-32) (-x32)" VIDEO_CARDS="intel nouveau radeon vmware (-freedreno) -i915 -i965 -ilo -r100 -r200 -r300 -r600 -radeonsi" 6,636 kB
[ebuild  N     ] x11-libs/cairo-1.12.16  USE="X glib opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-gles2) -legacy-drivers -openvg (-qt4) -static-libs -valgrind -xlib-xcb" 35,049 kB
[ebuild  N     ] app-text/poppler-0.24.5:0/44  USE="cairo cxx introspection jpeg lcms png qt4 tiff utils -cjk -curl -debug -doc -jpeg2k" 1,478 kB
[ebuild  N     ] virtual/opengl-7.0-r1  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] dev-qt/qtopengl-4.8.5:4  USE="exceptions qt3support (-aqua) -debug -egl -pch" 0 kB
[ebuild  N     ] media-libs/harfbuzz-0.9.28:0/0.9.18  USE="cairo glib graphite introspection truetype -icu -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 1,039 kB
[ebuild  N     ] x11-libs/pango-1.36.5  USE="X introspection -debug" ABI_X86="(64) (-32) (-x32)" 1,000 kB
[ebuild  N     ] x11-libs/gtk+-2.24.24:2  USE="cups introspection xinerama (-aqua) -debug -examples {-test} -vim-syntax" ABI_X86="(64) (-32) (-x32)" 13,012 kB
[ebuild  N     ] app-text/ghostscript-gpl-9.10-r2  USE="X cups dbus gtk -bindist -djvu -idn -static-libs" LINGUAS="-de -ja -ko -zh_CN -zh_TW" 30,263 kB
[ebuild  N     ] net-print/cups-filters-1.0.53  USE="dbus foomatic jpeg png tiff -perl -static-libs -zeroconf" 1,282 kB
[ebuild  N     ] dev-db/libiodbc-3.52.7  USE="gtk" 1,015 kB
[ebuild  N     ] dev-libs/soprano-2.9.4  USE="dbus raptor redland virtuoso -debug -doc {-test}" 1,913 kB
[ebuild  N     ] media-libs/glu-9.0.0-r1  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 482 kB
[ebuild  N     ] virtual/glu-9.0-r1  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-libs/libsdl-1.2.15-r4  USE="X alsa joystick opengl sound video xinerama xv -aalib -custom-cflags -dga -directfb -fbcon -ggi -libcaca -nas -oss (-ps3) -pulseaudio -static-libs (-svga) -tslib" 3,829 kB
[ebuild  N     ] media-libs/libmpeg2-0.5.1-r2  USE="X sdl -static-libs" ABI_X86="(64) (-32) (-x32)" 513 kB
[ebuild  N     ] media-plugins/gst-plugins-mpeg2dec-0.10.19-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-meta-0.10-r9:0.10  USE="X a52 aac alsa cdda dts dvd flac mp3 mpeg ogg vorbis x264 xv xvid -dv -dvb -ffmpeg -http -jack -lame -libass -libvisual -mms -musepack -opus -oss -pulseaudio -taglib -theora -v4l -vcd -vpx -wavpack" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] app-crypt/pinentry-0.8.2  USE="gtk ncurses qt4 -caps -static" 419 kB
[ebuild  N     ] app-crypt/gnupg-2.0.26  USE="bzip2 ldap nls readline usb -adns -doc -mta (-selinux) -smartcard -static" 4,203 kB
[ebuild  N     ] x11-libs/gtk+-3.12.2:3  USE="X cups introspection xinerama (-aqua) -cloudprint -colord -debug -examples {-test} -vim-syntax -wayland" 14,664 kB
[ebuild  N     ] media-libs/phonon-4.6.0-r1  USE="gstreamer (-aqua) -debug -pulseaudio -vlc (-zeitgeist)" 275 kB
[ebuild  N     ] dev-db/mariadb-5.5.39  USE="community pam perl ssl -bindist -cluster -debug -embedded -extraengine -jemalloc -latin1 -max-idx-128 -minimal -oqgraph -profiling (-selinux) -sphinx -static -static-libs -systemtap -tcmalloc {-test} -tokudb" 45,489 kB
[ebuild  N     ] virtual/mysql-5.5  USE="-embedded -minimal -static -static-libs" 0 kB
[ebuild  N     ] dev-perl/DBD-mysql-4.20.0-r1  USE="-embedded" 135 kB
[ebuild  N     ] dev-qt/qtsql-4.8.5:4  USE="exceptions mysql qt3support sqlite (-aqua) -debug (-firebird) -freetds -oci8 -odbc -pch -postgres" 0 kB
[ebuild  N     ] dev-qt/qt3support-4.8.5:4  USE="accessibility exceptions (-aqua) -debug -pch" 0 kB
[ebuild  N     ] dev-qt/qtdeclarative-4.8.5:4  USE="accessibility exceptions qt3support (-aqua) -debug -pch -webkit" 0 kB
[ebuild  N     ] dev-qt/designer-4.8.5:4  USE="declarative exceptions qt3support (-aqua) -debug -pch (-phonon) -webkit" 0 kB
[ebuild  N     ] sys-auth/polkit-0.112-r1  USE="gtk introspection kde nls pam -examples (-selinux) -systemd" 1,396 kB
[ebuild  N     ] gnome-extra/polkit-gnome-0.105  304 kB
[ebuild  N     ] sys-auth/consolekit-0.4.6  USE="acl pam (policykit) -debug -doc (-selinux) -systemd-units {-test}" 370 kB
[ebuild  N     ] sys-auth/polkit-qt-0.103.0  USE="-debug -examples" 67 kB
[ebuild   R    ] sys-auth/pambase-20120417-r3  USE="consolekit* cracklib sha512 -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux) -systemd" 4 kB
[ebuild  N     ] sys-fs/udisks-2.1.3:2  USE="gptfdisk introspection -cryptsetup -debug (-selinux) -systemd" 889 kB
[ebuild  N     ] sys-power/upower-0.99.0-r1:0/2  USE="introspection -ios" 420 kB
[ebuild  N     ] kde-base/kdelibs-4.12.5-r2:4/4.12  USE="acl alsa bzip2 fam handbook mmx nls opengl (policykit) semantic-desktop spell sse sse2 ssl udev udisks upower -3dnow (-altivec) (-aqua) -debug -doc -jpeg2k -kerberos -lzma -openexr {-test} -zeroconf" 11,281 kB
[ebuild  N     ] sys-auth/polkit-kde-agent-0.99.0-r1:4  USE="(-aqua) -debug" LINGUAS="-ca -ca@valencia -cs -da -de -en_GB -eo -es -et -fi -fr -ga -gl -hr -hu -is -it -ja -km -lt -mai -ms -nb -nds -nl -pa -pt -pt_BR -ro -ru -sk -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -uk -zh_TW" 34 kB
[ebuild  N     ] kde-base/nepomuk-core-4.12.5:4/4.12  USE="exif pdf (-aqua) -debug -epub -ffmpeg -taglib" 372 kB
[ebuild  N     ] kde-base/katepart-4.12.5:4/4.12  USE="handbook (-aqua) -debug" 2,582 kB
[ebuild  N     ] kde-base/nepomuk-widgets-4.12.5:4/4.12  USE="(-aqua) -debug" 48 kB
[ebuild  N     ] kde-base/kdesu-4.12.5:4/4.12  USE="handbook (-aqua) -debug" 7,673 kB
[ebuild  N     ] kde-base/khelpcenter-4.12.5:4/4.12  USE="(-aqua) -debug" 0 kB
[ebuild  N     ] net-libs/libproxy-0.4.11-r2  USE="kde -gnome -mono -networkmanager -perl -python -spidermonkey {-test} -webkit" ABI_X86="(64) (-32) (-x32)" PYTHON_TARGETS="python2_7" 92 kB
[ebuild  N     ] net-libs/glib-networking-2.40.1-r1  USE="libproxy ssl -gnome -smartcard {-test}" ABI_X86="(64) (-32) (-x32)" 360 kB
[ebuild  N     ] net-libs/libsoup-2.46.0-r1:2.4  USE="introspection ssl -debug -samba {-test}" ABI_X86="(64) (-32) (-x32)" 1,655 kB
[ebuild  N     ] media-plugins/gst-plugins-soup-0.10.31-r1:0.10  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-libs/phonon-gstreamer-4.6.3  USE="alsa network -debug" 71 kB
[ebuild   R    ] net-misc/openssh-6.6_p1-r1  USE="X* hpn ldap* pam tcpd -X509 -bindist* -kerberos -ldns -libedit (-selinux) -skey -static" 1,291 kB

Total: 280 packages (29 upgrades, 236 new, 1 in new slot, 14 reinstalls), Size of downloads: 728,699 kB

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

(chroot) JAASABAYON / #


The Gentoo was installed from:
stage3-amd64-20140717.tar.bz2
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13842

PostPosted: Sun Oct 12, 2014 3:42 pm    Post subject: Reply with quote

turboscrew wrote:
It looks like it is stuck in a loop with mouse. This repeats:
Code:
Oct  4 13:22:23 JAA-GENTOO kernel: [518801.065488] hid-generic 0003:093A:2510.20C0: input,hidraw0: USB HID v1.11 Mouse [PixArt USB Optical Mouse] on usb-0000:00:02.0-4/input0
Oct  4 13:23:23 JAA-GENTOO kernel: [518861.065088] usb 2-4: USB disconnect, device number 69
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.751029] usb 2-4: new low-speed USB device number 70 using ohci-pci
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.940041] usb 2-4: New USB device found, idVendor=093a, idProduct=2510
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.940044] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.940046] usb 2-4: Product: USB Optical Mouse
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.940048] usb 2-4: Manufacturer: PixArt
Oct  4 13:23:25 JAA-GENTOO kernel: [518862.950366] input: PixArt USB Optical Mouse as /devices/pci0000:00/0000:00:02.0/usb2/2-4/2-4:1.0/input/input8399
In some cases, this can happen if the kernel powers down the USB port for the mouse, then rediscovers it. It is annoying but usually harmless. If you have no use for the mouse, you should disconnect it to prevent this.
turboscrew wrote:
I've been under the impression that 3.12.21-gentoo-r1 uses OpenRC.
It can use either OpenRC or systemd. However, if you use systemd, there are some people (including me) who cannot help you because we avoid systemd.

Fortunately, or perhaps not, the command I asked you to run seems to say that there are no conflicts. You can perform the update whenever you are ready. I suspect that your original command implicitly prevented Portage from upgrading packages that it needed to upgrade, which caused the conflict. The command I suggested gives Portage the opportunity to upgrade supporting packages, which can sometimes avoid the conflict.
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Sun Oct 12, 2014 4:07 pm    Post subject: Reply with quote

You mean, I should do:
emerge --update --verbose --deep --newuse @world
(--pretend removed)
As soon as I get my boot-up working.

I was mistaken, the welcome was to Sabayon!

I reinstalled Grub (legacy) in the beginning of the Gentoo root partition and re-added the boot
using EasyBCD, but it still boots Windows as it should, Sabayon as it should, but Gentoo still hangs.

Could it be something about the disks?
Both Gentoo and Sabayon are on the partition 3 but on different disks.
Different systems seem to re-order the disks: one is older PATA and the other is SATA.
And the SATA partition 0 is the Windows whose boot manager is used for booting both
Gentoo (SATA, partition 3) and Sabayon (PATA, partition 3).

I've never done a cross-disk multiboot before.
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13842

PostPosted: Sun Oct 12, 2014 5:02 pm    Post subject: Reply with quote

Yes, either remove --pretend or change it to --ask. You can also use the short form of the command: emerge -uvDN @world.
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Sun Oct 12, 2014 7:01 pm    Post subject: Reply with quote

Hu wrote:
Yes, either remove --pretend or change it to --ask. You can also use the short form of the command: emerge -uvDN @world.

The latter looks better (--pretend => --ask).
Thanks!

I can only check if that solves the original problem when I get my new problem (booting) worked out.
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Mon Oct 13, 2014 7:07 am    Post subject: Reply with quote

I ran the command anyway (chrooted).
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)


Last edited by turboscrew on Mon Oct 13, 2014 7:11 am; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Mon Oct 13, 2014 7:10 am    Post subject: Reply with quote

do what is said:
Code:
emerge @preserved-rebuild
;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Mon Oct 13, 2014 7:18 am    Post subject: Reply with quote

Oh, you were quick. I hoped no-one saw it.
emerge --depclean instructed that, so that's why I removed the question:
what should I do with a bunch of preserved libraries.

[edit]
New obstacles:

Code:
emerge @preserved-rebuild
...
PERL5LIB=. po4a --variable srcdir=../../man --variable builddir=../../man --variable podir=./tmp-po --keep 0 ./po4a.cfg
Can't locate Locale/Po4a/Chooser.pm in @INC (you may need to install the Locale::Po4a::Chooser module) (@INC contains: . /etc/perl /usr/local/lib64/perl5/5.18.2/x86_64-linux /usr/local/lib64/perl5/5.18.2 /usr/lib64/perl5/vendor_perl/5.18.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.18.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.18.2/x86_64-linux /usr/lib64/perl5/5.18.2 .) at /usr/bin/po4a line 547.
BEGIN failed--compilation aborted at /usr/bin/po4a line 547.
make[3]: *** [all-local] Error 2
make[3]: Leaving directory `/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6/man/po4a'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6/man'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'
make: *** [all] Error 2
 * ERROR: sys-apps/man-db-2.6.6::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sys-apps/man-db-2.6.6::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/man-db-2.6.6::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'
 * S: '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'

>>> Failed to emerge sys-apps/man-db-2.6.6, Log file:

>>>  '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/build.log'

 * Messages for package sys-apps/man-db-2.6.6:

 * Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings
 * ERROR: sys-apps/man-db-2.6.6::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sys-apps/man-db-2.6.6::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/man-db-2.6.6::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'
 * S: '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'


Code:
(chroot) JAASABAYON / # emerge --info '=sys-apps/man-db-2.6.6::gentoo'
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.19-r1, 3.16.0-sabayon x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.16.0-sabayon-x86_64-AMD_Phenom-tm-_8550_Triple-Core_Processor-with-gentoo-2.2
KiB Mem:     3079076 total,    146620 free
KiB Swap:   16777212 total,  16766284 free
Timestamp of tree: Sat, 06 Sep 2014 00:45:01 +0000
ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.6, 3.3.3
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/"
LANG="en_US.iso88591"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.fi.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cdrbindist cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-apps/man-db-2.6.6 was built with the following:
USE="berkdb gdbm nls zlib (-selinux) -static-libs" ABI_X86="64"
CFLAGS="-O2 -pipe"
CXXFLAGS="-O2 -pipe"

_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13842

PostPosted: Mon Oct 13, 2014 10:36 pm    Post subject: Reply with quote

You had perl-5.16 earlier in the thread and now have perl-5.18. You probably skipped the advertised step of running perl-cleaner --all to rebuild packages that depend on the installed Perl version. In this case, that failure means you have a build tool installed that fails when run, so anything using it, such as man-db, fails to build.
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Mon Oct 13, 2014 11:01 pm    Post subject: Reply with quote

I run it:

Code:
...
[blocks B      ] <perl-core/ExtUtils-MakeMaker-6.660.0 ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking virtual/perl-ExtUtils-MakeMaker-6.660.0-r1)
[blocks B      ] <perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0" is blocking virtual/perl-Module-CoreList-3.30.0)
[blocks B      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
[blocks B      ] <perl-core/ExtUtils-Manifest-1.630.0 ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking virtual/perl-ExtUtils-Manifest-1.630.0-r1)
[blocks B      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)
[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)

Total: 58 packages (41 upgrades, 2 new, 15 reinstalls), Size of downloads: 4,636 kB
Conflict: 7 blocks (7 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

...

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 * If you encounter blockers involving virtuals and perl-core, here are
 * some things to try:
 *   Remove all perl-core packages from your world file
 *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
 *   Update all the installed Perl virtuals
 *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
 *   Afterwards re-run perl-cleaner
 *
 * Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.


I wonder if I have to install it all over again:
- it still doesn't boot
- it doesn't emerge wpa_supplicant
- it doesn't connect with wireless-tools
- it doesn't have a DE
and now this...
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Tue Oct 14, 2014 1:12 am    Post subject: Reply with quote

from the chroot, try:
Code:
emerge -Cav ExtUtils-MakeMaker virtual/perl-ExtUtils-MakeMaker Module-CoreList virtual/perl-Module-CoreList perl-version virtual/perl-version ExtUtils-CBuilder virtual/perl-ExtUtils-CBuilder ExtUtils-Manifest virtual/perl-ExtUtils-Manifest virtual/perl-IO IPC-Cmd virtual/perl-IPC-Cmd
emerge -1av --backtrack=300 ExtUtils-MakeMaker virtual/perl-ExtUtils-MakeMaker Module-CoreList virtual/perl-Module-CoreList perl-version virtual/perl-version ExtUtils-CBuilder virtual/perl-ExtUtils-CBuilder ExtUtils-Manifest virtual/perl-ExtUtils-Manifest virtual/perl-IO IPC-Cmd virtual/perl-IPC-Cmd
perl-cleaner reallyall
or as the machine suggested:
Code:
emerge --deselect --ask $(qlist -IC 'perl-core/*')
emerge -uD1a $(qlist -IC 'virtual/perl-*')
perl-cleaner reallyall

this possibly caused those thats :)
_________________
Defund the FCC.


Last edited by DONAHUE on Wed Oct 15, 2014 2:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Tue Oct 14, 2014 9:35 pm    Post subject: Reply with quote

I'll try those hopefully tomorrow.
I'll report back here.
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Wed Oct 15, 2014 7:12 am    Post subject: Reply with quote

Well:

(chroot) JAASABAYON / # emerge --deselect --ask $(qlist -IC 'perl-core/*')
>>> No matching atoms found in "world" favorites file...


Your second command gave:
Code:
[uninstall     ] perl-core/IO-1.25
[blocks b      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)
[ebuild  N     ] virtual/perl-version-0.990.200-r1  0 kB
[uninstall     ] perl-core/version-0.990.100
[blocks b      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
[blocks B      ] <perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0" is blocking virtual/perl-Module-CoreList-3.30.0)
[blocks B      ] <perl-core/ExtUtils-MakeMaker-6.660.0 ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking virtual/perl-ExtUtils-MakeMaker-6.660.0-r1)
[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)
[blocks B      ] <perl-core/ExtUtils-Manifest-1.630.0 ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking virtual/perl-ExtUtils-Manifest-1.630.0-r1)

Total: 15 packages (2 upgrades, 13 new, 2 uninstalls), Size of downloads: 571 kB
Conflict: 7 blocks (5 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ExtUtils-MakeMaker

  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for merge) pulled in by
    Module-CoreList

  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-CBuilder

  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    IPC-Cmd

  (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ExtUtils-Manifest

  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge) pulled in by
    ExtUtils-CBuilder

  (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-Manifest
    >=virtual/perl-ExtUtils-Manifest-1.600.0 required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-ExtUtils-Manifest-1.630.0-r1 required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-Module-CoreList

  (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-IPC-Cmd
    virtual/perl-IPC-Cmd required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-IPC-Cmd-0.800.0-r1 required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-MakeMaker


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):


and

Code:

(chroot) JAASABAYON / # perl-cleaner really all
perl-cleaner -- Find & rebuild packages and Perl header files broken due to a perl upgrade

Usage: /usr/sbin/perl-cleaner [OPTION]

Options:
  -h, --help     Print usage
  -V, --version  Print version
  -p, --pretend  Pretend (don't do anything)
  -v, --verbose  Increase verbosity (may be specified multiple times)
  -q, --quiet    Decrease verbosity
  --modules      Rebuild perl modules for old installs of perl
  --allmodules   Rebuild all perl modules
  --libperl      Rebuild anything linked against libperl
  --ph-clean     Clean out old ph files from a previous perl
  --phupdate     Update existing ph files, useful after an upgrade to system parts like the kernel
  --phall        Short for --ph-clean --phupdate
  --all          Short for --modules --libperl --phall
  --reallyall    Short for --allmodules --libperl --phall
  --leftovers    Shows all files that were not rebuilt
  -P PM, --package-manager PM
                 Use package manager PM, where PM can be one of:
                  * portage (Default)
                  * pkgcore
                  * paludis
  -- OPTIONS     Pass additional options to package manager


Should I remove some perls?
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1770
Location: Here and Away Again

PostPosted: Thu Oct 16, 2014 3:26 pm    Post subject: ><)))°€ Reply with quote

Teegrins, turboscrew!


For one:

Code:
perl-cleaner really all

The really all here should be reallyall (you can see that in the output as well, amongst the listed options).


For two, I would probably personally tackle this issue in the means DONAHUE suggested above (the one with emerge -Cav). The -C (--uninstall) will get rid of packages without checking dependencies, meaning it will uninstall the packages even if something in the system still requires them. This way they wont be bothering you any longer when trying to install other versions (normally not required, but it has often seemed the more quick-like way out than finding out the actual root of a block, which really hasn't happened many times to me).

Care should be taken with its use, however, due to the dependency part of the deal. For normal maintenance, the -c (--depclean) option is often better.

The “No matching atoms found in "world" favorites file...” is good, as it means those packages have not ended up into your world file, but may also be puzzling as it would have explained some (or parts at least) of the issues.


I hope this helps!
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Thu Oct 16, 2014 7:27 pm    Post subject: Reply with quote

Hmmm ....

Code:

(chroot) JAASABAYON / # emerge -Cav ExtUtils-MakeMaker virtual/perl-ExtUtils-MakeMaker Module-CoreList virtual/perl-Module-CoreList perl-version virtual/perl-version ExtUtils-CBuilder virtual/perl-ExtUtils-CBuilder ExtUtils-Manifest virtual/perl-ExtUtils-Manifest virtual/perl-IO IPC-Cmd virtual/perl-IPC-Cmd
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

>>> These are the packages that would be unmerged:                                                                                     

--- Couldn't find 'ExtUtils-MakeMaker' to unmerge.

--- Couldn't find 'virtual/perl-ExtUtils-MakeMaker' to unmerge.

--- Couldn't find 'Module-CoreList' to unmerge.

--- Couldn't find 'virtual/perl-Module-CoreList' to unmerge.

--- Couldn't find 'perl-version' to unmerge.

--- Couldn't find 'virtual/perl-version' to unmerge.

--- Couldn't find 'ExtUtils-CBuilder' to unmerge.

--- Couldn't find 'virtual/perl-ExtUtils-CBuilder' to unmerge.

--- Couldn't find 'ExtUtils-Manifest' to unmerge.

--- Couldn't find 'virtual/perl-ExtUtils-Manifest' to unmerge.

--- Couldn't find 'virtual/perl-IO' to unmerge.

--- Couldn't find 'IPC-Cmd' to unmerge.

--- Couldn't find 'virtual/perl-IPC-Cmd' to unmerge.

>>> No packages selected for removal by unmerge
(chroot) JAASABAYON / # emerge -1av --backtrack=300 ExtUtils-MakeMaker virtual/perl-ExtUtils-MakeMaker Module-CoreList virtual/perl-Module-CoreList perl-version virtual/perl-version ExtUtils-CBuilder virtual/perl-ExtUtils-CBuilder ExtUtils-Manifest virtual/perl-ExtUtils-Manifest virtual/perl-IO IPC-Cmd virtual/perl-IPC-Cmd

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] virtual/perl-ExtUtils-Manifest-1.630.0-r1  0 kB
[ebuild  N     ] virtual/perl-IPC-Cmd-0.800.0-r1  0 kB
[ebuild     U  ] virtual/perl-ExtUtils-Install-1.590.0-r1 [1.580.0-r1] 0 kB
[ebuild  N     ] perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 12 kB
[ebuild     U  ] virtual/perl-File-Temp-0.230.0 [0.220.0-r3] 0 kB
[ebuild  N     ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1  0 kB
[ebuild  N     ] perl-core/Module-CoreList-2.840.0  59 kB
[ebuild  N     ] virtual/perl-Module-CoreList-3.30.0  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1  0 kB
[ebuild  N     ] perl-core/ExtUtils-Manifest-1.610.0-r1  29 kB
[ebuild  N     ] perl-core/ExtUtils-MakeMaker-6.640.0-r1  412 kB
[ebuild  N     ] perl-core/IPC-Cmd-0.780.0-r1  27 kB
[ebuild  N     ] perl-core/ExtUtils-CBuilder-0.280.205-r1  34 kB
[ebuild  N     ] virtual/perl-IO-1.280.0-r1  0 kB
[uninstall     ] perl-core/IO-1.25
[blocks b      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)
[ebuild  N     ] virtual/perl-version-0.990.200-r1  0 kB
[uninstall     ] perl-core/version-0.990.100
[blocks b      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
[blocks B      ] <perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0" is blocking virtual/perl-Module-CoreList-3.30.0)
[blocks B      ] <perl-core/ExtUtils-MakeMaker-6.660.0 ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking virtual/perl-ExtUtils-MakeMaker-6.660.0-r1)
[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)
[blocks B      ] <perl-core/ExtUtils-Manifest-1.630.0 ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking virtual/perl-ExtUtils-Manifest-1.630.0-r1)

Total: 15 packages (2 upgrades, 13 new, 2 uninstalls), Size of downloads: 571 kB
Conflict: 7 blocks (5 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ExtUtils-MakeMaker

  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for merge) pulled in by
    Module-CoreList

  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-CBuilder

  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    IPC-Cmd

  (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ExtUtils-Manifest

  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge) pulled in by
    ExtUtils-CBuilder

  (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-Manifest
    >=virtual/perl-ExtUtils-Manifest-1.600.0 required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-ExtUtils-Manifest-1.630.0-r1 required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-Module-CoreList

  (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-IPC-Cmd
    virtual/perl-IPC-Cmd required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-IPC-Cmd-0.800.0-r1 required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-MakeMaker


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

(chroot) JAASABAYON / # perl-cleaner reallyall

 * Beginning a clean up of .ph files
 * Excluding files for 0.0.0 and 0.0.0/x86_64-linux from cleaning

 * Locating ph files for removal

 * Updating ph files.
 * Ignore all "No such file..." messages!
Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 *   Adding to list: dev-perl/SGMLSpm:0
 *   Adding to list: dev-perl/XML-Parser:0
 *   Adding to list: dev-perl/Text-WrapI18N:0
 *   Adding to list: dev-perl/Locale-gettext:0
 *   Adding to list: dev-perl/Text-CharWidth:0
 *   Adding to list: dev-perl/TermReadKey:0
 *   Adding to list: perl-core/Archive-Tar:0
 *                   virtual/perl-Archive-Tar:0
 *   Adding to list: perl-core/CPAN-Meta-Requirements:0
 *                   virtual/perl-CPAN-Meta-Requirements:0
 *   Adding to list: perl-core/CPAN-Meta:0
 *                   virtual/perl-CPAN-Meta:0
 *   Adding to list: perl-core/IO-Compress:0
 *                   virtual/perl-IO-Compress:0
 *   Adding to list: perl-core/Params-Check:0
 *                   virtual/perl-Params-Check:0
 *   Adding to list: perl-core/Module-Build:0
 *                   virtual/perl-Module-Build:0
 *   Adding to list: perl-core/ExtUtils-ParseXS:0
 *                   virtual/perl-ExtUtils-ParseXS:0
 *   Adding to list: perl-core/Module-Load-Conditional:0
 *                   virtual/perl-Module-Load-Conditional:0
 *   Adding to list: perl-core/CPAN-Meta-YAML:0
 *                   virtual/perl-CPAN-Meta-YAML:0
 *   Adding to list: perl-core/Module-Metadata:0
 *                   virtual/perl-Module-Metadata:0
 *   Adding to list: perl-core/Compress-Raw-Zlib:0
 *                   virtual/perl-Compress-Raw-Zlib:0
 *   Adding to list: perl-core/File-Spec:0
 *                   virtual/perl-File-Spec:0
 *   Adding to list: perl-core/Module-Load:0
 *                   virtual/perl-Module-Load:0
 *   Adding to list: perl-core/Parse-CPAN-Meta:0
 *                   virtual/perl-Parse-CPAN-Meta:0
 *   Adding to list: perl-core/Scalar-List-Utils:0
 *                   virtual/perl-Scalar-List-Utils:0
 *   Adding to list: perl-core/Test-Harness:0
 *                   virtual/perl-Test-Harness:0
 *   Adding to list: perl-core/version:0
 *   Adding to list: perl-core/Compress-Raw-Bzip2:0
 *                   virtual/perl-Compress-Raw-Bzip2:0
 *   Adding to list: perl-core/IO:0
 *   Adding to list: app-text/po4a:0
 * emerge -vD1 --backtrack=30 dev-perl/SGMLSpm:0 dev-perl/XML-Parser:0 dev-perl/Text-WrapI18N:0 dev-perl/Locale-gettext:0 dev-perl/Text-CharWidth:0 dev-perl/TermReadKey:0 perl-core/Archive-Tar:0 virtual/perl-Archive-Tar:0 perl-core/CPAN-Meta-Requirements:0 virtual/perl-CPAN-Meta-Requirements:0 perl-core/CPAN-Meta:0 virtual/perl-CPAN-Meta:0 perl-core/IO-Compress:0 virtual/perl-IO-Compress:0 perl-core/Params-Check:0 virtual/perl-Params-Check:0 perl-core/Module-Build:0 virtual/perl-Module-Build:0 perl-core/ExtUtils-ParseXS:0 virtual/perl-ExtUtils-ParseXS:0 perl-core/Module-Load-Conditional:0 virtual/perl-Module-Load-Conditional:0 perl-core/CPAN-Meta-YAML:0 virtual/perl-CPAN-Meta-YAML:0 perl-core/Module-Metadata:0 virtual/perl-Module-Metadata:0 perl-core/Compress-Raw-Zlib:0 virtual/perl-Compress-Raw-Zlib:0 perl-core/File-Spec:0 virtual/perl-File-Spec:0 perl-core/Module-Load:0 virtual/perl-Module-Load:0 perl-core/Parse-CPAN-Meta:0 virtual/perl-Parse-CPAN-Meta:0 perl-core/Scalar-List-Utils:0 virtual/perl-Scalar-List-Utils:0 perl-core/Test-Harness:0 virtual/perl-Test-Harness:0 perl-core/version:0 perl-core/Compress-Raw-Bzip2:0 virtual/perl-Compress-Raw-Bzip2:0 perl-core/IO:0 app-text/po4a:0

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] virtual/perl-version-0.990.200-r1  0 kB
[ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2 [0.8.0-r1] 0 kB
[ebuild     U  ] virtual/perl-Scalar-List-Utils-1.270.0-r2 [1.270.0-r1] 0 kB
[ebuild   R    ] virtual/perl-Module-Metadata-1.0.11-r1  0 kB
[ebuild   R    ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1  0 kB
[ebuild   R    ] dev-perl/SGMLSpm-1.03-r7  0 kB
[ebuild     U  ] dev-perl/Text-CharWidth-0.40.0-r1 [0.40.0] 9 kB
[ebuild     U  ] dev-perl/TermReadKey-2.300.200-r1 [2.300.200] 0 kB
[ebuild     U  ] virtual/perl-Archive-Tar-1.900.0-r2 [1.900.0-r1] 0 kB
[ebuild     U  ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2 [2.122.0-r1] 0 kB
[ebuild     U  ] virtual/perl-CPAN-Meta-2.120.921-r2 [2.120.921-r1] 0 kB
[ebuild     U  ] virtual/perl-IO-Compress-2.60.0-r1 [2.60.0] 0 kB
[ebuild   R    ] virtual/perl-Params-Check-0.360.0-r1  0 kB
[ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
[ebuild     U  ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2 [3.180.0-r1] 0 kB
[ebuild     U  ] virtual/perl-Compress-Raw-Zlib-2.60.0-r2 [2.60.0-r1] 0 kB
[ebuild     U  ] virtual/perl-File-Spec-3.400.0-r2 [3.400.0-r1] 0 kB
[ebuild   R    ] virtual/perl-Module-Load-0.240.0-r1  0 kB
[ebuild     U  ] virtual/perl-Test-Harness-3.260.0-r2 [3.260.0-r1] 0 kB
[ebuild     U  ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2 [2.60.0-r1] 0 kB
[ebuild  N     ] perl-core/JSON-PP-2.272.0-r1  41 kB
[ebuild  N     ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1  0 kB
[ebuild  N     ] virtual/perl-IO-1.280.0-r1  0 kB
[ebuild     U  ] virtual/perl-File-Temp-0.230.0 [0.220.0-r3] 0 kB
[ebuild  N     ] perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 12 kB
[ebuild  N     ] virtual/perl-Module-CoreList-3.30.0  0 kB
[ebuild     U  ] dev-perl/XML-Parser-2.410.0-r2 [2.410.0] 0 kB
[ebuild   R    ] virtual/perl-Module-Load-Conditional-0.540.0-r1  0 kB
[ebuild     U  ] perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 31 kB
[ebuild   R    ] perl-core/Compress-Raw-Zlib-2.60.0  231 kB
[ebuild   R    ] perl-core/File-Spec-3.400.0  137 kB
[ebuild   R    ] perl-core/Module-Load-0.240.0  6 kB
[ebuild   R    ] perl-core/Scalar-List-Utils-1.270.0  68 kB
[ebuild   R    ] perl-core/Test-Harness-3.260.0  288 kB
[ebuild     U  ] perl-core/version-0.990.100-r1 [0.990.100] 105 kB
[ebuild   R    ] perl-core/Compress-Raw-Bzip2-2.60.0  133 kB
[ebuild     U  ] perl-core/IO-1.25-r1 [1.25] 52 kB
[ebuild     U  ] dev-perl/Text-WrapI18N-0.60.0-r1 [0.60.0] 4 kB
[ebuild     U  ] perl-core/Archive-Tar-1.900.0-r1 [1.900.0] 57 kB
[ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1 [2.122.0] 21 kB
[ebuild   R    ] perl-core/IO-Compress-2.60.0  238 kB
[ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 12 kB
[ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1 [3.180.0] 62 kB
[ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  13 kB
[ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 27 kB
[ebuild     U  ] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 75 kB
[ebuild     U  ] perl-core/Module-Build-0.400.300-r1 [0.400.300] USE="{-test}" 301 kB
[ebuild     U  ] perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400] 8 kB
[ebuild     U  ] dev-perl/Locale-gettext-1.50.0-r1 [1.50.0] 0 kB
[ebuild     U  ] app-text/po4a-0.45 [0.42] USE="{-test}" 2,158 kB
[blocks B      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)

Total: 51 packages (29 upgrades, 7 new, 15 reinstalls), Size of downloads: 4,076 kB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-version-0.77 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-version required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.870 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.82 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.87 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-IO-1.280.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-IO-1.280.0-r1 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-IO required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)

  (perl-core/IO-1.25-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/IO:0

  (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/version:0


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 * If you encounter blockers involving virtuals and perl-core, here are
 * some things to try:
 *   Remove all perl-core packages from your world file
 *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
 *   Update all the installed Perl virtuals
 *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
 *   Afterwards re-run perl-cleaner
 *
 * Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.


_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43186
Location: 56N 3W

PostPosted: Thu Oct 16, 2014 7:29 pm    Post subject: Reply with quote

Chiitoo

Code:
perl-cleaner --reallyall

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1770
Location: Here and Away Again

PostPosted: Thu Oct 16, 2014 11:31 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Chiitoo

Code:
perl-cleaner --reallyall

Oh yes, that's what I was trying to say!

The

Code:
perl-cleaner really all

was a quote from the original post, and I was adjusting the spacing only below it. Thanks for clearing that up though! (I blame this fever that has been tormenting me for so long that I probably should go show it to a doctor-like person.)

It does seem as if perl-cleaner actually takes the arguments without any dashing just as well! Still a good pointer. Apologies for any confusion caused.


So those packages indeed are not there, and the ones that are, are seemingly being resolved automagically (the small b in the output). Hrm. I wonder if increasing the backtrack even further, to something like 1000 would help (I think I saw it being helpful some time ago somewhere around here, but I forget if it was perl-related).

Perhaps also add the -t (--tree) option for emerge so it's easy to see which package is pulling in which. I'm unsure if it can be of any help with this type of issues though.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Fri Oct 17, 2014 2:38 pm    Post subject: Reply with quote

Quote:
I wonder if increasing the backtrack even further, to something like 1000 would help


Erm...???

[edit}

Ah: "emerge -1av --backtrack=300...".

Code:

(chroot) JAASABAYON / # emerge -1av --backtrack=1000 ExtUtils-MakeMaker virtual/perl-ExtUtils-MakeMaker Module-CoreList virtual/perl-Module-CoreList perl-version virtual/perl-version ExtUtils-CBuilder virtual/perl-ExtUtils-CBuilder ExtUtils-Manifest virtual/perl-ExtUtils-Manifest virtual/perl-IO IPC-Cmd virtual/perl-IPC-Cmd 

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] virtual/perl-ExtUtils-Manifest-1.630.0-r1  0 kB
[ebuild  N     ] virtual/perl-IPC-Cmd-0.800.0-r1  0 kB
[ebuild     U  ] virtual/perl-ExtUtils-Install-1.590.0-r1 [1.580.0-r1] 0 kB
[ebuild  N     ] perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 12 kB
[ebuild     U  ] virtual/perl-File-Temp-0.230.0 [0.220.0-r3] 0 kB
[ebuild  N     ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1  0 kB
[ebuild  N     ] perl-core/Module-CoreList-2.840.0  59 kB
[ebuild  N     ] virtual/perl-Module-CoreList-3.30.0  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1  0 kB
[ebuild  N     ] perl-core/ExtUtils-Manifest-1.610.0-r1  29 kB
[ebuild  N     ] perl-core/ExtUtils-MakeMaker-6.640.0-r1  412 kB
[ebuild  N     ] perl-core/IPC-Cmd-0.780.0-r1  27 kB
[ebuild  N     ] perl-core/ExtUtils-CBuilder-0.280.205-r1  34 kB
[ebuild  N     ] virtual/perl-IO-1.280.0-r1  0 kB
[uninstall     ] perl-core/IO-1.25
[blocks b      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)
[ebuild  N     ] virtual/perl-version-0.990.200-r1  0 kB
[uninstall     ] perl-core/version-0.990.100
[blocks b      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
[blocks B      ] <perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0" is blocking virtual/perl-Module-CoreList-3.30.0)
[blocks B      ] <perl-core/ExtUtils-MakeMaker-6.660.0 ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking virtual/perl-ExtUtils-MakeMaker-6.660.0-r1)
[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)
[blocks B      ] <perl-core/ExtUtils-Manifest-1.630.0 ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking virtual/perl-ExtUtils-Manifest-1.630.0-r1)

Total: 15 packages (2 upgrades, 13 new, 2 uninstalls), Size of downloads: 571 kB
Conflict: 7 blocks (5 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ExtUtils-MakeMaker

  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for merge) pulled in by
    Module-CoreList

  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-CBuilder

  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    IPC-Cmd

  (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    ExtUtils-Manifest

  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge) pulled in by
    ExtUtils-CBuilder

  (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-Manifest
    >=virtual/perl-ExtUtils-Manifest-1.600.0 required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-ExtUtils-Manifest-1.630.0-r1 required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-Module-CoreList

  (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-IPC-Cmd
    virtual/perl-IPC-Cmd required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-IPC-Cmd-0.800.0-r1 required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-MakeMaker


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



It seems like perl-core/xxx blocks virtual/perl-xxx-r1.
Maybe the all the old perl-stuff can be removed and current perl-stuff installed?
The installation has never fully worked yet, so no 'local' scripts exist.
(It was installed on July 24, and it still doesn't even have network connection.)
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum