Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201410-01 ] Bash: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Sat Oct 04, 2014 11:26 pm    Post subject: [ GLSA 201410-01 ] Bash: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Bash: Multiple vulnerabilities (GLSA 201410-01)
Severity: high
Exploitable: local, remote
Date: October 04, 2014
Bug(s): #523742, #524256
ID: 201410-01

Synopsis

Multiple parsing flaws in Bash could allow remote attackers to
inject code or cause a Denial of Service condition.


Background

Bash is the standard GNU Bourne Again SHell.

Affected Packages

Package: app-shells/bash
Vulnerable: < 4.2_p52
Unaffected: >= 3.1_p22 < 3.2
Unaffected: >= 3.2_p56 < 3.3
Unaffected: >= 4.0_p43 < 4.1
Unaffected: >= 4.1_p16 < 4.2
Unaffected: >= 4.2_p52
Architectures: All supported architectures


Description

Florian Weimer, Todd Sabin, Michal Zalewski et al. discovered further
parsing flaws in Bash. The unaffected Gentoo packages listed in this GLSA
contain the official patches to fix the issues tracked as CVE-2014-6277,
CVE-2014-7186, and CVE-2014-7187. Furthermore, the official patch known
as “function prefix patch” is included which prevents the
exploitation of CVE-2014-6278.


Impact

A remote attacker could exploit these vulnerabilities to execute
arbitrary commands or cause a Denial of Service condition via various
vectors.


Workaround

There is no known workaround at this time.

Resolution

All Bash 3.1 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-3.1_p22:3.1"
   
All Bash 3.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-3.2_p56:3.2"
   
All Bash 4.0 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.0_p43:4.0"
   
All Bash 4.1 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.1_p16:4.1"
   
All Bash 4.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.2_p52"
   


References

CVE-2014-6277
CVE-2014-6278
CVE-2014-7186
CVE-2014-7187
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum