Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
System suspends, but no change to restart. How to debug?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
curator
Apprentice
Apprentice


Joined: 10 Apr 2007
Posts: 193

PostPosted: Tue Oct 14, 2014 3:54 pm    Post subject: System suspends, but no change to restart. How to debug? Reply with quote

Hi all,
I installed gentoo on my new Thinkpad X240. Many things work, some not (including WWAN, see other post). But since I switched to systemd, suspend seems to work out of the box - nearly.

When I close the lid or let the computer untouch without power, I goes to sleep (power LED blinking). However, I am not able to start the computer again.Neither keypress no hitting the powerbutton helps.The only thing that works is holding the power button for 5 seconds and pressing the power button again for a resh boot. Any ideas how to overcome this issue?

kind regards,
curator


Last edited by curator on Wed Oct 22, 2014 8:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1036
Location: Massachusetts USA

PostPosted: Tue Oct 14, 2014 5:18 pm    Post subject: Reply with quote

Is the acpid.service enabled?
Back to top
View user's profile Send private message
curator
Apprentice
Apprentice


Joined: 10 Apr 2007
Posts: 193

PostPosted: Tue Oct 14, 2014 6:45 pm    Post subject: Reply with quote

Hey, thanks for helping. I installed acpid, but now nothing happens when I close my lid and then computer shut down completly when I press the power button.

However, if I type systemctl suspend the same effect as before occurs...

EDIT: Sry, reread your post. I enabled the service and started it manaully. Now, lid close and powerbutton press works again as expected, but the computer is still not able to start again.

Any more ideas?

kind regards,
curator
Back to top
View user's profile Send private message
curator
Apprentice
Apprentice


Joined: 10 Apr 2007
Posts: 193

PostPosted: Thu Oct 16, 2014 8:21 pm    Post subject: Reply with quote

Noone any idea? Or at least an idea were I can start to search?
Back to top
View user's profile Send private message
curator
Apprentice
Apprentice


Joined: 10 Apr 2007
Posts: 193

PostPosted: Wed Oct 22, 2014 8:53 pm    Post subject: Reply with quote

After many google searches, I am still not any further. I cant even decide, whether it is a kernel or an OS issue. However, I dont think it has anything to do with systemd or acpi, since even a simple
Code:
echo mem > /sys/power/state


is enough for a suspend, but pressing power button has absolutly no effect. No chance at all to come from the "blinking" power button back to a running system...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum