Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Unerklärliche Abhängigkeiten
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1559
Location: Schweiz

PostPosted: Fri Oct 17, 2014 6:53 am    Post subject: [solved] Unerklärliche Abhängigkeiten Reply with quote

Beim Versuch "x11-misc/sddm" zu aktualisieren meldet portage auf einmal eine mir unerklärliche Abhängigkeit zum neuen xorg 1.16 obwohl im ebuild vom "x11-misc/sddm" nichts der gleichen drin steht:
Code:
# emerge -pv sddm                         

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] x11-base/xorg-drivers-1.16 [1.15] INPUT_DEVICES="evdev -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard -mouse -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="radeon radeonsi -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -modesetting -neomagic -nouveau -nv -nvidia (-omap) (-omapfb) -qxl -r128 -rendition -s3% -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo)" 0 kB
[ebuild     U ~] x11-proto/xproto-7.0.26 [7.0.25] USE="-doc" ABI_X86="(64) -32 (-x32)" 299 kB
[ebuild     U ~] x11-proto/fontsproto-2.1.3 [2.1.2] USE="-doc" 151 kB
[ebuild  N    ~] media-libs/libepoxy-1.2  USE="{-test}" ABI_X86="(64) -32 (-x32)" 261 kB
[ebuild     U ~] x11-base/xorg-server-1.16.1:0/1.16.1 [1.15.0:0/1.15.0] USE="glamor%* ipv6 nptl suid systemd%* udev wayland%* xorg -dmx -doc -kdrive -minimal (-selinux) -static-libs -tslib -unwind -xnest -xvfb" 5,667 kB
[ebuild     U #] x11-misc/sddm-0.9.0-r1 [0.9.0] USE="qt4 systemd -consolekit (-qt5) -upower" 0 kB
[blocks B      ] x11-libs/glamor ("x11-libs/glamor" is blocking x11-base/xorg-server-1.16.1)

Total: 6 packages (5 upgrades, 1 new), Size of downloads: 6,377 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-proto/fontsproto:0

  (x11-proto/fontsproto-2.1.2::gentoo, installed) pulled in by
    <x11-proto/fontsproto-2.1.3 required by (x11-libs/libXfont-1.4.8::gentoo, installed)

  (x11-proto/fontsproto-2.1.3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/fontsproto-2.1.3 required by (x11-base/xorg-server-1.16.1::gentoo, ebuild scheduled for merge)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.16.1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.15.1 required by (x11-misc/sddm-0.9.0-r1::gentoo, ebuild scheduled for merge)

  (x11-base/xorg-server-1.15.0::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.15.0= required by (x11-libs/glamor-0.6.0::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-evdev-2.8.2::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-ati-7.3.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/glamor-0.6.0::gentoo, installed) pulled in by
    >=x11-libs/glamor-0.6 required by (x11-drivers/xf86-video-ati-7.3.0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Versteht einer von euch was der Quatsch soll?

EDIT:
Ich habs selbst herausgefunden.
Da dass ebuild vom sddm den "x11-base/xorg-server-1.15.1" will aber dieser noch testing ist wollte portage seinerseits gleich den neusten xorg installieren welcher auf testing verfügbar ist.
Ein "=x11-base/xorg-server-1.15.1::gentoo ~amd64" in die "package.accept_keywords" Hat das Problem gelöst.
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum