Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
EFI, two VGA cards and switcheroo: the struggle of Aspire
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Barvinok
n00b
n00b


Joined: 29 Sep 2013
Posts: 29
Location: Ukraine

PostPosted: Sun Oct 19, 2014 6:21 am    Post subject: EFI, two VGA cards and switcheroo: the struggle of Aspire Reply with quote

Hi!

I have an Acer Aspire E1-572G and its main problems with Gentoo are
* EFI booting
* TWO video cards = Intel Haswell something (see below) and Radeon HD 8750M

What I've done so far: it now dualboots (using rEFInd) between Windows 8.1 and minimal Gentoo (systemd + console). Seeing how things are done in Windows, I'd happily go with a way to manually switch between video cards before X is started. However, it seems that neither of its video cards is willing to work at all under Gentoo. Details are below.

1. I found out, that since EFI is apparently running in graphics mode only (despite "textmode" option in rEFInd) the screen freezes on boot unless I enable CONFIG_FB_EFI; moreover, if I enable intel modesetting by default, the screen goes blank completely during boot.
2. even though there are "VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle" line in its dmesg (see below) and debugfs is enabled, there is no "vgaswitcheroo" entry under /sys/kernel/debug
3. despite both video drivers enabled in kernel, lspci shows only the radeon kernel module as loaded.
4. if I force the system to know only about one of the videocards (by removing the other's xorg-driver and kernel module), X complains "No devices detected" and "No screens found" on either videocard.

Here's the details:
zcat /proc/config.gz | wgetpaste - https://bpaste.net/show/c42970351a95
wgetpaste --info-only - https://bpaste.net/show/379e6014264d
lspci -knn | wgetpaste - https://bpaste.net/show/74373a633abe
dmesg | wgetpaste - https://bpaste.net/show/2da6fd1330ad
wgetpaste /var/log/Xorg.0.log - https://bpaste.net/show/158d8ff07226

I'd also be quite happy with intel-only configuration for my Gentoo, leaving radeon for games on windows.

Any suggestion?
_________________
Unlike reality, stupidity is inescapable
Back to top
View user's profile Send private message
Barvinok
n00b
n00b


Joined: 29 Sep 2013
Posts: 29
Location: Ukraine

PostPosted: Sun Oct 19, 2014 8:45 am    Post subject: Reply with quote

Turned out, vgaswitcheroo did not appear because I disabled intel modesetting in the kernel command line to avoid screen blanking once intel fb driver takes hold of the screen from that of EFI fb driver.
This also effectively prevented Intel vga driver from loading 8O
Now that I have X and GNOME up and running on IGD, the only question remains is this:
how do I select some kind of preference if there's more than one fb driver? I'd really love to see booting process (on EFI fb) before X starts.
_________________
Unlike reality, stupidity is inescapable
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum