Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
EFI stub requires EFI framebuffer?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
milktoast84
n00b
n00b


Joined: 03 Oct 2014
Posts: 17

PostPosted: Sat Oct 18, 2014 4:56 am    Post subject: EFI stub requires EFI framebuffer? Reply with quote

I'm trying to configure my kernel so it's happy with the NVIDIA card on my Macbook Air from 2010, but I discovered a funny quirk that I haven't wrapped my mind around.

The EFI frame buffer option seems to be required for my efi stub to boot? (The screen stays on apple white, and the mouse light turns off) Is that normal? Expected? (It may be interfering with my nvidia driver, if so I hope not) Would switching back to rEFInd directed at a grub loader change anything?
Back to top
View user's profile Send private message
s4e8
Guru
Guru


Joined: 29 Jul 2006
Posts: 309

PostPosted: Sat Oct 18, 2014 7:28 am    Post subject: Reply with quote

EFI fb or KMS driver is required in EFI mode. In nvidia case, you must choose between EFI fb or nouveau.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sat Oct 18, 2014 2:15 pm    Post subject: Reply with quote

s4e8 wrote:
EFI fb or KMS driver is required in EFI mode. In nvidia case, you must choose between EFI fb or nouveau.

:sigh:
EFI_FB does not conflict with intel KMS, so I doubt with does with nouveau either.
It's (after all) only something for FRAMEBUFER_CONSOLE to tap into before the correct driver takes over.
Back to top
View user's profile Send private message
s4e8
Guru
Guru


Joined: 29 Jul 2006
Posts: 309

PostPosted: Sun Oct 19, 2014 11:43 am    Post subject: Reply with quote

yes. KMS supersede EFI fb.
Back to top
View user's profile Send private message
milktoast84
n00b
n00b


Joined: 03 Oct 2014
Posts: 17

PostPosted: Wed Oct 22, 2014 4:19 am    Post subject: Reply with quote

Quick update:

Dropped efi entirely.Turns out the only reason my kernel works is because some key functionality is taken care of by switching to an efi stub. No boot yet.

Screen goes black, no backlight, then heads to next rEFInd boot option.

Could KMS be what I'm missing? I'm not even sure if it's already enabled( he says like a smiling crazy person on the edge)

Any other guess at what I missed in the kernel? What the stub provides?

All the other modules enabled were detected by a script I ran with an installed Debian desktop. Then I just applied as many as would fit, pretty much all of them with no trouble.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum