Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] no sound in headphone jack
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jyoung
Apprentice
Apprentice


Joined: 20 Mar 2007
Posts: 193

PostPosted: Tue Oct 21, 2014 4:56 pm    Post subject: [SOLVED] no sound in headphone jack Reply with quote

Hi Folks,

I'm in the weird situation that the internal speakers on my machine work fine, but I'm not getting sound through the headphone jack. When I plug in headphones, the internal speakers go silent but nothing comes through the headphones. I know that it's not a hardware problem because when I boot off a boot disk with mplayer on it, the headphones work fine. I've checked all the settings in alsamixer, and everything seems turned on.

This problem started shortly after, possibly simultaneously with, an installation of pulse audio. However, when I uninstalled pulseaudio out and deactivated consolkit, the problem persisted (I've since reinstalled pulseaudio).

Any ideas?


Last edited by jyoung on Tue Oct 28, 2014 5:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
HerrSchafer
Tux's lil' helper
Tux's lil' helper


Joined: 18 May 2011
Posts: 139

PostPosted: Tue Oct 21, 2014 5:59 pm    Post subject: Reply with quote

Hi, jyoung!
I'm with the very same trouble! I use XFCE and I have removed pulseaudio stuff, but the problem is earlier than pulseaudio.
I've tried to recompile the kernel (3.14.4 ck) with other sound options than default, with no success.
I'll be following this thread closely!
_________________
“Long is the way, and hard, that out of hell leads up to light.”
― John Milton
Back to top
View user's profile Send private message
jyoung
Apprentice
Apprentice


Joined: 20 Mar 2007
Posts: 193

PostPosted: Tue Oct 21, 2014 9:52 pm    Post subject: Reply with quote

Actually, I'm running XFCE too, and I've also looked through my kernel sound options based on what I've found in similar threads.
Back to top
View user's profile Send private message
HerrSchafer
Tux's lil' helper
Tux's lil' helper


Joined: 18 May 2011
Posts: 139

PostPosted: Wed Oct 22, 2014 2:31 am    Post subject: Reply with quote

I have solved, my problem:

Code:
emerge alsa-utils
rc-update add alsasound default
service alsasound start


It works properly mutting/unmutting the speakers and I could hear sound at headphone/external speakers.


__________________
edit: right package listed at emerge
_________________
“Long is the way, and hard, that out of hell leads up to light.”
― John Milton


Last edited by HerrSchafer on Wed Oct 22, 2014 10:13 am; edited 1 time in total
Back to top
View user's profile Send private message
jyoung
Apprentice
Apprentice


Joined: 20 Mar 2007
Posts: 193

PostPosted: Wed Oct 22, 2014 6:09 am    Post subject: Reply with quote

HerrSchafer, when I run
Code:
emerge alsasound

emerge can't find the package 'alsasound'. Did you mean alsa-tools? Possibly alsa-core?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Oct 22, 2014 7:29 am    Post subject: Reply with quote

i have one box that the channels are always muted after starting the box. And i wont bother fixing it as i just unmute it in alsamixer and it works

run alsamixer and check if they are muted. Alsamixer will give you some informations on the status
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Oct 22, 2014 7:37 am    Post subject: Reply with quote

The channels are usually muted on bootup. The responsible for setting it back to "normal" (whatever settings you had before the last shutdown) is the alsasound service, which needs to be added to any given runlevel.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
HerrSchafer
Tux's lil' helper
Tux's lil' helper


Joined: 18 May 2011
Posts: 139

PostPosted: Wed Oct 22, 2014 10:10 am    Post subject: Reply with quote

What a shame! Sorry for my mistake.

Code:
emerge alsa-utils


Then will be avaliable a daemon alsasound wich solves the problem.
_________________
“Long is the way, and hard, that out of hell leads up to light.”
― John Milton
Back to top
View user's profile Send private message
jyoung
Apprentice
Apprentice


Joined: 20 Mar 2007
Posts: 193

PostPosted: Thu Oct 23, 2014 3:42 pm    Post subject: Reply with quote

Hi Folks,

HerrSchafer, I've given your suggestion a try with alsa-utils (already emerged) and adding alsasound to my default runlevel, but with no effect. It sounds like our setups are so similar - can you think of anything else that you changed in your configuration?

A few of you suggested that maybe the headphone jack was mutted by default at bootup, and that I could unmute it with alsamixer. I regularly use alsamixer to adjust my sound levels, and I noticed that back when I first installed pulseaudio the layout of alsamixer changed. Rather than having many playback channels, there's now only one. I originally assumed that it was the master channel, but perhaps the headphone jack channel really is just muted.

Does anyone know why alsamixer might offer only one channel after pulseaudio is installed and, that being the case, how could I unmute or adjust the headphone jack channel?
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Thu Oct 23, 2014 4:11 pm    Post subject: Reply with quote

Assuming that pulse is not running, the settings are controlled by the .asoundrc in your home dir. So, erasing that should reset it to the default state. There might be global config files in /etc. I have no idea if pulse also breaks those. Never used it. Never understood what's about.

That, aside, assuming pulse is no longer in your system. If it is, then I have no idea.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
HerrSchafer
Tux's lil' helper
Tux's lil' helper


Joined: 18 May 2011
Posts: 139

PostPosted: Thu Oct 23, 2014 4:14 pm    Post subject: Reply with quote

@jyoung

I cannot find the thread from where I readed the steps I've followed... I'll look for it.
_________________
“Long is the way, and hard, that out of hell leads up to light.”
― John Milton
Back to top
View user's profile Send private message
jyoung
Apprentice
Apprentice


Joined: 20 Mar 2007
Posts: 193

PostPosted: Thu Oct 23, 2014 4:28 pm    Post subject: Reply with quote

i92guboj, I currently have pulseaudio running. Before my first post, I did try an experiment where I unmerged it and turned consolekit off. When I tried that, the headphone jack still produced no sound, so I re-emerged pulseaudio and added consolkit back it.

One curious thing, though: while I had pulseaudio unmerged, alsamixer displayed many playback channels, just as it had before.

Also, I looked in my home directory, and there's no .asoundrc file - should I create one?
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Thu Oct 23, 2014 4:42 pm    Post subject: Reply with quote

Well. As said above, I can't help with pulse 'cause I know nothing about it. Sorry.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
HerrSchafer
Tux's lil' helper
Tux's lil' helper


Joined: 18 May 2011
Posts: 139

PostPosted: Thu Oct 23, 2014 8:36 pm    Post subject: Reply with quote

Well, I kicked pulseaudio of my system... May Be because of this, it worked for me and not for you.
And I'm very excited about kicking also the *kit brothers...
_________________
“Long is the way, and hard, that out of hell leads up to light.”
― John Milton
Back to top
View user's profile Send private message
jyoung
Apprentice
Apprentice


Joined: 20 Mar 2007
Posts: 193

PostPosted: Tue Oct 28, 2014 4:03 pm    Post subject: Reply with quote

Hi Folks,

The main reason that I installed pulseaudio in the first place was that it's used by the current version of skype. But, the gentoo skype wiki suggested an alternative, and given the problems it seems to be causing I decided to pull it out.

When I first installed it, I was having some trouble getting it work with skype, so I put the pulse flag in my global USE flag in /etc/make.conf. I don't normally do this, but it seemed that pulseaudio is linked to quite a lot of other systems. When I began the process of pulling pulseaudio out, I removed this flag and did a system update. When I did this, I regained the use of my headphone jack without breaking skype.

It seems that the root cause of the problem was putting the pulse flag in the global USE variable - I think we can list this thread as 'solved'. Thanks everyone for your input!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum