Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hibernate fails with kms on radeon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
bulkin
n00b
n00b


Joined: 08 Nov 2008
Posts: 16

PostPosted: Sun Oct 26, 2014 3:24 pm    Post subject: Hibernate fails with kms on radeon Reply with quote

After switching to the open source driver, hibernate stopped working. The screen switches off, usb devices turn off, then after a second or two usb devices are powered on again. The system becomes completely unresposive, even the reset button does not work, only holding the power button turns the pc off.

I've tried tuxonice on kernel 3.16 and swsusp on 3.16 and 3.17. In all cases suspend to ram works perfectly. After booting with nomodeset (no kms and hence radeon driver not loaded), the system hibernates successfully, so the issue seems to be localized to kms and/or radeon modules.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Oct 29, 2014 1:41 pm    Post subject: Reply with quote

MAy I ask why you need to use / want to use the open source gpu driver?
Back to top
View user's profile Send private message
bulkin
n00b
n00b


Joined: 08 Nov 2008
Posts: 16

PostPosted: Thu Oct 30, 2014 3:34 pm    Post subject: Reply with quote

You mean, apart from the fact that fglrx is an abomination? :)
With the open-source driver vdpau just works, one can finally use the up to date xorg-server and the overall experience is much more stable, while framerates are not much lower.
Also, most Unity3d-based games caused a system lock up on fglrx.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5635

PostPosted: Fri Oct 31, 2014 2:39 am    Post subject: Reply with quote

Can you at least SSH into the machine when it appears frozen? If that works, try manually hibernating with one of the flags in "pm-hibernate --help". (in my case, I needed --quirk-dpms-on to get suspend working right)

Oh, and how are you loading the card firmware? That might be an issue, building it into the kernel may help.
Back to top
View user's profile Send private message
bulkin
n00b
n00b


Joined: 08 Nov 2008
Posts: 16

PostPosted: Sat Nov 01, 2014 11:01 pm    Post subject: Reply with quote

The machine becomes completely frozen: no network response, no video signal.
I've tried all the quirks -- they don't help. Firmware is already built into kernel.
Tried some debugging approaches listed here: https://www.kernel.org/doc/Documentation/power/basic-pm-debugging.txt
No Magic number appears in dmesg after reboot and the system freezes on the "devices" stage. The only difference between doing pm-hibernate and
Code:

# echo devices > /sys/power/pm_test
# echo platform > /sys/power/disk
# echo disk > /sys/power/state

is that usb devices aren't powered on in the latter case.
Back to top
View user's profile Send private message
Streetwalrus
n00b
n00b


Joined: 25 Dec 2014
Posts: 1

PostPosted: Thu Dec 25, 2014 10:59 pm    Post subject: Reply with quote

Hi.

I use Arch Linux but I have the exact same issue as you, same results when doing the debugging stuff. I found however that booting with radeon.dpm=0 allows hibernating just fine and leaves KMS/DRM enabled, you just need to switch performance profiles by hand.

I'm keeping this as a temporary solution before I look into fixing it in the kernel module.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum