Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Whats next course of action?
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sat Nov 01, 2014 3:54 pm    Post subject: Whats next course of action? Reply with quote

Hi, ALL,
I just sync'ed my tree and it told me that I need to update Portage.\
I did just that but then in the end I got following message:

Code:

!!! existing preserved libs:
>>> package: dev-db/mysql-5.5.39
 *  - /usr/lib64/libmysqlclient.so.16
 *  - /usr/lib64/mysql/libmysqlclient.so.16
 *  - /usr/lib64/mysql/libmysqlclient.so.16.0.0
 *      used by /usr/lib64/perl5/vendor_perl/5.16.3/x86_64-linux/auto/DBD/mysql/mysql.so (dev-perl/DBD-mysql-4.20.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


And so I did just that and got following results:

Code:

IgorDellGentoo igor # emerge @preserved-rebuild

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.18.2-r2 [5.16.3]
[ebuild  N     ] perl-core/File-Temp-0.230.0
[ebuild     U  ] virtual/perl-File-Temp-0.230.0-r1 [0.220.0-r2]
[ebuild     U  ] dev-perl/DBD-mysql-4.20.0-r1 [4.20.0]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r2::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-File-Spec-3.400.0-r1::gentoo, installed)
    (and 5 more with the same problem)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/subversion-1.7.14::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-Compress-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Scalar-List-Utils-1.270.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The problem is I don't see a mySQL to be pulled to be rebuilt during the last command. Unless its trying to rebuild just perl mySQL DBD package and failing.

Did I do something wrong? And if I'm right, how do I resolve the conflict?

Thank you.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 884

PostPosted: Sat Nov 01, 2014 4:00 pm    Post subject: Reply with quote

Code:
perl-cleaner all
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sat Nov 01, 2014 4:09 pm    Post subject: Reply with quote

Perfect Gentleman,
And then do:

emerge @preserved-rebuild

right?

Thank you.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 884

PostPosted: Sat Nov 01, 2014 4:15 pm    Post subject: Reply with quote

yep
p.s. but why this in "Kernel & Hardware" ?
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sat Nov 01, 2014 5:56 pm    Post subject: Reply with quote

Code:

IgorDellGentoo igor # perl-cleaner all
                                                                                                                                                                                               
 * Beginning a clean up of .ph files
 * Excluding files for 5.16.3 and 5.16.3/x86_64-linux from cleaning
                                                                                                                                                                                               
 * Locating ph files for removal
                                                                                                                                                                                               
 * Updating ph files.
 * Ignore all "No such file..." messages!
Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 * No package needs to be reinstalled.

 * Finding left over modules and header

 * The following files remain. These were either installed by hand
 * or edited. This script cannot deal with them.

IgorDellGentoo igor # emerge @preserved-rebuild

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.18.2-r2 [5.16.3]
[ebuild  N     ] perl-core/File-Temp-0.230.0
[ebuild     U  ] virtual/perl-File-Temp-0.230.0-r1 [0.220.0-r2]
[ebuild     U  ] dev-perl/DBD-mysql-4.20.0-r1 [4.20.0]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r2::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-File-Spec-3.400.0-r1::gentoo, installed)
    (and 5 more with the same problem)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/subversion-1.7.14::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-Compress-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Scalar-List-Utils-1.270.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

IgorDellGentoo igor #


Any other suggestions?

Thank you.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 884

PostPosted: Sat Nov 01, 2014 6:06 pm    Post subject: Reply with quote

maybe this thread https://forums.gentoo.org/viewtopic-t-1001442-highlight-.html could help
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sat Nov 01, 2014 7:13 pm    Post subject: Reply with quote

Perfect Gentleman,
I believe that the thread you referenced is a little different problem. See below.

Code:

IgorDellGentoo plaso-build # emerge -pv perl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.18.2-r2:0/5.18 [5.16.3:0/5.16] USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB
[ebuild  N     ] perl-core/File-Temp-0.230.0  50 kB
[ebuild     U  ] virtual/perl-File-Temp-0.230.0-r1 [0.220.0-r2] 0 kB

Total: 3 packages (2 upgrades, 1 new), Size of downloads: 13,796 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r2::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-File-Spec-3.400.0-r1::gentoo, installed)
    (and 5 more with the same problem)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/subversion-1.7.14::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-Compress-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Scalar-List-Utils-1.270.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Basically what it says is: I have an old perl installed and I don't want to get rid of it, because some packages are still depend on it. But at the same time, I will try to upgrade to the new version.
Maybe it just a good idea to run revdep-rebuild?

Thank you.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6024

PostPosted: Sat Nov 01, 2014 7:24 pm    Post subject: Reply with quote

May be worth trying those suggestions at the bottom - add "<dev-lang/perl-5.18.2" to p.mask and use --backtrack=$some-large-number.

I'm not sure how well those will actually work (I'm using Paludis) but in theory, it should knock enough sense into the dependency resolver to get a solution.
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 140
Location: Berlin (Germany)

PostPosted: Sat Nov 01, 2014 7:37 pm    Post subject: Reply with quote

First check if there are perl-core or dev-perl packages in your world file - remove them (at least temporary if necessary). Next update perl (emerge perl -v1, check if it is 5.18, maybe --nodeps is required, but it shouldn't - if you get file collisions uninstall offending packages). After that run emerge -v1 $(qlist -CI perl) .
If you run perlcleaner --all at this point, it shouldn't find anything to reinstall. Now emerge @preserved-rebuild should work.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sat Nov 01, 2014 7:54 pm    Post subject: Reply with quote

N8Fear wrote:

First check if there are perl-core or dev-perl packages in your world file - remove them (at least temporary if necessary).


Code:

IgorDellGentoo plaso-build # emerge --deselect --ask $(qlist -IC 'perl-core/*')
>>> No matching atoms found in "world" favorites file...
IgorDellGentoo plaso-build # emerge --deselect --ask $(qlist -IC 'dev-perl/*')
>>> No matching atoms found in "world" favorites file...


N8Fear wrote:

Next update perl (emerge perl -v1, check if it is 5.18, maybe --nodeps is required, but it shouldn't - if you get file collisions uninstall offending packages).


Trying to run "emerge -pv1 perl", I'm getting the same output as before:

Code:

IgorDellGentoo plaso-build # emerge -pv1 perl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.18.2-r2:0/5.18 [5.16.3:0/5.16] USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB
[ebuild  N     ] perl-core/File-Temp-0.230.0  50 kB
[ebuild     U  ] virtual/perl-File-Temp-0.230.0-r1 [0.220.0-r2] 0 kB

Total: 3 packages (2 upgrades, 1 new), Size of downloads: 13,796 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r2::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-File-Spec-3.400.0-r1::gentoo, installed)
    (and 5 more with the same problem)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/subversion-1.7.14::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-Compress-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Scalar-List-Utils-1.270.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


So which package I need to uninstall?

N8Fear wrote:

After that run emerge -v1 $(qlist -CI perl) . If you run perlcleaner --all at this point, it shouldn't find anything to reinstall. Now emerge @preserved-rebuild should work.


Thank you.
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 140
Location: Berlin (Germany)

PostPosted: Sat Nov 01, 2014 8:02 pm    Post subject: Reply with quote

Try "emerge -C $(qlist -CI virtual/perl)" first.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sat Nov 01, 2014 8:13 pm    Post subject: Reply with quote

42 virtual Perl packages was removed.
Now moving on to upgrading Perl....

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sat Nov 01, 2014 8:17 pm    Post subject: Reply with quote

OK, trying to upgrade Perl fail with the same error, but I think the list became smaller ;-):

Code:

IgorDellGentoo plaso-build # emerge -pv1 perl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.18.2-r2:0/5.18 [5.16.3:0/5.16] USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB
[ebuild  N     ] perl-core/File-Temp-0.230.0  50 kB
[ebuild  N     ] virtual/perl-File-Temp-0.230.0-r1  0 kB

Total: 3 packages (1 upgrade, 2 new), Size of downloads: 13,796 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/subversion-1.7.14::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Thank you.
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 140
Location: Berlin (Germany)

PostPosted: Sat Nov 01, 2014 8:25 pm    Post subject: Reply with quote

Make a list (you have one in the post before ;-) ) an unmerge all of the offending packages - likely they will get pulled in later anyways.

You could also try emerge -C $(qlist -CI dev-perl) and then emerge -v1 perl subversion git (this should take care of the dev-vcs/stuff in the blocker list). emerge @system @world -uvDNa should reinstall everything that you didn't add manually later.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sat Nov 01, 2014 9:03 pm    Post subject: Reply with quote

N8Fear wrote:

Make a list (you have one in the post before ;-) ) an unmerge all of the offending packages - likely they will get pulled in later anyways.

You could also try emerge -C $(qlist -CI dev-perl) and then emerge -v1 perl subversion git (this should take care of the dev-vcs/stuff in the blocker list). emerge @system @world -uvDNa should reinstall everything that you didn't add manually later.


OK, I decided to go second route.
So running:

Code:

emerge -C $(qlist -CI dev-perl)
emerge -v1 perl subversion git


finished successfully.

Next as said by the perl emerge I tried:

Code:

IgorDellGentoo plaso-build # perl-cleaner --all

 * Beginning a clean up of .ph files
 * Excluding files for 5.18.2 and 5.18.2/x86_64-linux from cleaning

 * Locating ph files for removal

 * Updating ph files.
 * Ignore all "No such file..." messages!
Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 *   Adding to list: perl-core/Digest-MD5:0
 *                   virtual/perl-Digest-MD5:0
 *   Adding to list: perl-core/Sys-Syslog:0
 *   Adding to list: perl-core/Compress-Raw-Zlib:0
 *   Adding to list: perl-core/Params-Check:0
 *   Adding to list: perl-core/ExtUtils-ParseXS:0
 *   Adding to list: perl-core/IO:0
 *   Adding to list: perl-core/Parse-CPAN-Meta:0
 *   Adding to list: perl-core/Storable:0
 *   Adding to list: perl-core/CPAN-Meta:0
 *   Adding to list: perl-core/ExtUtils-Install:0
 *   Adding to list: perl-core/Archive-Tar:0
 *   Adding to list: perl-core/File-Spec:0
 *   Adding to list: perl-core/Test-Harness:0
 *   Adding to list: perl-core/Compress-Raw-Bzip2:0
 *   Adding to list: perl-core/Module-Load:0
 *   Adding to list: perl-core/Scalar-List-Utils:0
 *                   virtual/perl-Scalar-List-Utils:0
 *   Adding to list: perl-core/Encode:0
 *   Adding to list: perl-core/ExtUtils-CBuilder:0
 *   Adding to list: perl-core/Module-CoreList:0
 *   Adding to list: perl-core/CPAN-Meta-Requirements:0
 *   Adding to list: perl-core/IO-Compress:0
 *   Adding to list: perl-core/version:0
 *   Adding to list: perl-core/Module-Build:0
 *                   virtual/perl-Module-Build:0
 *   Adding to list: perl-core/CPAN-Meta-YAML:0
 *   Adding to list: perl-core/Time-Local:0
 *   Adding to list: perl-core/ExtUtils-Manifest:0
 *   Adding to list: perl-core/ExtUtils-MakeMaker:0
 *   Adding to list: perl-core/IPC-Cmd:0
 *   Adding to list: perl-core/Module-Load-Conditional:0
 *   Adding to list: perl-core/Module-Metadata:0
 *   Adding to list: app-text/po4a:0
 * emerge -vD1 --backtrack=30 perl-core/Digest-MD5:0 virtual/perl-Digest-MD5:0 perl-core/Sys-Syslog:0 perl-core/Compress-Raw-Zlib:0 perl-core/Params-Check:0 perl-core/ExtUtils-ParseXS:0 perl-core/IO:0 perl-core/Parse-CPAN-Meta:0 perl-core/Storable:0 perl-core/CPAN-Meta:0 perl-core/ExtUtils-Install:0 perl-core/Archive-Tar:0 perl-core/File-Spec:0 perl-core/Test-Harness:0 perl-core/Compress-Raw-Bzip2:0 perl-core/Module-Load:0 perl-core/Scalar-List-Utils:0 virtual/perl-Scalar-List-Utils:0 perl-core/Encode:0 perl-core/ExtUtils-CBuilder:0 perl-core/Module-CoreList:0 perl-core/CPAN-Meta-Requirements:0 perl-core/IO-Compress:0 perl-core/version:0 perl-core/Module-Build:0 virtual/perl-Module-Build:0 perl-core/CPAN-Meta-YAML:0 perl-core/Time-Local:0 perl-core/ExtUtils-Manifest:0 perl-core/ExtUtils-MakeMaker:0 perl-core/IPC-Cmd:0 perl-core/Module-Load-Conditional:0 perl-core/Module-Metadata:0 app-text/po4a:0

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] virtual/perl-File-Spec-3.400.0-r2  0 kB
[ebuild  N     ] dev-perl/Net-Daemon-0.480.0-r1  0 kB
[ebuild  N     ] virtual/perl-Storable-2.410.0-r1  0 kB
[ebuild  N     ] virtual/perl-Sys-Syslog-0.320.0-r2  0 kB
[ebuild  N     ] virtual/perl-version-0.990.200-r1  0 kB
[ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
[ebuild   R    ] virtual/perl-Scalar-List-Utils-1.270.0-r2  0 kB
[ebuild  N     ] virtual/perl-Locale-Maketext-Simple-0.210.0-r4  0 kB
[ebuild  N     ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2  0 kB
[ebuild  N     ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1  0 kB
[ebuild  N     ] virtual/perl-JSON-PP-2.272.20-r1  0 kB
[ebuild  N     ] virtual/perl-Perl-OSType-1.3.0-r1  0 kB
[ebuild  N     ] virtual/perl-Module-Metadata-1.0.11-r1  0 kB
[ebuild  N     ] virtual/perl-CPAN-Meta-2.120.921-r2  0 kB
[ebuild  N     ] virtual/perl-Params-Check-0.360.0-r1  0 kB
[ebuild  N     ] dev-perl/SGMLSpm-1.03-r7  92 kB
[ebuild  N     ] dev-perl/TermReadKey-2.300.200-r1  37 kB
[ebuild  N     ] dev-perl/Text-CharWidth-0.40.0-r1  9 kB
[ebuild  N     ] virtual/perl-Digest-1.170.0-r3  0 kB
[ebuild  N     ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1  0 kB
[ebuild  N     ] virtual/perl-Test-Simple-0.980.0-r5  0 kB
[ebuild  N     ] virtual/perl-IO-1.280.0-r1  0 kB
[ebuild  N     ] virtual/perl-Package-Constants-0.20.0-r4  0 kB
[ebuild  N     ] virtual/perl-IO-Compress-2.60.0-r1  0 kB
[ebuild  N     ] virtual/perl-IO-Zlib-1.100.0-r4  0 kB
[ebuild  N     ] virtual/perl-IPC-Cmd-0.800.0-r1  0 kB
[ebuild  N     ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2  0 kB
[ebuild  N     ] virtual/perl-Compress-Raw-Zlib-2.60.0-r2  0 kB
[ebuild  N     ] virtual/perl-Test-Harness-3.260.0-r2  0 kB
[ebuild  N     ] virtual/perl-Archive-Tar-1.900.0-r2  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-Manifest-1.630.0-r1  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-Install-1.590.0-r1  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-Command-1.170.0-r5  0 kB
[ebuild  N     ] virtual/perl-Module-Load-Conditional-0.540.0-r1  0 kB
[ebuild  N     ] virtual/perl-Module-CoreList-3.30.0  0 kB
[ebuild  N     ] virtual/perl-Module-Load-0.240.0-r1  0 kB
[ebuild   R    ] virtual/perl-Digest-MD5-2.520.0-r2  0 kB
[ebuild     U  ] perl-core/Sys-Syslog-0.320.0-r1 [0.320.0] 0 kB
[ebuild   R    ] perl-core/Compress-Raw-Zlib-2.60.0  231 kB
[ebuild     U  ] perl-core/IO-1.25-r1 [1.25] 52 kB
[ebuild     U  ] perl-core/Storable-2.390.0-r1 [2.390.0] 0 kB
[ebuild     U  ] perl-core/ExtUtils-Install-1.540.0-r1 [1.540.0] 66 kB
[ebuild   R    ] perl-core/File-Spec-3.400.0  137 kB
[ebuild   R    ] perl-core/Test-Harness-3.260.0  288 kB
[ebuild   R    ] perl-core/Compress-Raw-Bzip2-2.60.0  133 kB
[ebuild   R    ] perl-core/Module-Load-0.240.0  6 kB
[ebuild   R    ] perl-core/Scalar-List-Utils-1.270.0  68 kB
[ebuild     U  ] perl-core/Encode-2.470.0-r1 [2.470.0] 0 kB
[ebuild   R    ] perl-core/Module-CoreList-2.840.0  59 kB
[ebuild     U  ] perl-core/version-0.990.100-r1 [0.990.100] 105 kB
[ebuild     U  ] perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 31 kB
[ebuild     U  ] perl-core/Time-Local-1.230.0-r1 [1.230.0] 0 kB
[ebuild     U  ] perl-core/ExtUtils-Manifest-1.610.0-r1 [1.610.0] 29 kB
[ebuild  N     ] dev-perl/File-BaseDir-0.30.0-r1  USE="{-test}" 0 kB
[ebuild  N     ] dev-perl/PlRPC-0.202.0-r2  0 kB
[ebuild  N     ] dev-perl/Text-WrapI18N-0.60.0-r1  4 kB
[ebuild     U  ] perl-core/Digest-MD5-2.520.0-r1 [2.520.0] 0 kB
[ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 12 kB
[ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1 [3.180.0] 62 kB
[ebuild     U  ] perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400] 8 kB
[ebuild     U  ] perl-core/Archive-Tar-1.900.0-r1 [1.900.0] 57 kB
[ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1 [2.122.0] 21 kB
[ebuild   R    ] perl-core/IO-Compress-2.60.0  238 kB
[ebuild     U  ] perl-core/Module-Build-0.400.300-r1 [0.400.300] USE="{-test}" 301 kB
[ebuild     U  ] perl-core/ExtUtils-MakeMaker-6.640.0-r1 [6.640.0] 412 kB
[ebuild     U  ] perl-core/IPC-Cmd-0.780.0-r1 [0.780.0] 27 kB
[ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  13 kB
[ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 27 kB
[ebuild  N     ] dev-perl/File-DesktopEntry-0.40.0-r1  USE="{-test}" 0 kB
[ebuild  N     ] dev-perl/DBI-1.628.0  USE="{-test}" 573 kB
[ebuild     U  ] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 75 kB
[ebuild     U  ] perl-core/ExtUtils-CBuilder-0.280.205-r1 [0.280.205] 34 kB
[ebuild  N     ] dev-perl/File-MimeInfo-0.170.0-r1  USE="{-test}" 0 kB
[ebuild  N     ] dev-perl/Locale-gettext-1.50.0-r1  8 kB
[ebuild  N     ] dev-perl/DBD-mysql-4.20.0-r1  USE="-embedded" 0 kB
[ebuild     U  ] app-text/po4a-0.45-r1 [0.42] USE="{-test}" 2,158 kB
[blocks B      ] <perl-core/ExtUtils-MakeMaker-6.660.0 ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking virtual/perl-ExtUtils-MakeMaker-6.660.0-r1)
[blocks B      ] <perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0" is blocking virtual/perl-Module-CoreList-3.30.0)
[blocks B      ] <perl-core/ExtUtils-Install-1.590.0 ("<perl-core/ExtUtils-Install-1.590.0" is blocking virtual/perl-ExtUtils-Install-1.590.0-r1)
[blocks B      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
[blocks B      ] <perl-core/ExtUtils-Manifest-1.630.0 ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking virtual/perl-ExtUtils-Manifest-1.630.0-r1)
[blocks B      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)
[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)
[blocks B      ] <perl-core/Storable-2.410.0 ("<perl-core/Storable-2.410.0" is blocking virtual/perl-Storable-2.410.0-r1)

Total: 79 packages (22 upgrades, 45 new, 12 reinstalls), Size of downloads: 5,357 kB
Conflict: 9 blocks (9 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-MakeMaker:0

  (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-version-0.77 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-version required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.870 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.82 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.87 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)

  (perl-core/ExtUtils-Install-1.540.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-Install:0

  (perl-core/IO-1.25-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/IO:0

  (perl-core/Storable-2.390.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Storable:0

  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    >=virtual/perl-ExtUtils-CBuilder-0.27 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-CBuilder required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for merge)

  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/IPC-Cmd:0

  (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-Manifest:0

  (virtual/perl-Storable-2.410.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-Storable-2.410.0-r1 required by (dev-perl/PlRPC-0.202.0-r2::gentoo, ebuild scheduled for merge)
    >=virtual/perl-Storable-1.0.7 required by (dev-perl/PlRPC-0.202.0-r2::gentoo, ebuild scheduled for merge)

  (virtual/perl-IO-1.280.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-IO-1.280.0-r1 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-IO required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)

  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-CBuilder:0

  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Module-CoreList:0

  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-Module-CoreList-0.22 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    =virtual/perl-Module-CoreList-3.30.0 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)

  (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/version:0

  (virtual/perl-ExtUtils-MakeMaker-6.660.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
    >=virtual/perl-ExtUtils-MakeMaker-6.56 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.


Now this I don't understand.
At this point the system should've contain only perl itself. So how come there is so many failures? ;-)

Thank you.
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 140
Location: Berlin (Germany)

PostPosted: Sat Nov 01, 2014 9:09 pm    Post subject: Reply with quote

Run emerge @system @world -uvDN before perl-cleaner --all (maybe even emerge @preserved-rebuild )
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sun Nov 02, 2014 1:46 pm    Post subject: Reply with quote

OK, the upgrade finished successfully.
Now going thru the post-install messages I see this:

Code:

 * Messages for package dev-python/pyyaml-3.11:

 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at http://bugs.gentoo.org unless you report exactly which
 * two packages install the same file(s). See
 * http://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how to
 * solve the problem. And once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *      /usr/lib64/python2.7/site-packages/PyYAML-3.11-py2.7.egg-info
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * None of the installed packages claim the file(s).
 *
 * Package 'dev-python/pyyaml-3.11' merged despite file collisions. If
 * necessary, refer to your elog messages for the whole content of the
 * above message.
 *
 * Installation of a regular file is blocked by a directory:
 *   '/usr/lib64/python2.7/site-packages/PyYAML-3.11-py2.7.egg-info'
 * This file will be merged with a different name:
 *   '/usr/lib64/python2.7/site-packages/PyYAML-3.11-py2.7.egg-info.backup.0000'
 *


How do I resolve this?
I have both python 2.7 and python 3.x installed. The active one is 2.7.

Thank you.
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 140
Location: Berlin (Germany)

PostPosted: Sun Nov 02, 2014 2:44 pm    Post subject: Reply with quote

Run equery b /usr/lib64/python2.7/site-packages/PyYAML-3.11-py2.7.egg-info - this should output the name of the package that'S owning the file. If portage doesn't know it you manually installed it or it got orphaned somehow - in this case I'd just delete it.
Otherwise reinstall the package that owns it and try again.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sun Nov 02, 2014 3:11 pm    Post subject: Reply with quote

Code:

IgorDellGentoo igor # equery b /usr/lib64/python2.7/site-packages/PyYAML-3.11-py2.7.egg-info
 * Searching for /usr/lib64/python2.7/site-packages/PyYAML-3.11-py2.7.egg-info ...
dev-python/pyyaml-3.11 (/usr/lib64/python2.7/site-packages/PyYAML-3.11-py2.7.egg-info)


Its actually not a file but a directory. And it looks like it just text files inside:

Code:

IgorDellGentoo igor # cd /usr/lib64/python2.7/site-packages/PyYAML-3.11-py2.7.egg-info
IgorDellGentoo PyYAML-3.11-py2.7.egg-info # ls -la
total 36
drwxr-xr-x  2 root root  4096 Aug 25 00:28 .
drwxr-xr-x 64 root root 12288 Nov  2 13:11 ..
-rw-r--r--  1 root root  1665 Aug 25 00:28 PKG-INFO
-rw-r--r--  1 root root   546 Aug 25 00:28 SOURCES.txt
-rw-r--r--  1 root root     1 Aug 25 00:28 dependency_links.txt
-rw-r--r--  1 root root   726 Aug 25 00:28 installed-files.txt
-rw-r--r--  1 root root    11 Aug 25 00:28 top_level.txt


Probably orphaned from the old 2.7 version.

Deleting....

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Mon Nov 03, 2014 12:42 am    Post subject: Reply with quote

Continue going thru the post-install messages, I see the following:

Code:

 * Messages for package sys-fs/udev-216:

 *   CONFIG_FHANDLE:     is not set when it should be.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.
 *
 * Starting from version >= 197 the new predictable network interface names are
 * used by default, see:
 * http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
 * http://cgit.freedesktop.org/systemd/systemd/tree/src/udev/udev-builtin-net_id.c
 *
 * Example command to get the information for the new interface name before booting
 * (replace <ifname> with, for example, eth0):
 * # udevadm test-builtin net_id /sys/class/net/<ifname> 2> /dev/null
 *
 * You can use either kernel parameter "net.ifnames=0", create empty
 * file /etc/systemd/network/99-default.link, or symlink it to /dev/null
 * to disable the feature.
 *
 * You need to restart udev as soon as possible to make the upgrade go
 * into effect.
 * The method you use to do this depends on your init system.
 * For sys-apps/openrc users it is:
 * # /etc/init.d/udev --nodeps restart
 *
 * For more information on udev on Gentoo, upgrading, writing udev rules, and
 * fixing known issues visit:
 * http://wiki.gentoo.org/wiki/Udev
 * http://wiki.gentoo.org/wiki/Udev/upgrade


I can rebuild the kernel and reboot and then re-emerge udev, but the question is: Will I have access to the system after reboot?
This is udev we are talking about...

Thank you.
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 140
Location: Berlin (Germany)

PostPosted: Mon Nov 03, 2014 3:44 am    Post subject: Reply with quote

I'd simply apply Occam's razor: since you have access to the system right now without CONFIG_FHANDLE you'll likely have after reboot: especially if you rebuild a kernel with CONFIG_FHANDLE before reboot.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Tue Nov 04, 2014 2:59 am    Post subject: Reply with quote

Hi,
Yes, I rebuilt the kernel, reboot and it worked.
And now I think I have a known issue:

Code:

PERL5LIB=. po4a --variable srcdir=../../man --variable builddir=../../man --variable podir=./tmp-po --keep 0 ./po4a.cfg
Can't locate Locale/Po4a/Chooser.pm in @INC (you may need to install the Locale::Po4a::Chooser module) (@INC contains: . /etc/perl /usr/local/lib64/perl5/5.18.2/x86_64-linux /usr/local/lib64/perl5/5.18.2 /usr/lib64/perl5/vendor_perl/5.18.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.18.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.18.2/x86_64-linux /usr/lib64/perl5/5.18.2 .) at /usr/bin/po4a line 547.
BEGIN failed--compilation aborted at /usr/bin/po4a line 547.
Makefile:1443: recipe for target 'all-local' failed
make[3]: *** [all-local] Error 2
make[3]: Leaving directory '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6/man/po4a'
Makefile:1697: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6/man'
Makefile:1413: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'
Makefile:1340: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: sys-apps/man-db-2.6.6::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sys-apps/man-db-2.6.6::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/man-db-2.6.6::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'
 * S: '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'

>>> Failed to emerge sys-apps/man-db-2.6.6, Log file:

>>>  '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/build.log'

 * Messages for package sys-apps/man-db-2.6.6:

 * Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings
 * ERROR: sys-apps/man-db-2.6.6::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sys-apps/man-db-2.6.6::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/man-db-2.6.6::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/man-db-2.6.6/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'
 * S: '/var/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: sys-libs/gdbm-1.11
 *  - /usr/lib64/libgdbm.so.3
 *  - /usr/lib64/libgdbm.so.3.0.0
 *      used by /usr/bin/catman (sys-apps/man-db-2.6.6)
 *      used by /usr/bin/mandb (sys-apps/man-db-2.6.6)
 *      used by /usr/bin/whatis (sys-apps/man-db-2.6.6)
 *      used by 2 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 2 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.


I think I will need to build po4a, right?

Thank you.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8129
Location: ~Brussels - Belgique

PostPosted: Tue Nov 04, 2014 8:12 am    Post subject: Reply with quote

Try first
Code:
perl-cleaner --all

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Wed Nov 05, 2014 2:33 am    Post subject: Reply with quote

This is what "perl-cleaner --all" yields:

Code:

IgorDellGentoo igor # perl-cleaner --all

 * Beginning a clean up of .ph files
 * Excluding files for 5.18.2 and 5.18.2/x86_64-linux from cleaning

 * Locating ph files for removal

 * Updating ph files.
 * Ignore all "No such file..." messages!
Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 *   Adding to list: perl-core/Digest-MD5:0
 *                   virtual/perl-Digest-MD5:0
 *   Adding to list: perl-core/Sys-Syslog:0
 *                   virtual/perl-Sys-Syslog:0
 *   Adding to list: perl-core/Compress-Raw-Zlib:0
 *                   virtual/perl-Compress-Raw-Zlib:0
 *   Adding to list: perl-core/Params-Check:0
 *   Adding to list: perl-core/ExtUtils-ParseXS:0
 *   Adding to list: perl-core/Parse-CPAN-Meta:0
 *   Adding to list: perl-core/CPAN-Meta:0
 *   Adding to list: perl-core/ExtUtils-Install:0
 *   Adding to list: perl-core/Archive-Tar:0
 *   Adding to list: perl-core/File-Spec:0
 *                   virtual/perl-File-Spec:0
 *   Adding to list: perl-core/Test-Harness:0
 *   Adding to list: perl-core/Compress-Raw-Bzip2:0
 *   Adding to list: perl-core/Module-Load:0
 *   Adding to list: perl-core/Scalar-List-Utils:0
 *                   virtual/perl-Scalar-List-Utils:0
 *   Adding to list: perl-core/ExtUtils-CBuilder:0
 *   Adding to list: perl-core/Module-CoreList:0
 *   Adding to list: perl-core/CPAN-Meta-Requirements:0
 *   Adding to list: perl-core/IO-Compress:0
 *                   virtual/perl-IO-Compress:0
 *   Adding to list: perl-core/version:0
 *   Adding to list: perl-core/Module-Build:0
 *                   virtual/perl-Module-Build:0
 *   Adding to list: perl-core/CPAN-Meta-YAML:0
 *   Adding to list: perl-core/Time-Local:0
 *                   virtual/perl-Time-Local:0
 *   Adding to list: perl-core/ExtUtils-Manifest:0
 *   Adding to list: perl-core/IPC-Cmd:0
 *   Adding to list: perl-core/Module-Load-Conditional:0
 *   Adding to list: perl-core/Module-Metadata:0
 * emerge -vD1 --backtrack=30 perl-core/Digest-MD5:0 virtual/perl-Digest-MD5:0 perl-core/Sys-Syslog:0 virtual/perl-Sys-Syslog:0 perl-core/Compress-Raw-Zlib:0 virtual/perl-Compress-Raw-Zlib:0 perl-core/Params-Check:0 perl-core/ExtUtils-ParseXS:0 perl-core/Parse-CPAN-Meta:0 perl-core/CPAN-Meta:0 perl-core/ExtUtils-Install:0 perl-core/Archive-Tar:0 perl-core/File-Spec:0 virtual/perl-File-Spec:0 perl-core/Test-Harness:0 perl-core/Compress-Raw-Bzip2:0 perl-core/Module-Load:0 perl-core/Scalar-List-Utils:0 virtual/perl-Scalar-List-Utils:0 perl-core/ExtUtils-CBuilder:0 perl-core/Module-CoreList:0 perl-core/CPAN-Meta-Requirements:0 perl-core/IO-Compress:0 virtual/perl-IO-Compress:0 perl-core/version:0 perl-core/Module-Build:0 virtual/perl-Module-Build:0 perl-core/CPAN-Meta-YAML:0 perl-core/Time-Local:0 virtual/perl-Time-Local:0 perl-core/ExtUtils-Manifest:0 perl-core/IPC-Cmd:0 perl-core/Module-Load-Conditional:0 perl-core/Module-Metadata:0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] virtual/perl-File-Spec-3.400.0-r2  0 kB
[ebuild   R    ] virtual/perl-Sys-Syslog-0.320.0-r2  0 kB
[ebuild  N     ] virtual/perl-version-0.990.200-r1  0 kB
[ebuild   R    ] virtual/perl-Scalar-List-Utils-1.270.0-r2  0 kB
[ebuild   R    ] virtual/perl-Compress-Raw-Zlib-2.60.0-r2  0 kB
[ebuild   R    ] virtual/perl-IO-Compress-2.60.0-r1  0 kB
[ebuild  N     ] virtual/perl-Locale-Maketext-Simple-0.210.0-r4  0 kB
[ebuild  N     ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2  0 kB
[ebuild   R    ] virtual/perl-Time-Local-1.230.0-r1  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1  0 kB
[ebuild  N     ] virtual/perl-JSON-PP-2.272.20-r1  0 kB
[ebuild  N     ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1  0 kB
[ebuild  N     ] virtual/perl-Perl-OSType-1.3.0-r1  0 kB
[ebuild  N     ] virtual/perl-Module-Metadata-1.0.11-r1  0 kB
[ebuild  N     ] virtual/perl-Params-Check-0.360.0-r1  0 kB
[ebuild   R    ] virtual/perl-Digest-MD5-2.520.0-r2  0 kB
[ebuild  N     ] virtual/perl-Digest-1.170.0-r3  0 kB
[ebuild  N     ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2  0 kB
[ebuild  N     ] virtual/perl-Test-Simple-0.980.0-r5  0 kB
[ebuild  N     ] virtual/perl-Package-Constants-0.20.0-r4  0 kB
[ebuild  N     ] virtual/perl-IO-Zlib-1.100.0-r4  0 kB
[ebuild  N     ] virtual/perl-IPC-Cmd-0.800.0-r1  0 kB
[ebuild  N     ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2  0 kB
[ebuild  N     ] virtual/perl-Test-Harness-3.260.0-r2  0 kB
[ebuild  N     ] virtual/perl-Archive-Tar-1.900.0-r2  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2  0 kB
[ebuild  N     ] virtual/perl-CPAN-Meta-2.120.921-r2  0 kB
[ebuild  N     ] virtual/perl-Module-Load-Conditional-0.540.0-r1  0 kB
[ebuild  N     ] virtual/perl-Module-CoreList-3.30.0  0 kB
[ebuild  N     ] virtual/perl-Module-Load-0.240.0-r1  0 kB
[ebuild     U  ] perl-core/Sys-Syslog-0.320.0-r1 [0.320.0] 0 kB
[ebuild   R    ] perl-core/Compress-Raw-Zlib-2.60.0  231 kB
[ebuild     U  ] perl-core/ExtUtils-Install-1.540.0-r1 [1.540.0] 66 kB
[ebuild   R    ] perl-core/File-Spec-3.400.0  137 kB
[ebuild   R    ] perl-core/Test-Harness-3.260.0  288 kB
[ebuild   R    ] perl-core/Compress-Raw-Bzip2-2.60.0  133 kB
[ebuild   R    ] perl-core/Module-Load-0.240.0  6 kB
[ebuild   R    ] perl-core/Scalar-List-Utils-1.270.0  68 kB
[ebuild   R    ] perl-core/Module-CoreList-2.840.0  59 kB
[ebuild     U  ] perl-core/version-0.990.100-r1 [0.990.100] 105 kB
[ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
[ebuild     U  ] perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 31 kB
[ebuild     U  ] perl-core/Time-Local-1.230.0-r1 [1.230.0] 0 kB
[ebuild     U  ] perl-core/ExtUtils-Manifest-1.610.0-r1 [1.610.0] 29 kB
[ebuild     U  ] perl-core/Digest-MD5-2.520.0-r1 [2.520.0] 0 kB
[ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 12 kB
[ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1 [3.180.0] 62 kB
[ebuild     U  ] perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400] 8 kB
[ebuild     U  ] perl-core/Archive-Tar-1.900.0-r1 [1.900.0] 57 kB
[ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1 [2.122.0] 21 kB
[ebuild   R    ] perl-core/IO-Compress-2.60.0  238 kB
[ebuild     U  ] perl-core/Module-Build-0.400.300-r1 [0.400.300] USE="{-test}" 301 kB
[ebuild     U  ] perl-core/IPC-Cmd-0.780.0-r1 [0.780.0] 27 kB
[ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  13 kB
[ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 27 kB
[ebuild     U  ] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 75 kB
[ebuild     U  ] perl-core/ExtUtils-CBuilder-0.280.205-r1 [0.280.205] 34 kB
[blocks B      ] <perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0" is blocking virtual/perl-Module-CoreList-3.30.0)
[blocks B      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)

Total: 57 packages (17 upgrades, 23 new, 17 reinstalls), Size of downloads: 2,017 kB
Conflict: 4 blocks (4 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-version-0.77 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-version required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.870 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.82 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.87 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)

  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Module-CoreList:0

  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    >=virtual/perl-ExtUtils-CBuilder-0.27 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-CBuilder required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for merge)

  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/IPC-Cmd:0

  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-CBuilder:0

  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-Module-CoreList-0.22 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    =virtual/perl-Module-CoreList-3.30.0 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)

  (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/version:0


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 * If you encounter blockers involving virtuals and perl-core, here are
 * some things to try:
 *   Remove all perl-core packages from your world file
 *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
 *   Update all the installed Perl virtuals
 *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
 *   Afterwards re-run perl-cleaner
 *
 * Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.


Any idea on how to fix?

Thank you.
Back to top
View user's profile Send private message
kurly
Apprentice
Apprentice


Joined: 02 Apr 2012
Posts: 254

PostPosted: Wed Nov 05, 2014 3:00 am    Post subject: Reply with quote

ONEEYEMAN wrote:

Code:


 * If you encounter blockers involving virtuals and perl-core, here are
 * some things to try:
 *   Remove all perl-core packages from your world file
 *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
 *   Update all the installed Perl virtuals
 *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
 *   Afterwards re-run perl-cleaner
 *
 * Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.


Any idea on how to fix?

Thank you.
Yes, I have some ideas. You're welcome. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum