Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SD reader fail: Realtek Semiconductor Co., Ltd. Device 5289
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 642

PostPosted: Wed Nov 05, 2014 9:43 am    Post subject: SD reader fail: Realtek Semiconductor Co., Ltd. Device 5289 Reply with quote

Hi,
I've one of these SD card readers
Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)

but I can't get it to work in my system. Nothing comes up in dmesg and it seems no /dev point is created. Apparently they're very difficult to get to work but this thread is from 2012.
https://forums.gentoo.org/viewtopic-t-922794-start-0.html

I was wondering if anyone knew anything else about this or had a way of making it work with modern kernels
Here's some extra information

Thanks for any help you can offer.
James

Quote:

Module Size Used by
nvidia 11012914 0
mxm_wmi 1355 0
ath9k 145085 0
ath9k_common 1943 1 ath9k
ath9k_hw 409655 2 ath9k_common,ath9k
uvcvideo 70679 0
videobuf2_vmalloc 2808 1 uvcvideo
ath 15185 3 ath9k_common,ath9k,ath9k_hw
videobuf2_memops 1807 1 videobuf2_vmalloc
videobuf2_core 27375 1 uvcvideo
videodev 104994 2 uvcvideo,videobuf2_core
x86_pkg_temp_thermal 4725 0
rtsx_pci 25905 0
mfd_core 2945 1 rtsx_pci
r8169 57850 0
wmi 7883 1 mxm_wmi


Quote:
linux # grep MMC .config
CONFIG_PCI_MMCONFIG=y
# Supported MMC/SDIO adapters
CONFIG_MMC=m
# CONFIG_MMC_DEBUG is not set
# CONFIG_MMC_UNSAFE_RESUME is not set
# CONFIG_MMC_CLKGATE is not set
# MMC/SD/SDIO Card Drivers
CONFIG_MMC_BLOCK=m
CONFIG_MMC_BLOCK_MINORS=8
CONFIG_MMC_BLOCK_BOUNCE=y
# CONFIG_MMC_TEST is not set
# MMC/SD/SDIO Host Controller Drivers
CONFIG_MMC_SDHCI=m
CONFIG_MMC_SDHCI_PCI=m
CONFIG_MMC_RICOH_MMC=y
# CONFIG_MMC_SDHCI_ACPI is not set
# CONFIG_MMC_SDHCI_PLTFM is not set
# CONFIG_MMC_WBSD is not set
# CONFIG_MMC_TIFM_SD is not set
# CONFIG_MMC_SDRICOH_CS is not set
# CONFIG_MMC_CB710 is not set
# CONFIG_MMC_VIA_SDMMC is not set
# CONFIG_MMC_VUB300 is not set
# CONFIG_MMC_USHC is not set
# CONFIG_MMC_REALTEK_PCI is not set

_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Nov 05, 2014 4:09 pm    Post subject: Reply with quote

is the device listed in the output of lspci or lsusb?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum