Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/etc/fstab - mount options ignored?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
palettentreter
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2006
Posts: 100

PostPosted: Sat Nov 08, 2014 1:16 am    Post subject: /etc/fstab - mount options ignored? Reply with quote

Hey everyone,

I've noticed something strange when mounting a removable SATA drive. In /etc/fstab I have:
Code:

UUID=053a76f6-d8c6-44d7-aa40-41fa460f3849 /run/media/ich/stuff/ ext4 exec,noatime,acl,user,noauto       0 2

but when I do "mount /run/media/ich/stuff/", I end up with:
Code:

# mount | grep stuff
/dev/sdb5 on /run/media/ich/stuff type ext4 (rw,nosuid,nodev,noexec,noatime,data=ordered,user)

8O
So apparently the exec mount option is ignored. How can that be? The fstab manpage even says it should be default. I considered this a pretty simple mechanism, but WTF?

Any ideas what might be getting in between me and my options?
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1317

PostPosted: Sat Nov 08, 2014 1:28 am    Post subject: Reply with quote

Hi!

Put the exec option after the user option.
Code:
noatime,acl,user,exec,noauto
Back to top
View user's profile Send private message
palettentreter
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2006
Posts: 100

PostPosted: Sat Nov 08, 2014 3:27 am    Post subject: Reply with quote

Awesome, thanks! :D 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum