Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Updating armv7a-hardfloat-linux-gnueabi-*
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Sat Nov 08, 2014 3:00 pm    Post subject: Updating armv7a-hardfloat-linux-gnueabi-* Reply with quote

destroyedlolo,

The cross compiler should be listed in your world file so it should be upgraded with eveything else in @world.
What (cross) version are you looking for?

Forked from another tread where this level of detail was off topic - NeddySeaggon
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.


Last edited by NeddySeagoon on Sat Nov 08, 2014 8:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
destroyedlolo
l33t
l33t


Joined: 17 Jun 2011
Posts: 695
Location: Close to Annecy (France)

PostPosted: Sat Nov 08, 2014 4:37 pm    Post subject: Reply with quote

Hi Neddy;

NeddySeagoon wrote:
The cross compiler should be listed in your world file so it should be upgraded with eveything else in @world.
What (cross) version are you looking for?


I would like my armv7a-hardfloat-linux-gnueabi-* being updated.
But despite it is in my world file :
Code:
PiV laurent # grep 'arm-*' /var/lib/portage/world
cross-armv7a-hardfloat-linux-gnueabi/binutils
cross-armv7a-hardfloat-linux-gnueabi/gcc
cross-armv7a-hardfloat-linux-gnueabi/glibc
cross-armv7a-hardfloat-linux-gnueabi/linux-headers

despite the last stable version for ARM is 4.8.3 (and has been upgraded on my banana), I wasn't able to make it upgraded on my x86 box
Code:
PiV laurent # gcc-config -l
 [1] armv7a-hardfloat-linux-gnueabi-4.7.3 *

 [2] x86_64-pc-linux-gnu-4.7.3 *
 [3] x86_64-pc-linux-gnu-4.8.3


I naively tested to upgrade it manually but

Code:
PiV laurent # emerge -vp cross-armv7a-hardfloat-linux-gnueabi/gcc

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "cross-armv7a-hardfloat-linux-gnueabi/gcc".


So I duno how to upgrade but by removing the cross tool chain and reinstalling it.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Sat Nov 08, 2014 5:05 pm    Post subject: Reply with quote

destroyedlolo,

Please post your emerge --info
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
destroyedlolo
l33t
l33t


Joined: 17 Jun 2011
Posts: 695
Location: Close to Annecy (France)

PostPosted: Sat Nov 08, 2014 5:54 pm    Post subject: Reply with quote

Code:
PiV laurent # emerge --info
Portage 2.2.8-r2 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.19-r1, 3.14.14-gentoo x86_64)
=================================================================
System uname: Linux-3.14.14-gentoo-x86_64-Intel-R-_Core-TM-_i5-3210M_CPU_@_2.50GHz-with-gentoo-2.2
KiB Mem:     8057976 total,    256408 free
KiB Swap:     249000 total,    249000 free
Timestamp of tree: Sun, 02 Nov 2014 15:00:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.7, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.7.3-r1, 4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7-avx -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l5.0"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://celeron.chez.moi/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr apng archive avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups curl cxx dbus device-mapper dga dri dts dv dvd dvdr emboss encode exif faac fam fbcon ffmpeg firefox flac fontconfig fuse g3dvl gd gdbm gif gimp glamor gphoto2 gpm gtk gvfs hddtemp iconv imlib joystick jpeg jpeg2k lcms ldap libcaca libnotify mad matroska mmx mng modules mp3 mp4 mpeg multilib ncurses networkmanager nls nptl nsplugin ogg oggvorbis opengl openmp pam pango pcre pdf png policykit ppds ppp pulseaudio python qt3support qt4 readline sdl session smp speex spell sqlite sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification subversion svg syslog tcpd theora threads tiff truetype udev udisks unicode upower usb vdpau vorbis vpx win32codecs wxwidgets x264 xcb xinerama xml xosd xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_file authz_default authz_groupfile authz_host authz_user autoindex cgi dav dav_fs dav_lock deflate dir env filter info log_config mime negotiation setenvif status unique_id userdir" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2 canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" SANE_BACKENDS="snapscan" USERLAND="GNU" VIDEO_CARDS="intel" XFCE_PLUGINS="brightness clock trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3 3.4"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Sat Nov 08, 2014 6:17 pm    Post subject: Reply with quote

destroyedlolo,

For testing only, what does
Code:
ACCEPT_KEYWORDS="~amd64"  emerge -uDNp1 cross-armv7a-hardfloat-linux-gnueabi/gcc

Tell you?

This is for one line only, telling portage to consider keyword masked packages. Do not use this command to install anything as portage will not remember it and will downgrade next time.
There is a correct way to install keyword wasked packages and this isn't it. We only want to know what portage would do if we let it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
destroyedlolo
l33t
l33t


Joined: 17 Jun 2011
Posts: 695
Location: Close to Annecy (France)

PostPosted: Sat Nov 08, 2014 8:02 pm    Post subject: Reply with quote

many things :D

Code:
PiV laurent # ACCEPT_KEYWORDS="~amd64"  emerge -uDNp1a cross-armv7a-hardfloat-linux-gnueabi/gcc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-lang/python-exec-2.0.1-r1  PYTHON_TARGETS="(python3_4*)"
[ebuild     U  ] app-arch/xz-utils-5.0.7 [5.0.5-r1]
[ebuild     U  ] app-arch/bzip2-1.0.6-r7 [1.0.6-r6]
[ebuild     U  ] dev-libs/expat-2.1.0-r4 [2.1.0-r3]
[ebuild     U  ] sys-devel/gnuconfig-20140728 [20140212]
[ebuild     U  ] sys-devel/binutils-config-4 [3-r3]
[ebuild  N     ] sys-apps/gentoo-functions-0.8
[ebuild     U  ] dev-libs/lzo-2.08-r1 [2.08]
[ebuild     U  ] sys-libs/timezone-data-2014i-r1 [2014g]
[ebuild     U  ] app-text/poppler-data-0.4.7 [0.4.6]
[ebuild     U  ] sys-devel/gcc-config-1.8 [1.7.3]
[ebuild     U  ] dev-libs/libffi-3.1-r3 [3.0.13-r1]
[ebuild     U  ] sys-devel/patch-2.7.1-r3 [2.6.1] USE="-xattr%"
[ebuild     U  ] media-libs/libogg-1.3.2 [1.3.1]
[ebuild     U  ] sci-libs/fftw-3.3.4 [3.3.3-r2]
[ebuild     U  ] media-libs/ilmbase-2.1.0 [1.0.2] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] media-libs/libpng-1.6.13 [1.6.12]
[ebuild     U  ] sys-devel/m4-1.4.17 [1.4.16]
[ebuild     U  ] sys-apps/coreutils-8.23 [8.21] USE="-multicall%"
[ebuild     U  ] dev-libs/gmp-6.0.0a [5.1.3-r1]
[ebuild     U  ] virtual/acl-0-r2 [0-r1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] app-arch/zip-3.0-r2 [3.0-r1]
[ebuild     U  ] dev-libs/mpfr-3.1.2_p10 [3.1.2-r1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] dev-libs/nettle-2.7.1-r1 [2.7.1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] media-libs/libpano13-2.9.19 [2.9.18]
[ebuild     U  ] dev-libs/mpc-1.0.2-r1 [1.0.1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] media-libs/giflib-4.2.3-r1 [4.1.6-r3]
[ebuild     U  ] sys-libs/readline-6.3_p8-r1 [6.2_p5-r1]
[ebuild     U  ] net-misc/rsync-3.1.1 [3.0.9-r3]
[ebuild     U  ] media-libs/openexr-2.1.0 [1.7.0] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] sys-devel/bc-1.06.95-r1 [1.06.95]
[ebuild     U  ] sys-fs/udev-init-scripts-27 [26-r2]
[ebuild     U  ] sys-auth/pambase-20140313 [20120417-r3]
[ebuild     U  ] dev-libs/libusb-1.0.19 [1.0.18]
[ebuild     U  ] app-admin/perl-cleaner-2.17 [2.16]
[ebuild     U  ] app-admin/python-updater-0.13 [0.11]
[ebuild     U  ] app-admin/eselect-python-20140125 [20111108]
[ebuild     U  ] app-text/docbook-xsl-stylesheets-1.78.0-r1 [1.78.0]
[ebuild     U  ] app-text/build-docbook-catalog-1.20 [1.19.1]
[ebuild     U  ] media-fonts/dejavu-2.34 [2.33]
[ebuild     U  ] app-shells/bash-4.3_p30 [4.2_p53]
[ebuild     U  ] dev-lang/python-2.7.8 [2.7.7]
[ebuild     U  ] app-misc/ca-certificates-20140927.3.17.2 [20130906-r1] USE="cacert%*"
[ebuild     U  ] sys-apps/file-5.20-r1 [5.19]
[ebuild     U  ] dev-python/pyelftools-0.22 [0.21-r4] USE="-examples%" PYTHON_TARGETS="-python3_4%"
[ebuild     U  ] dev-python/setuptools-7.0 [2.2] USE="{-test%}"
[ebuild     U  ] dev-util/boost-build-1.55.0 [1.52.0-r1]
[ebuild     U  ] sys-libs/cracklib-2.9.2 [2.9.1-r1]
[ebuild     U  ] app-misc/pax-utils-0.9.1 [0.8.1]
[ebuild     U  ] dev-libs/boost-1.55.0-r2 [1.52.0-r7] USE="-context%" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="-python3_4%"
[ebuild     U  ] dev-python/numpy-1.9.0-r1 [1.8.0-r1]
[ebuild     U  ] dev-python/cython-0.21.1 [0.19.1-r1] PYTHON_TARGETS="-python3_4%"
[ebuild     U  ] sys-apps/kmod-18-r2 [18-r1]
[ebuild     U  ] sys-devel/gettext-0.19.3 [0.18.3.2]
[ebuild     U  ] sys-devel/make-4.1-r1 [4.0-r1]
[ebuild     U  ] sys-apps/findutils-4.5.14-r1 [4.4.2-r1] USE="-debug%"
[ebuild     U  ] sys-apps/sed-4.2.2 [4.2.1-r1]
[ebuild     U  ] sys-apps/util-linux-2.25.2 [2.24.1-r3]
[ebuild     U  ] dev-libs/libgpg-error-1.15 [1.13]
[ebuild     U  ] dev-libs/elfutils-0.160 [0.158]
[ebuild     U  ] sys-devel/bison-3.0.2 [2.4.3]
[ebuild     U  ] media-gfx/exiv2-0.24 [0.23-r1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] app-admin/eselect-1.4.3 [1.4.1]
[ebuild     U  ] dev-libs/libpcre-8.36 [8.35]
[ebuild     U  ] sys-apps/portage-2.2.14 [2.2.8-r2] PYTHON_TARGETS="-pypy%"
[ebuild     U  ] dev-lang/swig-2.0.12 [2.0.9]
[ebuild     U  ] dev-libs/gobject-introspection-1.40.0-r2 [1.40.0-r1]
[ebuild     U  ] x11-misc/shared-mime-info-1.3 [1.2-r1]
[ebuild     U  ] dev-libs/dbus-glib-0.102 [0.100.2-r1]
[ebuild     U  ] x11-libs/libvdpau-0.8 [0.7] USE="{-test%}"
[ebuild     U  ] app-text/poppler-0.26.5 [0.24.5] USE="(-qt5)"
[ebuild     U  ] sys-kernel/linux-headers-3.17-r1 [3.13]
[ebuild     U  ] x11-misc/xdg-utils-1.1.0_rc2-r1 [1.1.0_rc2]
[ebuild     U  ] app-text/qpdf-5.1.2 [5.1.1]
[ebuild     U  ] dev-libs/libtasn1-4.2 [3.6]
[ebuild  NS    ] sys-devel/automake-1.14.1 [1.11.6, 1.13.4]
[ebuild     U  ] sys-devel/libtool-2.4.3-r1 [2.4.2-r1]
[ebuild     U  ] x11-libs/libXext-1.3.3 [1.3.2]
[ebuild     U  ] x11-proto/xproto-7.0.26 [7.0.25]
[ebuild     U  ] media-libs/fontconfig-2.11.1-r1 [2.10.92]
[ebuild     U  ] dev-db/sqlite-3.8.7 [3.8.6]
[ebuild     U  ] x11-libs/xtrans-1.3.5 [1.3.3]
[ebuild     U  ] x11-proto/inputproto-2.3.1 [2.3]
[ebuild  NS    ] sys-libs/db-6.0.30-r1 [4.8.30-r1] USE="cxx -doc -examples -java -tcl {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] x11-libs/pixman-0.32.6 [0.32.4]
[ebuild     U  ] dev-libs/libgcrypt-1.6.2 [1.5.4-r1]
[ebuild     U  ] net-nds/openldap-2.4.40-r2 [2.4.38-r2] USE="-static-libs%"
[ebuild  N     ] dev-scheme/guile-1.8.8-r1  USE="deprecated nls regex threads -debug -debug-freelist -debug-malloc -discouraged -emacs -networking"
[ebuild     U  ] dev-libs/icu-53.1 [52.1]
[ebuild     U  ] media-libs/flac-1.3.0-r1 [1.3.0]
[ebuild     U  ] x11-misc/util-macros-1.19.0 [1.18.0]
[ebuild     U  ] sci-libs/gsl-1.16 [1.14] USE="-static-libs%"
[ebuild     U  ] sci-libs/hdf5-1.8.13 [1.8.10]
[ebuild     U  ] dev-libs/libatomic_ops-7.4.0 [7.2d]
[ebuild     U  ] dev-libs/json-c-0.12 [0.11-r1]
[ebuild     U  ] x11-libs/libXi-1.7.4 [1.7.2]
[ebuild     U  ] x11-libs/libICE-1.0.9 [1.0.8-r1]
[ebuild     U  ] net-misc/curl-7.38.0 [7.37.1]
[ebuild     U  ] x11-libs/libXft-2.3.2 [2.3.1-r1]
[ebuild     U  ] x11-libs/libSM-1.2.2-r1 [1.2.2]
[ebuild     U  ] dev-util/cmake-3.0.2 [2.8.12.2-r1] USE="-doc%"
[ebuild     U  ] media-libs/glew-1.11.0 [1.10.0-r2]
[ebuild     U  ] media-libs/vigra-1.10.0 [1.8.0] USE="-mpi%" PYTHON_TARGETS="python2_7%*"
[ebuild     U  ] dev-lang/perl-5.20.1-r2 [5.18.2-r2]
[ebuild     U  ] perl-core/File-Temp-0.230.400-r1 [0.230.0]
[ebuild     U  ] virtual/perl-File-Temp-0.230.400-r2 [0.230.0-r1]
[ebuild     U  ] virtual/perl-File-Spec-3.480.0 [3.400.0-r2]
[ebuild  N     ] dev-perl/Text-Unidecode-0.40.0-r1
[ebuild  N     ] dev-perl/libintl-perl-1.230.0
[ebuild     U  ] dev-util/gtk-doc-am-1.21 [1.20]
[ebuild     U  ] sys-apps/help2man-1.46.4 [1.43.3]
[ebuild     U  ] media-libs/exiftool-9.74 [9.12]
[ebuild     U  ] dev-libs/libical-1.0.1 [0.48-r2] USE="-doc% -introspection%"
[ebuild     U  ] virtual/perl-Module-Build-0.420.500 [0.400.300-r1]
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.980.0 [6.660.0-r1]
[ebuild     U  ] dev-libs/libxml2-2.9.2 [2.9.1-r4]
[ebuild  N     ] dev-perl/Unicode-EastAsianWidth-1.330.0-r1
[ebuild     U  ] sys-apps/texinfo-5.2 [4.13-r2]
[ebuild  N     ] sys-devel/autogen-5.18.4  USE="-libopts -static-libs"
[ebuild     U  ] dev-perl/File-MimeInfo-0.210.0 [0.170.0-r1]
[ebuild     U  ] dev-libs/libxslt-1.1.28-r4 [1.1.28-r3]
[ebuild     U  ] x11-proto/xcb-proto-1.11 [1.10] PYTHON_TARGETS="-python3_4%"
[ebuild     U  ] x11-libs/libxcb-1.11 [1.10]
[ebuild     U  ] net-libs/gnutls-3.3.9 [2.12.23-r6] USE="crywrap%* -dane%" ABI_X86="(64%*) -32% (-x32)" LINGUAS="en%* fr%* -cs% -de% -fi% -it% -ms% -nl% -pl% -sv% -uk% -vi% -zh_CN%"
[ebuild     U  ] app-text/xmlto-0.0.26 [0.0.25]
[ebuild     U  ] net-print/cups-2.0.0-r2 [1.7.5]
[ebuild     U  ] app-text/ghostscript-gpl-9.15 [9.10-r2]
[ebuild     U  ] net-print/cups-filters-1.0.54 [1.0.53]
[ebuild     U  ] dev-libs/glib-2.40.2 [2.40.0-r1]
[uninstall     ] dev-util/gdbus-codegen-2.40.0
[blocks b      ] <dev-util/gdbus-codegen-2.40.2 ("<dev-util/gdbus-codegen-2.40.2" is blocking dev-libs/glib-2.40.2)
[ebuild     U  ] x11-libs/cairo-1.12.16-r3 [1.12.16] USE="lto%*" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] sys-fs/udev-217 [216]
[ebuild     U  ] dev-util/pkgconfig-0.28-r2 [0.28-r1]
[ebuild     U  ] gnome-extra/polkit-gnome-0.105-r1 [0.105]
[ebuild     U  ] x11-libs/libnotify-0.7.6 [0.7.5-r1]
[ebuild     U  ] net-wireless/bluez-5.24 [5.21-r1]
[ebuild     U  ] media-libs/lensfun-0.3.0 [0.2.8-r1]
[ebuild     U  ] media-libs/harfbuzz-0.9.35 [0.9.28]
[ebuild     U  ] media-sound/pulseaudio-5.0-r3 [5.0-r2] USE="-zeroconf%"
[ebuild     U  ] x11-libs/pango-1.36.8 [1.36.5]
[ebuild     U  ] media-video/ffmpeg-2.2.10 [1.2.6-r1] USE="opengl%* sse%* sse2%* sse3%* sse4_2%* -amrenc% (-armv5te) (-armv6) (-armv6t2) (-armvfp) -avx2% -fma3% -fma4% -gme% -ladspa% (-mips32r2) (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -quvi% -sse4% -ssh% -wavpack% -webp% -x265% -zvbi%" FFTOOLS="ffhash%*"
[ebuild     U  ] x11-libs/gtk+-2.24.25 [2.24.24]
[ebuild     U  ] media-libs/libcanberra-0.30-r2 [0.30-r1]
[ebuild  N     ] media-libs/libxmi-1.3  USE="-static-libs"
[ebuild     U  ] media-libs/plotutils-2.6-r1 [2.6]
[blocks b      ] <=media-libs/plotutils-2.6 ("<=media-libs/plotutils-2.6" is blocking media-libs/libxmi-1.3)
[blocks b      ] media-libs/libxmi ("media-libs/libxmi" is blocking media-libs/plotutils-2.6)
[ebuild     U  ] media-gfx/enblend-4.1.3 [4.1.1] USE="-image-cache*"
[ebuild  r  U  ] media-gfx/hugin-2014.0.0-r1 [2013.0.0-r1] PYTHON_SINGLE_TARGET="-python3_4%" PYTHON_TARGETS="-python3_4%"
[blocks B      ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-fs/udev-init-scripts-27, sys-apps/kmod-18-r2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.1-r2::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.20.1* required by (virtual/perl-File-Spec-3.480.0::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

  (dev-lang/perl-5.18.2-r2::gentoo, installed) pulled in by
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTML-Parser-3.710.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/File-DesktopEntry-0.40.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-vcs/git-2.0.4::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/LWP-Protocol-https-6.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/URI-1.600.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/File-Listing-6.40.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Message-6.30.0-r1::gentoo, installed)
    =dev-lang/perl-5.18* required by (virtual/perl-libnet-1.220.0-r2::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.10.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/TermReadKey-2.300.200-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Locale-gettext-1.50.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Encode-Locale-1.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Daemon-6.10.0-r1::gentoo, installed)
    (and 7 more with the same problems)

x11-libs/libxcb:0

  (x11-libs/libxcb-1.10::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.3:0/0=[abi_x86_64(-)] required by (media-libs/mesa-10.3.1::gentoo, installed)

  (x11-libs/libxcb-1.11::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/icu:0

  (dev-libs/icu-53.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-52.1::gentoo, installed) pulled in by
    >=dev-libs/icu-4.8.1.1:0/52= required by (app-office/libreoffice-bin-4.2.6.3::gentoo, installed)
    dev-libs/icu:0/52 required by (app-office/libreoffice-bin-4.2.6.3::gentoo, installed)
    dev-libs/icu:0/52= required by (app-text/libmspub-0.0.6::gentoo, installed)
    dev-libs/icu:0/52= required by (app-text/libebook-0.0.2::gentoo, installed)
    dev-libs/icu:0/52= required by (media-libs/raptor-2.0.9::gentoo, installed)
    dev-libs/icu:0/52= required by (media-libs/libvisio-0.0.30::gentoo, installed)
    dev-libs/icu:0/52= required by (media-libs/libcdr-0.0.14::gentoo, installed)
    (and 1 more with the same problems)

media-libs/openexr:0

  (media-libs/openexr-1.7.0::gentoo, installed) pulled in by
    >=media-libs/openexr-1.5:0/0= required by (media-video/cinelerra-20120707::gentoo, installed)

  (media-libs/openexr-2.1.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.5.4-r1::gentoo, installed) pulled in by
    >=dev-libs/libgcrypt-1.4:0/11= required by (app-crypt/gnupg-2.0.26::gentoo, installed)
    (and 3 more with the same problem)

  (dev-libs/libgcrypt-1.6.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-text/poppler:0

  (app-text/poppler-0.26.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.24.5::gentoo, installed) pulled in by
    app-text/poppler:0/44 required by (app-office/libreoffice-bin-4.2.6.3::gentoo, installed)
    >=app-text/poppler-0.24:0/44=[cairo] required by (app-text/evince-3.12.1::gentoo, installed)
    (and 2 more with the same problems)

media-video/ffmpeg:0

  (media-video/ffmpeg-2.2.10::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-video/ffmpeg-1.2.6-r1::gentoo, installed) pulled in by
    >=media-video/ffmpeg-1.2.1:0/0= required by (media-video/mplayer-1.2_pre20130729::gentoo, installed)
    (and 1 more with the same problem)

dev-libs/boost:0

  (dev-libs/boost-1.55.0-r2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.52.0-r7::gentoo, installed) pulled in by
    >=dev-libs/boost-1.51.0:0/1.52= required by (dev-libs/liborcus-0.5.1::gentoo, installed)
    dev-libs/boost:0/1.52= required by (dev-libs/libixion-0.5.0::gentoo, installed)
    dev-libs/boost:0/1.52= required by (app-text/libetonyek-0.0.3::gentoo, installed)
    dev-libs/boost:0/1.52= required by (dev-cpp/libcmis-0.4.1::gentoo, installed)
    dev-libs/boost:0/1.52 required by (app-office/libreoffice-bin-4.2.6.3::gentoo, installed)
    (and 2 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-init-scripts-27::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/udev-217::gentoo, ebuild scheduled for merge)

  (sys-apps/openrc-0.12.4::gentoo, installed) pulled in by
    sys-apps/openrc required by (virtual/service-manager-0::gentoo, installed)
    sys-apps/openrc required by @system
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2::gentoo, installed)

  (sys-apps/kmod-18-r2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/kmod required by (sys-apps/pciutils-3.2.0::gentoo, installed)
    sys-apps/kmod[tools] required by (virtual/modutils-0::gentoo, installed)
    >=sys-apps/kmod-16 required by (sys-fs/udev-217::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following packages are causing rebuilds:

  (dev-libs/boost-1.55.0-r2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-gfx/hugin-2014.0.0-r1::gentoo, ebuild scheduled for merge)
  (media-libs/openexr-2.1.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-gfx/hugin-2014.0.0-r1::gentoo, ebuild scheduled for merge)
  (media-libs/libpano13-2.9.19::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-gfx/hugin-2014.0.0-r1::gentoo, ebuild scheduled for merge)
  (media-libs/glew-1.11.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-gfx/hugin-2014.0.0-r1::gentoo, ebuild scheduled for merge)

!!! The following installed packages are masked:
- net-misc/tsclient-2.0.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (11 Oct 2014)
# Masked for removal in a month.
# Obsolete and unmaintained for years. You should switch
# to one of the many available alternatives like (#508854):
# - >=gnome-base/gnome-3.12 (either with standard or 'Classic' modes)
# - gnome-extra/cinnamon
# - mate-base/mate
# - xfce-base/xfce4-meta
# - ...
#<media-libs/clutter-gst-2.0.10

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


but again, w/o my X-gcc :cry:
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Sat Nov 08, 2014 8:33 pm    Post subject: Reply with quote

destroyedlolo,

I will poke at this some more but probably not this weekend. I don't have cross distcc on this install.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
destroyedlolo
l33t
l33t


Joined: 17 Jun 2011
Posts: 695
Location: Close to Annecy (France)

PostPosted: Sat Nov 08, 2014 8:36 pm    Post subject: Reply with quote

No problem, I'm not in hurry : I keep the old 4.7.3 for the moment :D

Nice W.E.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Sun Nov 09, 2014 3:53 pm    Post subject: Reply with quote

As already said, you have built the stable cross toolchain.

To have gcc 4.8, you have 2 options
1. call again crossdev without the -S option
2. edit /usr/arm*/etc/portage/make.conf and add ~arm in ACCEPT_KEYWORDS

Then only gcc-4.8 will be available for cross-arm.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Sun Nov 09, 2014 6:07 pm    Post subject: Reply with quote

Hello,

I have to apologize. GCC 4.8.3 is stable for arm, but as you are pointing out, there could be a problem within crossdev...

I will check it now ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Sun Nov 09, 2014 6:15 pm    Post subject: Reply with quote

On my (unstable) config, if I ask a stable cross environment for armv7, I get gcc 4.8

Can you try to get the latest portage tree, do a emerge -DuNav @world, and check if it will go better, once crossdev is up-to-date ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
destroyedlolo
l33t
l33t


Joined: 17 Jun 2011
Posts: 695
Location: Close to Annecy (France)

PostPosted: Mon Nov 10, 2014 11:49 pm    Post subject: Reply with quote

XavierMiller wrote:
Can you try to get the latest portage tree, do a emerge -DuNav @world, and check if it will go better, once crossdev is up-to-date ?


I did a system upgrade with the command above but the result is the same :
Code:
PiV ~ # gcc-config -l
 [1] armv7a-hardfloat-linux-gnueabi-4.7.3 *

 [2] x86_64-pc-linux-gnu-4.7.3 *
 [3] x86_64-pc-linux-gnu-4.8.3


But I wonder if the problem is not on emerge side :
Code:
PiV ~ # emerge -a gcc

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies |

 
[ Results for search key : gcc ]
[ Applications found : 2 ]

*  cross-armv7a-hardfloat-linux-gnueabi/gcc
      Latest version installed: 4.7.3-r1
      Homepage:      http://gcc.gnu.org/
      Description:   The GNU Compiler Collection
      License:       GPL-3+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.3+

*  sys-devel/gcc
      Latest version available: 4.8.3
      Latest version installed: 4.8.3
      Size of files: 84,145 kB
      Homepage:      http://gcc.gnu.org/
      Description:   The GNU Compiler Collection
      License:       GPL-3+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.3+

!!! The short ebuild name "gcc" is ambiguous. Please specify
!!! one of the above fully-qualified ebuild names instead.

... done!
PiV ~ # emerge -a cross-armv7a-hardfloat-linux-gnueabi/gcc

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "cross-armv7a-hardfloat-linux-gnueabi/gcc".


It seems it doesn't know how to deal with cross version.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Tue Nov 11, 2014 4:50 pm    Post subject: Reply with quote

no, the error message says that "emerge gcc" is ambigous because you have multiple "gcc". You need to use the category (sys-devel/gcc or cross-armv7a-*/gcc).

If you have eix, could you give us the output of
Code:
eix cross-armv7a-hardfloat-linux-gnueabi/gcc
?

Have you tried to uninstall the arm toolchain (crossdev -C) and re-create it?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
destroyedlolo
l33t
l33t


Joined: 17 Jun 2011
Posts: 695
Location: Close to Annecy (France)

PostPosted: Tue Nov 11, 2014 6:49 pm    Post subject: Reply with quote

XavierMiller wrote:
no, the error message says that "emerge gcc" is ambigous because you have multiple "gcc". You need to use the category (sys-devel/gcc or cross-armv7a-*/gcc).

Not if you see the end of my capture :wink:
Code:
PiV ~ # emerge -a cross-armv7a-hardfloat-linux-gnueabi/gcc

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "cross-armv7a-hardfloat-linux-gnueabi/gcc".


XavierMiller wrote:
If you have eix, could you give us the output of
Code:
eix cross-armv7a-hardfloat-linux-gnueabi/gcc
?

Code:
PiV laurent # eix cross-armv7a-hardfloat-linux-gnueabi/gcc
No matches found.


XavierMiller wrote:
Have you tried to uninstall the arm toolchain (crossdev -C) and re-create it?

Not yet but if I upgrade, I'll have to way to trouble shoot until next Gcc update.


Last edited by destroyedlolo on Tue Nov 11, 2014 7:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Tue Nov 11, 2014 7:01 pm    Post subject: Reply with quote

It looks really strange...

Try to uninstall the cross target (crossdev -C), then clean all armv7 references (in /etc/portage and /usr), then reinstall the cross toolchain.

It looks like there is a typo...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Tue Nov 11, 2014 7:28 pm    Post subject: Reply with quote

destroyedlolo,

It loosks like cross-armv7a-hardfloat-linux-gnueab/* is provided by an overlay, not portage.

Code:
$ emerge -a cross-armv7a-hardfloat-linux-gnueabi/gcc -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "cross-armv7a-hardfloat-linux-gnueabi/gcc".


You will therefore need to sync the overlay using layman to get the new ebuilds.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
destroyedlolo
l33t
l33t


Joined: 17 Jun 2011
Posts: 695
Location: Close to Annecy (France)

PostPosted: Tue Nov 11, 2014 10:50 pm    Post subject: Reply with quote

You got it, thanks a lot.

Crossdev needs a local overlay and the documentation I used was incomplete : I have to add in my /etc/portage/make.conf
Code:
PORTDIR_OVERLAY="/usr/local/portage"


After adding this line, my cross tool chain is correctly updated (no need to use Layman here as it is only local).

Thanks for both of you for the time you spent on this issue :D
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Wed Nov 12, 2014 9:08 am    Post subject: Reply with quote

Pfiouuuuuuuu !!!! :)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum