Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] UDEV hangs on boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
erzapito
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2007
Posts: 104

PostPosted: Wed Nov 12, 2014 1:48 pm    Post subject: [SOLVED] UDEV hangs on boot Reply with quote

Hi, I just finished intalling a clean gentoo but when booting it seems that udev hangs just after this:

"waiting for uevents to be processed"

I know it's udev because if I don't initialize it, the system finishes booting.

One thing that bothers me is that after 10 seconds (more or less) the caret stops blinking.

I'm really lost and I don't know even where to look to see what's udev doing to get stuck.


Last edited by erzapito on Wed Nov 12, 2014 6:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Wed Nov 12, 2014 2:09 pm    Post subject: Reply with quote

it should be stuck while waiting for firmware loading to timeout.
have a look at https://forums.gentoo.org/viewtopic.php?p=7648414
Back to top
View user's profile Send private message
erzapito
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2007
Posts: 104

PostPosted: Wed Nov 12, 2014 2:22 pm    Post subject: Reply with quote

I've seen that message but it happens with udev 216 and with eudev. What really bugs me is the caret stopping blinking.
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 202
Location: Switzerland

PostPosted: Wed Nov 12, 2014 2:54 pm    Post subject: Reply with quote

hi,
do you probably have an older nvidia card and are using the proprietray nvidia-drivers package? I had this problem too, when I merged a version of nvidia-drivers which were to new for my card. (I also must admit, that I didn't pay too much attention to the news after the merge, which statet, that the version of nvidia-drivers was to new for my card.)
So after i downgraded to the correct version of nvidia-drivers, everything went along well.

also, for me, pressing Ctrl+C when the "waiting for uevents to be processed" canceled the process and the system bootet to login (I do not use any graphical login manager).
_________________
For calming down your eyes or clearing your mind: www.patrickwehli.ch
Back to top
View user's profile Send private message
erzapito
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2007
Posts: 104

PostPosted: Wed Nov 12, 2014 2:56 pm    Post subject: Reply with quote

I have a Nvidia optimus double card, i'll try to remove the propietary drivers. About Ctrl+C, I have tried but didn't work.
Back to top
View user's profile Send private message
erzapito
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2007
Posts: 104

PostPosted: Wed Nov 12, 2014 6:52 pm    Post subject: Reply with quote

You were right, I removed the nvidia drivers and it booted perfectly.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43178
Location: 56N 3W

PostPosted: Wed Nov 12, 2014 7:24 pm    Post subject: Reply with quote

erzapito,

The Nvidia optimus is only a card and a half. The Nvidia half cannot refresh the display, hence its ontly a half a graphics card.
This is good for power consumption and price but bad for software complexity.

You must always usu the Intel graphics to refresh the display.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 202
Location: Switzerland

PostPosted: Thu Nov 13, 2014 10:02 am    Post subject: Reply with quote

hi,
I'm glad, you could fix it. There is also a wiki [1] which describes, how to use nvidia optimus cards on gentoo. If this reference is not enough, you could also have a look at the corresponding arch wiki [2].


[1]http://wiki.gentoo.org/wiki/NVIDIA_Driver_with_Optimus_Laptops
[2]https://wiki.archlinux.org/index.php/NVIDIA_Optimus
_________________
For calming down your eyes or clearing your mind: www.patrickwehli.ch
Back to top
View user's profile Send private message
erzapito
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2007
Posts: 104

PostPosted: Thu Nov 13, 2014 10:11 am    Post subject: Reply with quote

I've tried to setup it multiple times, but always got strange errors. Curenttly I'm pretty busy but I think I'll try to get it working again someday.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum