Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can not open Xorg?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
joshua83
n00b
n00b


Joined: 19 Oct 2014
Posts: 7

PostPosted: Wed Nov 12, 2014 7:12 am    Post subject: can not open Xorg? Reply with quote

I follow the link: https://wiki.gentoo.org/wiki/Xorg/Configuration
the xorg was installed, but i can not open it

here is the log:

Code:

[ 16237.957]
X.Org X Server 1.15.0
Release Date: 2013-12-27


[ 16238.014] X Protocol Version 11, Revision 0


[ 16238.034] Build Operating System: Linux 3.16.5-gentoo x86_64 Gentoo


[ 16238.054] Current Operating System: Linux localhost 3.16.5-gentoo #1 SMP Wed Nov 12 15:04:58 CST 2014 x86_64


[ 16238.054] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.16.5-gentoo root=UUID=03189834-1474-49b2-bd9e-c624a966f1d3 ro


[ 16238.096] Build Date: 12 November 2014 09:28:50PM


[ 16238.116]


[ 16238.137] Current version of pixman: 0.32.4


[ 16238.178] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.


[ 16238.178] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.


[ 16238.262] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 12 22:40:06 2014


[ 16238.283] (==) Using config file: "/etc/X11/xorg.conf"


[ 16238.304] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 16238.305] (==) ServerLayout "X.org Configured"


[ 16238.305] (**) |-->Screen "Screen0" (0)


[ 16238.305] (**) | |-->Monitor "Monitor0"


[ 16238.305] (**) | |-->Device "Card0"


[ 16238.305] (**) |-->Input Device "Mouse0"
[ 16238.305] (**) |-->Input Device "Keyboard0"


[ 16238.305] (==) Automatically adding devices
[ 16238.305] (==) Automatically enabling devices


[ 16238.305] (==) Automatically adding GPU devices


[ 16238.305] (WW) The directory "/usr/share/fonts/TTF/" does not exist.


[ 16238.305] Entry deleted from font path.


[ 16238.305] (WW) The directory "/usr/share/fonts/OTF/" does not exist.


[ 16238.305] Entry deleted from font path.


[ 16238.305] (WW) The directory "/usr/share/fonts/Type1/" does not exist.


[ 16238.305] Entry deleted from font path.


[ 16238.305] (WW) `fonts.dir* not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 16238.305] Entry deleted from font path.


[ 16238.305] (Run *mkfontdir* on "/usr/share/fonts/100dpi/").


[ 16238.305] (WW) `fonts.dir* not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 16238.305] Entry deleted from font path.


[ 16238.305] (Run *mkfontdir* on "/usr/share/fonts/75dpi/").


[ 16238.305] (WW) The directory "/usr/share/fonts/TTF/" does not exist.


[ 16238.305] Entry deleted from font path.


[ 16238.305] (WW) The directory "/usr/share/fonts/OTF/" does not exist.


[ 16238.305] Entry deleted from font path.


[ 16238.305] (WW) The directory "/usr/share/fonts/Type1/" does not exist.


[ 16238.305] Entry deleted from font path.


[ 16238.305] (WW) `fonts.dir* not found (or not valid) in "/usr/share/fonts/100dpi/".


[ 16238.305] Entry deleted from font path.


[ 16238.305] (Run *mkfontdir* on "/usr/share/fonts/100dpi/").


[ 16238.305] (WW) `fonts.dir* not found (or not valid) in "/usr/share/fonts/75dpi/".


[ 16238.305] Entry deleted from font path.


[ 16238.305] (Run *mkfontdir* on "/usr/share/fonts/75dpi/").


[ 16238.305] (**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/misc/
[ 16238.305] (**) ModulePath set to "/usr/lib64/xorg/modules"


[ 16238.305] (WW) Hotplugging is on, devices using drivers *kbd*, *mouse* or *vmmouse* will be disabled.


[ 16238.305] (WW) Disabling Mouse0


[ 16238.305] (WW) Disabling Keyboard0


[ 16238.305] (II) Loader magic: 0x7ecc60


[ 16238.305] (II) Module ABI versions:


[ 16238.305] X.Org ANSI C Emulation: 0.4


[ 16238.305] X.Org Video Driver: 15.0


[ 16238.305] X.Org XInput driver : 20.0


[ 16238.305] X.Org Server Extension : 8.0


[ 16238.306] (--) PCI:*(0:0:2:0) 8086:0166:17aa:5001 rev 9, Mem @ 0xcb000000/4194304, 0xb0000000/268435456, I/O @ 0x00007000/64


[ 16238.306] (--) PCI: (0:1:0:0) 10de:1058:17aa:5001 rev 161, Mem @ 0xca000000/16777216, 0xc0000000/134217728, 0xc8000000/33554432, I/O @ 0x00006000/128
[ 16238.327] Initializing built-in extension Generic Event Extension


[ 16238.348] Initializing built-in extension SHAPE


[ 16238.368] Initializing built-in extension MIT-SHM


[ 16238.388] Initializing built-in extension XInputExtension


[ 16238.408] Initializing built-in extension XTEST


[ 16238.427] Initializing built-in extension BIG-REQUESTS


[ 16238.446] Initializing built-in extension SYNC


[ 16238.465] Initializing built-in extension XKEYBOARD


[ 16238.483] Initializing built-in extension XC-MISC


[ 16238.501] Initializing built-in extension XINERAMA


[ 16238.518] Initializing built-in extension XFIXES


[ 16238.535] Initializing built-in extension RENDER


[ 16238.552] Initializing built-in extension RANDR


[ 16238.568] Initializing built-in extension COMPOSITE


[ 16238.584] Initializing built-in extension DAMAGE


[ 16238.600] Initializing built-in extension MIT-SCREEN-SAVER


[ 16238.616] Initializing built-in extension DOUBLE-BUFFER


[ 16238.631] Initializing built-in extension RECORD


[ 16238.646] Initializing built-in extension DPMS


[ 16238.661] Initializing built-in extension Present


[ 16238.675] Initializing built-in extension DRI3


[ 16238.689] Initializing built-in extension X-Resource


[ 16238.703] Initializing built-in extension XVideo


[ 16238.717] Initializing built-in extension XVideo-MotionCompensation


[ 16238.731] Initializing built-in extension XFree86-VidModeExtension


[ 16238.744] Initializing built-in extension XFree86-DGA


[ 16238.757] Initializing built-in extension XFree86-DRI


[ 16238.770] Initializing built-in extension DRI2
[ 16238.770] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.


[ 16238.770] (II) LoadModule: "glx"


[ 16238.770] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so


[ 16238.770] (II) Module glx: vendor="X.Org Foundation"


[ 16238.770] compiled for 1.15.0, module version = 1.0.0


[ 16238.770] ABI class: X.Org Server Extension, version 8.0


[ 16238.770] (==) AIGLX enabled
[ 16238.783] Loading extension GLX


[ 16238.783] (II) LoadModule: "intel"


[ 16238.783] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so


[ 16238.783] (II) Module intel: vendor="X.Org Foundation"


[ 16238.783] compiled for 1.15.0, module version = 2.21.15


[ 16238.783] Module class: X.Org Video Driver


[ 16238.783] ABI class: X.Org Video Driver, version 15.0


[ 16238.783] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200


[ 16238.783] (--) using VT number 7




[ 16238.854] (EE) No devices detected.


[ 16238.854] (EE)
Fatal server error:


[ 16238.854] (EE) no screens found(EE)


[ 16238.854] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.


[ 16238.854] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.


[ 16238.854] (EE)




how to solve this?

mod edit by i92guboj: please, use code tags when appropiate.
Back to top
View user's profile Send private message
joshua83
n00b
n00b


Joined: 19 Oct 2014
Posts: 7

PostPosted: Wed Nov 12, 2014 7:16 am    Post subject: Reply with quote

i used these code:
Code:

#nano /etc/portage/make.conf       
add these         INPUT_DEVICES="evdev synaptics"
                        VIDEO_CARDS="intel"
# echo "x11-base/xorg-server udev" >> /etc/portage/package.use
# emerge --ask xorg-server
# env-update
# source /etc/profile
# Xorg -configure
# cp /root/xorg.conf.new /etc/X11/xorg.conf
# emerge twm xterm
# startx


xorg does not work
then
Code:
# emerge xf86-video-intel
# emerge

xorg does not work



my laptop is lenovo e430
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2643

PostPosted: Wed Nov 12, 2014 7:38 am    Post subject: Reply with quote

Would reading https://wiki.gentoo.org/wiki/Intel help?
If not will you please shouw us your output of lspci so we can see what yout hardware is
Code:
# lspci -k
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Nov 12, 2014 11:52 am    Post subject: Reply with quote

Try following that wiki. Failing that, you will need to set up modelines for your display. The GPU driver seems to start ok, the problem comes when detecting the display.

Also, please, try to use
Code:
...
tags around the snippets the code you paste. It greatly improves readability in graphic browsers. Don't mark the "Disable BBCode by default" option in your profile.

I will fix them this time.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
joshua83
n00b
n00b


Joined: 19 Oct 2014
Posts: 7

PostPosted: Wed Nov 12, 2014 12:51 pm    Post subject: Reply with quote

i think the problem is about the video card driver, because of using the genkernel.
here is the hardware info

Display:
Video Adapter Intel(R) HD Graphics 4000 (1692660 KB)
Video Adapter Intel(R) HD Graphics 4000 (1692660 KB)
Video Adapter Intel(R) HD Graphics 4000 (1692660 KB)
Video Adapter NVIDIA GeForce 610M (1024 MB)
Monitor 通用即插即用监视器 [NoDB]

Multimedia:
Audio Adapter High Definition Audio 控制器 [8086-1E20] [NoDB]

Storage:
IDE Controller Intel(R) 7 Series/C216 Chipset Family 2 port Serial ATA Storage Controller - 1E09
IDE Controller Intel(R) 7 Series/C216 Chipset Family 4 port Serial ATA Storage Controller - 1E01
IDE Controller Realtek PCIE CardReader
Disk Drive WDC WD7500BPVT-08HXZT3 ATA Device (698 GB, IDE)
Optical Drive HL-DT-ST DVDRAM GT50N ATA Device
SMART Hard Disks Status OK

Partitions:
C: (NTFS) 25600 MB (4658 MB free)
D: (NTFS) 327.0 GB (139.1 GB free)
E: (NTFS) 321.6 GB (211.2 GB free)
Total Size 673.6 GB (354.9 GB free)

Input:
Keyboard PS/2 标准键盘
Mouse HID-compliant mouse
Mouse ThinkPad UltraNav Pointing Device

Network:
Primary IP Address 192.168.1.123
Primary MAC Address E0-06-E6-CE-0A-7B
Network Adapter 1x1 11b/g/n Wireless LAN PCI Express Half Mini Card Adapter (192.168.1.123)
Network Adapter Microsoft Virtual WiFi Miniport Adapter
Network Adapter Realtek PCIe GBE Family Controller
Network Adapter VirtualBox Host-Only Ethernet Adapter (192.168.56.1)

Peripherals:
Printer Fax
Printer Microsoft XPS Document Writer
USB2 Controller Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E26 [8086-1E26] [NoDB]
USB2 Controller Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller - 1E2D [8086-1E2D] [NoDB]
USB Device Generic USB Hub
USB Device Generic USB Hub
USB Device Integrated Camera
USB Device USB Composite Device
USB Device USB 输入设备
Battery Microsoft AC Adapter
Battery Microsoft ACPI-Compliant Control Method Battery
Battery Microsoft Composite Battery

DMI:
DMI BIOS Vendor LENOVO
DMI BIOS Version H0ET72WW (2.06 )
DMI System Manufacturer LENOVO
DMI System Product 3254B85
DMI System Version ThinkPad Edge E430
DMI System Serial Number MP272RP
DMI System UUID 01B39311-D451CB11-A91CD275-A2E8A592
DMI Motherboard Manufacturer LENOVO
DMI Motherboard Product 3254B85
DMI Motherboard Version Not Available
DMI Motherboard Serial Number 1ZM4A2BE31I
DMI Chassis Manufacturer LENOVO
DMI Chassis Version Not Available
DMI Chassis Serial Number MP272RP
DMI Chassis Asset Tag No Asset Information
DMI Chassis Type Notebook
Back to top
View user's profile Send private message
joshua83
n00b
n00b


Joined: 19 Oct 2014
Posts: 7

PostPosted: Wed Nov 12, 2014 12:56 pm    Post subject: Reply with quote

BTW
Finished installing gentoo, I reboot it
i use ifconfig
but there is no wirless network
i emerge wpa_applicant already
what is the wrong
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2643

PostPosted: Wed Nov 12, 2014 1:00 pm    Post subject: Reply with quote

joshua83 wrote:
i use ifconfig
but there is no wirless network
https://wiki.gentoo.org/wiki/Network_management_using_DHCPCD
Back to top
View user's profile Send private message
joshua83
n00b
n00b


Joined: 19 Oct 2014
Posts: 7

PostPosted: Thu Nov 13, 2014 2:26 am    Post subject: Reply with quote

this is the output of lspci -k

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
Subsystem: Lenovo Device 5000
Kernel driver in use: ivb_uncore
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
Kernel driver in use: pcieport
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
Subsystem: Lenovo Device 5001
Kernel driver in use: i915
Kernel modules: i915
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
Subsystem: Lenovo Device 5000
Kernel driver in use: xhci_hcd
Kernel modules: xhci_hcd
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
Subsystem: Lenovo Device 5000
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
Subsystem: Lenovo Device 5000
Kernel driver in use: ehci-pci
Kernel modules: ehci_pci
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
Subsystem: Lenovo Device 5000
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
Subsystem: Lenovo Device 5000
Kernel driver in use: ehci-pci
Kernel modules: ehci_pci
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
Subsystem: Lenovo Device 5000
00:1f.2 IDE interface: Intel Corporation 7 Series Chipset Family 4-port SATA Controller [IDE mode] (rev 04)
Subsystem: Lenovo Device 5000
Kernel driver in use: ata_piix
Kernel modules: ata_piix, pata_acpi
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
Subsystem: Lenovo Device 5000
Kernel modules: i2c_i801
00:1f.5 IDE interface: Intel Corporation 7 Series Chipset Family 2-port SATA Controller [IDE mode] (rev 04)
Subsystem: Lenovo Device 5000
Kernel driver in use: ata_piix
Kernel modules: ata_piix, pata_acpi
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce 610M] (rev a1)
Subsystem: Lenovo Device 5001
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
Subsystem: Lenovo Device 5000
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
Subsystem: Realtek Semiconductor Co., Ltd. Device 8195
0c:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
Subsystem: Lenovo Device 5000
Kernel driver in use: r8169
Kernel modules: r8169


how can i choise my driver?
thank you
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2643

PostPosted: Thu Nov 13, 2014 6:35 am    Post subject: Reply with quote

joshua83 wrote:
how can i choise my driver?
thank you
It's "Kernel driver in use" in blocks having "VGA compatible controller"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum