Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Laptop built-in keyboard and mousepad work intermittently
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jonathan183
Guru
Guru


Joined: 13 Dec 2011
Posts: 309

PostPosted: Sat Nov 15, 2014 4:58 pm    Post subject: Laptop built-in keyboard and mousepad work intermittently Reply with quote

I have a Toshiba Satellite C55D-A-12N which came with Windows 8.1 pre-installed (I don't use Windows so not sure if the problem would happen there also).
I have installed Linux Mint Debian Edition, Arch Linux, and Gentoo.
The problem I am having is that intermittently the built-in keyboard and mouse pad stop working. The problem has occurred in Gentoo and Arch so is not unique to the kernel config (or init system), I think it happens in Mint as well but I infrequently boot into Mint so can't remember if it has happened in that as well.

I have a password set for startup, the built-in keyboard always works for this. The system boots to a command prompt but sometimes the built in keyboard and mouse do not work, so I can't login. If I plug in a USB keyboard and mouse they work and I can use the laptop. I can shutdown and restart the laptop and sometimes the built-in keyboard and mouse work and sometimes they do not.
The built-in keyboard and mouse work fine for a random number of startups between 1 and 10 (tried cold boot and shutdown with the keyboard working 5 times in a row), and then don't work for a random number of startup between 1 and 5 (tried cold boot and shutdown with the keyboard not working 3 times in a row).

I have tried making atkbd a module and loading it which does not seem to make any difference. However if I plug in a usb keyboard and do
Code:
modprobe -v -r atkbd
modprobe -v atkbd

the built in keyboard and mouse start working again.

I have dmesg output for atkbd unload, load and plug-in of the usb keyboard with the built-in keyboard working as https://bpaste.net/show/64afeb567598 and when the built-in keyboard does not work at https://bpaste.net/show/114a82f3bc70

If anyone knows how to cure this issue, I'd appreciate a link to a solution ... if I figure it out I'll add it to this thread.
Back to top
View user's profile Send private message
C5ace
Apprentice
Apprentice


Joined: 23 Dec 2013
Posts: 295
Location: Brisbane, Australia

PostPosted: Mon Dec 01, 2014 11:11 pm    Post subject: Reply with quote

Try Windows or one of the LiveDVD's to determine if you have a hardware problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum