Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] masked by corruption???
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Nov 16, 2014 5:09 pm    Post subject: [gelöst] masked by corruption??? Reply with quote

Hallo zusammen,

habe wieder etwas neues "entdeckt":

Code:
!!! All ebuilds that could satisfy ">=dev-perl/perl-kolab-2.1" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-perl/perl-kolab-2.2.0_alpha20081010::kolab (masked by: corruption)
- dev-perl/perl-kolab-2.2.0_alpha20081009::kolab (masked by: corruption)
- dev-perl/perl-kolab-2.2_alpha20080528::kolab (masked by: corruption)
- dev-perl/perl-kolab-2.2_alpha20080505::kolab (masked by: corruption)
- dev-perl/perl-kolab-2.1::kolab (masked by: corruption)

(dependency required by "net-mail/kolabd-2.1::kolab" [ebuild])
(dependency required by "kolabd" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Was kann man da tun? Das habe ich bereits versucht.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Sun Nov 16, 2014 10:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Nov 16, 2014 5:43 pm    Post subject: Reply with quote

Na, das ist wahrscheinlich nicht die komplette Fehlermeldung?! ;)
Weiter vorn sollte normal mit dabeistehen warum oder weswegen diese Ebuilds als Korrupt abgetan wurden.
Magst mal die komplette Ausgabe von
Code:
emerge -pv dev-perl/perl-kolab
posten?
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Nov 16, 2014 5:48 pm    Post subject: Reply with quote

Code:
These are the packages that would be merged, in order:

Calculating dependencies \ * ERROR: dev-perl/perl-kolab-2.2.0_alpha20081010::kolab failed (depend phase):
 *   EAPI= is not supported by perl-module.eclass
 *
 * Call stack:
 *                               ebuild.sh, line 545:  Called source '/var/lib/layman/kolab/dev-perl/perl-kolab/perl-kolab-2.2.0_alpha20081010.ebuild'
 *   perl-kolab-2.2.0_alpha20081010.ebuild, line   5:  Called inherit 'perl-module'
 *                               ebuild.sh, line 277:  Called __qa_source '/usr/portage/eclass/perl-module.eclass'
 *                               ebuild.sh, line  80:  Called source '/usr/portage/eclass/perl-module.eclass'
 *                      perl-module.eclass, line  48:  Called die
 * The specific snippet of code:
 *              die "EAPI=${EAPI} is not supported by perl-module.eclass"
 *
 * If you need support, post the output of `emerge --info '=dev-perl/perl-kolab-2.2.0_alpha20081010::kolab'`,
 * the complete build log and the output of `emerge -pqv '=dev-perl/perl-kolab-2.2.0_alpha20081010::kolab'`.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/dev-perl/perl-kolab-2.2.0_alpha20081010/work/perl-kolab-2.2.0_alpha20081010'
 | * ERROR: dev-perl/perl-kolab-2.2.0_alpha20081009::kolab failed (depend phase):
 *   EAPI= is not supported by perl-module.eclass
 *
 * Call stack:
 *                               ebuild.sh, line 545:  Called source '/var/lib/layman/kolab/dev-perl/perl-kolab/perl-kolab-2.2.0_alpha20081009.ebuild'
 *   perl-kolab-2.2.0_alpha20081009.ebuild, line   5:  Called inherit 'perl-module'
 *                               ebuild.sh, line 277:  Called __qa_source '/usr/portage/eclass/perl-module.eclass'
 *                               ebuild.sh, line  80:  Called source '/usr/portage/eclass/perl-module.eclass'
 *                      perl-module.eclass, line  48:  Called die
 * The specific snippet of code:
 *              die "EAPI=${EAPI} is not supported by perl-module.eclass"
 *
 * If you need support, post the output of `emerge --info '=dev-perl/perl-kolab-2.2.0_alpha20081009::kolab'`,
 * the complete build log and the output of `emerge -pqv '=dev-perl/perl-kolab-2.2.0_alpha20081009::kolab'`.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/dev-perl/perl-kolab-2.2.0_alpha20081009/work/perl-kolab-2.2.0_alpha20081009'
 / * ERROR: dev-perl/perl-kolab-2.2_alpha20080528::kolab failed (depend phase):
 *   EAPI= is not supported by perl-module.eclass
 *
 * Call stack:
 *                             ebuild.sh, line 545:  Called source '/var/lib/layman/kolab/dev-perl/perl-kolab/perl-kolab-2.2_alpha20080528.ebuild'
 *   perl-kolab-2.2_alpha20080528.ebuild, line   5:  Called inherit 'perl-module'
 *                             ebuild.sh, line 277:  Called __qa_source '/usr/portage/eclass/perl-module.eclass'
 *                             ebuild.sh, line  80:  Called source '/usr/portage/eclass/perl-module.eclass'
 *                    perl-module.eclass, line  48:  Called die
 * The specific snippet of code:
 *              die "EAPI=${EAPI} is not supported by perl-module.eclass"
 *
 * If you need support, post the output of `emerge --info '=dev-perl/perl-kolab-2.2_alpha20080528::kolab'`,
 * the complete build log and the output of `emerge -pqv '=dev-perl/perl-kolab-2.2_alpha20080528::kolab'`.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/dev-perl/perl-kolab-2.2_alpha20080528/work/perl-kolab-2.2_alpha20080528'
 - * ERROR: dev-perl/perl-kolab-2.2_alpha20080505::kolab failed (depend phase):
 *   EAPI= is not supported by perl-module.eclass
 *
 * Call stack:
 *                             ebuild.sh, line 545:  Called source '/var/lib/layman/kolab/dev-perl/perl-kolab/perl-kolab-2.2_alpha20080505.ebuild'
 *   perl-kolab-2.2_alpha20080505.ebuild, line   5:  Called inherit 'perl-module'
 *                             ebuild.sh, line 277:  Called __qa_source '/usr/portage/eclass/perl-module.eclass'
 *                             ebuild.sh, line  80:  Called source '/usr/portage/eclass/perl-module.eclass'
 *                    perl-module.eclass, line  48:  Called die
 * The specific snippet of code:
 *              die "EAPI=${EAPI} is not supported by perl-module.eclass"
 *
 * If you need support, post the output of `emerge --info '=dev-perl/perl-kolab-2.2_alpha20080505::kolab'`,
 * the complete build log and the output of `emerge -pqv '=dev-perl/perl-kolab-2.2_alpha20080505::kolab'`.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/dev-perl/perl-kolab-2.2_alpha20080505/work/perl-kolab-2.2_alpha20080505'
 \ * ERROR: dev-perl/perl-kolab-2.1::kolab failed (depend phase):
 *   EAPI= is not supported by perl-module.eclass
 *
 * Call stack:
 *               ebuild.sh, line 545:  Called source '/var/lib/layman/kolab/dev-perl/perl-kolab/perl-kolab-2.1.ebuild'
 *   perl-kolab-2.1.ebuild, line   5:  Called inherit 'eutils' 'perl-module'
 *               ebuild.sh, line 277:  Called __qa_source '/usr/portage/eclass/perl-module.eclass'
 *               ebuild.sh, line  80:  Called source '/usr/portage/eclass/perl-module.eclass'
 *      perl-module.eclass, line  48:  Called die
 * The specific snippet of code:
 *              die "EAPI=${EAPI} is not supported by perl-module.eclass"
 *
 * If you need support, post the output of `emerge --info '=dev-perl/perl-kolab-2.1::kolab'`,
 * the complete build log and the output of `emerge -pqv '=dev-perl/perl-kolab-2.1::kolab'`.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/dev-perl/perl-kolab-2.1/work/perl-kolab-2.1'
... done!

!!! All ebuilds that could satisfy "dev-perl/perl-kolab" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-perl/perl-kolab-2.2.0_alpha20081010::kolab (masked by: corruption)
- dev-perl/perl-kolab-2.2.0_alpha20081009::kolab (masked by: corruption)
- dev-perl/perl-kolab-2.2_alpha20080528::kolab (masked by: corruption)
- dev-perl/perl-kolab-2.2_alpha20080505::kolab (masked by: corruption)
- dev-perl/perl-kolab-2.1::kolab (masked by: corruption)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Stimmt, da ist mehr. Ich dachte, die Meldung sei spezifisch genug. Ist das ein "Joker" für alle nicht anders abgedeckte Fehler?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Nov 16, 2014 7:36 pm    Post subject: Reply with quote

Ja, so in etwa, zb wenn ein ebuld so wie hier mit der aktuellen eclass nicht mehr kompatibel ist, und so nicht ausgeführt werden kann.

Ich kenne das kolab Overlay nicht, aber soweit ich das sehe sind die ebuilds recht alt. Vermutlich müssten sie überholt und auf die neueren eclasses angepasst werden.

Der Fehler ist (wie in der Fehlermeldung genannt),
EAPI= is not supported by perl-module.eclass

Vermutlich ist in den Ebulds noch gar keine EAPI angegeben (was damals durchaus korrekt sein konnte).

Fazit: Wenn du diese alten Ebulds nutzen möchtest wirst du sie anpassen müssen.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Nov 16, 2014 8:01 pm    Post subject: Reply with quote

HM, klingt nicht so, als könnte ich das allein.... Dann such ich mir etwas anderes.

Ich würde mir gerne einen eigenen Server aufsetzen, mit dem ich alle Familienhandies (Termine/Kontakte/Mails) synchronisiere kann - eben groupware wie exchange nur Opensource...

Kennst Du da eine Alternative?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
misterjack
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1603
Location: Germany -> Saxony -> Leipzig

PostPosted: Mon Nov 17, 2014 2:07 am    Post subject: Reply with quote

uhai wrote:
Kennst Du da eine Alternative?

Ich nutze Owncloud für Kalender/Kontakte. Mail per Imap.
_________________
„Meine Meinung steht fest! Bitte verwirren Sie mich nicht mit Tatsachen.“
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum