Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] udev-217 fails with kernel 3.17.3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 550
Location: USA

PostPosted: Mon Nov 17, 2014 4:11 pm    Post subject: [SOLVED] udev-217 fails with kernel 3.17.3 Reply with quote

I have udev-217 and the linux-3.17.3-gentoo kernel. On boot I get an error message similar to
Code:
worker [1540]...is taking a long time
for several devices: ata, sda3, cpu, usb, etc. Then it times out and the thread is killed. I don't know if it would ever boot as I've waited 15 minutes and then hard rebooted.

This doesn't happen with an older kernel, linux-3.17.1-gentoo.

Any tips on how to fix this will be gratefully received.

[SOLVED] Fitzcarraldo suggests using an older version of udev. E.g. udev-216 works with the 3.17.3 kernel. [/SOLVED]


Last edited by cfgauss on Tue Nov 18, 2014 6:11 am; edited 1 time in total
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1655
Location: United Kingdom

PostPosted: Mon Nov 17, 2014 4:27 pm    Post subject: Reply with quote

I had exactly the same message when I upgraded from udev-216-r1 to udev-217 (or eudev-2.1.1); see the thread udev-217 stalls booting. Have you tried downgrading to udev-216-r1 to see if the problem goes away? In my case the problem was caused by the new functionality introduced in udev-217 and eudev-2.1.1 regarding the loading of driver microcode/firmware. I only had the problem with CPU firmware, not iwlwifi firmware, presumably for the reason given by Gentoo user till in the aforementioned thread. Gentoo user nollo also gave another possible work-around, which I have not tried yet, if you're using genkernel to build your kernel.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum