Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub2 hangs after showing "Loading Linux-3.16.5-gentoo ..."
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
wzg1977
n00b
n00b


Joined: 23 Nov 2014
Posts: 5

PostPosted: Sun Nov 23, 2014 1:14 pm    Post subject: Grub2 hangs after showing "Loading Linux-3.16.5-gentoo Reply with quote

i am trying to install gentoo in virtualbox exactly following the x86 handbook excepting the partition layout.
because years ago i installed gentoo succeedly,so when preparing disk i carelessly follow the memory.

now after configuring the boot loader,grub2 hangs after showing "Loading Linux-3.16.5-gentoo ..."
i try to find what happens.
i copy the kernel of livecd to the /boot,grub2 can boot the kernel into the system

it seems i compiled the kernel wrongly.

but i follows the handbook using the legacy grub,grub does boot the kernel i compiled.

so i dont't know what's wrong .
Cant someone help me??

my fstab.conf like :
Code:
/dev/sda1     /boot     ext2    noauto,noatime 1 2
/dev/sda3     /           ext4    noatime 0 1
/dev/sda2    none     swap    sw   0 0
.....
 
Back to top
View user's profile Send private message
pgu
Guru
Guru


Joined: 30 Jul 2009
Posts: 594
Location: Oslo, Norway

PostPosted: Mon Nov 24, 2014 8:20 pm    Post subject: Reply with quote

Unfortunately I'm not able to help, but your problem appears to be similar to mine:

https://forums.gentoo.org/viewtopic-t-1004948.html
Back to top
View user's profile Send private message
pgu
Guru
Guru


Joined: 30 Jul 2009
Posts: 594
Location: Oslo, Norway

PostPosted: Tue Nov 25, 2014 3:22 pm    Post subject: Reply with quote

It seems like you're missing file system support in your kernel, or that your output is lost somehow. If your /etc/fstab is wrong you usually get a panic message when I tries to mount it, but you should observe some kernel messages before that.
Back to top
View user's profile Send private message
pgu
Guru
Guru


Joined: 30 Jul 2009
Posts: 594
Location: Oslo, Norway

PostPosted: Tue Nov 25, 2014 3:23 pm    Post subject: Reply with quote

Also did you remember to mount your boot partition prior to doing your "make install". It's easy to forget and then you're left with the previous version of the kernel and your changes appears not to work since there were never included in the file on the boot partition.
Back to top
View user's profile Send private message
oblivion_vr
n00b
n00b


Joined: 19 May 2013
Posts: 22

PostPosted: Wed Nov 26, 2014 9:07 pm    Post subject: Re: Grub2 hangs after showing "Loading Linux-3.16.5-ge Reply with quote

wzg1977 wrote:
i am trying to install gentoo in virtualbox exactly following the x86 handbook excepting the partition layout.
because years ago i installed gentoo succeedly,so when preparing disk i carelessly follow the memory.

now after configuring the boot loader,grub2 hangs after showing "Loading Linux-3.16.5-gentoo ..."
i try to find what happens.
i copy the kernel of livecd to the /boot,grub2 can boot the kernel into the system

it seems i compiled the kernel wrongly.

but i follows the handbook using the legacy grub,grub does boot the kernel i compiled.

so i dont't know what's wrong .
Cant someone help me??

my fstab.conf like :
Code:
/dev/sda1     /boot     ext2    noauto,noatime 1 2
/dev/sda3     /           ext4    noatime 0 1
/dev/sda2    none     swap    sw   0 0
.....
 


Hey,

Were you successful in solving this problem? Because I too am facing similar problem.

My problem is exactly the same. I installed gentoo reading the handbook. Did manual configuration of the kernel. But upon reboot the boot process gets stuck on "Loading Linux-3.16.5-gentoo ...".

Now, the strange thing is when I press "C" on the boot screen. it takes me to the grub prompt. when i do -
grub> linux /<kernel-image-path> root=/dev/sda3
grub> boot

the system correctly boots.

Does any one has any idea? Do I need to use initrd with virtualbox + grub2 combination?
Back to top
View user's profile Send private message
wzg1977
n00b
n00b


Joined: 23 Nov 2014
Posts: 5

PostPosted: Thu Nov 27, 2014 2:23 am    Post subject: Reply with quote

it seems i screwed up the kernel configuraiton because i can use genkernel to build a working kernel that grub2 can boot.
but what made me puzzled that i did build a kernel previously that grub legacy can boot but grub2 does not.

now i load the genkernel configuraiton to change when i do things "make menuconfig"
a stupid question is i cann't restore to the initial configure state after "emerge gentoo-source"
i try to do these:
Code:
make mrproper
make menuconfig

i find the options are still the same with some time before.
for example
Code:
general setup->
     local version - append to kernel release

always restore to what i entered a certain time before
even i "rm -rf /usr/src/*" and resinstall gentoo-sources again.
it's weird

pgu wrote:
It seems like you're missing file system support in your kernel, or that your output is lost somehow. If your /etc/fstab is wrong you usually get a panic message when I tries to mount it, but you should observe some kernel messages before that.
Back to top
View user's profile Send private message
wzg1977
n00b
n00b


Joined: 23 Nov 2014
Posts: 5

PostPosted: Thu Nov 27, 2014 2:31 am    Post subject: Re: Grub2 hangs after showing "Loading Linux-3.16.5-ge Reply with quote

i do not solve the problem now.
but i can use
Code:
genkernel  all

to get a working kernel that grub2 can boot
it seems that the problem is in the configuration of the kernel.
but i did build a kernel that grub legacy can boot and grub2 does not
and as you mentioned it can boot from grub2 command line .
and it also cannot boot with initramfs.
so it's weird.

oblivion_vr wrote:

Hey,

Were you successful in solving this problem? Because I too am facing similar problem.

My problem is exactly the same. I installed gentoo reading the handbook. Did manual configuration of the kernel. But upon reboot the boot process gets stuck on "Loading Linux-3.16.5-gentoo ...".

Now, the strange thing is when I press "C" on the boot screen. it takes me to the grub prompt. when i do -
grub> linux /<kernel-image-path> root=/dev/sda3
grub> boot

the system correctly boots.

Does any one has any idea? Do I need to use initrd with virtualbox + grub2 combination?
Back to top
View user's profile Send private message
wzg1977
n00b
n00b


Joined: 23 Nov 2014
Posts: 5

PostPosted: Thu Nov 27, 2014 3:46 am    Post subject: Re: Grub2 hangs after showing "Loading Linux-3.16.5-ge Reply with quote

You remind me.
The problem might be relative with grub2.
when you type "E" on the grub prompt,
delete or comment the line "set gfxpayload=keep"
type "F10" to boot
The boot messages scroll in the screen.
Just deleting the line in /boot/grub/grub.cfg,it will work

does anyone know why??

oblivion_vr wrote:
wzg1977 wrote:
i am trying to install gentoo in virtualbox exactly following the x86 handbook excepting the partition layout.
because years ago i installed gentoo succeedly,so when preparing disk i carelessly follow the memory.

now after configuring the boot loader,grub2 hangs after showing "Loading Linux-3.16.5-gentoo ..."
i try to find what happens.
i copy the kernel of livecd to the /boot,grub2 can boot the kernel into the system

it seems i compiled the kernel wrongly.

but i follows the handbook using the legacy grub,grub does boot the kernel i compiled.

so i dont't know what's wrong .
Cant someone help me??

my fstab.conf like :
Code:
/dev/sda1     /boot     ext2    noauto,noatime 1 2
/dev/sda3     /           ext4    noatime 0 1
/dev/sda2    none     swap    sw   0 0
.....
 


Hey,

Were you successful in solving this problem? Because I too am facing similar problem.

My problem is exactly the same. I installed gentoo reading the handbook. Did manual configuration of the kernel. But upon reboot the boot process gets stuck on "Loading Linux-3.16.5-gentoo ...".

Now, the strange thing is when I press "C" on the boot screen. it takes me to the grub prompt. when i do -
grub> linux /<kernel-image-path> root=/dev/sda3
grub> boot

the system correctly boots.

Does any one has any idea? Do I need to use initrd with virtualbox + grub2 combination?
Back to top
View user's profile Send private message
wzg1977
n00b
n00b


Joined: 23 Nov 2014
Posts: 5

PostPosted: Thu Nov 27, 2014 4:19 am    Post subject: Re: Grub2 hangs after showing "Loading Linux-3.16.5-ge Reply with quote

I dig something to find why.
in grub manual
Code:
‘keep’ to preserve the graphics mode set using ‘gfxmode’

so the problem is there is no graphic driver.
enable the option and all will be fine.
Code:
Device Driver->
  Graphics Driver->
    FrameBuffer Devices->
      VESA VGA graphics Support

wzg1977 wrote:
You remind me.
The problem might be relative with grub2.
when you type "E" on the grub prompt,
delete or comment the line "set gfxpayload=keep"
type "F10" to boot
The boot messages scroll in the screen.
Just deleting the line in /boot/grub/grub.cfg,it will work
does anyone know why??
Back to top
View user's profile Send private message
oblivion_vr
n00b
n00b


Joined: 19 May 2013
Posts: 22

PostPosted: Sat Nov 29, 2014 8:27 pm    Post subject: Re: Grub2 hangs after showing "Loading Linux-3.16.5-ge Reply with quote

wzg1977 wrote:
I dig something to find why.
in grub manual
Code:
‘keep’ to preserve the graphics mode set using ‘gfxmode’

so the problem is there is no graphic driver.
enable the option and all will be fine.
Code:
Device Driver->
  Graphics Driver->
    FrameBuffer Devices->
      VESA VGA graphics Support

wzg1977 wrote:
You remind me.
The problem might be relative with grub2.
when you type "E" on the grub prompt,
delete or comment the line "set gfxpayload=keep"
type "F10" to boot
The boot messages scroll in the screen.
Just deleting the line in /boot/grub/grub.cfg,it will work
does anyone know why??


Thanks a lot. Enabling "VESA VGA graphics Support" worked for me too. It was a good learning.

Thanks again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum