Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge kdelibs scheitert an patch??
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Mon Nov 24, 2014 9:01 pm    Post subject: emerge kdelibs scheitert an patch?? Reply with quote

Hallo Gemeinde,

ich habe meine KDE-Installation wohl versaut... Ich wollte KDE loswerden, habe LXDE mit Openbox installiert und KDE weggeputzt. Nur Digikam will ich behalten.

Digikam war danach zerschossen, also Neuinstallation, leider abgebrochen:

Code:
 * Applying kdelibs-4.6.2-armlinking.patch ...

 * Failed Patch: kdelibs-4.6.2-armlinking.patch !
 *  ( /var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.6.2-armlinking.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/kde-base/kdelibs-4.14.49.9999/temp/kdelibs-4.6.2-armlinking.patch.out

 * ERROR: kde-base/kdelibs-4.14.49.9999::kde failed (prepare phase):
 *   Failed Patch: kdelibs-4.6.2-armlinking.patch!
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 4465:  Called kde4-base_src_prepare
 *   environment, line 3492:  Called cmake-utils_src_prepare
 *   environment, line 1412:  Called _execute_optionally 'src_prepare'
 *   environment, line  723:  Called enable_cmake-utils_src_prepare
 *   environment, line 1743:  Called epatch '/var/lib/layman/kde/kde-base/kdelibs/files/dist/01_gentoo_set_xdg_menu_prefix-1.patch' '/var/lib/layman/kde/kde-base/kdelibs/files/dist/02_gentoo_append_xdg_config_dirs-1.patch' '/var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.14.0-mimetypes.patch' '/var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.4.90-xslt.patch' '/var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.6.2-armlinking.patch' '/var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.6.3-no_suid_kdeinit.patch' '/var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.8.1-norpath.patch' '/var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.9.3-werror.patch' '/var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.10.0-udisks.patch'
 *   environment, line 1853:  Called epatch '/var/lib/layman/kde/kde-base/kdelibs/files/kdelibs-4.6.2-armlinking.patch'
 *   environment, line 2030:  Called die
 * The specific snippet of code:
 *               die "Failed Patch: ${patchname}!";
 *
 * If you need support, post the output of `emerge --info '=kde-base/kdelibs-4.14.49.9999::kde'`,
 * the complete build log and the output of `emerge -pqv '=kde-base/kdelibs-4.14.49.9999::kde'`.
 * The complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.14.49.9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.14.49.9999/temp/environment'.
 * Working directory: '/var/tmp/portage/kde-base/kdelibs-4.14.49.9999/work/kdelibs-4.14.49.9999'
 * S: '/var/tmp/portage/kde-base/kdelibs-4.14.49.9999/work/kdelibs-4.14.49.9999'


Den armlink-patch gibt es aber in diesem Verzeichnis....?!

Was kann ich da jetzt tun?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Nov 24, 2014 9:36 pm    Post subject: Reply with quote

Tja, das passiert wenn man live-ebuilds verwendet ;)
TIP: Wenn KDE nur für Digikam gebraucht wird die kde-Pakete einfach aus dem offiziellen Prtage-Tree nehmen, am besten stable ;)

(Du kannst jetzt auch den langwierigen Weg gehen und den veralteten Patch auf bugzilla melden und hoffen dass einer der KDE Gentoo Devs Zeit hat...)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Mon Nov 24, 2014 9:40 pm    Post subject: Reply with quote

d.h. aber auch, dass ich nicht digikam-4.4 bekomme, oder?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Nov 24, 2014 9:48 pm    Post subject: Reply with quote

Digikam-4.4.0 braucht mindestens kde-4.10. Mit stable kdelibs kommst du da hin.
Digikam selber kannst du natürlich weiter aus ~arch nehmen, wenn du willst - mir gings nur um die kdelibs.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Mon Nov 24, 2014 10:33 pm    Post subject: Reply with quote

ok, ein wenig aufgeräumt - jetzt hänge ich hier:

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

kde-base/kdelibs:4

  (kde-base/kdelibs-4.12.5-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kdelibs-4.12.5:4[aqua=,opengl,semantic-desktop?] required by (kde-base/pykde4-4.12.5::gentoo, ebuild scheduled for merge)

  (kde-base/kdelibs-4.14.2::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kdelibs-4.14.2:4[aqua=] required by (kde-base/katepart-4.14.2::gentoo, ebuild scheduled for merge)


das bekomme ich nicht aufgelöst... 4.12 würde mir ja reichen, wo kommen die 4.14er her??

uhai

PS: katepart-4.14.2 ist nicht installiert und keywords habe ich auch keine mehr für die 4.14.2er...???
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Thu Nov 27, 2014 9:08 pm    Post subject: Reply with quote

Code:
>=kde-base/kdelibs-4.14.2:4[aqua=] required by (kde-base/kdepimlibs-4.14.2::gentoo, ebuild scheduled for merge)


Wie kommen denn die 4.14er da immer wieder rein? kdepimlibs ist derzeit nicht installiert...

Kann ich die Abhängigkeiten irgendwie anzeigen lassen?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Nov 28, 2014 6:59 am    Post subject: Reply with quote

mit "--tree" siehst Du einiges.
Zu Not kannst Du auch kde-base/kdepimlibs-4.14.2 hart maskieren, dann kommt eine Meldung, dass Paket xxx kdepimlibs unbedingt braucht.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Fri Nov 28, 2014 2:42 pm    Post subject: Reply with quote

Komisch, bei emerge --tree habe ich die 4 4.14er Palete auf der gleichen Stufe, nach dem ich alle maskiert hatte, lief dass ohne dass eine Paket sich beschwert hätte...

uhai

PS:
Code:

bei emerge -auDNT world bekomme ich:

[blocks B      ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-apps/kmod-19)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-53.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-52.1::gentoo, installed) pulled in by
    >=dev-libs/icu-51.2-r1:0/52=[abi_x86_64(-)] required by (media-libs/harfbuzz-0.9.28::gentoo, installed)
    dev-libs/icu:0/52= required by (app-text/libmspub-0.1.1::gentoo, installed)
    dev-libs/icu:0/52= required by (gnome-extra/evolution-data-server-3.12.4::gentoo, installed)
    dev-libs/icu:0/52= required by (media-libs/raptor-2.0.9::gentoo, installed)
    (and 3 more with the same problems)

app-text/libmspub:0

  (app-text/libmspub-0.1.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/libmspub-0.0.6::gentoo, ebuild scheduled for merge) pulled in by
    =app-text/libmspub-0.0* required by (app-office/libreoffice-4.2.6.3::gentoo, ebuild scheduled for merge)

dev-libs/liborcus:0

  (dev-libs/liborcus-0.5.1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/liborcus-0.5* required by (app-office/libreoffice-4.2.6.3::gentoo, ebuild scheduled for merge)

  (dev-libs/liborcus-0.7.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/libixion:0

  (dev-libs/libixion-0.5.0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/libixion-0.5* required by (dev-libs/liborcus-0.5.1::gentoo, ebuild scheduled for merge)

  (dev-libs/libixion-0.7.0::gentoo, installed) pulled in by
    >=dev-libs/libixion-0.7.0 required by (dev-libs/liborcus-0.7.0::gentoo, installed)

kde-base/kdepimlibs:4

  (kde-base/kdepimlibs-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kdepimlibs-4.14.3:4[aqua=] required by (kde-base/baloo-4.14.3::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (kde-base/kdepimlibs-4.12.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

kde-base/kde-l10n:4

  (kde-base/kde-l10n-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kde-l10n-4.13.1:4[aqua=,linguas_de(+)] required by (kde-misc/tellico-2.3.9::gentoo, installed)

  (kde-base/kde-l10n-4.12.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

kde-base/kdelibs:4

  (kde-base/kdelibs-4.12.5-r2::gentoo, installed) pulled in by
    >=kde-base/kdelibs-4.12.5:4[aqua=,opengl,semantic-desktop?] required by (kde-base/pykde4-4.12.5::gentoo, installed)
    >=kde-base/kdelibs-4.8.4:4[aqua=,opengl?,semantic-desktop?] required by (media-sound/amarok-2.8.0::gentoo, ebuild scheduled for merge)
    >=kde-base/kdelibs-4.12.5:4[aqua=,semantic-desktop] required by (kde-base/kdepimlibs-4.12.5::gentoo, installed)

  (kde-base/kdelibs-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kdelibs-4.14.3:4[aqua=] required by (kde-base/kfilemetadata-4.14.3::gentoo, ebuild scheduled for merge)
    (and 18 more with the same problem)

kde-base/oxygen-icons:4

  (kde-base/oxygen-icons-4.12.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-base/oxygen-icons-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/oxygen-icons-4.14.3:4[aqua=] required by (kde-base/kdepimlibs-4.14.3::gentoo, ebuild scheduled for merge)
    (and 12 more with the same problem)

kde-base/libkcddb:4

  (kde-base/libkcddb-4.12.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-base/libkcddb-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/libkcddb-4.13.1:4[aqua=] required by (kde-misc/tellico-2.3.9::gentoo, installed)

kde-base/kde-env:4

  (kde-base/kde-env-4.12.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-base/kde-env-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kde-env-4.14.3:4[aqua=] required by (kde-base/kdelibs-4.14.3::gentoo, ebuild scheduled for merge)

kde-base/nepomuk-widgets:4

  (kde-base/nepomuk-widgets-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/nepomuk-widgets-4.14.3:4[aqua=] required by (kde-base/kdelibs-4.14.3::gentoo, ebuild scheduled for merge)

  (kde-base/nepomuk-widgets-4.12.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

kde-base/nepomuk-core:4

  (kde-base/nepomuk-core-4.12.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-base/nepomuk-core-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/nepomuk-core-4.14.3:4[aqua=] required by (kde-base/kdelibs-4.14.3::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

kde-base/katepart:4

  (kde-base/katepart-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/katepart-4.14.3:4[aqua=] required by (kde-base/kdelibs-4.14.3::gentoo, ebuild scheduled for merge)

  (kde-base/katepart-4.12.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

net-libs/gnutls:0

  (net-libs/gnutls-3.3.10::gentoo, installed) pulled in by
    >=net-libs/gnutls-3.0.20:0 required by (media-video/vlc-2.1.5::gentoo, installed)

  (net-libs/gnutls-2.12.23-r6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-text/poppler:0

  (app-text/poppler-0.24.5::gentoo, installed) pulled in by
    app-text/poppler:0/44=[xpdf-headers(+)] required by (dev-tex/luatex-0.70.1-r2::gentoo, installed)
    >=app-text/poppler-0.12.3-r3:0/44= required by (app-text/texlive-core-2012-r1::gentoo, installed)
    app-text/poppler:0/44=[qt4] required by (dev-python/python-poppler-qt4-0.16.3-r1::gentoo, installed)

  (app-text/poppler-0.26.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

kde-base/khelpcenter:4

  (kde-base/khelpcenter-4.12.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-base/khelpcenter-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/khelpcenter-4.14.3:4[aqua=] required by (kde-base/kdelibs-4.14.3::gentoo, ebuild scheduled for merge)

kde-base/kdesu:4

  (kde-base/kdesu-4.14.3::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kdesu-4.14.3:4[aqua=] required by (kde-base/khelpcenter-4.14.3::gentoo, ebuild scheduled for merge)

  (kde-base/kdesu-4.12.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/openrc-0.12.4::gentoo, installed) pulled in by
    sys-apps/openrc required by @system
    sys-apps/openrc:= required by (app-admin/openrc-settingsd-1.0.1::gentoo, installed)
    sys-apps/openrc required by (virtual/service-manager-0::gentoo, installed)
    sys-apps/openrc:0/0= required by (app-admin/openrc-settingsd-1.0.1::gentoo, installed)
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2::gentoo, installed)

  (sys-apps/kmod-19::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/kmod required by (sys-apps/pciutils-3.2.0::gentoo, installed)
    >=sys-apps/kmod-15:0= required by (sys-apps/systemd-217-r2::gentoo, ebuild scheduled for merge)
    sys-apps/kmod[tools] required by (virtual/modutils-0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by kde-base/kdelibs-4.14.3
# required by kde-base/kdesu-4.14.3
# required by kde-base/khelpcenter-4.14.3
=kde-base/katepart-4.14.3 ~amd64
# required by kde-base/nepomuk-core-4.14.3[migrator]
# required by kde-base/kdelibs-4.14.3[nepomuk]
# required by kde-base/kdesu-4.14.3
# required by kde-base/khelpcenter-4.14.3
=kde-base/baloo-4.14.3 ~amd64
# required by kde-base/baloo-4.14.3
# required by kde-base/nepomuk-core-4.14.3[migrator]
# required by kde-base/kdelibs-4.14.3[nepomuk]
# required by kde-base/kdesu-4.14.3
# required by kde-base/khelpcenter-4.14.3
=kde-base/kfilemetadata-4.14.3 ~amd64
# required by media-plugins/kipi-plugins-3.5.0[calendar]
# required by @selected
# required by @world (argument)
=kde-base/kdepimlibs-4.14.3 ~amd64
# required by kde-base/kdelibs-4.12.5-r2[handbook]
# required by kde-base/kdebase-data-4.12.5
# required by app-editors/kile-2.1.3-r1
# required by @selected
# required by @world (argument)
=kde-base/khelpcenter-4.14.3 ~amd64
# required by kde-base/kdelibs-4.14.3[nepomuk]
# required by kde-base/kdesu-4.14.3
# required by kde-base/khelpcenter-4.14.3
=kde-base/nepomuk-core-4.14.3 ~amd64
# required by kde-base/kdelibs-4.14.3[nepomuk]
# required by kde-base/kdesu-4.14.3
# required by kde-base/khelpcenter-4.14.3
=kde-base/nepomuk-widgets-4.14.3 ~amd64
# required by dev-vcs/kdesvn-1.6.0-r1
# required by @selected
# required by @world (argument)
=kde-base/oxygen-icons-4.14.3 ~amd64
# required by app-cdr/k3b-2.0.2-r4
# required by @selected
# required by @world (argument)
=kde-base/kdelibs-4.14.3 ~amd64
# required by kde-base/kdelibs-4.12.5-r2
# required by kde-base/kdebase-data-4.12.5
# required by app-editors/kile-2.1.3-r1
# required by @selected
# required by @world (argument)
=kde-base/kde-env-4.14.3 ~amd64
# required by app-cdr/k3b-2.0.2-r4
# required by @selected
# required by @world (argument)
=kde-base/libkcddb-4.14.3 ~amd64
# required by kde-misc/tellico-2.3.9[scanner]
# required by @selected
# required by @world (argument)
=kde-base/libksane-4.14.3 ~amd64
# required by kde-misc/tellico-2.3.9[linguas_de]
# required by @selected
# required by @world (argument)
=kde-base/kde-l10n-4.14.3 ~amd64
# required by kde-base/khelpcenter-4.12.5
# required by kde-base/kdelibs-4.12.5-r2[handbook]
# required by kde-base/kdebase-data-4.12.5
# required by app-editors/kile-2.1.3-r1
# required by @selected
# required by @world (argument)
=kde-base/kdesu-4.14.3 ~amd64


Wieso will er immer noch die 4.14er?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum