Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Extremely laggy 3d acceleration w/ intel graphics
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
recursion
n00b
n00b


Joined: 03 Nov 2014
Posts: 22

PostPosted: Thu Nov 27, 2014 1:42 am    Post subject: [solved] Extremely laggy 3d acceleration w/ intel graphics Reply with quote

Hi all, last month I tried installing steam via the overlay and I ran into a little performance problem (it was extremely slow like 1 frame every two or three seconds) blamed the overlay, then installed the program manually but the same problem persisted. Let it alone for a while and today I decided to charge at it again and I think it can only be a driver problem.

Some relevant info:
uname -a
Code:
Linux mare 3.16.5-gentoo #1 SMP Mon Nov 17 13:47:33 EST 2014 i686 Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz GenuineIntel GNU/Linux


kernel settings
Code:
 |   |<*> /dev/agpgart (AGP Support)  --->                                         
  │ │        -*- VGA Arbitration                                                           
  │ │        (16)  Maximum number of GPUs                                                 
  │ │        [ ] Laptop Hybrid Graphics - GPU switching support                             
  │ │            Direct Rendering Manager  --->                                             
  │ │            Frame buffer Devices  --->                                                 
  │ │        -*- Backlight & LCD device support  --->                                       
  │ │            Console display driver support  --->                                     
  │ │        [*] Bootup logo  --->   

 <*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->                                                      │ │ 
  │ │                                                            I2C encoder or helper chips  --->                                                                                          │ │ 
  │ │                                                        < > PTN3460 DP/LVDS bridge                                                                                                     │ │ 
  │ │                                                        < > 3dfx Banshee/Voodoo3+                                                                                                      │ │ 
  │ │                                                        < > ATI Rage 128                                                                                                               │ │ 
  │ │                                                        < > ATI Radeon                                                                                                                 │ │ 
  │ │                                                        < > Nouveau (nVidia) cards                                                                                                     │ │ 
  │ │                                                        < > Intel I810                                                                                                                 │ │ 
  │ │                                                        <*> Intel 8xx/9xx/G3x/G4x/HD Graphics                                                                                          │ │ 
  │ │                                                        [*]   Enable modesetting on intel by default                                                                                   │ │ 
  │ │                                                        [*]   Enable legacy fbdev support for the modesetting intel driver                                                             │ │ 
  │ │                                                        [ ]   Enable preliminary support for prerelease Intel hardware by default



Originally, per the official intel website which states the i7-3520M (HD graphics 4000) is a 3rd generation processor and per the wiki I set
VIDEO_CARD="intel i915"
i915 for mesa and intel for xorg.
In this thread https://forums.gentoo.org/viewtopic-t-927876-start-0.html its said that for mesa the intel covers both i965 and i915 but only if neither i915 or i965 are set. But I find that both flags are up

equery uses mesa

Code:
 + + video_cards_i915     : VIDEO_CARDS setting to build driver for Intel i915 video cards
 - + video_cards_i965     : VIDEO_CARDS setting to build driver for Intel i965 video cards
 - - video_cards_ilo      : VIDEO_CARDS setting to build unofficial gallium driver for Intel gen6/7 video cards
 + + video_cards_intel    : VIDEO_CARDS setting to build driver for Intel video cards




Contrary to the wiki, in this thread its said that HD 4000 needs the i965
https://forums.gentoo.org/viewtopic-t-927758-highlight-.html

Also more conflicting info Im getting is between the wiki feature matrix and this intel website https://01.org/linuxgraphics/community/vaapi concerning VAAPI support ...

Anyway Im kinda lost and dont know what to do and my head hurts.


Last edited by recursion on Thu Nov 27, 2014 8:06 am; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2586

PostPosted: Thu Nov 27, 2014 6:24 am    Post subject: Re: Intel video drivers Reply with quote

recursion wrote:
Let it alone for a while and today I decided to charge at it again and I think it can only be a driver problem.
What's your output of lspci?
Quote:
# lspci -k
Back to top
View user's profile Send private message
recursion
n00b
n00b


Joined: 03 Nov 2014
Posts: 22

PostPosted: Thu Nov 27, 2014 7:23 am    Post subject: Reply with quote

Code:
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
   Subsystem: Dell Device 0534
   Kernel driver in use: ivb_uncore
lspci: Unable to load libkmod resources: error -12
[b]00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
   Subsystem: Dell Device 0534
   Kernel driver in use: i915[/b]
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
   Subsystem: Dell Device 0534
   Kernel driver in use: xhci_hcd
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
   Subsystem: Dell Device 0534
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
   Subsystem: Dell Device 0534
   Kernel driver in use: e1000e
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
   Subsystem: Dell Device 0534
   Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
   Subsystem: Dell Device 0534
   Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
   Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
   Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
   Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
   Kernel driver in use: pcieport
00:1c.5 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 (rev c4)
   Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
   Subsystem: Dell Device 0534
   Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation QM77 Express Chipset LPC Controller (rev 04)
   Subsystem: Dell Device 0534
   Kernel driver in use: lpc_ich
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 04)
   Subsystem: Dell Device 0534
   Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
   Subsystem: Dell Device 0534
02:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)
   Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN
   Kernel driver in use: iwlwifi
0b:00.0 SD Host controller: O2 Micro, Inc. OZ600FJ0/OZ900FJ0/OZ600FJS SD/MMC Card Reader Controller (rev 05)
   Subsystem: Dell Device 0534
   Kernel driver in use: sdhci-pci
Back to top
View user's profile Send private message
recursion
n00b
n00b


Joined: 03 Nov 2014
Posts: 22

PostPosted: Thu Nov 27, 2014 8:04 am    Post subject: Reply with quote

Hallelujah big picture mode is running smoothly so HL2 based games should be the same.

I remember encountering this same problem with archlinux a few months back but I have no idea how I could have solved it without use flags, maybe some environment variables and some symlinking but anyway.

i7-3520M (3rd generation CPU, with integrated HD Graphics 4000) => VIDEO_CARDS="intel i965"
Recompile mesa. My head still hurts.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum