Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo on Cubieboard2, part2 [Unsuccessful]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Irre
Guru
Guru


Joined: 09 Nov 2013
Posts: 337
Location: Stockholm

PostPosted: Thu Nov 27, 2014 10:31 pm    Post subject: gentoo on Cubieboard2, part2 [Unsuccessful] Reply with quote

Building a new kernel

Code:
emerge -v genkernel gentoo-sources

nohup genkernel --install --integrated-initramfs --kernel-config=/proc/config.gz all &

We will probably need some swap later
Code:
dd if=/dev/zero of=/swapfile bs=1M count=512
mkswap /swapfile
echo '/swapfile none swap sw 0 0' >> /etc/fstab
swapon /swapfile

emerge -v ntp gentoolkit htop
rc-config add ntp-client

OPTIONAL Fetch all sources:
Code:
emerge -ve --fetchonly world

To check genkernel in progress, enter:
Code:
htop

or
Code:
tail -f nohup.out

When all done, after some hours, we must update a config file again:
Code:
mount /dev/mmcblk0p1 /mnt
nano -w /mnt/uEnv.cb2 (change two lines:)

#kernel=/boot/uImage-3.4.101
kernel=/sda1/boot/kernel-genkernel-arm-3.14.14-gentoo-sun7i

cp /mnt/uEnv.cb2 /mnt/uEnv.cb2-gentoo (keep a copy)

reboot

:evil:** The new kernel didn't boot. I had to remove SDHC-card and undo last changes to be able to boot again **
I don't understand what's wrong. Perhaps the boot-loader must be reinstalled or reconfigured.
I have no HDMI-monitor, so I can only log in via ssh. this will be hard to solve.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum