Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wacom Intuos2 XD1212-U doesn't work after re-connecting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Lebkoungcity
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2008
Posts: 125
Location: Lebkoungcity (='Gingerbreadcity' =Nuremberg)

PostPosted: Sun Nov 30, 2014 3:58 pm    Post subject: Wacom Intuos2 XD1212-U doesn't work after re-connecting Reply with quote

Hi,

I have a Wacom Intuos2 XD1212-U tablet that works fine when I plug it in but doesn't when I unplug and then re-connect it.

Here's the system messages when I first plug it in:

Code:
tail -f /var/log/messages
[...]
Nov 30 16:34:39 pulp-fiction kernel: [ 8657.798100] usb 3-1: new full-speed USB device number 3 using uhci_hcd
Nov 30 16:34:39 pulp-fiction kernel: [ 8657.953855] usb 3-1: New USB device found, idVendor=056a, idProduct=0044
Nov 30 16:34:39 pulp-fiction kernel: [ 8657.953873] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Nov 30 16:34:39 pulp-fiction kernel: [ 8657.953885] usb 3-1: Product: XD-1212-U
Nov 30 16:34:39 pulp-fiction kernel: [ 8657.953897] usb 3-1: Manufacturer: Tablet
Nov 30 16:34:40 pulp-fiction laptop-mode: Laptop mode
Nov 30 16:34:40 pulp-fiction laptop-mode: enabled, active
Nov 30 16:34:40 pulp-fiction kernel: [ 8659.002970] input: Wacom Intuos2 12x12 as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/input/input10
Nov 30 16:34:40 pulp-fiction kernel: [ 8659.008722] usbcore: registered new interface driver wacom
Nov 30 16:34:41 pulp-fiction laptop-mode: Laptop mode
Nov 30 16:34:41 pulp-fiction laptop-mode: enabled, active
[...]


Now I un-plug it:
Code:
[...]
Nov 30 16:40:20 pulp-fiction kernel: [ 8998.250192] usb 3-1: USB disconnect, device number 3                                                   
Nov 30 16:40:20 pulp-fiction laptop-mode: Laptop mode                                                                                         
Nov 30 16:40:20 pulp-fiction laptop-mode: enabled, active                                                                                     
Nov 30 16:40:20 pulp-fiction laptop-mode: Laptop mode                                                                                         
Nov 30 16:40:20 pulp-fiction laptop-mode: enabled, active
[...]


This is it with re-plugging the device:
Code:
[...]
Nov 30 16:41:28 pulp-fiction kernel: [ 9066.425154] usb 3-1: new full-speed USB device number 4 using uhci_hcd                                 
Nov 30 16:41:28 pulp-fiction kernel: [ 9066.580695] usb 3-1: New USB device found, idVendor=056a, idProduct=0044                               
Nov 30 16:41:28 pulp-fiction kernel: [ 9066.580713] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0                         
Nov 30 16:41:28 pulp-fiction kernel: [ 9066.580725] usb 3-1: Product: XD-1212-U                                                               
Nov 30 16:41:28 pulp-fiction kernel: [ 9066.580737] usb 3-1: Manufacturer: Tablet                                                             
Nov 30 16:41:28 pulp-fiction kernel: [ 9066.584310] input: Wacom Intuos2 12x12 as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/input/input11                                                                                                                                             
Nov 30 16:41:28 pulp-fiction laptop-mode: Laptop mode                                                                                         
Nov 30 16:41:28 pulp-fiction laptop-mode: enabled, active                                                                                     
Nov 30 16:41:29 pulp-fiction laptop-mode: Laptop mode                                                                                         
Nov 30 16:41:29 pulp-fiction laptop-mode: enabled, active
[...]


I think the problem is that the wacom module is not unloaded when I pull the plug out. After the first loading it sits there but for some unknown reason it just works once. What proves this idea is that when I unload it (after unplugging the tablet) with
Code:
modprobe -r wacom

I can use the tablet again.

And to tell the full story:
To use the tablet I just added wacom to make.conf:
Code:
INPUT_DEVICES="evdev keyboard mouse synaptics wacom"

after a
Code:
emerge -auvDN world

the tablet was usable (OK the "buttons" on top of the active area aren't recognized, this area is just treated as the rest of the tablet - but that's another issue ;) )

So, is there something that can be done in order to use the tablet after re-plugging it (besides unloading the module by hand)? Some kind of automatic unloading the module when the plug is pulled out?

Greetings,
Andy

edit:
Forgot to mention: Of course I activated the module in the kernel first:
Code:
<M>   Wacom Intuos/Graphire tablet support (USB)

And another thing I tried:
The module needs to be compiled as a module! When compiled-in (meaning <*> instead of <M>) the tablet does not work at all.
_________________
"The most dangerous world view is the world view of the ones who haven't viewed the world."
Alexander von Humboldt (1769-1859)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum