Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't get my Ethernet adapter working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
mvlabat
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2014
Posts: 82

PostPosted: Mon Dec 01, 2014 9:53 pm    Post subject: [SOLVED] Can't get my Ethernet adapter working Reply with quote

Hi. I installed Gentoo almost a year ago. Struggling with my WiFi adapter I finally managed to make it working. Now it's the time to configure my Ethernet. ) Here's the name of my Ethernet controller:
Quote:
Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)

Sorry, I don't know what kind of information do you need. Tell me the commands I have to enter and I'll provide you all the information. The issue is that entering ifconfig -a doesn't display my ethernet adapter (so I can't configure my wicd):
Quote:
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 10934 bytes 921580 (899.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 10934 bytes 921580 (899.9 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

sit0: flags=128<NOARP> mtu 1480
sit txqueuelen 0 (IPv6-in-IPv4)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlp9s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.190.101 netmask 255.255.255.0 broadcast 192.168.190.255
inet6 fe80::e8b:fdff:febc:67bd prefixlen 64 scopeid 0x20<link>
ether 0c:8b:fd:bc:67:bd txqueuelen 1000 (Ethernet)
RX packets 105145 bytes 119232268 (113.7 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 70366 bytes 11005183 (10.4 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


Hope for your help, kind Gentoo community. Thank you


Last edited by mvlabat on Tue Dec 02, 2014 2:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43200
Location: 56N 3W

PostPosted: Mon Dec 01, 2014 11:40 pm    Post subject: Reply with quote

mvlabat,

Code:
Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)
You need the r8169 driver.
You may need bug fix firmware too.

Make r8169 as a module. Look in dmesg for it trying to load firmware and failing
Install linux-firmware if you don't have it already.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mvlabat
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2014
Posts: 82

PostPosted: Tue Dec 02, 2014 2:46 pm    Post subject: Reply with quote

Thank you! After emerging linux-firmware and reconfiguring kernel it worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum