Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(sorta) Solved! Opencascade Won't Build
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 16 May 2003
Posts: 229
Location: West Grove, PA

PostPosted: Mon Dec 01, 2014 12:35 am    Post subject: (sorta) Solved! Opencascade Won't Build Reply with quote

Anybody having trouble building opencascade 6.7.1?

It craps out on me just after starting to complain about GLinptr not being declared.

Here's the first hint of error:

In file included from /usr/include/GL/glx.h:333:0,
from ../../../../inc/InterfaceGraphic_X11.hxx:24,
from ../../../../inc/InterfaceGraphic.hxx:23,
from ../../../../inc/OpenGl_GlCore11.hxx:48,
from ../../../../inc/OpenGl_GlCore12.hxx:19,
from ../../../../inc/OpenGl_GlCore13.hxx:19,
from ../../../../inc/OpenGl_GlCore14.hxx:19,
from ../../../../inc/OpenGl_GlCore15.hxx:19,
from ../../../../inc/OpenGl_GlCore20.hxx:19,
from ../../../../inc/OpenGl_ShaderObject.hxx:21,
from ../../../../inc/OpenGl_ShaderProgram.hxx:30,
from ../../../../inc/OpenGl_ShaderManager.hxx:25,
from ../../../../src/OpenGl/OpenGl_AspectLine.cxx:20:
/usr/include/GL/glxext.h:480:143: error: 'GLintptr' has not been declared
void ( *PFNGLXCOPYBUFFERSUBDATANVPROC) (Display *dpy, GLXContext readCtx, GLXContext writeCtx, GLenum readTarget, GLenum writeTarget, GLintptr re

Here's my system info:

emerge --info '=sci-libs/opencascade-6.7.1::gentoo'
Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.3, glibc-2.20, 3.17.4-gentoo x86_64)
System Settings
System uname: Linux-3.17.4-gentoo-x86_64-AMD_Phenom-tm-_II_X4_940_Processor-with-gentoo-2.2
KiB Mem: 8176304 total, 1058192 free
KiB Swap: 16777212 total, 16677100 free
Timestamp of tree: Sun, 30 Nov 2014 18:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash: 4.3_p30-r1
dev-java/java-config: 2.2.0
dev-lang/perl: 5.20.1-r3
dev-lang/python: 2.7.8, 3.3.5-r1, 3.4.2
dev-util/cmake: 3.0.2
dev-util/pkgconfig: 0.28-r2
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.13.6
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.69
sys-devel/automake: 1.13.4, 1.14.1
sys-devel/binutils: 2.24-r3
sys-devel/gcc: 4.8.3
sys-devel/gcc-config: 1.8
sys-devel/libtool: 2.4.3-r2
sys-devel/make: 4.1-r1
sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)
sys-libs/glibc: 2.20
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 apm apng asf bash-completion berkdb bzip2 cairo cdda cddb cdparanoia cdr clang cli consolekit corefonts cracklib crypt cups cxx dbus dcc_video declarative designer desktopglobe dga dot dri dts dvd dvdr emboss encode exif extra extraengine fam fbcon fbosd fdformat firefox flac flash fontconfig foomaticdb fortran freeimage gbm gd gdbm gif git gl2ps glamor gnome gphoto2 gpm gstreamer gtk gtk3 handbook hddtemp hog iconv icu id3tag imagemagick imap inotify jadetex java jpeg kde kdenlive kipi kontact latex lcms libnotify lm_sensors lzma lzo mad marble mdnsresponder-compat melt midi minizip mmx mmxext mng modules mp3 mp4 mpeg mplayer mtp multilib mvl mysql ncurses networking nfs nls nptl nsplugin ntp ocr ogg ogm opengl openmp opus pam pango pcre pdf phonon plasma pm-utils png policykit ppds pulseaudio python qt3support qt4 quicktime qwt rar raw rdesktop readline run-as-root sasl scanner script scripttools sdl semantic-desktop sensord session smp sound sox spell sql sqlite sse sse2 sse3 sse4 ssl ssse3 startup-notification svg symlink syslog taglib tcpd theora threads tiff timidity truetype udev udisks unicode unzip upcall upower usb v4l vnc vorbis webkit winbind wmf wxwidgets x264 xcb xcomposite xetex xine xinerama xml xmp xrandr xscreensaver xv xvfb xvid xvmc zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Anybody have any suggestions to try?

TIA! ^
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation

Last edited by Vorlon on Thu Dec 04, 2014 1:51 am; edited 1 time in total
Back to top
View user's profile Send private message
Retired Dev
Retired Dev

Joined: 29 Feb 2008
Posts: 1017
Location: CET

PostPosted: Mon Dec 01, 2014 5:47 am    Post subject: Re: Opencascade Won't Build Reply with quote

Vorlon wrote:
Anybody have any suggestions to try?

Upgrade/downgrade mesa?
Back to top
View user's profile Send private message

Joined: 22 Mar 2006
Posts: 553

PostPosted: Tue Dec 02, 2014 10:15 pm    Post subject: Reply with quote

Yeah, it's broken. I ran into it trying to install FreeCAD. Here's what I did to get around it.

emerge the package, and just as soon as you see it finish extracting the tarball, (it will take a couple of seconds) hit Ctrl-Z to suspend the process.

cd down into the build directory and edit two files:
cd /var/tmp/portage/sci-libs/opencascade-6.7.1
sudo vi work/opencascade-6.7.1/inc/OpenGl_GlCore11.hxx
sudo vi work/opencascade-6.7.1/src/OpenGl/OpenGl_GlCore11.hxx

In both of those files find this line:

add this line right after it:

save both files, and run "fg" to resume the build.

This is touched upon in section 5.4 of the OpenGL ABI spec.

Back to top
View user's profile Send private message

Joined: 16 May 2003
Posts: 229
Location: West Grove, PA

PostPosted: Thu Dec 04, 2014 1:50 am    Post subject: Reply with quote

That did the trick, Troy.

Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum