Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201412-08 ] Multiple packages, Multiple vulnerabilities fixed in 2010
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Fri Dec 12, 2014 12:26 am    Post subject: [ GLSA 201412-08 ] Multiple packages, Multiple vulnerabiliti Reply with quote

Gentoo Linux Security Advisory

Title: Multiple packages, Multiple vulnerabilities fixed in 2010 (GLSA 201412-08)
Severity: high
Exploitable: local, remote
Date: December 11, 2014
Bug(s): #159556, #208464, #253822, #259968, #298067, #300375, #300943, #302478, #307525, #307633, #315235, #316697, #319719, #320961, #322457, #325507, #326759, #326953, #329125, #329939, #331421, #332527, #333661
ID: 201412-08

Synopsis

This GLSA contains notification of vulnerabilities found in several
Gentoo packages which have been fixed prior to January 1, 2011. The worst
of these vulnerabilities could lead to local privilege escalation and
remote code execution. Please see the package list and CVE identifiers
below for more information.


Background

For more information on the packages listed in this GLSA, please see
their homepage referenced in the ebuild.


Affected Packages

Package: dev-util/insight
Vulnerable: < 6.7.1-r1
Unaffected: >= 6.7.1-r1
Architectures: All supported architectures

Package: dev-perl/perl-tk
Vulnerable: < 804.028-r2
Unaffected: >= 804.028-r2
Architectures: All supported architectures

Package: dev-util/sourcenav
Vulnerable: < 5.1.4
Unaffected: >= 5.1.4
Architectures: All supported architectures

Package: dev-lang/tk
Vulnerable: < 8.4.18-r1
Unaffected: >= 8.4.18-r1
Architectures: All supported architectures

Package: sys-block/partimage
Vulnerable: < 0.6.8
Unaffected: >= 0.6.8
Architectures: All supported architectures

Package: app-antivirus/bitdefender-console
Vulnerable: <= 7.1
Architectures: All supported architectures

Package: net-mail/mlmmj
Vulnerable: < 1.2.17.1
Unaffected: >= 1.2.17.1
Architectures: All supported architectures

Package: sys-apps/acl
Vulnerable: < 2.2.49
Unaffected: >= 2.2.49
Architectures: All supported architectures

Package: x11-apps/xinit
Vulnerable: < 1.2.0-r4
Unaffected: >= 1.2.0-r4
Architectures: All supported architectures

Package: app-arch/gzip
Vulnerable: < 1.4
Unaffected: >= 1.4
Architectures: All supported architectures

Package: app-arch/ncompress
Vulnerable: < 4.2.4.3
Unaffected: >= 4.2.4.3
Architectures: All supported architectures

Package: dev-libs/liblzw
Vulnerable: < 0.2
Unaffected: >= 0.2
Architectures: All supported architectures

Package: media-gfx/splashutils
Vulnerable: < 1.5.4.3-r3
Unaffected: >= 1.5.4.3-r3
Architectures: All supported architectures

Package: sys-devel/m4
Vulnerable: < 1.4.14-r1
Unaffected: >= 1.4.14-r1
Architectures: All supported architectures

Package: kde-base/kdm
Vulnerable: < 4.3.5-r1
Unaffected: >= 4.3.5-r1
Architectures: All supported architectures

Package: x11-libs/gtk+
Vulnerable: < 2.18.7
Unaffected: >= 2.18.7
Architectures: All supported architectures

Package: kde-base/kget
Vulnerable: < 4.3.5-r1
Unaffected: >= 4.3.5-r1
Architectures: All supported architectures

Package: app-text/dvipng
Vulnerable: < 1.13
Unaffected: >= 1.13
Architectures: All supported architectures

Package: app-misc/beanstalkd
Vulnerable: < 1.4.6
Unaffected: >= 1.4.6
Architectures: All supported architectures

Package: sys-apps/pmount
Vulnerable: < 0.9.23
Unaffected: >= 0.9.23
Architectures: All supported architectures

Package: sys-auth/pam_krb5
Vulnerable: < 4.3
Unaffected: >= 4.3
Architectures: All supported architectures

Package: app-text/gv
Vulnerable: < 3.7.1
Unaffected: >= 3.7.1
Architectures: All supported architectures

Package: net-ftp/lftp
Vulnerable: < 4.0.6
Unaffected: >= 4.0.6
Architectures: All supported architectures

Package: www-client/uzbl
Vulnerable: < 2010.08.05
Unaffected: >= 2010.08.05
Architectures: All supported architectures

Package: x11-misc/slim
Vulnerable: < 1.3.2
Unaffected: >= 1.3.2
Architectures: All supported architectures

Package: net-misc/iputils
Vulnerable: < 20100418
Unaffected: >= 20100418
Architectures: All supported architectures

Package: media-tv/dvbstreamer
Vulnerable: < 1.1-r1
Unaffected: >= 1.1-r1
Architectures: All supported architectures


Description

Vulnerabilities have been discovered in the packages listed below.
Please review the CVE identifiers in the Reference section for details.
  • Insight
  • Perl Tk Module
  • Source-Navigator
  • Tk
  • Partimage
  • Mlmmj
  • acl
  • Xinit
  • gzip
  • ncompress
  • liblzw
  • splashutils
  • GNU M4
  • KDE Display Manager
  • GTK+
  • KGet
  • dvipng
  • Beanstalk
  • Policy Mount
  • pam_krb5
  • GNU gv
  • LFTP
  • Uzbl
  • Slim
  • Bitdefender Console
  • iputils
  • DVBStreamer


Impact

A context-dependent attacker may be able to gain escalated privileges,
execute arbitrary code, cause Denial of Service, obtain sensitive
information, or otherwise bypass security restrictions.


Workaround

There are no known workarounds at this time.

Resolution

All Insight users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-util/insight-6.7.1-r1"
   
All Perl Tk Module users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-perl/perl-tk-804.028-r2"
   
All Source-Navigator users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-util/sourcenav-5.1.4"
   
All Tk users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/tk-8.4.18-r1"
   
All Partimage users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-block/partimage-0.6.8"
   
All Mlmmj users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-mail/mlmmj-1.2.17.1"
   
All acl users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-apps/acl-2.2.49"
   
All Xinit users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=x11-apps/xinit-1.2.0-r4"
   
All gzip users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-arch/gzip-1.4"
   
All ncompress users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-arch/ncompress-4.2.4.3"
   
All liblzw users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/liblzw-0.2"
   
All splashutils users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=media-gfx/splashutils-1.5.4.3-r3"
   
All GNU M4 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-devel/m4-1.4.14-r1"
   
All KDE Display Manager users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=kde-base/kdm-4.3.5-r1"
   
All GTK+ users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=x11-libs/gtk+-2.18.7"
   
All KGet 4.3 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=kde-base/kget-4.3.5-r1"
   
All dvipng users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-text/dvipng-1.13"
   
All Beanstalk users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-misc/beanstalkd-1.4.6"
   
All Policy Mount users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-apps/pmount-0.9.23"
   
All pam_krb5 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-auth/pam_krb5-4.3"
   
All GNU gv users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-text/gv-3.7.1"
   
All LFTP users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-ftp/lftp-4.0.6"
   
All Uzbl users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=www-client/uzbl-2010.08.05"
   
All Slim users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=x11-misc/slim-1.3.2"
   
All iputils users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-misc/iputils-20100418"
   
All DVBStreamer users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-tv/dvbstreamer-1.1-r1"
   
Gentoo has discontinued support for Bitdefender Console. We recommend
that users unmerge Bitdefender Console:
Code:
# emerge --unmerge "app-antivirus/bitdefender-console"
   
NOTE: This is a legacy GLSA. Updates for all affected architectures have
been available since 2011. It is likely that your system is already no
longer affected by these issues.


References

CVE-2006-3005
CVE-2007-2741
CVE-2008-0553
CVE-2008-1382
CVE-2008-5907
CVE-2008-6218
CVE-2008-6661
CVE-2009-0040
CVE-2009-0360
CVE-2009-0361
CVE-2009-0946
CVE-2009-2042
CVE-2009-2624
CVE-2009-3736
CVE-2009-4029
CVE-2009-4411
CVE-2009-4896
CVE-2010-0001
CVE-2010-0436
CVE-2010-0732
CVE-2010-0829
CVE-2010-1000
CVE-2010-1205
CVE-2010-1511
CVE-2010-2056
CVE-2010-2060
CVE-2010-2192
CVE-2010-2251
CVE-2010-2529
CVE-2010-2809
CVE-2010-2945
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum