Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201412-09 ] Multiple packages, Multiple vulnerabilities fixed in 2011
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Fri Dec 12, 2014 1:26 am    Post subject: [ GLSA 201412-09 ] Multiple packages, Multiple vulnerabiliti Reply with quote

Gentoo Linux Security Advisory

Title: Multiple packages, Multiple vulnerabilities fixed in 2011 (GLSA 201412-09)
Severity: high
Exploitable: local, remote
Date: December 11, 2014
Bug(s): #194151, #294253, #294256, #334087, #344059, #346897, #350598, #352608, #354209, #355207, #356893, #358611, #358785, #358789, #360891, #361397, #362185, #366697, #366699, #369069, #370839, #372971, #376793, #381169, #386321, #386361
ID: 201412-09

Synopsis

This GLSA contains notification of vulnerabilities found in several
Gentoo packages which have been fixed prior to January 1, 2012. The worst
of these vulnerabilities could lead to local privilege escalation and
remote code execution. Please see the package list and CVE identifiers
below for more information.


Background

For more information on the packages listed in this GLSA, please see
their homepage referenced in the ebuild.


Affected Packages

Package: games-sports/racer-bin
Vulnerable: >= 0.5.0-r1
Architectures: All supported architectures

Package: media-libs/fmod
Vulnerable: < 4.38.00
Unaffected: >= 4.38.00
Architectures: All supported architectures

Package: dev-php/PEAR-Mail
Vulnerable: < 1.2.0
Unaffected: >= 1.2.0
Architectures: All supported architectures

Package: sys-fs/lvm2
Vulnerable: < 2.02.72
Unaffected: >= 2.02.72
Architectures: All supported architectures

Package: app-office/gnucash
Vulnerable: < 2.4.4
Unaffected: >= 2.4.4
Architectures: All supported architectures

Package: media-libs/xine-lib
Vulnerable: < 1.1.19
Unaffected: >= 1.1.19
Architectures: All supported architectures

Package: media-sound/lastfmplayer
Vulnerable: < 1.5.4.26862-r3
Unaffected: >= 1.5.4.26862-r3
Architectures: All supported architectures

Package: net-libs/webkit-gtk
Vulnerable: < 1.2.7
Unaffected: >= 1.2.7
Architectures: All supported architectures

Package: sys-apps/shadow
Vulnerable: < 4.1.4.3
Unaffected: >= 4.1.4.3
Architectures: All supported architectures

Package: dev-php/PEAR-PEAR
Vulnerable: < 1.9.2-r1
Unaffected: >= 1.9.2-r1
Architectures: All supported architectures

Package: dev-db/unixODBC
Vulnerable: < 2.3.0-r1
Unaffected: >= 2.3.0-r1
Architectures: All supported architectures

Package: sys-cluster/resource-agents
Vulnerable: < 1.0.4-r1
Unaffected: >= 1.0.4-r1
Architectures: All supported architectures

Package: net-misc/mrouted
Vulnerable: < 3.9.5
Unaffected: >= 3.9.5
Architectures: All supported architectures

Package: net-misc/rsync
Vulnerable: < 3.0.8
Unaffected: >= 3.0.8
Architectures: All supported architectures

Package: dev-libs/xmlsec
Vulnerable: < 1.2.17
Unaffected: >= 1.2.17
Architectures: All supported architectures

Package: x11-apps/xrdb
Vulnerable: < 1.0.9
Unaffected: >= 1.0.9
Architectures: All supported architectures

Package: net-misc/vino
Vulnerable: < 2.32.2
Unaffected: >= 2.32.2
Architectures: All supported architectures

Package: dev-util/oprofile
Vulnerable: < 0.9.6-r1
Unaffected: >= 0.9.6-r1
Architectures: All supported architectures

Package: app-admin/syslog-ng
Vulnerable: < 3.2.4
Unaffected: >= 3.2.4
Architectures: All supported architectures

Package: net-analyzer/sflowtool
Vulnerable: < 3.20
Unaffected: >= 3.20
Architectures: All supported architectures

Package: gnome-base/gdm
Vulnerable: < 3.8.4-r3
Unaffected: >= 3.8.4-r3
Architectures: All supported architectures

Package: net-libs/libsoup
Vulnerable: < 2.34.3
Unaffected: >= 2.34.3
Architectures: All supported architectures

Package: app-misc/ca-certificates
Vulnerable: < 20110502-r1
Unaffected: >= 20110502-r1
Architectures: All supported architectures

Package: dev-vcs/gitolite
Vulnerable: < 1.5.9.1
Unaffected: >= 1.5.9.1
Architectures: All supported architectures

Package: dev-util/qt-creator
Vulnerable: < 2.1.0
Unaffected: >= 2.1.0
Architectures: All supported architectures


Description

Vulnerabilities have been discovered in the packages listed below.
Please review the CVE identifiers in the Reference section for details.
  • FMOD Studio
  • PEAR Mail
  • LVM2
  • GnuCash
  • xine-lib
  • Last.fm Scrobbler
  • WebKitGTK+
  • shadow tool suite
  • PEAR
  • unixODBC
  • Resource Agents
  • mrouted
  • rsync
  • XML Security Library
  • xrdb
  • Vino
  • OProfile
  • syslog-ng
  • sFlow Toolkit
  • GNOME Display Manager
  • libsoup
  • CA Certificates
  • Gitolite
  • QtCreator
  • Racer


Impact

A context-dependent attacker may be able to gain escalated privileges,
execute arbitrary code, cause Denial of Service, obtain sensitive
information, or otherwise bypass security restrictions.


Workaround

There are no known workarounds at this time.

Resolution

All FMOD Studio users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/fmod-4.38.00"
   
All PEAR Mail users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-php/PEAR-Mail-1.2.0"
   
All LVM2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-fs/lvm2-2.02.72"
   
All GnuCash users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-office/gnucash-2.4.4"
   
All xine-lib users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/xine-lib-1.1.19"
   
All Last.fm Scrobbler users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=media-sound/lastfmplayer-1.5.4.26862-r3"
   
All WebKitGTK+ users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-1.2.7"
   
All shadow tool suite users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-apps/shadow-4.1.4.3"
   
All PEAR users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-php/PEAR-PEAR-1.9.2-r1"
   
All unixODBC users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/unixODBC-2.3.0-r1"
   
All Resource Agents users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=sys-cluster/resource-agents-1.0.4-r1"
   
All mrouted users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-misc/mrouted-3.9.5"
   
All rsync users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-misc/rsync-3.0.8"
   
All XML Security Library users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/xmlsec-1.2.17"
   
All xrdb users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=x11-apps/xrdb-1.0.9"
   
All Vino users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-misc/vino-2.32.2"
   
All OProfile users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-util/oprofile-0.9.6-r1"
   
All syslog-ng users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-admin/syslog-ng-3.2.4"
   
All sFlow Toolkit users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-analyzer/sflowtool-3.20"
   
All GNOME Display Manager users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=gnome-base/gdm-3.8.4-r3"
   
All libsoup users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/libsoup-2.34.3"
   
All CA Certificates users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=app-misc/ca-certificates-20110502-r1"
   
All Gitolite users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-vcs/gitolite-1.5.9.1"
   
All QtCreator users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-util/qt-creator-2.1.0"
   
Gentoo has discontinued support for Racer. We recommend that users
unmerge Racer:
Code:
# emerge --unmerge "games-sports/racer-bin"
   
NOTE: This is a legacy GLSA. Updates for all affected architectures have
been available since 2012. It is likely that your system is already no
longer affected by these issues.


References

CVE-2007-4370
CVE-2009-4023
CVE-2009-4111
CVE-2010-0778
CVE-2010-1780
CVE-2010-1782
CVE-2010-1783
CVE-2010-1784
CVE-2010-1785
CVE-2010-1786
CVE-2010-1787
CVE-2010-1788
CVE-2010-1790
CVE-2010-1791
CVE-2010-1792
CVE-2010-1793
CVE-2010-1807
CVE-2010-1812
CVE-2010-1814
CVE-2010-1815
CVE-2010-2526
CVE-2010-2901
CVE-2010-3255
CVE-2010-3257
CVE-2010-3259
CVE-2010-3362
CVE-2010-3374
CVE-2010-3389
CVE-2010-3812
CVE-2010-3813
CVE-2010-3999
CVE-2010-4042
CVE-2010-4197
CVE-2010-4198
CVE-2010-4204
CVE-2010-4206
CVE-2010-4492
CVE-2010-4493
CVE-2010-4577
CVE-2010-4578
CVE-2011-0007
CVE-2011-0465
CVE-2011-0482
CVE-2011-0721
CVE-2011-0727
CVE-2011-0904
CVE-2011-0905
CVE-2011-1072
CVE-2011-1097
CVE-2011-1144
CVE-2011-1425
CVE-2011-1572
CVE-2011-1760
CVE-2011-1951
CVE-2011-2471
CVE-2011-2472
CVE-2011-2473
CVE-2011-2524
CVE-2011-3365
CVE-2011-3366
CVE-2011-3367
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum