Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201412-10 ] Multiple packages, Multiple vulnerabilities fixed in 2012
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2235

PostPosted: Fri Dec 12, 2014 2:26 am    Post subject: [ GLSA 201412-10 ] Multiple packages, Multiple vulnerabiliti Reply with quote

Gentoo Linux Security Advisory

Title: Multiple packages, Multiple vulnerabilities fixed in 2012 (GLSA 201412-10)
Severity: high
Exploitable: local, remote
Date: December 11, 2014
Bug(s): #284536, #300903, #334475, #358787, #371320, #372905, #399427, #401645, #427802, #428776
ID: 201412-10

Synopsis

This GLSA contains notification of vulnerabilities found in several
Gentoo packages which have been fixed prior to January 1, 2013. The worst
of these vulnerabilities could lead to local privilege escalation and
remote code execution. Please see the package list and CVE identifiers
below for more information.


Background

For more information on the packages listed in this GLSA, please see
their homepage referenced in the ebuild.


Affected Packages

Package: www-apps/egroupware
Vulnerable: < 1.8.004.20120613
Unaffected: >= 1.8.004.20120613
Architectures: All supported architectures

Package: x11-libs/vte
Vulnerable: < 0.32.2
Unaffected: >= 0.32.2
Unaffected: >= 0.28.2-r204 < 0.28.3
Unaffected: >= 0.28.2-r206 < 0.28.3
Architectures: All supported architectures

Package: net-analyzer/lft
Vulnerable: < 3.33
Unaffected: >= 3.33
Architectures: All supported architectures

Package: dev-php/suhosin
Vulnerable: < 0.9.33
Unaffected: >= 0.9.33
Architectures: All supported architectures

Package: x11-misc/slock
Vulnerable: < 1.0
Unaffected: >= 1.0
Architectures: All supported architectures

Package: sys-cluster/ganglia
Vulnerable: < 3.3.7
Unaffected: >= 3.3.7
Architectures: All supported architectures

Package: net-im/gg-transport
Vulnerable: < 2.2.4
Unaffected: >= 2.2.4
Architectures: All supported architectures


Description

Vulnerabilities have been discovered in the packages listed below.
Please review the CVE identifiers in the Reference section for details.
  • EGroupware
  • VTE
  • Layer Four Traceroute (LFT)
  • Suhosin
  • Slock
  • Ganglia
  • Jabber to GaduGadu Gateway


Impact

A context-dependent attacker may be able to gain escalated privileges,
execute arbitrary code, cause Denial of Service, obtain sensitive
information, or otherwise bypass security restrictions.


Workaround

There is no known workaround at this time.

Resolution

All EGroupware users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=www-apps/egroupware-1.8.004.20120613"
   
All VTE 0.32 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=x11-libs/vte-0.32.2"
   
All VTE 0.28 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=x11-libs/vte-0.28.2-r204"
   
All Layer Four Traceroute users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-analyzer/lft-3.33"
   
All Suhosin users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-php/suhosin-0.9.33"
   
All Slock users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=x11-misc/slock-1.0"
   
All Ganglia users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-cluster/ganglia-3.3.7"
   
All Jabber to GaduGadu Gateway users should upgrade to the latest
version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-im/gg-transport-2.2.4"
   
NOTE: This is a legacy GLSA. Updates for all affected architectures have
been available since 2013. It is likely that your system is already no
longer affected by these issues.


References

CVE-2008-4776
CVE-2010-2713
CVE-2010-3313
CVE-2010-3314
CVE-2011-0765
CVE-2011-2198
CVE-2012-0807
CVE-2012-0808
CVE-2012-1620
CVE-2012-2738
CVE-2012-3448
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum