Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] nvidia-drivers-343* cause udev to hang
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
e3k
Guru
Guru


Joined: 01 Oct 2007
Posts: 354
Location: Inner Space

PostPosted: Sun Dec 14, 2014 9:40 am    Post subject: [solved] nvidia-drivers-343* cause udev to hang Reply with quote

the last 2 updates of nvidia-drivers:343-22-r2 and 343-36 are causing udev to hang with the message "waiting for uevents to be processed".
in both cases a downgrade to a 340* driver fixes this issue.

i could not find anything about it in gentoo bugs, please let me know your opinion before i open a bug.

kernel used = 3.12.21-gentoo-r1
_________________
((O.o))


Last edited by e3k on Sun Dec 14, 2014 12:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
mahdi1234
Guru
Guru


Joined: 19 Feb 2005
Posts: 537
Location: far from new world orderia

PostPosted: Sun Dec 14, 2014 11:47 am    Post subject: Reply with quote

What graphic card do you have?

Could it be related to this - http://www.nvidia.com/object/IO_32667.html - basically that you have to stay at 340?

check also log of build process, maybe you see something like this
Code:
 * ***** WARNING *****
 *
 * You are currently installing a version of nvidia-drivers that is
 * known not to work with a video card you have installed on your
 * system. If this is intentional, please ignore this. If it is not
 * please perform the following steps:
 *
 * Add the following mask entry to /etc/portage/package.mask by
 * echo ">=x11-drivers/nvidia-drivers-341.0.0" >> /etc/portage/package.mask
 *
 * Failure to perform the steps above could result in a non-working
 * X setup.
 *
 * For more information please read:
 * http://www.nvidia.com/object/IO_32667.html
 * Checking for suitable kernel configuration options... 


cheers ...
_________________
http://gentoo.mahdi.cz <-- gentoo package search engine
Back to top
View user's profile Send private message
e3k
Guru
Guru


Joined: 01 Oct 2007
Posts: 354
Location: Inner Space

PostPosted: Sun Dec 14, 2014 12:18 pm    Post subject: Reply with quote

thanks mahdi1234. yes my card is among the others in list. geforce 9600gt.
i will now mask everything above 340
---
The Linux 340.* legacy driver series is the last to support the G8x, G9x, and GT2xx GPUs, and motherboard chipsets based on them. Support for new Linux kernels and X servers, as well as fixes for critical bugs, will be included in 340.* legacy releases through the end of 2019.
_________________
((O.o))
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum