Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201412-28 ] Ruby on Rails: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2235

PostPosted: Sun Dec 14, 2014 9:26 pm    Post subject: [ GLSA 201412-28 ] Ruby on Rails: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Ruby on Rails: Multiple vulnerabilities (GLSA 201412-28)
Severity: high
Exploitable: remote
Date: December 14, 2014
Bug(s): #354249, #379511, #386377, #450974, #453844, #456840, #462452
ID: 201412-28

Synopsis

Multiple vulnerabilities were found in Ruby on Rails, the worst of
which allowing for execution of arbitrary code.


Background

Ruby on Rails is a web-application and persistence framework.

Affected Packages

Package: dev-ruby/rails
Vulnerable: < 2.3.18
Unaffected: >= 2.3.18
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in Ruby on Rails. Please
review the CVE identifiers referenced below for details.


Impact

A remote attacker could execute arbitrary code or cause a Denial of
Service condition. Furthermore, a remote attacker may be able to execute
arbitrary SQL commands, change parameter names for form inputs and make
changes to arbitrary records in the system, bypass intended access
restrictions, render arbitrary views, inject arbitrary web script or
HTML, or conduct cross-site request forgery (CSRF) attacks.


Workaround

There is no known workaround at this time.

Resolution

All Ruby on Rails 2.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-ruby/rails-2.3.18"
   
NOTE: All applications using Ruby on Rails should also be configured to
use the latest version available by running “rake rails:update”
inside the application directory.
NOTE: This is a legacy GLSA and stable updates for Ruby on Rails,
including the unaffected version listed above, are no longer available
from Gentoo. It may be possible to upgrade to the 3.2, 4.0, or 4.1
branches, however these packages are not currently stable.


References

CVE-2010-3933
CVE-2011-0446
CVE-2011-0447
CVE-2011-0448
CVE-2011-0449
CVE-2011-2929
CVE-2011-2930
CVE-2011-2931
CVE-2011-2932
CVE-2011-3186
CVE-2013-0155
CVE-2013-0156
CVE-2013-0276
CVE-2013-0277
CVE-2013-0333
CVE-2013-1854
CVE-2013-1855
CVE-2013-1856
CVE-2013-1857
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum