Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
very newb. cant install: x11-drivers/ati-drivers-13.1_pre897
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
papandreoos
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2014
Posts: 136

PostPosted: Wed Dec 17, 2014 9:22 pm    Post subject: very newb. cant install: x11-drivers/ati-drivers-13.1_pre897 Reply with quote

i have ati radeon hd 2400 pro.
in this wiki you can see that this driver is good for my card:
http://wiki.gentoo.org/wiki/Fglrx#Hardware_support
i also did the: Force legacy driver when you have Radeon HD 2000 - 4000, below.

so now i run this command:
Code:
emerge --ask --changed-use --deep @world

and get this error:
Code:
ERROR: x11-drivers/ati-drivers-13.1_pre897::gentoo failed (compile phase):
 *   fgl_glxgears build failed
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 3178:  Called die
 * The specific snippet of code:
 *       "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU -I"${S}"/${FOLDER_PREFIX}usr/include fgl_glxgears.c -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed";
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-13.1_pre897::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-13.1_pre897::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/extra/fgl_glxgears'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work'

>>> Failed to emerge x11-drivers/ati-drivers-13.1_pre897, Log file:

>>>  '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/temp/build.log'

 * Messages for package x11-drivers/ati-drivers-13.1_pre897:

 *
 * Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration informations please refer to:
 * http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 * ERROR: x11-drivers/ati-drivers-13.1_pre897::gentoo failed (compile phase):
 *   fgl_glxgears build failed
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 3178:  Called die
 * The specific snippet of code:
 *       "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU -I"${S}"/${FOLDER_PREFIX}usr/include fgl_glxgears.c -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed";
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-13.1_pre897::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-13.1_pre897::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/extra/fgl_glxgears'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work'


as you can see, here it tells something different from the wiki above:
Code:
 Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration informations please refer to:
 * http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml


here is my:
Code:
emerge --info '=x11-drivers/ati-drivers-13.1_pre897::gentoo'


Code:
Portage 2.2.14 (python 2.7.7-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.8.3, glibc-2.19-r1, 3.17.6-1-ARCH x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.17.6-1-ARCH-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.2
KiB Mem:     4051140 total,    362196 free
KiB Swap:    4620284 total,   4553604 free
Timestamp of tree: Wed, 17 Dec 2014 15:15:02 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.7, 3.3.5-r1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.isoc.org.il/pub/gentoo/ ftp://mirror.isoc.org.il/gentoo/ http://files.gentoo.gr/ http://ftp.ntua.gr/pub/linux/gentoo/ http://gentoo.inode.at/ http://gd.tuwien.ac.at/opsys/linux/gentoo/ http://gentoo.supp.name/ http://gentoo.modulix.net/gentoo/ http://de-mirror.org/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync25.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv introspection ipv6 jpeg lcms ldap libnotify libsecret mad mmx mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline sdl session socialweb spell sse sse2 ssl startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



here is the output of:
Code:
emerge -pqv '=x11-drivers/ati-drivers-13.1_pre897::gentoo'
:

Code:
[ebuild  N    ] x11-drivers/ati-drivers-13.1_pre897  USE="modules multilib qt4 -debug -disable-watermark -pax_kernel -static-libs"


and here is the output of
Code:
/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/temp/build.log


Code:
* Package:    x11-drivers/ati-drivers-13.1_pre897
 * Repository: gentoo
 * Maintainer: x11@gentoo.org jekarlson@gmail.com,proxy-maint@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux modules multilib qt4 userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.16.5-gentoo/build
 * Found sources for kernel version:
 *     3.16.5-gentoo
 * Checking for suitable kernel configuration options...                                                                                                                          [ ok ]
 *
 * Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration informations please refer to:
 * http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 *
>>> Unpacking source...
>>> Unpacking amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.zip to /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work
Warning: target directory exists /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work
>>> Unpacking xvba-sdk-0.74-404001.tar.gz to /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/xvba_sdk
>>> Source unpacked in /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work
>>> Preparing source in /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work ...
 * Applying ati-powermode-opt-path-3.patch ...                                                                                                                                    [ ok ]
 * Applying ati-drivers-x32_something_something.patch ...                                                                                                                         [ ok ]
 * Applying ati-drivers-do_mmap.patch ...                                                                                                                                         [ ok ]
 * Applying ati-drivers-vm-reserverd.patch ...                                                                                                                                    [ ok ]
 * Applying ati-drivers-12.9-KCL_AGP_FindCapsRegisters-stub.patch ...                                                                                                             [ ok ]
 * Applying ati-drivers-kernel-3.8-acpihandle.patch ...                                                                                                                           [ ok ]
 * Applying typesafe-kuid.diff ...                                                                                                                                                [ ok ]
 * Applying linux-3.10-proc.diff ...                                                                                                                                              [ ok ]
 * Converting 2.6.x/Makefile to use M= instead of SUBDIRS= ...                                                                                                                    [ ok ]
>>> Unpacking ./../common/usr/src/ati/fglrx_sample_source.tgz to /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/extra
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work ...
 * Preparing fglrx module
make -j3 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' GCC_VER_MAJ=4 KVER=3.16.5-gentoo KDIR=/usr/src/linux 'CFLAGS_MODULE+=-DMODULE -DATI -DFGL' CFLAGS_MODULE+=-DCOMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space kmod_build
make -C /usr/src/linux M=/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory '/usr/src/linux-3.16.5-gentoo'
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
  LD [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
  LD [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory '/usr/src/linux-3.16.5-gentoo'
 * Building fgl_glxgears ...
In file included from fgl_glxgears.c:81:0:
/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/usr/include/GL/glATI.h:5370:0: warning: "GL_PROXY_TEXTURE_2D_MULTISAMPLE" redefined [enabled by default]
 #define GL_PROXY_TEXTURE_2D_MULTISAMPLE                    0X9101
 ^
In file included from /usr/include/GL/gl.h:2055:0,
                 from /usr/include/GL/glu.h:38,
                 from fgl_glxgears.c:64:
/usr/include/GL/glext.h:1454:0: note: this is the location of the previous definition
 #define GL_PROXY_TEXTURE_2D_MULTISAMPLE   0x9101
 ^
In file included from fgl_glxgears.c:81:0:
/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/usr/include/GL/glATI.h:5388:28: error: conflicting types for ‘PFNGLTEXIMAGE2DMULTISAMPLEPROC’
 typedef GLvoid (APIENTRY * PFNGLTEXIMAGE2DMULTISAMPLEPROC) (GLenum target, GLsizei samples, GLint internalformat,
                            ^
In file included from /usr/include/GL/gl.h:2055:0,
                 from /usr/include/GL/glu.h:38,
                 from fgl_glxgears.c:64:
/usr/include/GL/glext.h:1485:25: note: previous declaration of ‘PFNGLTEXIMAGE2DMULTISAMPLEPROC’ was here
 typedef void (APIENTRYP PFNGLTEXIMAGE2DMULTISAMPLEPROC) (GLenum target, GLsizei samples, GLenum internalformat, GLsizei width, GLsizei height, GLboolean fixedsamplelocations);
                         ^
In file included from fgl_glxgears.c:81:0:
/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/usr/include/GL/glATI.h:5390:28: error: conflicting types for ‘PFNGLTEXIMAGE3DMULTISAMPLEPROC’
 typedef GLvoid (APIENTRY * PFNGLTEXIMAGE3DMULTISAMPLEPROC) (GLenum target, GLsizei samples, GLint internalformat,
                            ^
In file included from /usr/include/GL/gl.h:2055:0,
                 from /usr/include/GL/glu.h:38,
                 from fgl_glxgears.c:64:
/usr/include/GL/glext.h:1486:25: note: previous declaration of ‘PFNGLTEXIMAGE3DMULTISAMPLEPROC’ was here
 typedef void (APIENTRYP PFNGLTEXIMAGE3DMULTISAMPLEPROC) (GLenum target, GLsizei samples, GLenum internalformat, GLsizei width, GLsizei height, GLsizei depth, GLboolean fixedsamplelocations);
                         ^
In file included from fgl_glxgears.c:81:0:
/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/common/usr/include/GL/glATI.h:6008:25: error: conflicting types for ‘GLDEBUGPROCARB’
 typedef void (APIENTRY *GLDEBUGPROCARB)(GLenum source,
                         ^
In file included from /usr/include/GL/gl.h:2055:0,
                 from /usr/include/GL/glu.h:38,
                 from fgl_glxgears.c:64:
/usr/include/GL/glext.h:2711:26: note: previous declaration of ‘GLDEBUGPROCARB’ was here
 typedef void (APIENTRY  *GLDEBUGPROCARB)(GLenum source,GLenum type,GLuint id,GLenum severity,GLsizei length,const GLchar *message,const void *userParam);
                          ^
 * ERROR: x11-drivers/ati-drivers-13.1_pre897::gentoo failed (compile phase):
 *   fgl_glxgears build failed
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 3178:  Called die
 * The specific snippet of code:
 *       "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU -I"${S}"/${FOLDER_PREFIX}usr/include fgl_glxgears.c -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed";
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-13.1_pre897::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-13.1_pre897::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work/extra/fgl_glxgears'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-13.1_pre897/work'


thanks for your help!
Back to top
View user's profile Send private message
papandreoos
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2014
Posts: 136

PostPosted: Thu Dec 18, 2014 1:56 pm    Post subject: Reply with quote

anyone? :)
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Thu Dec 18, 2014 7:52 pm    Post subject: Reply with quote

That driver is very old and probably some software component on your system is too new for it.
Best report a bug on https://bugs.gentoo.org/
Back to top
View user's profile Send private message
papandreoos
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2014
Posts: 136

PostPosted: Thu Dec 18, 2014 10:49 pm    Post subject: Reply with quote

chithanh wrote:
That driver is very old and probably some software component on your system is too new for it.
Best report a bug on https://bugs.gentoo.org/


thanks, but i already install the open source driver :-).
the installation had no problems, but after i reboot, i have this problem:
https://drive.google.com/file/d/0By6Xl7VImF6eQktxVThBaDg3RjBWODJDMnhjRkh2RGNTendV/view?usp=sharing

before i installed the ati open source drivers, i could boot into command line in gentoo.
/dev/sda7 is my gentoo installation.
i do not have any other partitions for /boot, or /var etc'.
everything (that belongs to gentoo) is in /dev/sda7.

(i have other partitions for windows and archlinux)

here is the grub menu entry of gentoo:
Code:
menuentry 'Gentoo Base System release 2.2 (on /dev/sda7)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-f55b10e0-e35b-43df-b38c-0d35003d30a1' {
   insmod part_msdos
   insmod ext2
   set root='hd0,msdos7'
   if [ x$feature_platform_search_hint = xy ]; then
     search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7  f55b10e0-e35b-43df-b38c-0d35003d30a1
   else
     search --no-floppy --fs-uuid --set=root f55b10e0-e35b-43df-b38c-0d35003d30a1
   fi
   linux /boot/vmlinuz-3.16.5-gentoo root=/dev/sda7
   initrd /boot/initramfs-genkernel-x86_64-3.16.5-gentoo


what can i do to solve this?
i can give any information you need.
just say :).
it's a couple of days now, i'm trying to get gnome desktop environment running on my gentoo system, without success.
and now i even can't get into the command line as before.
Back to top
View user's profile Send private message
papandreoos
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2014
Posts: 136

PostPosted: Sun Dec 21, 2014 11:41 am    Post subject: Reply with quote

i deleted the partition and create a new one again, and now i'm starting a new installation of gentoo, from my archlinux.
Back to top
View user's profile Send private message
Deathwing00
Bodhisattva
Bodhisattva


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Sat Dec 27, 2014 4:25 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Kernel & Hardware.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum