Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo-sources-3.17.7 and rebuild virtualbox-modu.. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
pdr
l33t
l33t


Joined: 20 Mar 2004
Posts: 604

PostPosted: Fri Dec 19, 2014 1:34 pm    Post subject: gentoo-sources-3.17.7 and rebuild virtualbox-modu.. [SOLVED] Reply with quote

New version of virtualbox and virtualbox-modules runs fine with 3.17.7

NOT ENOUGH ROOM IN SUBJECT TO MARK
Upshot seems to be have to wait for a stable 4.3 VirtualBox

I get a compilation error running "emerge @module-rebuild" to rebuild virtualbox-modules for new kernel:

Code:
...
make[2]: Entering directory '/usr/src/linux-3.17.7-gentoo'
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/linux/VBoxNetAdp-linux.o
  CC [M]  /var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/VBoxNetAdp.o
/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/linux/VBoxNetAdp-linux.c: In function ‘vboxNetAdpOsCreate’:
/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/linux/VBoxNetAdp-linux.c:186:48: error: macro "alloc_netdev" requires 4 arguments, but only 3 given
/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/linux/VBoxNetAdp-linux.c:184:15: error: ‘alloc_netdev’ undeclared (first use in this function)
/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/linux/VBoxNetAdp-linux.c:184:15: note: each undeclared identifier is reported only once for each function it appears in
/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/linux/VBoxNetAdp-linux.c: At top level:
/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/linux/VBoxNetAdp-linux.c:159:13: warning: ‘vboxNetAdpNetDevInit’ defined but not used [-Wunused-function]
scripts/Makefile.build:257: recipe for target '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/linux/VBoxNetAdp-linux.o' failed
make[3]: *** [/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp/linux/VBoxNetAdp-linux.o] Error 1
Makefile:1373: recipe for target '_module_/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp' failed
make[2]: *** [_module_/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp] Error 2
make[2]: Leaving directory '/usr/src/linux-3.17.7-gentoo'
Makefile:200: recipe for target 'vboxnetadp' failed
make[1]: *** [vboxnetadp] Error 2
make[1]: Leaving directory '/var/tmp/portage/app-emulation/virtualbox-modules-4.2.24/work/vboxnetadp'
cp: cannot stat ‘vboxnetadp/vboxnetadp.ko’: No such file or directory


Had to boot back into 3.16.5 so I could use VirtualBox...


Last edited by pdr on Tue Dec 23, 2014 1:26 pm; edited 2 times in total
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 260
Location: Northern California

PostPosted: Fri Dec 19, 2014 7:25 pm    Post subject: Reply with quote

Yup. Same here. See this bug:

https://bugs.gentoo.org/show_bug.cgi?id=526652

After applying the patch attached to that bug report it compiled fine.

EDIT: However, virtualbox no longer runs. It now errors out with a "Failed to load VMMR0.ro (VERR_NO_EXEC_MEMORY) error.

After some googling, it appears this is a known problem fixed in virtualbox > 4.3 something.

So, it appears stable users have been left in the dust again by a stable kernel upgrade. Depressing, but familiar. Looks like the only options are to stay on kernel 3.16.5 for now, or move on to unstable virtualbox.
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 260
Location: Northern California

PostPosted: Sat Dec 20, 2014 4:19 am    Post subject: Reply with quote

FYI , after work I investigated some more. It appears the devs are working on stabilizing a working version:

https://bugs.gentoo.org/show_bug.cgi?id=525506

I've had success unmasking the version they're working on:

[/etc/portage/package.accept_keywords]
=app-emulation/virtualbox-4.3.16
=dev-util/kbuild-0.1.9998_pre20131130
=app-emulation/virtualbox-additions-4.3.16
=app-emulation/virtualbox-extpack-oracle-4.3.16.95972
=app-emulation/virtualbox-modules-4.3.16

So that's a workaround for now.
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 119
Location: JiangSu,China

PostPosted: Mon Dec 22, 2014 8:11 am    Post subject: Reply with quote

same question.

So, just wait until the virtualbox version 4.3.XX is unmasked , right?
Back to top
View user's profile Send private message
pdr
l33t
l33t


Joined: 20 Mar 2004
Posts: 604

PostPosted: Mon Dec 22, 2014 12:30 pm    Post subject: Reply with quote

I'll stick with 3.16.5 - nothing I know about in 3.17.7 that will make or break me, but this *is* my work workstation and I need VirtualBox to run Windows for some software tools I use.
Back to top
View user's profile Send private message
double_crane
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2011
Posts: 119
Location: JiangSu,China

PostPosted: Tue Dec 23, 2014 8:58 am    Post subject: Reply with quote

now virtualbox 4.3.18 is marked as stable .

it compiles well .no such error
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum