Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Change]Mouse and keyboard quit working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 293
Location: South Carolina

PostPosted: Tue Dec 23, 2014 3:48 am    Post subject: [Change]Mouse and keyboard quit working Reply with quote

After upgrading kernel to 3.16.5, I can boot to a login screen, but neither mouse or keyboard will work. I can only reboot the computer by turning it off manually and restarting it. I can boot to the live cd and chroot and use emerge and all that. But as soon as I get a gui, boom, no mouse or keyboard.

[Edit] Any ideas on how to get my Xfce working again? Also, I am running systemd, which I like and don't have a serious problem with learning its ins and outs. To me, it's just another way of doing things. After all, after using M$ stuff for years, and learning how to triple boot a Mac, really??? Just looking for some suggestions, thanks in advance.[/Edit]
_________________
Thanks,
Mark
__________________________________________________________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams


Last edited by mark2 on Wed Dec 24, 2014 6:04 am; edited 1 time in total
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 293
Location: South Carolina

PostPosted: Tue Dec 23, 2014 11:05 pm    Post subject: Reply with quote

I have re-emerged/re-installed the kernel, run through menuconfig to see if I had usb support. I can't seem to find any anomalies that are causing my USB ports to shut down. Even connecting another keyboard does not help. Tried connecting a ps2 keyboard and that didn't help. I did notice down in one section that only the AT keyboard was selected. But would this also disable the mouse (which is a wireless Logitech, btw)? I can use both before I restart to go into the Gui. Could it be my Xfce?
_________________
Thanks,
Mark
__________________________________________________________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 293
Location: South Carolina

PostPosted: Wed Dec 24, 2014 6:18 am    Post subject: Reply with quote

I thought I would try using genkernel since the manual menuconfig wasn't getting me anywhere. So, it is loading the kernel now but it stops because it cannot find the root fs. Part of where boot stopped i copied manually here:
Code:
RAMDISK: XZ image found at block 0
RAMDISK: EOF while reading compressed data
RAMDISK: EOF while reading compressed dataXZ-compressed data is corrupt
VFS: Cannot open root device "UUID=905045a6-9d3e-4c7c-9ea4-977f0a3b87cf" or unknown-block(0,0): error -6
Please append a correct "root"-boot option; here are the available partitions:
Kernel panic-not syncing: VFS: unable to mount root fs on unknown-block(0,0)


So now I need some help telling this how to find my root which is /dev/sda3. I can edit the boot script before it loads, but I am not sure where I put the instructions on what to put in there.

Any ideas out there?
_________________
Thanks,
Mark
__________________________________________________________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum