Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201412-44 ] policycoreutils
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Fri Dec 26, 2014 9:26 pm    Post subject: [ GLSA 201412-44 ] policycoreutils Reply with quote

Gentoo Linux Security Advisory

Title: policycoreutils: Privilege escalation (GLSA 201412-44)
Severity: high
Exploitable: local
Date: December 26, 2014
Bug(s): #509896
ID: 201412-44

Synopsis

A vulnerability in policycoreutils could lead to local privilege
escalation.


Background

policycoreutils is a collection of SELinux policy utilities.

Affected Packages

Package: sys-apps/policycoreutils
Vulnerable: < 2.2.5-r4
Unaffected: >= 2.2.5-r4
Architectures: All supported architectures


Description

The seunshare utility is owned by root with 4755 permissions which can
be exploited by a setuid system call.


Impact

A local attacker may be able to gain escalated privileges.

Workaround

There is no known workaround at this time.

Resolution

All policycoreutils users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=sys-apps/policycoreutils-2.2.5-r4"
   


References

CVE-2014-3215


Last edited by GLSA on Thu Jun 18, 2015 4:16 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum