Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] probleme beim networkmanager install
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Mon Dec 29, 2014 7:56 pm    Post subject: [SOLVED] probleme beim networkmanager install Reply with quote

Hallo,

bin Gentoo Neuling (komme von Debian) und noch viele Fragen.
Ich wollte den networkmanager installieren nur leider tut ers nicht.

[blocks B ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-fs/udev-init-scripts-27, sys-apps/kmod-19)
[blocks B ] <sys-fs/lvm2-2.02.103 ("<sys-fs/lvm2-2.02.103" is blocking sys-fs/udev-218)
[blocks B ] <dev-python/python-exec-10000 ("<dev-python/python-exec-10000" is blocking dev-lang/python-exec-2.0.1-r1)



Danke fuer eure Hilfe.

gruss rrbs


Last edited by rrbs on Thu Jan 01, 2015 12:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon Dec 29, 2014 8:25 pm    Post subject: Reply with quote

Bitte etwas ausführlicher: was ist der Befehl den du absetzt und was ist die vollständige ausgabe von emerge.
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Mon Dec 29, 2014 8:31 pm    Post subject: Reply with quote

Befehl: emerge net-misc/networkmanager

Ausgabe:
Code:

 * IMPORTANT: 15 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies                         n * ERROR: dev-libs/glib-9999 failed (depend phase):
 *   git.eclass could not be found by inherit()
 *
 * Call stack:
 *            ebuild.sh, line 551:  Called source '/var/lib/layman/gnome/dev-libs/glib/glib-9999.ebuild'
 *     glib-9999.ebuild, line  10:  Called inherit 'gnome2-live'
 *            ebuild.sh, line 286:  Called __qa_source '/var/lib/layman/gnome/eclass/gnome2-live.eclass'
 *            ebuild.sh, line  80:  Called source '/var/lib/layman/gnome/eclass/gnome2-live.eclass'
 *   gnome2-live.eclass, line  15:  Called inherit 'autotools' 'gnome2' 'gnome2-utils' 'libtool' 'git'
 *            ebuild.sh, line 261:  Called die
 * The specific snippet of code:
 *              [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
 *
 * If you need support, post the output of `emerge --info '=dev-libs/glib-9999'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/glib-9999'`.
 * This ebuild used the following eclasses from overlays:
 *   /var/lib/layman/gnome/eclass/gnome2-live.eclass
 *   /var/lib/layman/gnome/eclass/gnome2.eclass
 * This ebuild is from an overlay named 'gnome': '/var/lib/layman/gnome/'
 * Working directory: '/root'
 * S: '/var/tmp/portage/dev-libs/glib-9999/work/glib-9999'
                  ... done!     
[ebuild     U  ] virtual/libiconv-0-r1 [0] USE="-abi_mips_n32% -abi_mips_n64% -abi_mips_o32% -abi_ppc_32% -abi_ppc_64% -abi_s390_32% -abi_s390_64% -abi_x86_32% -abi_x86_64% -abi_x86_x32%"
[ebuild     U  ] dev-libs/libffi-3.1-r3 [3.0.11] USE="-abi_mips_n32% -abi_mips_n64% -abi_mips_o32% -abi_ppc_32% -abi_ppc_64% -abi_s390_32% -abi_s390_64% -abi_x86_32% -abi_x86_64% -abi_x86_x32% -pax_kernel%"
[ebuild  N     ] dev-lang/python-exec-2.0.1-r1  PYTHON_TARGETS="python2_7 -jython2_5 (-jython2_7) -pypy -pypy3 (-python3_3) -python3_4"
[ebuild     U  ] virtual/libffi-3.0.13-r1 [3.0.11] USE="-abi_mips_n32% -abi_mips_n64% -abi_mips_o32% -abi_ppc_32% -abi_ppc_64% -abi_s390_32% -abi_s390_64% -abi_x86_32% -abi_x86_64% -abi_x86_x32%"
[ebuild  N     ] net-libs/libndp-1.4  USE="-debug"
[ebuild     U  ] sys-apps/kmod-19 [12] USE="-python%" PYTHON_TARGETS="python2_7%* (-python3_3) -python3_4%"
[ebuild  N     ] net-misc/dhcp-4.3.1  USE="client ipv6 server ssl -ldap (-selinux) -vim-syntax"
[ebuild  N     ] net-libs/libqmi-1.10.2  USE="-doc -static-libs"
[ebuild     U  ] sys-kernel/linux-headers-3.17-r1 [3.6]
[ebuild     U  ] dev-util/gtk-doc-am-1.21 [1.18]
[ebuild     U  ] sys-libs/zlib-1.2.8-r1 [1.2.7] USE="-abi_mips_n32% -abi_mips_n64% -abi_mips_o32% -abi_ppc_32% -abi_ppc_64% -abi_s390_32% -abi_s390_64% -abi_x86_32% -abi_x86_64% -abi_x86_x32%"
[ebuild     U  ] net-misc/iputils-20121221-r1 [20101006-r2] USE="filecaps%* -caps% -gnutls%"
[ebuild     U  ] dev-lang/python-2.7.9-r1 [2.7.3-r2] USE="-hardened%"
[ebuild     U  ] dev-libs/newt-0.52.15 [0.52.14-r2] PYTHON_TARGETS="python2_7%*"
[ebuild     U  ] dev-libs/glib-2.42.1 [2.32.4-r1] USE="mime%* -abi_mips_n32% -abi_mips_n64% -abi_mips_o32% -abi_ppc_32% -abi_ppc_64% -abi_s390_32% -abi_s390_64% -abi_x86_32% -abi_x86_64% -abi_x86_x32%" PYTHON_TARGETS="python2_7%*"
[ebuild     U  ] sys-fs/udev-218 [196-r1] USE="-abi_mips_n32% -abi_mips_n64% -abi_mips_o32% -abi_ppc_32% -abi_ppc_64% -abi_s390_32% -abi_s390_64% -abi_x86_32% -abi_x86_64% -abi_x86_x32%"
[ebuild     U  ] virtual/udev-215 [196] USE="-systemd%"
[ebuild     U  ] sys-apps/hwids-20141214 [20121210] USE="net%* pci%* usb%*"
[ebuild     U  ] sys-fs/udev-init-scripts-27 [18]
[ebuild  N     ] virtual/libgudev-215-r1  USE="-abi_mips_n32 -abi_mips_n64 -abi_mips_o32 -abi_ppc_32 -abi_ppc_64 -abi_s390_32 -abi_s390_64 -abi_x86_32 -abi_x86_64 -abi_x86_x32 -introspection -static-libs -systemd"
[ebuild     U  ] net-misc/modemmanager-1.4.0 [0.6.0.0] USE="introspection%* qmi%* -mbim% -qmi-newest% -vala%"
[ebuild  N     ] net-misc/networkmanager-0.9.10.1_pre20141101  USE="consolekit dhclient introspection modemmanager ncurses nss ppp wext wifi -bluetooth -connection-sharing -dhcpcd -gnutls -resolvconf (-selinux) -systemd -teamd {-test} -vala -zeroconf"
[blocks B      ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-fs/udev-init-scripts-27, sys-apps/kmod-19)
[blocks B      ] <sys-fs/lvm2-2.02.103 ("<sys-fs/lvm2-2.02.103" is blocking sys-fs/udev-218)
[blocks B      ] <dev-python/python-exec-10000 ("<dev-python/python-exec-10000" is blocking dev-lang/python-exec-2.0.1-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/glib-2.42.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.34.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-fs/udev-218::gentoo, ebuild scheduled for merge)

sys-kernel/linux-headers:0

  (sys-kernel/linux-headers-3.6::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-kernel/linux-headers-3.17-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-kernel/linux-headers-3.7 required by (sys-fs/udev-218::gentoo, ebuild scheduled for merge)

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/glib-2.42.1::gentoo, ebuild scheduled for merge)

  (sys-libs/zlib-1.2.7::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-util/gtk-doc-am:0

  (dev-util/gtk-doc-am-1.18::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-util/gtk-doc-am-1.21::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-util/gtk-doc-am-1.20 required by (dev-libs/glib-2.42.1::gentoo, ebuild scheduled for merge)

sys-fs/udev:0

  (sys-fs/udev-218::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-208-r1 required by (virtual/udev-215::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (sys-fs/udev-196-r1::gentoo, installed) pulled in by
    >=sys-fs/udev-171-r5[gudev,hwdb] required by (sys-fs/udisks-1.0.4-r3::gentoo, installed)
    >=sys-fs/udev-196-r1[acl,gudev,hwdb] required by (virtual/udev-196::gentoo, installed)

virtual/udev:0

  (virtual/udev-196::gentoo, installed) pulled in by
    >=virtual/udev-143[hwdb] required by (media-sound/pulseaudio-2.99.3::gentoo, installed)

  (virtual/udev-215::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/udev-215 required by (sys-fs/zfs-9999::gentoo, installed)
    >=virtual/udev-206 required by (sys-apps/hwids-20141214::gentoo, ebuild scheduled for merge)
    (and 12 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
#required by virtual/libgudev-215-r1[-systemd], required by net-misc/networkmanager-0.9.10.1_pre20141101, required by net-misc/networkmanager (argument)
=sys-fs/udev-218 gudev

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

!!! The following installed packages are masked:
- net-irc/xchat-xsys-2.2.0-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (24 Nov 2012)
# Overflow issues (#277459), upstream lost interest on it.
# Removal in a month.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Last edited by rrbs on Mon Dec 29, 2014 9:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon Dec 29, 2014 8:56 pm    Post subject: Reply with quote

wann hast du das letzte mal ein update gemacht? das solltest du mal machen (emerge -uDN world), bevor du was neues installierst. dazu auch die news beachten ( siehe ganz am anfang deiner ausgabe "eselect news read new").
Möglicherweise ist auch dein portage tree nicht ganz OK, wegen des Fehlers am Anfang. Deswegen am besten vor allem anderen "emerge --sync".
[EDIT]Ich seh gerade: der Fehler liegt in einem overlay. Also ist der portage tree wohl ok, und du musst nur das overlay updaten ("layman -S")[/EDIT]

danach könne wir mal weiter schauen.
Achja, und bitte CODE Tags für lange ausgaben verwenden.
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Mon Dec 29, 2014 10:05 pm    Post subject: Reply with quote

So, hab ein "layman -S" gemacht und ein "emerge --sync".

Da wurde ich darauf hingewiesen portage mittels "emerge --oneshot portage" upzudaten und rannt gleich ins naechste.
Ich wuerde versuchen, erstmal mein System komplett upzugraden, oder lieber nicht?

Code:


Calculating dependencies                            ... done!         
[ebuild  N     ] dev-lang/python-exec-2.0.1-r1  PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy) (pypy3) (python2_7) (python3_3) (python3_4)"
[ebuild     U  ] dev-lang/python-2.7.9-r1 [2.7.3-r2] USE="-hardened%"
[ebuild  NS    ] dev-lang/python-3.3.5-r1 [2.7.3-r2, 3.2.3-r1] USE="gdbm ipv6 ncurses readline sqlite ssl threads xml -build -doc -examples -hardened -tk -wininst"
[ebuild     U  ] sys-apps/portage-2.2.15 [2.2.0_alpha145] LINGUAS="ru%*" PYTHON_TARGETS="python2_7%* python3_3%* -pypy% -python3_4%"
[blocks B      ] <sys-apps/sandbox-2.6-r1 ("<sys-apps/sandbox-2.6-r1" is blocking dev-lang/python-3.3.5-r1)
[blocks B      ] <dev-python/python-exec-10000 ("<dev-python/python-exec-10000" is blocking dev-lang/python-exec-2.0.1-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-python/python-exec-0.2::gentoo, installed) pulled in by
    dev-python/python-exec[python_targets_python2_7,python_targets_python3_2] required by (dev-python/setuptools-0.6.32::gentoo, installed)
    dev-python/python-exec required by (dev-python/lxml-3.0.1::gentoo, installed)

  (dev-lang/python-3.3.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/python required by (app-portage/layman-2.0.0_rc5::gentoo, installed)
    dev-lang/python required by (dev-python/numpy-1.6.2::gentoo, installed)
    =dev-lang/python-3.3* required by (dev-python/pycairo-1.10.0-r3::gentoo, installed)
    dev-lang/python required by (app-admin/python-updater-0.10-r2::gentoo, installed)
    dev-lang/python required by (dev-python/pylibacl-0.5.0::gentoo, installed)
    dev-lang/python required by (dev-python/sip-4.14.1::gentoo, installed)
    =dev-lang/python-3.3*[threads] required by (kde-base/pykde4-4.9.4::gentoo, installed)
    dev-lang/python required by (dev-python/decorator-3.4.0::gentoo, installed)
    dev-lang/python required by (app-portage/esearch-1.3::gentoo, installed)
    dev-lang/python[xml] required by (app-portage/mirrorselect-2.1.0-r3::gentoo, installed)
    dev-lang/python[readline] required by (app-portage/esearch-1.3::gentoo, installed)
    dev-lang/python required by (app-portage/g-octave-0.4.1-r3::gentoo, installed)
    dev-lang/python required by (dev-python/PyQt4-4.9.5::gentoo, installed)
    =dev-lang/python-3.3* required by (kde-base/pykde4-4.9.4::gentoo, installed)
    dev-lang/python required by (dev-libs/boost-1.52.0-r4::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[ssl(+),bzip2(+)] required by (sys-apps/portage-2.2.15::gentoo, ebuild scheduled for merge)
    dev-lang/python required by (dev-python/pyopenssl-0.13::gentoo, installed)
    dev-lang/python required by (x11-proto/xcb-proto-1.8::gentoo, installed)
    dev-lang/python required by (media-gfx/inkscape-0.48.3.1::gentoo, installed)
    dev-lang/python required by (dev-python/zope-interface-3.8.0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[bzip2(+)] required by (sys-apps/portage-2.2.15::gentoo, ebuild scheduled for merge)
    dev-lang/python[ncurses] required by (dev-python/urwid-1.1.1::gentoo, installed)
    dev-lang/python required by (dev-python/setproctitle-1.1.6::gentoo, installed)
    dev-lang/python required by (dev-python/pycrypto-2.6-r1::gentoo, installed)
    dev-lang/python required by (dev-python/urwid-1.1.1::gentoo, installed)
    dev-lang/python[xml] required by (media-gfx/inkscape-0.48.3.1::gentoo, installed)
    dev-lang/python required by (dev-python/pyxattr-0.5.0::gentoo, installed)
    =dev-lang/python-3.3* required by (dev-python/beautifulsoup-4.1.3::gentoo, installed)

  (sys-apps/sandbox-2.6::gentoo, installed) pulled in by
    >=sys-apps/sandbox-2.2 required by (sys-apps/portage-2.2.15::gentoo, ebuild scheduled for merge)

  (dev-lang/python-exec-2.0.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/python-exec:2 required by (sys-apps/portage-2.2.15::gentoo, ebuild scheduled for merge)
    dev-lang/python-exec:=[python_targets_python2_7(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_pypy(-)] required by (dev-python/pyxdg-0.25::gentoo, installed)
    dev-lang/python-exec:=[python_targets_python3_3(-),python_targets_python2_7(-),-python_single_target_pypy(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python2_7(-)] required by (sys-apps/portage-2.2.15::gentoo, ebuild scheduled for merge)
    dev-lang/python-exec:=[-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-portage/gentoolkit-9999::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- net-misc/openswan-2.6.38::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mike Gilbert <floppym@gentoo.org> (13 Jun 2014)
# Masked due to security bug 499870.
# Please migrate to net-misc/libreswan.
# If you are a Gentoo developer, feel free to pick up maintenence of openswan
# and remove this mask after resolving the security issue.

- app-backup/rdiff-backup-1.3.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Patrick Lauer <patrick@gentoo.org> (09 Apr 2014)
# Dead upstream, has known dataloss bugs.
# Please use something more sane: rsnapshot, backuppc, obnam, ...

- media-libs/mesa-9.0.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (26 Mar 2014)
# Affected by multiple vulnerabilities, #445916, #471098 and #472280

- net-nds/openldap-2.4.33-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (20 Mar 2014)
# Security mask of vulnerable versions, wrt bug #424167

- net-dialup/ppp-2.4.5-r3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (28 Aug 2014)
# Security mask, wrt bug #519650
# If your application is broken due to this mask,
# please file a separate bug report

- media-video/vlc-2.0.4::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (8 Jun 2014)
# Mask VLC ebuilds that are affected with security bug CVE-2013-6934:
#
#     A vulnerability has been discovered in VLC Media Player, which can be
#     exploited by malicious people to compromise a user's system.
#
# Some ebuilds also have other buffer and integer overflow security bugs like
# CVE-2013-1954, CVE-2013-3245, CVE-2013-4388 and CVE-2013-6283.
#
# Users should consider to upgrade VLC Media Player to at least version 2.1.2.

- app-antivirus/clamav-0.97.6-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (09 Dec 2014)
# Security mask, wrt bug #529728

- app-admin/hwreport-0.10.0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Christian Faulhammer <fauli@gentoo.org> (02 Sep 2014)
# website not working anymore and will stay like this,
# tool is useless. See bug 504734

- sys-power/upower-0.9.18::gentoo (masked by: package.mask)
/usr/portage/profiles/base/package.mask:
# Rick Farina <zerochaos@gentoo.org> (6 Jun 2013)
# Pm-utils based hibernate and suspend support has discontinued.
# For continued support, use the upower-pm-utils fork or systemd.
# Systemd users can switch to a systemd profile or unmask <sys-power/upower-0.99.0
# Openrc users can "emerge -C upower && emerge -1 upower-pm-utils"

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Dec 29, 2014 10:33 pm    Post subject: Reply with quote

Was hast du denn da für overlays drin? glib-9999 ist ja schon etwas seltsam, aber python-exec-10000 ist ja nun extrem seltsam. Sachen in Overlays sind stellenweise noch nicht für den alltäglichen Gebrauch geeignet. Da sollte man als Anfänger erst mal vorsichtig sein.

Und dann diese Meldung: The following installed packages are masked.
Da hast du dir wohl einiges unmaskiert und das jetzt in der package.unmask wieder rückgängig gemacht, die Pakete sind aber immer noch drauf. Das hilft dir im Moment auch erst mal nicht weiter, aber du hast da wohl schon für ein ziemliches Durcheinander an Versionen gesorgt.

Zunächst solltest du als erstes, so es dir ja auch gesagt wurde, portage auf Version 2.2.15 bringen. Wie bist du denn an die 2.2.0_alpha145 geraten?
Als nächstes solltest du schauen, was du in der package.unmask stehen hast und was für overlays du nutzt und warum. Problematisch an der Sache ist, dass das zu einem Downgrade führt, welcher in manchen Situationen zu Problemen führt. Bei bestimmten Anwendungen sollte man nicht zurück gehen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Tue Dec 30, 2014 3:44 am    Post subject: Reply with quote

Doch, dev-python/python-exec-10000er Versionen hat es einst im offiziellen Tree gegeben, die wurden aber inzwischen entfernt (da normal nicht mehr benötigt).
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-python/python-exec/python-exec-10000.2.ebuild?hideattic=0&view=markup

dev-python/python-exec (nicht zu verwechseln mit dev-lang/python-exec!)
sollte man nun aber gefahrlos deinstallieren können - das war ja nur ein "Compatibility package for dev-lang/python-exec"

Schau dazu auch in der vermutlich noch nicht gelesenen News die es einst dazu gab :)
less /usr/portage/metadata/news/2013-11-07-python-exec-package-move/2013-11-07-python-exec-package-move.en.txt

/edit
oder besser, schau mal nach allen bisher noch nicht gelesenen News (mit "eselect news read")
Mit denen werden meist hilfreiche Infos zu den Updates mitgegeben.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Dec 30, 2014 6:30 am    Post subject: Reply with quote

Noch ein Hinweis dazu, wenn ich jetzt das Datum der News von Josef erwähnten News lese, dann ist diese Installation seit über einem Jahr nicht mehr aktualisiert werden. Man sollte sein Gentoo mindestens alle 6 Monate updaten. Wenn man länger wartet, dann besteht die Gefahr, dass da etwas klemmt.
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Tue Dec 30, 2014 7:40 am    Post subject: Reply with quote

na das klingt ja lustig. ;-)
Ich glaube das klingt nach jeder Menge arbeit und extrem neu lernen.
Ich befasse mich zwar schon lange mit Linux (meine erste Version war LST), dann aber immer vorrangig mit Debian und ich muss sagen,
die Umstellung ist schon heftig aber es wird werden. :-)

So zwischendurch schon mal vielen Dank fuer Eure Hilfe dabei.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Tue Dec 30, 2014 2:33 pm    Post subject: Reply with quote

Ja, das ist das Problem mit gentoo, wenn man längere Zeit nichts geupdatet hat.

Ich würde folgendes vorschlagen:
Als erstes portage updaten. Danach komplettes Systemupdate und danach solltest du machen können was dir beliebt.

Um portage aktualisiert zu bekommen, müssen wir mal das Problem mit python-exec/python lösen. Ich würde mal probieren:
Code:
emerge -C dev-python/python-exec

und danach
Code:
emerge -1 python-exec


der erste befehl deinstalliert python-exec, ohne auf abhängigkeiten zu prüfen. und danach wird ein neues python-exec installiert. der block kommt glaube ich dadurch zu stande, dass dein installiertes python-exec in der Kategorie dev-python ist, inzwischen ist aber python-exec in der kategore dev-lang und portage bekommt das nicht gelöst.
danach kannst du nochmal
Code:
emerge -1 portage
probieren und eventulle probleme posten (oder auch wenn es vorher schon probleme gibt, sollte aber nicht, hoffe ich)

Achja, und news lesen!
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Tue Dec 30, 2014 3:29 pm    Post subject: Reply with quote

so bis zu
Code:
emerge -1 portage
ging alles dann:

Code:

Calculating dependencies                     ... done!   
[ebuild     U  ] dev-lang/python-2.7.9-r1 [2.7.3-r2] USE="-hardened%"
[ebuild  NS    ] dev-lang/python-3.3.5-r1 [2.7.3-r2, 3.2.3-r1] USE="gdbm ipv6 ncurses readline sqlite ssl threads xml -build -doc -examples -hardened -tk -wininst"
[ebuild     U  ] sys-apps/portage-2.2.15 [2.2.0_alpha145] LINGUAS="ru%*" PYTHON_TARGETS="python2_7%* python3_3%* -pypy% -python3_4%"
[blocks B      ] <sys-apps/sandbox-2.6-r1 ("<sys-apps/sandbox-2.6-r1" is blocking dev-lang/python-3.3.5-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-3.3.5-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/python required by (app-portage/layman-2.0.0_rc5::gentoo, installed)
    dev-lang/python required by (dev-python/numpy-1.6.2::gentoo, installed)
    =dev-lang/python-3.3* required by (dev-python/pycairo-1.10.0-r3::gentoo, installed)
    dev-lang/python required by (app-admin/python-updater-0.10-r2::gentoo, installed)
    dev-lang/python required by (dev-python/pylibacl-0.5.0::gentoo, installed)
    dev-lang/python required by (dev-python/sip-4.14.1::gentoo, installed)
    =dev-lang/python-3.3*[threads] required by (kde-base/pykde4-4.9.4::gentoo, installed)
    dev-lang/python required by (dev-python/decorator-3.4.0::gentoo, installed)
    dev-lang/python required by (app-portage/esearch-1.3::gentoo, installed)
    dev-lang/python[xml] required by (app-portage/mirrorselect-2.1.0-r3::gentoo, installed)
    dev-lang/python[readline] required by (app-portage/esearch-1.3::gentoo, installed)
    dev-lang/python required by (app-portage/g-octave-0.4.1-r3::gentoo, installed)
    dev-lang/python required by (dev-python/PyQt4-4.9.5::gentoo, installed)
    =dev-lang/python-3.3* required by (kde-base/pykde4-4.9.4::gentoo, installed)
    dev-lang/python required by (dev-libs/boost-1.52.0-r4::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[ssl(+),bzip2(+)] required by (sys-apps/portage-2.2.15::gentoo, ebuild scheduled for merge)
    dev-lang/python required by (dev-python/pyopenssl-0.13::gentoo, installed)
    dev-lang/python required by (x11-proto/xcb-proto-1.8::gentoo, installed)
    dev-lang/python required by (media-gfx/inkscape-0.48.3.1::gentoo, installed)
    dev-lang/python required by (dev-python/zope-interface-3.8.0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[bzip2(+)] required by (sys-apps/portage-2.2.15::gentoo, ebuild scheduled for merge)
    dev-lang/python[ncurses] required by (dev-python/urwid-1.1.1::gentoo, installed)
    dev-lang/python required by (dev-python/setproctitle-1.1.6::gentoo, installed)
    dev-lang/python required by (dev-python/pycrypto-2.6-r1::gentoo, installed)
    dev-lang/python required by (dev-python/urwid-1.1.1::gentoo, installed)
    dev-lang/python[xml] required by (media-gfx/inkscape-0.48.3.1::gentoo, installed)
    dev-lang/python required by (dev-python/pyxattr-0.5.0::gentoo, installed)
    =dev-lang/python-3.3* required by (dev-python/beautifulsoup-4.1.3::gentoo, installed)

  (sys-apps/sandbox-2.6::gentoo, installed) pulled in by
    >=sys-apps/sandbox-2.2 required by (sys-apps/portage-2.2.15::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- net-misc/openswan-2.6.38::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mike Gilbert <floppym@gentoo.org> (13 Jun 2014)
# Masked due to security bug 499870.
# Please migrate to net-misc/libreswan.
# If you are a Gentoo developer, feel free to pick up maintenence of openswan
# and remove this mask after resolving the security issue.

- app-backup/rdiff-backup-1.3.3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Patrick Lauer <patrick@gentoo.org> (09 Apr 2014)
# Dead upstream, has known dataloss bugs.
# Please use something more sane: rsnapshot, backuppc, obnam, ...

- media-libs/mesa-9.0.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (26 Mar 2014)
# Affected by multiple vulnerabilities, #445916, #471098 and #472280

- net-nds/openldap-2.4.33-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (20 Mar 2014)
# Security mask of vulnerable versions, wrt bug #424167

- net-dialup/ppp-2.4.5-r3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (28 Aug 2014)
# Security mask, wrt bug #519650
# If your application is broken due to this mask,
# please file a separate bug report

- media-video/vlc-2.0.4::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (8 Jun 2014)
# Mask VLC ebuilds that are affected with security bug CVE-2013-6934:
#
#     A vulnerability has been discovered in VLC Media Player, which can be
#     exploited by malicious people to compromise a user's system.
#
# Some ebuilds also have other buffer and integer overflow security bugs like
# CVE-2013-1954, CVE-2013-3245, CVE-2013-4388 and CVE-2013-6283.
#
# Users should consider to upgrade VLC Media Player to at least version 2.1.2.

- app-antivirus/clamav-0.97.6-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (09 Dec 2014)
# Security mask, wrt bug #529728

- app-admin/hwreport-0.10.0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Christian Faulhammer <fauli@gentoo.org> (02 Sep 2014)
# website not working anymore and will stay like this,
# tool is useless. See bug 504734

- sys-power/upower-0.9.18::gentoo (masked by: package.mask)
/usr/portage/profiles/base/package.mask:
# Rick Farina <zerochaos@gentoo.org> (6 Jun 2013)
# Pm-utils based hibernate and suspend support has discontinued.
# For continued support, use the upower-pm-utils fork or systemd.
# Systemd users can switch to a systemd profile or unmask <sys-power/upower-0.99.0
# Openrc users can "emerge -C upower && emerge -1 upower-pm-utils"

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


wie krieg ich das bereinigt? sandbox erstmal deinstallieren?
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Dec 30, 2014 3:34 pm    Post subject: Reply with quote

Du hast portage aber noch nicht aktualisiert. Es taucht immer noch in der Liste mit den Updates auf.

Und dann versuch mal, sandbox manuell zu aktualisieren.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Tue Dec 30, 2014 4:12 pm    Post subject: Reply with quote

rrbs wrote:
wie krieg ich das bereinigt? sandbox erstmal deinstallieren?
Nein, die sandbox würde ich besser nicht deinstallieren.
Versuche sie gleich mit zu aktualisieren
Code:
emerge -av1 sandbox portage
Wenn das noch nicht klappt nimm noch die --deep Option mit hinzu.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Dec 30, 2014 4:56 pm    Post subject: Reply with quote

Auf gar keinen Fall etwas deinstallieren, außer du weißt genau, was du tust. Niemals versuchen, einen Block zu lösen, indem du das blockende Programm deinstallierst. Das kann zur Folge haben, dass dann gar nichts mehr geht. Der build-Prozess, den emerge anstößt, der benötigt einige Programme. Wenn du eins davon löscht, dann hast du hinterher schlechte Karten.

Was sage ich dazu immer: Ein Einbeiniger kann auch nicht laufen, wenn er sich das verbleibende Bein abhackt.

dev-python/python-exec-10000 ist aber so ein Fall, den du mit
Code:
emerge -C python-exec
auflösen kannst. Da musst du dann auch hinterher gar nichts manuell installieren, dass geschieht dann beim world-Update automatisch.

Ich liste hier noch mal so ein paar Grundregeln auf, damit es nicht zu sehr in die Hose geht...
1. Verwende keine Overlays und trage auch nichts in die package.unmask ein ohne triftigen Grund.
2. Lese die News mit eselect news read.
3. Lese die Logs in /var/log/portage/elog.
4. Aktualisiere dein System mindestens einmal im Monat.

Dann ist eigentlich alles ganz easy....
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Tue Dec 30, 2014 5:19 pm    Post subject: Reply with quote

soweit scheint alles funktioniert zu haben.
jetzt versuche ich mein System auf Stand zu bringen mit
Code:
"emerge -uDNva world"
:

Ausgabe
Code:

These are the packages that would be merged, in order:

Calculating dependencies                        ... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtgui-4.8.5:4[accessibility,dbus(+)] required by (kde-base/killbots-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                                                   
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                   
    (and 224 more with the same problems)

  (dev-qt/qtgui-4.8.4:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtgui-4.7.0:4[accessibility,dbus] required by (net-im/kmess-2.0.6.2:4/4::gentoo, installed)
                                         ^^^^                                                                                               
    ~dev-qt/qtgui-4.8.4[-aqua,-debug,glib,qt3support] required by (dev-qt/qtcore-4.8.4:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                             
    (and 1 more with the same problems)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                   
    >=dev-qt/qtcore-4.8.5:4[qt3support,ssl] required by (kde-base/libkdeedu-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                                             
    dev-qt/qtcore:4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-dns/avahi-0.6.31-r7:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                 
    (and 231 more with the same problems)

  (dev-qt/qtcore-4.8.4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.4[-aqua,-debug,qt3support] required by (dev-qt/qtsql-4.8.4:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                       
    (and 4 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtscript-4.8.5:4 required by (kde-base/drkonqi-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^^                                                                                                                                                           
    ~dev-qt/qtscript-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                                                                                                                                                                                   
    (and 218 more with the same problems)

  (dev-qt/qtscript-4.8.4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.4[-aqua,-debug] required by (dev-qt/qtgui-4.8.4:4/4::gentoo, installed)
    ^                ^^^^^                                                                                                                             

dev-qt/qtdbus:4

  (dev-qt/qtdbus-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtdbus-4.8.5:4 required by (kde-base/filelight-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                             
    (and 218 more with the same problem)

  (dev-qt/qtdbus-4.8.4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-4.8.4[-aqua,-debug] required by (dev-qt/qtgui-4.8.4:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                             

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                                                                                                                                                                   
    >=dev-qt/qt3support-4.8.5:4[accessibility] required by (kde-base/kde-wallpapers-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    ^^                  ^^^^^^^                                                                                                                                                                                 
    (and 218 more with the same problems)

  (dev-qt/qt3support-4.8.4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.4[-aqua,-debug] required by (dev-qt/qtgui-4.8.4:4/4::gentoo, installed)
    ^                  ^^^^^                                                                                                                             

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.6[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                               
    >=dev-qt/qtsql-4.8.5:4[qt3support] required by (kde-base/kolourpaint-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                                           
    (and 219 more with the same problems)

  (dev-qt/qtsql-4.8.4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.4[-aqua,-debug,qt3support] required by (dev-qt/qt3support-4.8.4:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=sys-fs/cryptsetup-1.0.6-r2" has unmet requirements.
- sys-fs/cryptsetup-1.6.6::gentoo USE="gcrypt nls static -kernel -nettle -openssl -python -reencrypt -static-libs -udev -urandom" ABI_X86="64" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_3 -python3_4"

  The following REQUIRED_USE flag constraints are unsatisfied:
    static? ( !gcrypt )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( gcrypt kernel nettle openssl ) python? ( exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python2_7 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python2_7? ( python_targets_python2_7 ) ) static? ( !gcrypt )

(dependency required by "sys-apps/pmount-0.9.99_alpha-r5[crypt]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


so nun muss ich da noch einiges loesen. sieht schon etwas besser aus find ich.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Dec 30, 2014 5:36 pm    Post subject: Reply with quote

Da ist bei dir aber etwas richtig kaputt. Entweder im portage oder in der make.conf. Das, was da angezeigt wird, ist eigentlich ein ganz normales Update von qt, welches problemlos durchlaufen sollte.
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

Das ist eine Meldung, die gar nicht geht. Mach mal folgendes:
rm -r /usr/portage
emerge-webrsync
emerge --sync
Kopiere dir dann /usr/share/portage/config/make.conf.example nach /etc/portage/make.conf
Passe die make.conf an dein System an.

Ach so, noch ne Frage, was für ein Profil hast du gesetzt?
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Tue Dec 30, 2014 7:01 pm    Post subject: Reply with quote

brachte leider nix.
Code:
leselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0 *
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/gnome/systemd
  [6]   default/linux/amd64/13.0/desktop/kde
  [7]   default/linux/amd64/13.0/desktop/kde/systemd
  [8]   default/linux/amd64/13.0/developer
  [9]   default/linux/amd64/13.0/no-emul-linux-x86
  [10]  default/linux/amd64/13.0/no-emul-linux-x86/desktop
  [11]  default/linux/amd64/13.0/no-emul-linux-x86/desktop/gnome
  [12]  default/linux/amd64/13.0/no-emul-linux-x86/desktop/gnome/systemd
  [13]  default/linux/amd64/13.0/no-emul-linux-x86/desktop/kde
  [14]  default/linux/amd64/13.0/no-emul-linux-x86/desktop/kde/systemd
  [15]  default/linux/amd64/13.0/no-emul-linux-x86/developer
  [16]  default/linux/amd64/13.0/no-emul-linux-x86/selinux
  [17]  default/linux/amd64/13.0/no-multilib
  [18]  default/linux/amd64/13.0/x32
  [19]  hardened/linux/amd64
  [20]  hardened/linux/amd64/selinux
  [21]  hardened/linux/amd64/no-multilib
  [22]  hardened/linux/amd64/no-multilib/selinux
  [23]  hardened/linux/amd64/x32
  [24]  hardened/linux/musl/amd64
  [25]  default/linux/uclibc/amd64
  [26]  hardened/linux/uclibc/amd64
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Dec 30, 2014 7:05 pm    Post subject: Reply with quote

Du solltest dir die Profile mal ansehen und schauen, welches zu dir passt. Wenn du z.B. Gnome nutzt, hatte ich so den Eindruck, dann solltest du auch das entsprechende Profil setzen. Entweder systemd oder nicht. Es gibt doch eine sehr gute Installationsanleitung von gentoo, hast du die befolgt?
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Tue Dec 30, 2014 7:16 pm    Post subject: Reply with quote

ich nutze openbox bzw wmaker. kde und gnome mag ich garnicht.

ja nur ist das schon ne weile her(hatte das mit nem Bekannten gemacht, der kannte sich aus aber den gibts nicht mehr), hatte dann eben keine zeit mehr,
und nun wollte ich umsteigen.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Dec 30, 2014 7:18 pm    Post subject: Reply with quote

Dann solltest du dir mal folgendes ansehen: https://wiki.gentoo.org/wiki/Handbook:Main_Page

Edit: So langsam verstehe ich. Da hat dir jemand etwas vorgesetzt, wo du nie eine Ahnung von hattest, um was es sich da handelt. Mach die Kiste platt und installiere sie nach Anleitung neu. Dann verstehst du Gentoo und du weißt, was du hast. Aktuell weißt du nicht, was da auf deinem System so alles abgeht. Und dann ist es schwierig, dir zu helfen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Tue Dec 30, 2014 7:55 pm    Post subject: Reply with quote

Der Konflikt zwischen den Qt Versionen entsteht wahrscheinlich hier:
Quote:
Code:
  (dev-qt/qtgui-4.8.4:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtgui-4.7.0:4[accessibility,dbus] required by (net-im/kmess-2.0.6.2:4/4::gentoo, installed)

Das kommt vom noch installierten alten net-im/kmess welches qtgui mit USE=dbus fordert - diese Abhängigkeit kann nicht erfüllt werden da es inzwischen keine qtgui Version mit USE=dbus mehr im Tree gibt.
net-im/kmess gibt es mittlerweile nicht mehr im Tree, und damit auch kein aktualisiertes Ebuild mit passenden Abhängigkeiten mehr.
net-im/kmess deinstallieren sollte den Konflikt zwischen den Qt Versionen wahrscheinlich lösen.

............................................
Aber..
Quote:
ja nur ist das schon ne weile her(hatte das mit nem Bekannten gemacht, der kannte sich aus aber den gibts nicht mehr), hatte dann eben keine zeit mehr,
und nun wollte ich umsteigen.

Es werden bei diesem, seit langer Zeit nicht mehr gepflegten System (aus dem Testing-Zweig) sicherlich nicht die letzten Probleme sein. Problematisch sind auch die noch installierten inzwischen hart maskierten Pakete (wegen Sicherheitslücken) - um dessen Migration müsstest du dich auch noch kümmern.
Vermutlich ist es das beste selbst ein System von Grund auf neu aufzusetzen, welches du dann auch selbst warten kannst :)
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Tue Dec 30, 2014 8:29 pm    Post subject: Reply with quote

hab "net-im/kmess" deinstalliert, damit scheint vieles weg zu sein allerdings gibts da noch was .

upgrade mit:
Code:
emerge -uDNva world


ausgabe schon merklich kleiner.
[/code]
Code:

These are the packages that would be merged, in order:

Calculating dependencies       ... done!                       

!!! The ebuild selected to satisfy ">=sys-fs/cryptsetup-1.0.6-r2" has unmet requirements.
- sys-fs/cryptsetup-1.6.6::gentoo USE="gcrypt nls static -kernel -nettle -openssl -python -reencrypt -static-libs -udev -urandom" ABI_X86="64" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_3 -python3_4"

  The following REQUIRED_USE flag constraints are unsatisfied:
    static? ( !gcrypt )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( gcrypt kernel nettle openssl ) python? ( exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python2_7 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python2_7? ( python_targets_python2_7 ) ) static? ( !gcrypt )

(dependency required by "sys-apps/pmount-0.9.99_alpha-r5[crypt]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

[/
code]
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed Dec 31, 2014 12:54 am    Post subject: Reply with quote

das ist das Problem:
Code:
 The following REQUIRED_USE flag constraints are unsatisfied:
    static? ( !gcrypt )

Das heißt, das paket cryptsetup darf, wenn es das static useflag aktiviert hat nicht das gcrypt useflag aktiviert haben.
Im allegemeinen würde ich empfehlen das static flag für dieses paket (und eigentlich für alle, wo du es nicht extra brauchst) deaktivieren.

Zu deinem Profil: da würde ich dir das desktop profil empfehlen. da sind schon ein paar sinnvolle useflags global aktiviert.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum