Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel 3.17.7 and USB mouse
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 751

PostPosted: Sun Jan 04, 2015 9:38 pm    Post subject: Kernel 3.17.7 and USB mouse Reply with quote

Since I upgraded the kernel to 3.17.7, I've had a problem with the wireless USB mouse. It stops responding after a short while, and when I move it, it takes about a second or so until the mouse cursor moved. Hardware is ok - this behaviour goes away when I reboot into 3.16.5. I don't have a wired USB mouse to test (but can arrange for it).

I was wondering whether 3.17 introduced changes related to USB device powersaving, or could this be something e.g. interrupt related? Or something else entirely, like laptop-mode-tools?
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 751

PostPosted: Fri Jan 09, 2015 12:08 am    Post subject: Reply with quote

It's actually infuriating. The problem appeared under 3.16 as well, but only the second time booting into it. E.g.: run 3.16, mouse works fine, reboot into 3.16, mouse erratic. Reboot into 3.17, mouse ok, reboot back into 3.17, mouse erratic.

It must be a problem with the mouse itself. A wired USB mouse doesn't show these symptoms (but maybe I'll need just another reboot to be certain ...).
Back to top
View user's profile Send private message
Budoka
l33t
l33t


Joined: 03 Jun 2012
Posts: 687
Location: Tokyo, Japan

PostPosted: Fri Jan 09, 2015 1:34 am    Post subject: Reply with quote

I am having exactly the same problem but with a wired mouse. https://forums.gentoo.org/viewtopic-t-1008002-highlight-.html
Back to top
View user's profile Send private message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 487
Location: Hawaii

PostPosted: Fri Jan 09, 2015 6:32 am    Post subject: Reply with quote

Revert to an earlier kernel? Try a different usb port? I have some vodoo-ish usb symptoms at times. Seems to me its part of usb, and dumb juggling of connections, or reducing the total of attached usb devices seems to do the trick for me most times. Best is when my kids have each left a thumbdrive connected. No telling what will happen on the next boot after that.

My wired Logitech works fine under 3.17.7-gentoo and 3.18-ck, FWIW.
_________________
Asrock X470 Taichi
Ryzen 2700x
32Gb Samsung B-die (16GB dual rank x2) DDR4
Geforce GTX 1060 6GB
Samsung Evo 840 500Gb +Seagate 1TB HDD
Etc....
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 751

PostPosted: Sat Jan 10, 2015 1:00 am    Post subject: Reply with quote

Interesting comment about power management, which was high in my list of suspects.

Checked laptop-mode, but found that the USB autosuspend feature is disabled by default. I.e. adding the w/l mouse id to AUTOSUSPEND_USBID_BLACKLIST has no effect.

It's not powertop, I had it installed for a long time. USB traffic is quite low, too.

I would like to add that this happens while operating on mains power, and the wired mouse is (still) fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum