Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
intel_backlight dims on switching to VT or logging out
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
gotyaoi
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2013
Posts: 137

PostPosted: Tue Jan 06, 2015 7:31 am    Post subject: intel_backlight dims on switching to VT or logging out Reply with quote

So, odd situation, I'm finding that my laptop's backlight is going almost completely off if I switch to one of the VTs or logout of my X session. Switching back to X on f7 sets it back to full. I'm able to manipulate the backlight through sys/class/backlight/intel/backlight/* in either situation. When switching to a VT, the brightness file says the backlight is completely on, but the actual_brightness shows 0, even though the display isn't completely dark.

I say it's an odd situation because I first noticed it happening in 3.14 or 1.15, it went away in 3.16, and now it's back in 3.17 and 1.18.

I tried setting i915.inverted_brightness on the kernel command line, which did fix it (switching to VT or logging out has bright screen), but came with the expected issue of starting with my backlight off after boot and inverting my brightness keys (which are just acpid bindings into /sys/class/backlight/intel_backlight/*). So, somehow the KMS driver has the brightness values one way, while X has them the other way, or something...

Anyone seen anything similar?

xorg-server-1.16.2.901-r1
xf86-video-intel-2.99.914
laptop is a clevo w670


Last edited by gotyaoi on Thu Jan 08, 2015 8:27 am; edited 1 time in total
Back to top
View user's profile Send private message
gotyaoi
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2013
Posts: 137

PostPosted: Wed Jan 07, 2015 7:21 am    Post subject: Reply with quote

Well, an evening of git bisect later, I've narrowed it down to this commit: https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?id=6dda730e55f412a6dfb181cae6784822ba463847

Guess it's time to file a kernel bug or something.
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 527

PostPosted: Thu Jan 08, 2015 5:41 pm    Post subject: Reply with quote

Can you link the bug report here?
Back to top
View user's profile Send private message
gotyaoi
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2013
Posts: 137

PostPosted: Mon Jan 12, 2015 4:07 am    Post subject: Reply with quote

https://bugzilla.kernel.org/show_bug.cgi?id=91211
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum