Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
3D acceleration not working with ATI RADEON 7500M
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
hex0x5f
n00b
n00b


Joined: 23 Jun 2014
Posts: 12

PostPosted: Mon Jan 12, 2015 7:46 pm    Post subject: 3D acceleration not working with ATI RADEON 7500M Reply with quote

Hello,
I can't get 3D acceleration support running ( actually need it for VMware ).

output of glxinfo:
Code:

name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12


VIDEO_CARDS="radeonsi" in make.conf

output of lspci -k
Code:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
   Kernel driver in use: i915
   Kernel modules: i915
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series]
   Kernel driver in use: radeon
   Kernel modules: radeon, fglrx



How can I get 3D acceleration working ?

Thank you
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7072
Location: almost Mile High in the USA

PostPosted: Tue Jan 13, 2015 12:43 pm    Post subject: Reply with quote

(As an aside, I wonder why ATI decided to reuse old version numbers, the ATI Radeon 7500 was an old card ... the Radeon HD 7500 is a new card...)

You seem to be using both the OSS Radeon driver and the closed source FGLRX at the same time. Since the OSS Radeon driver tends to lag support for newer cards, you may be forced to use fglrx.

Which driver set are you using now or planning to use?

What opengl implementation are you using now? (check with eselect opengl list)?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
hex0x5f
n00b
n00b


Joined: 23 Jun 2014
Posts: 12

PostPosted: Tue Jan 13, 2015 2:00 pm    Post subject: Reply with quote

I guess it would be better to use FGLRX. Should I update the make.conf to fglrx and then update the packages ?

I currently use ati OpenGL implementation.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7072
Location: almost Mile High in the USA

PostPosted: Tue Jan 13, 2015 5:22 pm    Post subject: Reply with quote

Yes, should try that to make sure xorg knows about it, bit it should mostly know about it already since the ati-drivers package seems to doodle all over everything anyway.

The next question is to see what your Xorg log files say about acceleration /var/log/Xorg.0.log . X is running fine right now?

Also does glxgears work? (and also try fgl_glxgears that comes as part of ati-drivers)?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1729

PostPosted: Tue Jan 13, 2015 6:21 pm    Post subject: Reply with quote

I wonder if the video flag is correct. What the radeonsi is? I think it's "radeon" flag for modern open source drivers (galium drivers) and fglrx for binary one from AMD.

If you have radeon driver available, it will be loaded by default. You must blacklist it if you want to use fglrx
Back to top
View user's profile Send private message
hex0x5f
n00b
n00b


Joined: 23 Jun 2014
Posts: 12

PostPosted: Wed Jan 14, 2015 11:04 pm    Post subject: Reply with quote

I've re-emerged with fglrx set in VIDEO_CARDS, and also only the fglrx module is loaded ( w/o radeon ):

Code:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series]
   Subsystem: Samsung Electronics Co Ltd Device c0d8
   Kernel driver in use: fglrx_pci
   Kernel modules: fglrx


Xorg is not started, it says:

Code:


[    14.121] (II) fglrx(0): pEnt->device->identifier=0x1f33190
[    14.122] (EE)
Fatal server error:
[    14.122] (EE) atiddxProbe: fail to probe intel VGA device(EE)
[    14.122] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    14.122] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    14.122] (EE)



glxgears is not working:

Code:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12


same for fgl_glxgear:

Code:

Using GLX_SGIX_pbuffer
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12


the full Xorg log is at http://textuploader.com/6tqa
Back to top
View user's profile Send private message
hex0x5f
n00b
n00b


Joined: 23 Jun 2014
Posts: 12

PostPosted: Thu Jan 15, 2015 5:18 pm    Post subject: Reply with quote

I've also added the USE flags 'uxa -sna' to intel drivers package,
and finally Xorg started with fglrx.

Though, its responsiveness is a bit slow.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Thu Jan 15, 2015 5:36 pm    Post subject: Reply with quote

emerge --info please
can you post lspci | grep VGA (seems you have 2 video cards)
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7072
Location: almost Mile High in the USA

PostPosted: Thu Jan 15, 2015 5:41 pm    Post subject: Reply with quote

Also post more of your Xorg.0.log, it should say that you're running fglrx and whether or not it detected your card...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1729

PostPosted: Thu Jan 15, 2015 9:50 pm    Post subject: Reply with quote

There is more to switching to fglrx:

eselect mesa
eselect opengl

And yes, you need xorg.conf for this to work as well. I suggest checking out a guide on swithing video drivers, as it's not a routine activity and we are likely to forget about some important detail.
Back to top
View user's profile Send private message
hex0x5f
n00b
n00b


Joined: 23 Jun 2014
Posts: 12

PostPosted: Fri Jan 16, 2015 6:02 pm    Post subject: Reply with quote

Hello,
thank you all for your help

emerge --info:

Code:

Portage 2.2.14 (python 2.7.7-final-0, default/linux/amd64/13.0/desktop, gcc-4.8.3, glibc-2.19-r1, 3.16.5-gentoo x86_64)
=================================================================
System uname: Linux-3.16.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-3610QM_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem:     8067756 total,   3340284 free
KiB Swap:    8191996 total,   8191996 free
Timestamp of tree: Tue, 13 Jan 2015 19:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.7, 3.3.5-r1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.11.6-r1, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo sunrise jtriley bumblebee x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core-avx-i -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core-avx-i -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.supp.name/ http://mirror.isoc.org.il/pub/gentoo/ ftp://mirror.isoc.org.il/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/jtriley /var/lib/layman/bumblebee /usr/local/portage"
SYNC="rsync://rsync2.cz.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bidi bindist bluetooth branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg lcms ldap libnotify lock mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support readline sdl session spell sse sse2 ssl startup-notification svg tcpd thunar tiff truetype type1 udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en he" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fglrx intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



yes, I do have two VIDEO cards :

Code:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series]


the contents of Xorg.0.log are in an online text file in this link (only relevant parts of the log) :
http://textuploader.com/6ty5

eselect mesa :
Code:

64bit i915 (Intel 915, 945)
  [1]   classic
  [2]   gallium *
64bit i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
  [1]   classic *
64bit r300 (Radeon R300-R500)
64bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
64bit sw (Software renderer)
  [1]   classic
  [2]   gallium *
32bit i915 (Intel 915, 945)
  [1]   classic
  [2]   gallium *
32bit i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
  [1]   classic *
32bit r300 (Radeon R300-R500)
  [1]   gallium *
32bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
  [1]   gallium *
32bit sw (Software renderer)
  [1]   classic
  [2]   gallium *


eselect opengl:
Code:

Available OpenGL implementations:
  [1]   ati *
  [2]   xorg-x11
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum