Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Enable Gen v3 8GT x16 on capable systems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
F1r31c3r
Tux's lil' helper
Tux's lil' helper


Joined: 31 Aug 2007
Posts: 107
Location: UK

PostPosted: Mon Jan 12, 2015 9:05 pm    Post subject: Enable Gen v3 8GT x16 on capable systems Reply with quote

Recently i have been scanning around woundering why my GTX770 was not in Genv3.0 mode 8GT and stuck in Genv2.0 5GT's

I found the answer and thought i would share it for anyone else out their having difficulty with this error. Anyone want to feel free and update the WiKi on this go ahead.

So here is the information to do this on Gentoo possibly other distros.

Open to edit your nvidia.conf

Quote:
kwrite /etc/modprobe.d/nvidia.conf


DO NOT delete any of the existing option. All you need to do is add an aditional option to the end of the line.

Quote:
NVreg_EnablePCIeGen3=1


That is it, make sure to exit an X server,

Quote:
modprobe -r nvidia


Then

Quote:
modprobe nvidia


Reload your X server or you can simply reboot.

This worked for me and enable PCIeV3.0 8GT speed link.

Hope that was of use to someone.
_________________
A WikI, A collection of mass misinformation based on opinion and manipulation by a deception of freedom.
If we know the truth, then we should be free from deception (John 8:42-47 )
Back to top
View user's profile Send private message
pa1983
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2004
Posts: 100

PostPosted: Tue Jan 13, 2015 6:28 pm    Post subject: Reply with quote

Theirs work around existed on windows ever since the first Nvidia PCI-E 3.0 cards came out.
But there is a reason why your card is not tunning at 3.0 by default.

I have done what you did on my system when I bought a GTX 780.

As fare as I know nvidia only do this on systems using chipset that do not have official PCI-E 3.0 support.

Now the chipset in it self have nothing to do with PCI-E 3.0 since thats handled by the CPU's built in PCI-E controller BUT platforms dating back to first generation PCI-E 3.0 implementations often had processors that where PCI-3.0 capable in theory and also motherboard that was 3.0 capable in theory BUT they where never truly tested by the manufacturers since there was no proper way of testing PCI-E 3.0 compatibility.

So PCI-E 3.0 "ready" systems like my system according to articles I read could not be properly tested since the equipment that was to be standardized by pcisig was not ready nor shipped to partners so in reality early processors and motherboards are only in theory capable of PCI-E 3.0 and most of them not properly tested from what I read since the standard was just set and the testing methods and equipment standards not yet ready.

I suspect you might be running a X79 system. All LGA2011 processors for X79 have PCI-E 3.0 support BUT not even intel acknowledges this officially on the 3000 series processors.

I my self own the i7 3930K.
http://ark.intel.com/products/63697/Intel-Core-i7-3930K-Processor-12M-Cache-up-to-3_80-GHz
As you can see intel list it as PCI-E 2.0 compatible.

Later 4000 series have PCI-E 3.0 officially.
http://ark.intel.com/products/77780/Intel-Core-i7-4930K-Processor-12M-Cache-up-to-3_90-GHz

And theres a good reason for that. Test have shown that C0 stepped 3930K processors have stability problems running PCI-E 3.0 cards like GFX cards.
C2 stepped 3930K processors seems to be stable and compatible but thats not official but only trough testing by 3:e parties.

I my self run a C2 stepping. I made sure to check this before enabling PCI-E 3.0. Been stable since this summer with my GTX 780.

I still dont know if nvidia uses the "chipset" to decide if the driver should enable PCI-E 3.0 or not or if its now smarter and tries to identify the CPU.

My information is a bit old since the problem dates back to the introduction of PCI-E 3.0 and the motherboard manufacturers where fast to jump on that and also intel but since it took longer to standardize and get testing equipment out and hardware PCI-E 3.0 cards to test many dropped official support or well went with the "ready" marketing claim that in the end highly dependent on you CPU revision etc if it worked at all.

But one should be aware that if your motherboard was sold as PCI-E 3.0 "ready" it was most likley built before they could do standardized testings on them and also processors of that time might not be fully compatible aka unstable when operating at 3.0 specs.

But yea my information is a bit old and I am no expert on this. On a modern system PCI-E 3.0 should work just fine and as fare as I know nvidias drivers should not revert back to 2.0 specs unless it finds hardware that lacked official support when first marketed like X79 platform did.

Nvidia added this limitation to make sure systems ran stable with there PCI-E 3.0 capable graphic cards that had processors or chipset that where 3.0 capable but had no official support like the old i7 3930K for example.
I know many AMD fans found it funny that AMD had no such restrictions and blamed Nvidia for it.
But the way I see it, I rather have a stable system that fallows set standards and are tested against them then an unstable and untested system and even me as an old AMD user I never liked AMD's nor ATI's way of handeling there GFX marketing methods.

Nvidia after all left you the option to enable it on your system on your own risk and if you have no stability problems then why not run 3.0 speeds?
Its not like your GTX970 is limited in most every day scenario by PCI-E 3.0 and when PCI-E bus is a limit its usually to slow even at 3.0 speeds.
_________________
WS: i7 3930K@4Ghz, 32Gb ram, 256Gb NVME & 128Gb sata SSD, GTX780 3Gb & RX 460 2Gb
NAS: i3 4360 3.7Ghz, 20Gb ram, 256Gb SSD, 42Tb HDD, NIC: Intel 2x1Gbit
ROUTER: J1900 2Ghz, 8Gb ram, 128Gb SSD, NIC: 2x1Gbit, WIFI: Atheros AR9462 and AR5005G
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum