Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KMS / Nouveau --> Stuck in low graphics mode
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
elinepiepo
n00b
n00b


Joined: 13 Jan 2015
Posts: 3
Location: Europe

PostPosted: Wed Jan 14, 2015 12:50 am    Post subject: KMS / Nouveau --> Stuck in low graphics mode Reply with quote

Howdy folks :).

I seem to have run into a little snag while installing Gentoo... Basically, I'm doing a:

- LVM / Cryptsetup / Systemd install

on a:

- Intel E8400 Core2Duo w/ Nvidia GTX470 card.

I'm using Sakaki's wiki as a rough guide, but because I have NO UEFI system, some things work a bit differently for me.

The problem:

The system boots and is up-to-date. Portage is working fine. But, after compiling my kernel to activate Nouveau / KMS support, GRUB keeps being stuck in 640x480, and normal terminal too.

Furthermore, I've noticed that my (unencrypted) /dev/sda1 is not mounted after boot [EDIT: This issue is resolved, the nouveau problem still remains]

I've already tried:

- passing the "drm_kms_helper.edid_firmware=1280x1024.bin" parameter to the kernel, as per Arch-Linux' Wiki page

- compiling a new kernel with genkernel-next, sticking to the bare necessities (as mentioned here and here), having KMS / Nouveau kernel options enabled (as mentioned here)

- re-emerging grub, genkernel-next, lvm2 and gentoo-sources using home-made binaries (emerge -K )

- wiping everything on /dev/sda1 (/boot) and re-compiled + re installed kernel/initrd and reinstalled grub

- re-emerged @world using self made binaries

My config files:

- My Kernel Config
- /boot/grub/grub.cfg
- Genkernel.conf
- My Make.conf

Please notice that in grub.cfg, the kernel parameters list root=/ twice(!), namely "root=/dev/ram0" (which it should be) and "root=/dev/mapper/vg1-root" (which is wrong). I've already tried manually editing grub.cfg, deleting "root=/dev/mapper/vg1-root", but this also didn't help :( .

My eselect profile:
Code:

#eselect profile list
[5]   default/linux/amd64/13.0/desktop/gnome/systemd


lsblk gives:
Code:

#lsblk -o name,uuid,mountpoint
NAME           UUID                                   MOUNTPOINT
sda                                                   
├─sda1         323b1653-a80e-4141-9d46-654d271bd6f5   
└─sda2         be13cab7-6ae1-44e8-a60e-0bec0a4ad239   
  └─sda2       WAjsoL-b7rR-KhwR-R25B-LII7-HG8J-gBAZx5
    ├─vg1-swap de150af4-83b4-4a69-a7a8-0c0282ce391a   [SWAP]
    ├─vg1-root 4efaba2b-9d79-443b-982b-489090537951   /
    └─vg1-home fd88a3df-f01a-4c8d-aaf6-8a093f49c92c   /home
sdb            2014-07-17-06-54-13-00                 
└─sdb1         2014-07-17-06-54-13-00                 
sr0


My Fstab:
Code:

# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed); notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>         <mountpoint>   <type>      <opts>      <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
UUID=323b1653-a80e-4141-9d46-654d271bd6f5      /boot      ext2      noauto,noatime   1 2
UUID=4efaba2b-9d79-443b-982b-489090537951      /      ext4      noatime      0 0
UUID=de150af4-83b4-4a69-a7a8-0c0282ce391a      none      swap      sw      0 0
UUID=fd88a3df-f01a-4c8d-aaf6-8a093f49c92c               /home           ext4            noatime    0 2
/dev/cdrom      /mnt/cdrom   auto      noauto,ro   0 0
/dev/fd0      /mnt/floppy   auto      noauto      0 0
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0


Please help, what can I do??

:roll:


Last edited by elinepiepo on Wed Jan 14, 2015 12:06 pm; edited 2 times in total
Back to top
View user's profile Send private message
PeGa!
Tux's lil' helper
Tux's lil' helper


Joined: 13 May 2005
Posts: 101
Location: Capital Federal, Buenos Aires, Argentina

PostPosted: Wed Jan 14, 2015 7:09 am    Post subject: Reply with quote

Hi, first of all, a basic question: Did you enable kernel support for hi res terminal? Sorry, I can't look it in your kernel config right now.

Regarding the unmounted sda1, look for noauto in your fstab, something like:

Code:
/dev/sda1 /boot my_fs noauto,defaults 0 0


If you don't see noauto, specify auto. It should be mounted automatically.

Regards.
_________________
If it moves, it needs an ebuild.

Adopt an unanswered post.
Back to top
View user's profile Send private message
elinepiepo
n00b
n00b


Joined: 13 Jan 2015
Posts: 3
Location: Europe

PostPosted: Wed Jan 14, 2015 9:58 am    Post subject: Reply with quote

PeGa! wrote:
Regarding the unmounted sda1, look for noauto in your fstab, something like:

Code:
/dev/sda1 /boot my_fs noauto,defaults 0 0


If you don't see noauto, specify auto. It should be mounted automatically.


Thanks for the tip, /boot mounts now :D. But.... Still have Nouveau issues! :(

PeGa! wrote:
Hi, first of all, a basic question: Did you enable kernel support for hi res terminal? Sorry, I can't look it in your kernel config right now.


Thanks. I checked my kernel, but if i check
Code:
#/cat/proc/fb/
nothing shows, no output. that means no FB devices are setup, so, I have a driver related issue?

gr
Back to top
View user's profile Send private message
PeGa!
Tux's lil' helper
Tux's lil' helper


Joined: 13 May 2005
Posts: 101
Location: Capital Federal, Buenos Aires, Argentina

PostPosted: Wed Jan 14, 2015 3:49 pm    Post subject: Reply with quote

Take a look at this, this and this. Maybe you already read that information, in that case, it should be necessary a more detailed inspection of your kernel config.

Regards.
_________________
If it moves, it needs an ebuild.

Adopt an unanswered post.
Back to top
View user's profile Send private message
elinepiepo
n00b
n00b


Joined: 13 Jan 2015
Posts: 3
Location: Europe

PostPosted: Wed Jan 14, 2015 6:39 pm    Post subject: Reply with quote

PeGa! wrote:
Maybe you already read that information, in that case, it should be necessary a more detailed inspection of your kernel config.

Regards.


Thanks!

I did already read it, but I'm re-compiling my kernel with uvesafb now. Lets see if it brings something. I'll also experiment with the GRUB_GFXPAYLOAD_LINUX and GRUB_GFXMODE parameters in /etc/default/grub....

I installed gentoo once before, 10 years ago (was my first linux). I don't remember much from the experience, but the pain of setting up FB still haunts me :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum