Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] kernel 3.14.28 genkernel domdadm no root found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
dalu
Guru
Guru


Joined: 20 Jan 2003
Posts: 497

PostPosted: Thu Jan 15, 2015 7:42 am    Post subject: [solved] kernel 3.14.28 genkernel domdadm no root found Reply with quote

remote server
grub2
genkernel
latest all

/dev/sda2
/dev/sdb2
= RAID1
/dev/md0

kernel command line:
Code:

menuentry 'Gentoo GNU/Linux' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-3cfe0767-0815-44e8-9d8c-2a4cfd7d434d' {
        load_video
        insmod gzio
        insmod part_gpt
        insmod part_gpt
        insmod diskfilter
        insmod mdraid1x
        insmod ext2
        set root='mduuid/a5363d147aa7884e0ad5f401e0c3906e'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint='mduuid/a5363d147aa7884e0ad5f401e0c3906e'  3cfe0767-0815-44e8-9d8c-2a4cfd7d434d
        else
          search --no-floppy --fs-uuid --set=root 3cfe0767-0815-44e8-9d8c-2a4cfd7d434d
        fi
        echo    'Loading Linux x86_64-3.14.28-gentoo ...'
        linux   /boot/kernel-genkernel-x86_64-3.14.28-gentoo root=UUID=3cfe0767-0815-44e8-9d8c-2a4cfd7d434d ro domdadm init=/usr/lib/systemd/systemd
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initramfs-genkernel-x86_64-3.14.28-gentoo
}


Code:

genkernel --disklabel --mdadm all


fails to find or mount the UUIDed device
fine, type shell
ls dev
md0 present
cat /proc/mdstat
no raid assembled

can't do much more as I can't type / over remote serial console

kernel config MD
Code:

CONFIG_MD=y
CONFIG_BLK_DEV_MD=y
CONFIG_MD_AUTODETECT=y
CONFIG_MD_LINEAR=m
CONFIG_MD_RAID0=m
CONFIG_MD_RAID1=y
CONFIG_MD_RAID10=m
CONFIG_MD_RAID456=m
CONFIG_MD_MULTIPATH=m
CONFIG_MD_FAULTY=m


lspci
Code:

00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller (rev 05)

00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller (rev 05) (prog-if 01 [AHCI 1.0])
   Subsystem: ASUSTeK Computer Inc. P8 series motherboard
   Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 57
   I/O ports at f0b0 [size=8]
   I/O ports at f0a0 [size=4]
   I/O ports at f090 [size=8]
   I/O ports at f080 [size=4]
   I/O ports at f060 [size=32]
   Memory at fe601000 (32-bit, non-prefetchable) [size=2K]
   Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit-
   Capabilities: [70] Power Management version 3
   Capabilities: [a8] SATA HBA v1.0
   Capabilities: [b0] PCI Advanced Features
   Kernel driver in use: ahci (rescue system's)


Code:

CONFIG_SATA_AHCI=y
CONFIG_SATA_AHCI_PLATFORM=m
# CONFIG_SATA_ACARD_AHCI is not set



Code:

#
# Partition Types
#
CONFIG_PARTITION_ADVANCED=y
# CONFIG_ACORN_PARTITION is not set
# CONFIG_AIX_PARTITION is not set
# CONFIG_OSF_PARTITION is not set
# CONFIG_AMIGA_PARTITION is not set
# CONFIG_ATARI_PARTITION is not set
# CONFIG_MAC_PARTITION is not set
CONFIG_MSDOS_PARTITION=y
CONFIG_BSD_DISKLABEL=y
CONFIG_MINIX_SUBPARTITION=y
CONFIG_SOLARIS_X86_PARTITION=y
CONFIG_UNIXWARE_DISKLABEL=y
# CONFIG_LDM_PARTITION is not set
# CONFIG_SGI_PARTITION is not set
# CONFIG_ULTRIX_PARTITION is not set
# CONFIG_SUN_PARTITION is not set
# CONFIG_KARMA_PARTITION is not set
# CONFIG_EFI_PARTITION is not set (not an EFI bios)
# CONFIG_SYSV68_PARTITION is not set
CONFIG_CMDLINE_PARTITION=y
CONFIG_BLOCK_COMPAT=y


Last edited by dalu on Thu Jan 15, 2015 9:03 am; edited 1 time in total
Back to top
View user's profile Send private message
dalu
Guru
Guru


Joined: 20 Jan 2003
Posts: 497

PostPosted: Thu Jan 15, 2015 9:02 am    Post subject: Reply with quote

well I don't know why but it boots
I suspect the partition types but I'm not sure

well I wanted to post a working config but the forum truncated the output so it's useless.

anyhow, solved I guess
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum