Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sys-apps/openrc-0.13" is blocking sys-apps/kmod-19
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Fri Jan 16, 2015 6:06 am    Post subject: sys-apps/openrc-0.13" is blocking sys-apps/kmod-19 Reply with quote

Moin Kollegen,

ich habe wieder einen Block, den ich nicht in den Griff bekomme....

Code:
WARNING: One or more repositories have missing repo_name entries:

        /usr/local/portage/overlay/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.



 * IMPORTANT: config file '/etc/portage/package.accept_keywords/ystemctl is-failed' needs updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N     ] sys-apps/openrc-0.12.4  USE="ncurses netifrc pam unicode -debug -newnet (-prefix) (-selinux) -static-libs -tools" 0 KiB                                                                           
[nomerge       ] virtual/modutils-0
[ebuild  N    ~]  sys-apps/kmod-19  USE="python tools zlib -debug -doc -lzma -static-libs" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
[blocks B      ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-apps/kmod-19, sys-fs/udev-init-scripts-27)                                                                                         

Total: 2 packages (2 new), Size of downloads: 0 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/openrc-0.12.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/openrc required by @system
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2:0/0::gentoo, installed)
    sys-apps/openrc:= required by (app-admin/openrc-settingsd-1.0.1:0/0::gentoo, installed)
    sys-apps/openrc:0/0= required by (app-admin/openrc-settingsd-1.0.1:0/0::gentoo, installed)

  (sys-apps/kmod-19:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/kmod-15:0= required by (sys-apps/systemd-218-r1:0/2::gentoo, installed)
    >=sys-apps/kmod-15:0/0= required by (sys-apps/systemd-218-r1:0/2::gentoo, installed)
    sys-apps/kmod required by (sys-apps/pciutils-3.2.0:0/0::gentoo, installed)
    sys-apps/kmod[tools] required by (virtual/modutils-0:0/0::gentoo, installed)

  (sys-fs/udev-init-scripts-27:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-init-scripts-25 required by (sys-apps/systemd-218-r1:0/2::gentoo, installed)


Ich bastle daran schon ein paar Wochen erfolglos herum.... d.h. vorübergehend war das weg ?! Im Augenblick bekomme ich das aber nicht wieder hin.

Code:
tux uhai # emerge --info
WARNING: One or more repositories have missing repo_name entries:

        /usr/local/portage/overlay/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.


Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop, gcc-4.8.3, glibc-2.19-r1, 3.17.7-gentooy x86_64)
=================================================================
System uname: Linux-3.17.7-gentooy-x86_64-AMD_Phenom-tm-_II_X4_945_Processor-with-gentoo-2.2
KiB Mem:    16435192 total,  12872960 free
KiB Swap:   17414456 total,  17414456 free
Timestamp of tree: Thu, 15 Jan 2015 19:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.1
dev-util/ccache:          3.1.9-r4
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.12.6, 1.13.4, 1.14.1, 1.15
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.18 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo kde x-overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/fax /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde /usr/local/portage/overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi akonadi alsa amd64 apache2 avi berkdb bluetooth branding bzip2 cairo cdda cddb cdr cleartype cli corefonts cracklib crypt cups cxx dbus dga divx dts dv dvd dvdr dvdread emboss encode exif fam fame ffmpeg firefox flac fortran gdbm gif glamor gphoto2 gpm gps gtk gudev iconv introspection ipv6 java java6 javascript jpeg jpeg2k lcms ldap libnotify lm_sensors mad midi mjpeg mmx mng modules mp3 mp4 mpeg msn multilib ncurses networkmanager nls nptl nvidia ogg opengl openmp pam pango pcre pda pdf phonon png policykit ppds python qt3support qt4 quicktime raw readline scanner sdl session smp spell sql sse sse2 ssl startup-notification subtitles svg syslog systemd tcpd threads tiff timidity truetype type1 udev udisks unicode upower usb v4l v4l2 vcd vorbis wavpack win32codecs wmf wxwidgets x264 xcb xine xml xpm xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



Verursacht habe ich das vermutlich mit meiner Bastelei... momentan nutze ich LXQT mit dem Desktop-Profil. Jeder rat ist wie immer herzlich willkommen...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mrsteven
Veteran
Veteran


Joined: 04 Jul 2003
Posts: 1938

PostPosted: Fri Jan 16, 2015 8:44 am    Post subject: Reply with quote

Quote:
Code:
[ebuild  N    ~]  sys-apps/kmod-19  USE="python tools zlib -debug -doc -lzma -static-libs" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB

Warum zieht er eine unstable kmod-Version an (siehe ~ in emerge-Ausgabe)? Von deinen Basteleien wird wohl noch ein entsprechender Eintrag in /etc/portage/package.keywords übrig sein?
_________________
Unix philosophy: "Do one thing and do it well."
systemd: "Do everything and do it wrong."
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Fri Jan 16, 2015 11:38 am    Post subject: Reply with quote

Deine Version von kmod gehört zu testing und deine Version von openrc gehört zu stable. Das passiert, wenn man so etwas mischt. Entweder testing oder stable, kein Mischmasch.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Fri Jan 16, 2015 12:39 pm    Post subject: Reply with quote

Ursprung ist wahrscheinlich die installierte testing systemd-218-r1 Version, welche
>=sys-fs/udev-init-scripts-25 fordert, die dann
!<sys-apps/openrc-0.13"
fordert.

Mit der testing systemd Version wirst du so nicht um testing openrc herumkommen.
Sprich, entweder mit systemd auf stable zurückgehen, oder die geforderten Abhängigkeiten von testing-systemd erfüllen.

Schau doch auch mal ob wirklich die systemd testing-Version benötigt wird.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Fri Jan 16, 2015 5:02 pm    Post subject: Reply with quote

Vorher hatte ich KDE als Oberfläche und da waren teilweise testing-Pakete drin....

Ich habe in /etc/portage/package.accept_keywords/ jetzt die Einträge , die systemd betrreffen auskommentiert.

Das ist das Ergebnis:
Code:
[blocks B      ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-fs/udev-init-scripts-27, sys-apps/kmod-19)                                                                                         
[blocks B      ] <sys-apps/systemd-217 ("<sys-apps/systemd-217" is blocking sys-apps/kmod-19)

Total: 5 packages (2 upgrades, 1 downgrade, 2 new), Size of downloads: 2.327 KiB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/kmod-19:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/kmod[tools] required by (virtual/modutils-0:0/0::gentoo, installed)
    sys-apps/kmod required by (sys-apps/pciutils-3.2.0:0/0::gentoo, installed)
    >=sys-apps/kmod-15:0= required by (sys-apps/systemd-216-r2:0/2::gentoo, ebuild scheduled for merge)

  (sys-apps/openrc-0.12.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/openrc required by @system
    sys-apps/openrc:0/0= required by (app-admin/openrc-settingsd-1.0.1:0/0::gentoo, installed)
    sys-apps/openrc:= required by (app-admin/openrc-settingsd-1.0.1:0/0::gentoo, installed)
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2:0/0::gentoo, installed)

  (sys-apps/systemd-216-r2:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd:0= required by (gnome-base/gvfs-1.20.3:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (gnome-base/gvfs-1.20.3:0/0::gentoo, installed)
    sys-apps/systemd:0/2=[abi_x86_64(-)] required by (media-sound/pulseaudio-5.0-r4:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (media-gfx/sane-backends-1.0.24-r5:0/0::gentoo, installed)
    sys-apps/systemd required by @selected
    sys-apps/systemd:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (sys-apps/systemd:0=[abi_x86_64(-)]) required by (media-sound/pulseaudio-5.0-r4:0/0::gentoo, installed)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_64(-)]) required by (virtual/libudev-215-r1:0/1::gentoo, installed)
    >=sys-apps/systemd-209 required by (sys-process/procps-3.3.10-r1:0/0::gentoo, installed)
    sys-apps/systemd required by (net-wireless/bluez-5.27:0/3::gentoo, installed)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (media-gfx/sane-backends-1.0.24-r5:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0= required by (net-misc/networkmanager-1.0.0:0/0::gentoo, installed)
    sys-apps/systemd required by (sys-fs/udisks-2.1.3:2/2::gentoo, installed)
    >=sys-apps/systemd-209 required by (net-misc/networkmanager-1.0.0:0/0::gentoo, installed)
    sys-apps/systemd required by (sci-geosciences/gpsd-3.9-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0/2= required by (net-misc/networkmanager-1.0.0:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.8.12:0/0::gentoo, installed)
    >=sys-apps/systemd-197 required by (app-admin/openrc-settingsd-1.0.1:0/0::gentoo, installed)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1:0/0::gentoo, installed)                                                                                 
    sys-apps/systemd:0= required by (sys-auth/polkit-0.112-r2:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-auth/polkit-0.112-r2:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-apps/dbus-1.8.12:0/0::gentoo, installed)
    >=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r3:0/0::gentoo, installed)
    >=sys-apps/systemd-208:0 required by (virtual/udev-215:0/0::gentoo, installed)
    sys-apps/systemd required by (virtual/service-manager-0:0/0::gentoo, installed)



Anscheinend muss ich jetzt alle Einträge in diesen Dateien überprüfen, oder? Ich könnte vermutlich auch alle Dateien aus diesem Verzeichnis verschieben und dann sehen, wie sich das System verhält. Wie würdet Ihr da vorgehen?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Fri Jan 16, 2015 5:36 pm    Post subject: Reply with quote

Sowohl der Stable-Zweig als auch der Testing-Zweig sind in sich konsistent. Du solltest das nicht ohne triftigen Grund mischen. Wobei ich dir jetzt auch nicht raten würde, einfach alles aus der package.accept_keywords rauszuwerfen, weil das zu Downgrades führt, die auch Probleme machen können.

Ich würde dir raten, erst mal openrc-0.13 zu unmaskieren, dann hast du schon mal den Block weg. Und damit das Problem, um welches es hier geht. Langfristig solltest du aber nur Pakete aus einem Zweig nutzen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Fri Jan 16, 2015 7:25 pm    Post subject: Reply with quote

Schaut aus als wäre noch sys-fs/udev-init-scripts und sys-apps/kmod
aus testing freigeschaltet?
Falls ja, versuche es mal mit den stable Versionen.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sat Jan 17, 2015 10:15 am    Post subject: Reply with quote

Außer openrc musste ich noch zwei weitere Pakete freischalten. Jetzt passt es wieder...

Bleibt die Frage, wie ich mein System am Besten "putze". Ich würde gerne alle Eintrage in den Konfigurationen entfernen, die ich nicht mehr brauche. Und den Rest mal systematisch überprüfen. Gibt es da ein aktuelles/offizielles HowTo? Ich habe bisher nur relativ alte Anleitungen gefunden und möchte da nichts versemmeln....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sat Jan 17, 2015 10:33 am    Post subject: Reply with quote

Wie ich schon sagte, du musst dich erst mal entscheiden, ob du stable oder testing willst. Poste doch mal deine package.unmask und deine package.accept_keywords.

Und dann ziehst du eine Schiene durch. Wenn du auf testing willst, setze dazu ACCEPT_KEYWORDS in der make.conf. Wenn du stable willst, wirf alles aus package.unmask und package.accept_keywords raus. Ich kann dir aber nicht versprechen, dass die Downgrades dann keine Probleme machen. Eventuell klappt es am Besten, wenn du dann bei emerge -uDN world manuell die Updates auswählst und die Downgrades auslässt. Stable aktualisiert ja auch, dann bist du nach einiger Zeit durch. Das ist jetzt nicht so einfach zu sagen, kommt drauf an, was du da alles unmaskiert hast.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Jan 17, 2015 11:42 am    Post subject: Reply with quote

Klaus Meier wrote:
Wie ich schon sagte, du musst dich erst mal entscheiden, ob du stable oder testing willst. Poste doch mal deine package.unmask und deine package.accept_keywords.

Halte ich für ÄUßERST fragwürdig/gefährlich. Speziell bei der Toolchain wäre ich extrem vorsichtig (siehe kürzliche News wg. ABI von libstdc++, Probleme NACH glibc-Update * unsupported to downgrade, etc.). Auch beim Kernel würde ich mich auf das verlassen, was einem die Gentoo devs als stable empfehlen. Die letzten Kernel releases hatten einige Bugs, die zu Datenverlust geführt hätten - wenn man immer ~arch gefahren wäre.

Und auch der Hinweis, dass ARCH und ~ARCH jeweils in sich konsistent wären ist schlichtweg falsch. poppler ist da ein ganz böser Kandidat, der ständig die ABI wechselt. Die ständigen rebuilds von libreoffice &co sind ein HORROR! Setzt man dann auch libreoffice-bin ist man in de Po gekniffen. Da gibt es ab und an auch ~ARCH-Pakete, die dazu da sind eine neue poppler-Version stable zu setzen. Auch multilib bereitete einige Probleme in ~arch, weil noch nicht alles portiert war. Da ist man dann als ~arch-User schnell am Rand der Verzeiflung. Selektiv Pakete aus ~ARCH nehmen ist IMHO deutlich ungefährlicher und angenehmer.
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 482

PostPosted: Sat Jan 17, 2015 1:03 pm    Post subject: Reply with quote

Ja, ich sehe es genauso wie franzf und fahre auch ein "Mischsystem". So viel wie möglich stable und Testing nur das wo es eingen Grund für gibt.

Zum bereinigen der /etc/portage Dateien kann ich 2 Tools empfehlen:
Code:
eix-test-obsolete
(app-portage/eix)
Code:
portpeek -a
(app-portage/portpeek)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Sat Jan 17, 2015 4:07 pm    Post subject: Reply with quote

btw, inzwischen (von gestern auf heute) sind udev-init-scripts-27 und openrc-0.13.7 auf amd64 auch stable markiert worden.
Siehe nach einem emerge --sync
Code:
eshowkw udev-init-scripts openrc
Back to top
View user's profile Send private message
Poedel
n00b
n00b


Joined: 25 Oct 2006
Posts: 62

PostPosted: Sun Jan 18, 2015 8:35 am    Post subject: Reply with quote

mein Rechner spackt gerade auch mit systemD rum..
mein amd64 System ist im Grunde stable, ~ sind nur einige Programme, die nicht im stabilen Zweig sind oder nur im instabilen Funktionen enthalten, die ich benötige. Darf man wohl vernachlässigen, was das ewige Geweine um das mixing betrifft.
Ich kann aber überhaupt nicht deuten, warum die Kiste plötzlich systemd-217 emergieren will, wo ich weder systemd noch irgendeines der Programme von "equery d systemd" .. alles aus dem stable Zweig.
Aber wo Dr. Josef schon schreibt, dieses WE wäre da einiges passiert in der Richtung, werde ich wohl heute nachmittag noch einen emerge --sync durchführen und gucken, ob sich das Problem von alleine entfernt..

Quote:
[ebuild U ] sys-apps/kmod-19 [18-r1] USE="python tools zlib -debug -doc -lzma -static-libs" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 1.440 KiB
[ebuild U ] net-fs/nfs-utils-1.3.1-r1 [1.2.9-r3] USE="ipv6 libmount nfsidmap nfsv4 tcpd uuid -caps -kerberos -nfsdcld -nfsv41 (-selinux)" 768 KiB
[ebuild U ~] mail-client/thunderbird-31.4.0 [31.3.0] USE="crypt dbus gstreamer jit ldap minimal startup-notification -bindist -custom-cflags -custom-optimization -debug -hardened% -lightning -mozdom -pulseaudio (-selinux) -system-cairo -system-icu -system-jpeg -system-libvpx -system-sqlite" LINGUAS="de -ar -ast -be -bg -bn_BD -br -ca -cs -da -el -en_GB -es_AR -es_ES -et -eu -fi -fr -fy_NL -ga_IE -gd -gl -he -hr -hu -hy_AM -id -is -it -ja -ko -lt -nb_NO -nl -nn_NO -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv_SE -ta_LK -tr -uk -vi -zh_CN -zh_TW" 0 KiB
[ebuild U ~] www-client/google-chrome-39.0.2171.99_p1 [39.0.2171.95_p1] USE="plugins" LINGUAS="de -am -ar -bg -bn -ca -cs -da -el -en_GB -es -es_LA -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 0 KiB
[blocks B ] <sys-apps/systemd-217 ("<sys-apps/systemd-217" is blocking sys-apps/kmod-19)


edit:
ein Meter schlauer.. das neue stabilisierte kmod-19 würde dann systemd-217 ziehen ..also lassen wir kmod erstmal bei 18-r1
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1414

PostPosted: Sun Jan 18, 2015 9:14 am    Post subject: Reply with quote

Hi@,

Hier ist die Lösung.

Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
Poedel
n00b
n00b


Joined: 25 Oct 2006
Posts: 62

PostPosted: Sun Jan 18, 2015 9:47 am    Post subject: Reply with quote

Danke Mario, aber das Paket ist schon stable seit gestern ..

Quote:
[I] sys-fs/udev-init-scripts
Available versions: 26-r2^t 27^t **9999^t
Installed versions: 27^t(08:07:35 18.01.2015)


dennoch will er kmod-19 inhalieren, was systemd-217 zieht.
Beides geht nicht, also muß ich kmod maskieren solange.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun Jan 18, 2015 11:59 am    Post subject: Reply with quote

Bitte poste doch mal ein
Code:
emerge -uDNpvt @world

speziell das "t" für "--tree" wäre interessant, um zu sehen, warum systemd überhaupt reingezogen wird.
Kann nämlich nur mal wieder eine "intelligente" Reaktion von portage sein, weil sys-fs/udev irgendeine Abhängigkeit nicht erfüllen kann (USE-Flags, Block, ...)
Back to top
View user's profile Send private message
Poedel
n00b
n00b


Joined: 25 Oct 2006
Posts: 62

PostPosted: Sun Jan 18, 2015 12:08 pm    Post subject: Reply with quote

die kurze Version davon wäre:

Quote:
[nomerge ] sys-apps/pciutils-3.2.0 USE="kmod zlib -static-libs"
[ebuild U ] sys-apps/kmod-19 [18-r1] USE="python tools zlib -debug -doc -lzma -static-libs" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 1.440 KiB
[blocks B ] <sys-apps/systemd-217 ("<sys-apps/systemd-217" is blocking sys-apps/kmod-19)


für mich ist es so, daß durch das useflag kmod in pciutils kmod gezogen wird. Wenn das in Version 19 installiert wird, will es aber auch systemd-217 haben, was aber wieder kmod19 blockiert. Da beißt sich die Katze in Schwanz.
Daher habe ich verübergehend kmod-19 maskiert.

Oder möchtest du denn kompletten Output haben, mit dem ganzen "requested by" Gelumpe dran?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Sun Jan 18, 2015 12:50 pm    Post subject: Reply with quote

Ist vermutlich ein Fehler im ebuild

Das aktuell stable kmod-19.ebuild blockiert die aktuell stable systemd Version
kmod-19.ebuild,v 1.3:
 # Block systemd below 217 for -static-nodes-indicate-that-creation-of-static-nodes-.patch
RDEPEND="!sys-apps/module-init-tools
        !sys-apps/modutils
        !<sys-apps/openrc-0.13
        !<sys-apps/systemd-217
....

Und da systemd-217 noch nicht stable verfügbar ist kommt es hier zum Block

Sofern möglich würde ich (wie schon von Poedel vorgeschlagen) =sys-apps/kmod-19 vorübergehend maskieren,
oder ein paar Tage abwarten bis die Gentoo-Devs das gefixt haben.

/edit
Schaut dazu auch im Bug 530424
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1559
Location: Schweiz

PostPosted: Mon Jan 19, 2015 6:38 am    Post subject: Reply with quote

Meiner Meinung nach ist dieser kmod/systemd-Block einfach wieder einmal ein Spiegel für die Haltung einiger Devs gegenüber systemd...
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Mon Jan 19, 2015 7:46 am    Post subject: Reply with quote

schmidicom,
ach, nu halt bitte an mit diesen Verschwörungstheorien..
Meiner Meinung nach hat einer der Devs bei der Stabilisierung einfach eine Abhängigkeit übersehen - das kann passieren (sind auch nur Menschen die das machen).
Nach dem bemerken wurde der Fehler doch nun auch schnellstmöglich korrigiert.
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Tue Jan 20, 2015 2:39 pm    Post subject: Reply with quote

Nu is ja jut, das Update läuft jetzt sauber durch....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum