Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't mount partition from fstab: mounting it manually works
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
GSnake
Tux's lil' helper
Tux's lil' helper


Joined: 10 Sep 2012
Posts: 120
Location: Italy

PostPosted: Fri Jan 16, 2015 9:46 am    Post subject: Can't mount partition from fstab: mounting it manually works Reply with quote

Hello guys!
OpenRC is having some problem mounting my boot partition (sda1) while doing it manually works like a charm.

/etc/fstab:

Code:
/dev/sda1   /boot   ext2   defaults,noatime,discard   0 1
/dev/lvm/gentoo-root   /   f2fs   noatime,discard   0 1


If I try to issue sudo mount /dev/sda1 I get
Code:
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.


but I mount the partition manually by issuing sudo mount /dev/sda1 /boot no problems are detected.
What am I doing wrong?
Thank you guys!
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2617

PostPosted: Fri Jan 16, 2015 11:13 am    Post subject: Reply with quote

Why should you want to get /boot mounted on system start? For me it's ok staying unmounted and I always mount it manually when needed.
Here's my /etc/fstab:
Code:
# <fs>          <mountpoint>    <type>          <opts>                                  <dump/pass>

/dev/sda1       /boot           ext2            noauto,noatime                                  1 2
/dev/sda5       none            swap            sw                                              0 0
/dev/sda6       /               reiserfs        noatime                                         0 1
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri Jan 16, 2015 11:42 am    Post subject: Reply with quote

charles17 ... pretty formatting :)

Code:
% awk '!/(^#|^$)/ && gsub(/[ |\t]+/," ")1' /etc/fstab | column -t
/dev/sda1  /boot  ext2      noauto,noatime  1  2
/dev/sda5  none   swap      sw              0  0
/dev/sda6  /      reiserfs  noatime         0  1

best ... khay
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2617

PostPosted: Fri Jan 16, 2015 11:58 am    Post subject: Reply with quote

khayyam wrote:
Code:
% awk '!/(^#|^$)/ && gsub(/[ |\t]+/," ")1' /etc/fstab | column -t
Yep, really magic. And I have to admit I am not really (not at all) familiar with those nice tools :-(
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri Jan 16, 2015 12:59 pm    Post subject: Reply with quote

charles17 wrote:
khayyam wrote:
Code:
% awk '!/(^#|^$)/ && gsub(/[ |\t]+/," ")1' /etc/fstab | column -t

Yep, really magic. And I have to admit I am not really (not at all) familiar with those nice tools :-(

charles17 ... you are now :)

Basically, ignore quoted and empty lines, substitute any number of spaces or tabs for a single space, and make the columns align.

best ... khay
Back to top
View user's profile Send private message
GSnake
Tux's lil' helper
Tux's lil' helper


Joined: 10 Sep 2012
Posts: 120
Location: Italy

PostPosted: Fri Jan 16, 2015 2:03 pm    Post subject: Reply with quote

Okay but no one answered my question. Why do I get that error message?
Back to top
View user's profile Send private message
sera
Retired Dev
Retired Dev


Joined: 29 Feb 2008
Posts: 1017
Location: CET

PostPosted: Fri Jan 16, 2015 2:04 pm    Post subject: Reply with quote

Whether to manually mount or not is beside the question. Right, it's common to only mount /boot when needed.

If 'mount /dev/sda1' doesn't work but 'mount /dev/sda1 /boot' does then it's very likely the mount options listed in /etc/fstab which are the issue. In particular I doubt discard is available for ext2.

PS: I'd 'mount /boot' instead of 'mount /dev/sda1'
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6281

PostPosted: Fri Jan 16, 2015 2:10 pm    Post subject: Reply with quote

You have option "discard" specified which is unknown for ext2. If you specify the "full" mount command, fstab (and thus your faulty option) is ignored.
Back to top
View user's profile Send private message
GSnake
Tux's lil' helper
Tux's lil' helper


Joined: 10 Sep 2012
Posts: 120
Location: Italy

PostPosted: Sat Jan 17, 2015 8:42 am    Post subject: Reply with quote

Solved! Thank you guys! :-D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum