Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wie installiere ich externe Programme
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Thu Jan 08, 2015 9:42 pm    Post subject: wie installiere ich externe Programme Reply with quote

Hallo,

ich moechte AntiVir installieren. Auf der Seite gibt es ein ebuild fuer gentoo.
Wie mache ich das dann weiter, das sich das ebuild installieren laesst?

Danke.

gruss rrbs


Last edited by rrbs on Fri Jan 16, 2015 8:16 pm; edited 2 times in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1178

PostPosted: Fri Jan 09, 2015 12:42 am    Post subject: Reply with quote

indem du ein lokales overlay anlegst und das ebuild dort hinein kopierst: http://wiki.gentoo.org/wiki/Overlay/Local_overlay
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Fri Jan 09, 2015 8:49 pm    Post subject: Reply with quote

habe es nach der Anleitung gemacht.

ich habe folgenden Fehler:

emerge -av1 antivirus/antivir-core-2.1.12_p19
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/local/portage/overlay'
!!! 'antivirus/antivir-core-2.1.12_p19' is not a valid package atom.
!!! Please check ebuild(5) for full details.

Was hab ich falsch gemacht?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1178

PostPosted: Fri Jan 09, 2015 11:23 pm    Post subject: Reply with quote

Code:
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/local/portage/overlay'


Heißt, dass das entsprechende Verzeichnis nicht exitiert. Wenn du nach Anleitung vorgegangen bist, dann hättest du "/usr/local/portage/" in die make.conf eintragen sollen, nicht "/usr/local/portage/overlay". Überprüf das mal.

Code:
!!! 'antivirus/antivir-core-2.1.12_p19' is not a valid package atom.

Heißt, dass dein Befehl so nicht gültig ist: Wenn du die Version eines ebuilds explizit angeben willst, dann musst du mit "=" anfangen, also
Code:
emerge -av1 [b]=[/b]antivirus/antivir-core-2.1.12_p19


es reicht aber auch
Code:
emerge -av1 antivir-core
, du hast ja sowieso nur eine Version.


BTW: du kannst zwar beliebige Kategorien in deinem eigenen overlay anlegen (du hast jetzt wohl eine Kategorie "antivir" angelegt), aber wahrscheinlich wäre es besser, wenn du die Standard Kategorien verwendest, z.B. würde hier wohl "app-antivir" verwenden
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 482

PostPosted: Thu Jan 15, 2015 12:42 pm    Post subject: Reply with quote

Anstatt eines eigenen Overlays würde ich ein fremdes nehmen in dem das Ebuild auch drin ist. Dann brauchst Du Dich auch nicht um das Aktuell-halten des Ebuilds zu kümmern denn das übernimmt der Inhaber des Overlays. Lt http://gpo.zugaina.org/app-antivirus/antivir-core gibt es das Programm im wschlich-Overlay, und das Overlay ist via layman verfügbar.
Richte also Layman ein und dann ein
Code:
layman -a wschlich

Weitere Infos zu Overlays und Layman: http://www.gentoo.org/proj/en/overlays/userguide.xml
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Fri Jan 16, 2015 8:03 pm    Post subject: Reply with quote

vielen Dank, leider funzt das wschlich overlay nicht.

woher bekomme ich infos was die overlays enthalten?

Code:

emerge app-antivirus/antivir-core

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies   ... done!           

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) app-antivirus/antivir-core-2.1.12_p19::wschlich
>>> Downloading 'http://dl.antivir.de/down/unix/packages/antivir-workstation-prof-2.1.12-19.tar.gz'
--2015-01-16 20:17:53--  http://dl.antivir.de/down/unix/packages/antivir-workstation-prof-2.1.12-19.tar.gz
Resolving dl.antivir.de... 89.105.213.23, 80.190.148.70, 89.105.213.24, ...
Connecting to dl.antivir.de|89.105.213.23|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-01-16 20:17:56 ERROR 404: Not Found.

!!! Couldn't download 'antivir-workstation-prof-2.1.12-19.tar.gz'. Aborting.
 * Fetch failed for 'app-antivirus/antivir-core-2.1.12_p19', Log file:
 *  '/var/tmp/portage/app-antivirus/antivir-core-2.1.12_p19/temp/build.log'

>>> Failed to emerge app-antivirus/antivir-core-2.1.12_p19, Log file:

>>>  '/var/tmp/portage/app-antivirus/antivir-core-2.1.12_p19/temp/build.log'

 * Messages for package app-antivirus/antivir-core-2.1.12_p19:

 * Fetch failed for 'app-antivirus/antivir-core-2.1.12_p19', Log file:
 *  '/var/tmp/portage/app-antivirus/antivir-core-2.1.12_p19/temp/build.log'
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 482

PostPosted: Sat Jan 17, 2015 7:26 am    Post subject: Reply with quote

Der Fehler sagt dass das Ebuild die Datei antivir-workstation-prof-2.1.12-19.tar.gz nicht runterladen kann weil der Link im Ebuild nicht funktioniert. Wenn Du die Datei also selbst runterlädtst und nach /usr/portage/distfiles legst wird die Installation laufen.

Welche Ebuilds in welchem Overlay liegt kann man gut auf der Seite http://gpo.zugaina.org/ rausfinden.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum