Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Audio woes with Creative SoundCore 3D and Turtle beach Z300
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Vorell
n00b
n00b


Joined: 18 Jan 2015
Posts: 2

PostPosted: Sun Jan 18, 2015 7:13 pm    Post subject: Audio woes with Creative SoundCore 3D and Turtle beach Z300 Reply with quote

I thought I could chug through this issue on my own, but after two days of banging my head and google queries against this issue I am unable to resolve it on my own. So I'm hoping someone with more audio expertise could give me some pointers.

There are two audio devices which I am wanting to configure for use but I am unable to find much documentation on, especially on Gentoo.

I don't know if this information will be helpful but I am just trying to be as thorough as possible:
Code:

Motherboard / Case: ASRock M8
CPU: i7-4770k
USB Audio Device: Turtle Beach Z300


So here is what information I have gathered so far, all of which is based on previous kernels so it may or may not be accurate:

Creative SoundCore 3d as far as I know is based on a CA0132 chipset. I checked on creative's spec pages but they were more of an advert for manufacturers than anything really useful, so this assumption may be incorrect as its based on what I could find with google searches.

From what I read audio is possible to get going on the device using a modified version of snd-hda-intel (something about a 4k restriction, etc...)
I know these devices work under linux because up until recently I was using debian and they worked with zero issues.

First here are my lspci | grep Audio results:

Code:

00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
01:00.1 Audio device: NVIDIA Corporation GK110 HDMI Audio (rev a1)


This seems to confirm the snd-hda-intel theory.

A friend advised me to go minimalistic when compiling kernel audio options because they can conflict and create issues. So I added only what I thought was support for my chipsets and if I wasn't certain about a module I added it with the M flag under nconfig.

Here's the results of lsmod:
Code:

Module                  Size  Used by
snd_cs4281             12139  0
snd_ac97_codec         99405  1 snd_cs4281
ac97_bus                1126  1 snd_ac97_codec
snd_opl3_lib            6918  1 snd_cs4281
snd_rawmidi            15394  1 snd_cs4281
snd_hda_codec_ca0132    17559  0
btrfs                 736344  2
xor                     9849  1 btrfs
zlib_deflate           17366  1 btrfs
nvidia               8364827  48
raid6_pq               89031  1 btrfs
x86_pkg_temp_thermal     4312  0
e1000e                195039  0


and the results of the gentoo handbook find command for listing available kernel modules (only listing /sound/ modules):
Code:

/lib/modules/3.17.7-gentoo/kernel/sound/ac97_bus.ko
/lib/modules/3.17.7-gentoo/kernel/sound/core/seq/snd-seq-midi-emul.ko
/lib/modules/3.17.7-gentoo/kernel/sound/core/seq/snd-seq-midi.ko
/lib/modules/3.17.7-gentoo/kernel/sound/core/snd-rawmidi.ko
/lib/modules/3.17.7-gentoo/kernel/sound/drivers/mpu401/snd-mpu401-uart.ko
/lib/modules/3.17.7-gentoo/kernel/sound/drivers/opl3/snd-opl3-lib.ko
/lib/modules/3.17.7-gentoo/kernel/sound/drivers/opl3/snd-opl3-synth.ko
/lib/modules/3.17.7-gentoo/kernel/sound/pci/ac97/snd-ac97-codec.ko
/lib/modules/3.17.7-gentoo/kernel/sound/pci/cs46xx/snd-cs46xx.ko
/lib/modules/3.17.7-gentoo/kernel/sound/pci/hda/snd-hda-codec-ca0132.ko
/lib/modules/3.17.7-gentoo/kernel/sound/pci/hda/snd-hda-codec-generic.ko
/lib/modules/3.17.7-gentoo/kernel/sound/pci/oxygen/snd-oxygen-lib.ko
/lib/modules/3.17.7-gentoo/kernel/sound/pci/oxygen/snd-oxygen.ko
/lib/modules/3.17.7-gentoo/kernel/sound/pci/snd-cmipci.ko
/lib/modules/3.17.7-gentoo/kernel/sound/pci/snd-cs4281.ko


The cirrus audio module is loaded because from what I could tell turtle beach headphones use cirrus logic chipsets. I seem to recall it being loaded as a c-media device under Debian though, can't remember for certain.

I tried following the directions under ALSA in the gentoo wiki / handbook but I encounter the following issues:
alsamixer results:
Code:

This sound device does not have any controls.


aplay -l results: (Note that on my previous install attempt a few days ago I was able to get my devices listed in aplay but alsamixer kept reporting no controls)
Code:

**** List of PLAYBACK Hardware Devices ****       


Here are the results of dmesg | grep audio:
Code:

[    1.885085] sound hdaudioC0D0: No codec parser is available
[    1.967339] sound hdaudioC1D0: No codec parser is available


and dmesg | grep error:
Code:

[    3.055476] input: failed to attach handler kbd to device input11, error: -16
[    3.061466] sysrq: Failed to open input device, error -16
[    3.067482] input: failed to attach handler sysrq to device input11, error: -16


and finally here are the results of speaker-test:
Code:

speaker-test -t wav -c 2                                                                                                                                       
                                                                                                                                                                                 
speaker-test 1.0.28                                                                                                                                                             

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.0.28/work/alsa-lib-1.0.28/src/pcm/pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory


Once again any and all advice is appreciated. I'm not a stranger to the linux shell but I am new to having my hands on the kernel, so please include at least the base of the commands you want me to run if further command output is requested.
example: "list your installed audio kernel modules" vs "use lsmod to post your installed audio modules"

Thanks
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Wed Jan 21, 2015 11:36 am    Post subject: Reply with quote

What error occurs, when you play music from the internet (e.g. surfmusik.de or any other internet music)? You may use a player like vlc.
The error in dmesg looks like it comes from the input devices like keyboard and mouse.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum