Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hilfe beim Entschlüsseln von emerge Fehlermeldungen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2741
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Mon Jan 19, 2015 11:52 pm    Post subject: Hilfe beim Entschlüsseln von emerge Fehlermeldungen Reply with quote

Hi

ich habe seit 2 Monaten kein emerge --sync aufgeführt und nun war er so weit, wie immer habe ich block hier und da. Normalerweise ist es einfach die Blocks zu lösen, man muss nur die blockierende Version deinstallieren und emerge word nochmal ausführen.

Nun habe ich aber 2 Meldungen, die ich nicht so recht weiß, wie ich sie lösen soll:

1. x11-base/xorg-server:0

Code:

[ebuild     U  ] x11-base/xorg-server-1.15.2-r1:0/1.15.2 [1.15.0:0/1.15.0] USE="ipv6 nptl suid udev xorg -dmx -doc -kdrive -minimal (-selinux) -static-libs -tslib -unwind -xnest -xvfb" 5,449 kB
...

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.15.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.15.0::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-nv-2.1.20-r1::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-vesa-2.3.3::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-mouse-1.9.0::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-evdev-2.8.2::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-video-fbdev-0.4.4::gentoo, installed)
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-keyboard-1.7.0::gentoo, installed)



So, wenn ich es richtig verstehe, dann habe ich gerade x11-base/xorg-server-1.15.2-r1, da es Abhängigkeit von x11-drivers/xf86-* ist. Jetzt will das System aber auf x11-base/xorg-server-1.15.2-r1 updaten, und das erzeugt einen Fehler, nur ich verstehe nicht welchen. Ein grep "xf86\|xorg" /etc/portage/ -R bleibt leer, also habe ich niergendwo diese Pakete maskiert oder sonstwas. Wo ist genau hier der Fehler, und wie kann ich den lösen?


2. openrc & udev

Code:

[ebuild     U  ] sys-apps/openrc-0.13.8 [0.12.4] USE="ncurses netifrc pam unicode -debug -newnet (-prefix) (-selinux) -static-libs -tools" 148 kB
...
[blocks B      ] <sys-fs/udev-init-scripts-27 ("<sys-fs/udev-init-scripts-27" is blocking sys-apps/openrc-0.13.8)

...

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/openrc-0.13.8::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/openrc required by @system
    >=sys-apps/openrc-0.12 required by (net-misc/netifrc-0.2.2::gentoo, installed)
    sys-apps/openrc required by (virtual/service-manager-0::gentoo, installed)

  (sys-fs/udev-init-scripts-26-r2::gentoo, installed) pulled in by
    >=sys-fs/udev-init-scripts-26 required by (sys-fs/udev-216::gentoo, installed)


Normalerweise würde ich hier emerge -C "<sys-fs/udev-init-scripts-27" machen und emerge world neu ausführen. Aber bei einer wichtigen Systemkomponente möchte ich das nicht machen. Hab bei "eselect news list " nachgeschaut ob da was wegen udev steht, ich finde nur etwas älteres "2014-11-07 Upgrade to udev >= 217 or eudev >= 2.1", welches über CONFIG_FW_LOADER_USER_HELPER warnt. Bricht denn nicht mein system, wenn ich sys-fs/udev-init-scripts deinstalliere? Wie soll ich das lösen? sys-fs/udev-init-scripts-26 entfernen oder diese Version maskieren?

Danke
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4414

PostPosted: Tue Jan 20, 2015 8:12 am    Post subject: Reply with quote

Die letzten 2 Monate gab es AFAIK mindestens 2 neue stable portage-Versionen. Ich würde deshalb als erstes
Code:
emerge -1 portage

machen und schauen ob die neue Version mit den Blocks selbst zurechtkommt.
Denn der erste Block sollte definitiv kein Problem sein. Bei mir war es in letzter Zeit immer so, dass portage solche subslot-dependencies (-> unterschiedliche ABI) automatisch neu gebaut wurden.
Der zweite Block sollte auch automatisch gehen (AFAICS). Das Problem hier ist, dass openrc-0.13.8 auf >=udev-init-scripts-27 besteht, udev-init-scripts-27 im Gegenzug will >=openrc-0.13. Problem ist: du hast openrc-0.12* und udev-init-scripts-26* installiert. Deinstallieren sollte gehen (udev-init-scripts), du kannst aber auch die Keule auspacken und
Code:
emerge -1 --nodeps openrc udev-init-scripts

Wenn du procps <3.3.9-r2 installiert hast nimm das auch noch vorne ran.
Danach direkt das world-update ausführen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3720
Location: Germany

PostPosted: Tue Jan 20, 2015 10:03 am    Post subject: Reply with quote

pablo_supertux wrote:
emerge world
Sorry der nachfrage, aber nutzt du das Kommando wirklich so ohne weitere Optionen?
Falls ja, nimm besser -uDN mit hinzu.
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2741
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Jan 20, 2015 12:28 pm    Post subject: Reply with quote

@franz: danke für den Tipp, werde später ausprobieren
@Josef.95: nein, ich mache immer emerge -uvDN world aber im Post habe ich nur emerge world wegen der Abkürzung geschrieben
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2741
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Jan 20, 2015 1:26 pm    Post subject: Reply with quote

@franzf: hab erstmal portage aktualisiert und es hat sich verbessert, ich bekomme keine Fehlermeldung, leider auch 2 Blocks

Code:

[ebuild     U  ] sys-apps/kmod-19 [18-r1] USE="tools zlib -debug -doc -lzma -python -static-libs" PYTHON_TARGETS="python2_7 python3_3 -python3_4 (-python3_2%)" 1,440 KiB
...
[ebuild     U  ] sys-apps/openrc-0.13.8 [0.12.4] USE="ncurses netifrc pam unicode -debug -newnet (-prefix) (-selinux) -static-libs -tools" 148 KiB
[blocks b      ] <sys-apps/openrc-0.13.8 ("<sys-apps/openrc-0.13.8" is blocking sys-apps/kmod-19)
[blocks b      ] <sys-apps/openrc-0.13 ("<sys-apps/openrc-0.13" is blocking sys-fs/udev-init-scripts-27)



das ist im Grund dasselbe wie bei https://forums.gentoo.org/viewtopic-t-1008732.html und https://forums.gentoo.org/viewtopic-p-7684772.html doch leider schaffe ich dieses Block nicht zu lösen :oops:
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1189

PostPosted: Tue Jan 20, 2015 1:52 pm    Post subject: Reply with quote

das kleine b in "[blocks b ]" heißt eigentlich, dass portage den block durch updaten der entsprechenden pakete selbst beheben kann. Eigentlich sollte das laufen.
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2741
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Jan 20, 2015 6:52 pm    Post subject: Reply with quote

Oh Mann, so kann man sich schnell zum Clown machen. Hab seit Jahren die emerge manpage nicht mehr gelesen und wusste nicht, dass es einen Unterschied zwsichen b und B gab...
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1189

PostPosted: Wed Jan 21, 2015 6:25 am    Post subject: Reply with quote

kein Problem, kann jedem mal passieren :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum