Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
env-update errors during installation via SysRescCD
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
lynxx
n00b
n00b


Joined: 21 Jan 2015
Posts: 3

PostPosted: Wed Jan 21, 2015 1:16 pm    Post subject: env-update errors during installation via SysRescCD Reply with quote

Hi, I'm new to Gentoo and I'm trying to install it on AMDx64 laptop using System Rescue CD (mainly because I need WPA2 connection during installation).
After chrooting:
Code:
chroot /mnt/gentoo /bin/env -i TERM=$TERM /bin/bash

I tried to update the environment using:
Code:
source /etc/profile
env-update

and I've got this:
Code:
!!! Section 'x-portage' in repos.conf has location attributes set to nonexistent directory: '/usr/portage'
!!! Section 'gentoo' in repos.conf has location attributes set to nonexistent directory: '/usr/portage'
!!! Invalid Repository Location (not a dir): '/usr/portage'

What does it mean and how can I fix it?
Thanks for your help in advance.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2799

PostPosted: Wed Jan 21, 2015 1:27 pm    Post subject: Re: env-update errors during installation via SysRescCD Reply with quote

lynxx wrote:
I tried to update the environment using:
Code:
source /etc/profile
env-update
Second step before the first?
See bottom of page https://wiki.gentoo.org/wiki/Handbook:Parts/Installation/Base wrote:
# env-update && source /etc/profile
Back to top
View user's profile Send private message
lynxx
n00b
n00b


Joined: 21 Jan 2015
Posts: 3

PostPosted: Wed Jan 21, 2015 2:07 pm    Post subject: Re: env-update errors during installation via SysRescCD Reply with quote

charles17 wrote:
Second step before the first?
See bottom of page https://wiki.gentoo.org/wiki/Handbook:Parts/Installation/Base wrote:
# env-update && source /etc/profile


I tried and nothing has changed.
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 568

PostPosted: Wed Jan 21, 2015 5:13 pm    Post subject: Reply with quote

did you extract a portage snapshot to /usr before chrooting?
Back to top
View user's profile Send private message
lynxx
n00b
n00b


Joined: 21 Jan 2015
Posts: 3

PostPosted: Wed Jan 21, 2015 5:45 pm    Post subject: Reply with quote

No, I followed Handbook instructions, where it's advised to chroot first and then install a portage snapshot. http://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Base

Should it be done before chrooting?
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7328
Location: Saint Amant, Acadiana

PostPosted: Wed Jan 21, 2015 9:47 pm    Post subject: Reply with quote

What you are getting is probably not an error at all and could be safely ignored at this point. I just had a look at new wiki handbook very first time and I am not sure it is an improvement over good old Handbook.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum